Showing questions tagged: Show all questions
  • Solved
  • Archived

500 MB of RAM per tab??

Hi everyone, I have the problem in the Subject line. FF sucks about 500 MB to be run, on top of which it takes 500 MB per tab, and that makes it impossible to run a resea… (read more)

Hi everyone,

I have the problem in the Subject line. FF sucks about 500 MB to be run, on top of which it takes 500 MB per tab, and that makes it impossible to run a research on my 8 GB Mac. Yesterday I was looking for a lamp and had no more than 7 tabs open, 3 of which were largely text, 2 were online shops, and 1-2 were websites with pictures. No Facebook or social media, no YouTube. FF froze, made the whole Mac freeze (well, Mac is garbage nowadays but let's leave that out of this topic), and I had to wait MINUTES before I could close it, because the computer was nonreactive.

When I check online, I see people being like "why can't it manage more than 50 tabs?". 50?!?! My computer dies with a maximum of 10 when it's only text websites!

So, I guess there's something wrong with this.

- I don't have many extensions (SimilarWeb, VPN, and Flash Player), I always use incognito so I can't use the plugin that allows me to use several accounts at the same time, so I can't see what's messing with my Mac. - The Activity Monitor (pretty much Task Manager on Windows) shows "FirefoxCP Isolated Web Content" for each tab, could that have anything to do with my problem? - CPU usage is very low, some 0.5 to 10% max during heavy use. - I seem to remember I used to have dozens of tabs open in the past, although I can't be sure. Is this a recent problem?

I really hope there's a way to solve this, because now I always fear that opening FF while on a Zoom meeting might freeze the whole thing.

Thanks to anyone who might want to shed some light on this big problem.

Screenshots: RAM and CPU usage with 2 tabs open. Two, taking more than 1 GB of RAM and about 250 threads in total? While using 0.2% of the CPU? I'm lost

Asked by muvuth 6 months ago

Answered by FredMcD 6 months ago

We cannot get on Netflix, You Tube or Apple TV

All of a sudden, we cannot get on Netflix, You Tube or Apple TV. It always says, Hmm. We’re having trouble finding that site. We can’t connect to the server at www.netfli… (read more)

All of a sudden, we cannot get on Netflix, You Tube or Apple TV. It always says, Hmm. We’re having trouble finding that site.

We can’t connect to the server at www.netflix.com.

If that address is correct, here are three other things you can try:

   Try again later.
   Check your network connection.
   If you are connected but behind a firewall, check that Firefox has permission to access the Web.

Asked by carolorgain 3 months ago

Last reply by jeyson1099 3 months ago

Canvas Issues

I need to access Canvas as part of my school coursework. As of yesterday, Canvas refuses to load in Firefox. I've restarted my Mac, made sure Firefox is up to date, and t… (read more)

I need to access Canvas as part of my school coursework. As of yesterday, Canvas refuses to load in Firefox. I've restarted my Mac, made sure Firefox is up to date, and tried running Canvas in Chrome, where it worked just fine. My internet connection is also stable. All other websites seem to be working in Firefox, but for some reason Canvas doesn't load after any amount of time and the interface appears as the attached image. Any help? Firefox is my preferred browser and I actually cannot do any online coursework without Canvas, so any suggestions or advice are very welcome.

Asked by krismalbo86 3 months ago

Last reply by jscher2000 - Support Volunteer 3 months ago

  • Solved

Bookmarks Disappeared

After a computer reboot, ALL my bookmarks have disappeared. I'm running Firefox 98.0.2 on Mac 10.14.6 - I've followed all the 'help' advice: I opened firefox profiles, it… (read more)

After a computer reboot, ALL my bookmarks have disappeared. I'm running Firefox 98.0.2 on Mac 10.14.6 - I've followed all the 'help' advice: I opened firefox profiles, it only shows one. I rebooted Firefox (I was left with bare bones) and still no bookmarks and still only one profile. I've looked in the computer 'library' and I can find nothing compressed (the bookmarkbackups folder has 15 items but all are dated 2022). Can someone please help me retrieve them, I'm in the middle of a project and NEED the bookmarks. Thank you in advance!

Asked by artcreeping 3 months ago

Answered by artcreeping 3 months ago

Cold sweat: recovery codes didn't work!

Hi there, I just started a seldom-used FF profile to have it synced (you lose FF sync connection if you don't log in within 2 months, I think…). I set up my account for … (read more)

Hi there,

I just started a seldom-used FF profile to have it synced (you lose FF sync connection if you don't log in within 2 months, I think…). I set up my account for decent security: 2FA, wrote down the recovery key and recovery codes.

As I changed the password recently (didn't re-generate said recovery strings), I expected the disconnected state, all right. So I proceed on entering my new password, and out of curiosity, decide to make as if I didn't have the 2nd factor on hand

The Firefox Sync dialog page now asks me for a "Recovery code" that's 10 digits long. To my great surprise, none of those I saved when first setting up the account worked! I know I didn't use any of them.

More, the terminology had me confused: when is a recovery key used vs. code? Both files contain "Recovery codes" in their name, besides, a "digit" is: "1 any of the numerals from 0 to 9, especially when forming part of a number." Nowhere in Firefox Sync a string of 10 "digits" generated: the "recovery key" is 32 character long, in 8 sets of 4 characters, and the "recovery codes", as I understood it, 10 "character" long (and there are 8 of them), number and letters, so not digits.

Why none of my codes worked? Would have it been necessary to generate a new set after changing password?

Asked by gestos 3 months ago

Last reply by cor-el 3 months ago

restore / renew Authenticator

I once had Firefox connected to one of my three authentication apps on my iPhone (I forget which one, probably Google's). When I upgraded my iPhone, my authenticator apps… (read more)

I once had Firefox connected to one of my three authentication apps on my iPhone (I forget which one, probably Google's).

When I upgraded my iPhone, my authenticator apps lost their links and can't do their jobs. The lost connections include Firefox, and I see no way to reconnect. I've been over and over the help files.

I'm now using the permanent 10-character codes to restore Firefox Sync in my Firefox browsers on my four Macs. This is inconvenient and unsustainable.

Suggestions, please.

Asked by tarheel360vr 2 months ago

Last reply by cor-el 2 months ago

  • Solved

Using Facebook links from internet searchs resets my back-button history

Whenever I click on a web search link that goes to Facebook, my Firefox browser back button is cleared. This makes it impossible to go back to my original search easily. … (read more)

Whenever I click on a web search link that goes to Facebook, my Firefox browser back button is cleared. This makes it impossible to go back to my original search easily.

When I remember and notice, I open link in new tab to retain my history.
This started happening several months ago and can be frustrating when doing deep searches.
 I hope there is a security setting I am missing that is allowing Facebook access to my browsing history!
Thanks for your help!

Asked by rduckshow 2 months ago

Answered by cor-el 2 months ago

PRIVACY

Hello, I'd like to know how to change the DOM storage location to a USB flash drive so that I can have all my history and cookies and offline data stored on that flash dr… (read more)

Hello, I'd like to know how to change the DOM storage location to a USB flash drive so that I can have all my history and cookies and offline data stored on that flash drive. That way, I will always insert the USB drive prior to launching Mozilla firefox. Having to verify 2FA all the time is annoying as I always clear my history. I don't like leaving them on my PC anyway. I use a Macbook. Thanks.

Asked by dayodayowaynow7888 2 months ago

Last reply by dayodayowaynow7888 2 months ago

eBay, Aliexpress don't load parts of the page (broken profile?)

Hi there, Firefox is my daily browser and a few websites are causing recurrent issues. Aliexpress randomly switches language and currency, but the most annoying problem … (read more)

Hi there,

Firefox is my daily browser and a few websites are causing recurrent issues. Aliexpress randomly switches language and currency, but the most annoying problem is that it doesn't let me change it (clicking on it doesn't give the menu it's supposed to give), and searching any item in the search bar just gives the "spinning star symbol", and nothing else.

Similar issue in eBay: some menus just don't open, including submenus in the "Contact seller" form, which cripples the whole experience.

As a comparison: all these websites work fine in a slightly outdated Safari 14.1.2. and the most recent Vivaldi.

Now, I saw the issue being mentioned here 4 years ago.

What I tried:

  1. cookie /cache cleaning, which I did to no avail.
  2. Safe mode: no change
  3. Switched back privacy settings to "Standard": no change.
  4. Manually copied files from one profile folder to another: as could be expected, no change.
  5. I even tried a full refresh, but with extensive customization already performed over the years and most of it either in about:config or extensions, I couldn't spend the time re-setting everything back to normal.

FWIW a list of all files and folders shown in my profile folder. I specifically excluded the "known good" files (see step 4). Interestingly, FF also generated an "Invalidprefs.js" file.

Asked by gestos 2 months ago

Last reply by gestos 2 months ago

  • Solved

Redirects

Every time I enter a link to a google service, I see a notice that says "Your should be redirected in a moment..." and then I get redirected to the Stanford University we… (read more)

Every time I enter a link to a google service, I see a notice that says "Your should be redirected in a moment..." and then I get redirected to the Stanford University website (https://pass.stanford.edu/signin.html). It is not a specific website redirecting me, but rather some algorithm is detecting a google link and sending me to Stanford University instead . For instance, if I paste in a link to a particular location in Google Maps, I will end up at Stanford instead. I have no idea how to fix this, but it makes me avoid Firefox and use Chrome because Chrome does not redirect. I would rather use Firefox.

Asked by bruce98 2 months ago

Answered by bruce98 2 months ago

  • Solved

Unwelcome pop-up on download

I'm downloading a lot of images, and every time I do so a popup box appears showing the most recent five downloads and a button to show all downloads, It covers some of t… (read more)

I'm downloading a lot of images, and every time I do so a popup box appears showing the most recent five downloads and a button to show all downloads, It covers some of the icons I use for downloading images which is frustrating. If I right click on any of the downloads one of the options is to Clear Preview Panel, so I assumed it was called Preview Panel, but help does not know about that and I can't find how to stop it coming up (it used not to until I did something, I don't know what) It's driving me crazy.

Asked by Bazza43 2 months ago

Answered by Dropa 2 months ago

Unable to login into Credit Union

Just upgraded FF to V99.xxx I am no longer able to login into my credit union account which has worked flawlessly in previous versions of FF. The 2 step authentication… (read more)

Just upgraded FF to V99.xxx I am no longer able to login into my credit union account which has worked flawlessly in previous versions of FF. The 2 step authentication when entered, just sends me back to login again. A very repetative process whereby the 2 step authentication is not being recognized, thus back to login over and over again!

The process works correctly using Safari

MacOS 10.14.6, FF 99.0.1

Thanks

Asked by cldennis2014 2 months ago

Last reply by FredMcD 2 months ago

Bing!!!

When I use Firefox on my Mac, no matter what I have tried it keeps defaulting to the dreaded Bing Search Engine. I understand it has to do with Microsoft, but I don't use… (read more)

When I use Firefox on my Mac, no matter what I have tried it keeps defaulting to the dreaded Bing Search Engine. I understand it has to do with Microsoft, but I don't use any of their products because I don't like them. In settings/search I can restore the default search engines & delete Bing, but it always reverts back to insisting on using Bing again. I have followed several threads about this issue without permanent resolution. Help??

Asked by kathycasey 2 months ago

Last reply by margy809c 2 weeks ago

Spell check only works half the time.

Something changed a couple months ago where Firefox's spell check began only catching about half of my typos. Over the last 15 years I have become used to my browser prov… (read more)

Something changed a couple months ago where Firefox's spell check began only catching about half of my typos. Over the last 15 years I have become used to my browser providing spell checking services, looking for the little red lines to point out my mistakes, so now that this feature has stopped working reliably I am constantly submitting items with embarrassing typos, having to go back and edit almost every single post I make after the fact. Is there any way to get this working properly again? Thanks.

Asked by VincentBrick 2 months ago

Last reply by cor-el 2 months ago

How to increase the font size in the right click context menu? (2)

Greetings... I would like to increase the font size in right click menu box in FF 89.0 (64-bit) (see attached png) I found a similar 2018 query here at: https://suppo… (read more)

Greetings... I would like to increase the font size in right click menu box in FF 89.0 (64-bit) (see attached png)

I found a similar 2018 query here at: https://support.mozilla.org/en-US/questions/1241117#answer-1174375

and based on that exchange I added the following to userChrome.css file

/* FONT SIZE IN RIGHT CLICK MENU BOXES 5/1/22 */

  1. mainPopupSet menuitem,
  2. mainPopupSet menu { font-size: 16pt !important; }

/* */

I closed and reopened FF. This change has no effect on the menu font no matter what font-size value I enter. Have I done something wrong?

Asked by rarebooks 2 months ago

Last reply by cor-el 2 months ago

DOM tree disappears from Developer Tools upon page refresh

The issue I am experiencing is this - whenever I refresh a tab within my browser while developer tools is open on that tab, the DOM tree disappears completely. I am still… (read more)

The issue I am experiencing is this - whenever I refresh a tab within my browser while developer tools is open on that tab, the DOM tree disappears completely. I am still able to click "inspect" and hover over elements, and I still get the visual feedback of the styles being applied to that element. Additionally, the CSS styles still display in the right-hand side of developer tools when I inspect an element. The only issue I'm seeing within the "Inspector" tab within developer tools is the missing DOM tree.

The other tabs within developer tools (Console, Debugger, Network, Performance, etc...) seem to be working fine (as far as I can tell). Navigating to another page within this tab does not solve the issue.

If I open a new tab within the same browser window, I am able to see the DOM tree again, but only until the page refreshes in which case the error occurs again. I have experienced this issue intermittently for a couple of years now, but this is the first time where it has been persistent despite re-installing browser, restarting computer, etc...

Please let me know if there is any further information that I can provide that might help solve this issue.

Thanks very much for any help that anybody can provide.

Asked by jbslettebak 1 month ago