Page Not Loading in Firefox for Mac

Only one page does not load, otherwise Firefox is working ok. It is for my web-based email, Mail.com. I get a banner that says 'Upgrade to Firefox Quantum,' which seems t… (read more)

Only one page does not load, otherwise Firefox is working ok. It is for my web-based email, Mail.com. I get a banner that says 'Upgrade to Firefox Quantum,' which seems to be designed around Mail.com. I do not want this at all. I am using Firefox 82 for Mac. I've taken off the Enhanced Tracking for the mail.com site. They have written me three times with suggestions, all of which I've followed, e.g., clearing cache and cookies. Their site only loads partially. Thank you for any help you may have!

Asked by simonestreeter 3 months ago

Last reply by OBW47 3 months ago

Fonts displaying as question marks in boxes

Attached is an image of what I'm seeing. I've tried looking into fixes, like changing the security level in "security.sandbox.content.level" and it just changes the boxes… (read more)

Attached is an image of what I'm seeing. I've tried looking into fixes, like changing the security level in "security.sandbox.content.level" and it just changes the boxes to numbers and symbols (second attachment).

Asked by juliana.apolloni 2 months ago

Last reply by OBW47 2 months ago

Can't get BBC and Amazon to work

Running Firefox 84.0.1 on Mac Catalina 10.15.7. Consistently cannot load BBC.co.uk and Amazon.co.uk or Amazon.com with this error message "Unable to connect Firefox can’… (read more)

Running Firefox 84.0.1 on Mac Catalina 10.15.7. Consistently cannot load BBC.co.uk and Amazon.co.uk or Amazon.com with this error message "Unable to connect Firefox can’t establish a connection to the server at www.bbc.co.uk. The site could be temporarily unavailable or too busy. Try again in a few moments. If you are unable to load any pages, check your computer’s network connection. If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web."

I have tried many times and it's not the site is busy. Loads fine on my iPad. My browser runs no proxy. Browser works fine with other https sites. I have cleared history and cache. Running out of things to try!

Asked by matread13 2 weeks ago