Showing questions tagged: Show all questions
  • Solved
  • Archived

FF 116 Scrollbar Buttons Gone

Prior to Firefox 116, I could have the normal scrollbar up and down buttons showing by making: widget.non-native-theme.gtk.scrollbar.allow-buttons True But now it seems… (read more)

Prior to Firefox 116, I could have the normal scrollbar up and down buttons showing by making:

widget.non-native-theme.gtk.scrollbar.allow-buttons True

But now it seems to have no effect. This is under Linux/Mint/Cinnamon. Also, now long-pressing is doing smooth scrolling (I never want smooth scrolling anywhere) and can't find a way to stop that.

I have these set from before:

widget.gtk.overlay-scrollbars.enabled false widget.non-native-theme.gtk.scrollbar.round-thumb false widget.non-native-theme.gtk.scrollbar.thumb-size .85 widget.non-native-theme.scrollbar.size 14 widget.non-native-theme.scrollbar.size.override 14 general.smoothScroll false general.smoothScroll.other false general.smoothScroll.lines false general.smoothScroll.pages false general.smoothScroll.pixels false general.smoothScroll.mouseWheel false mousewheel.system_scroll_override.enabled false toolkit.scrollbox.smoothScroll false ui.scrollToClick 0

Any suggestions appreciated.

Seems like it is always a fight retaining usable scrollbars in Firefox that do not hide, do not change size on mouse-over, do not "warp" on left click, do warp on center click, have a thumb that shows page size, have a background that is not white, and are not microscopic in size! Just call me "traditional"  :)

Thanks

Asked by crxssi 10 months ago

Answered by Terry 10 months ago

  • Solved
  • Archived

Missing Bookmarks

An automatic update of Firefox which resulted in a "quit/create new profile" choice has removed all my bookmarks Of the four profiles stored in "about:profile" three are… (read more)

An automatic update of Firefox which resulted in a "quit/create new profile" choice has removed all my bookmarks

Of the four profiles stored in "about:profile" three are identical (ie. have only the default bookmarks stored) and one, generates a "quit/create new profile" message.

The "bookmarksbackup" folder (in /home/user/.Mozilla/Firefox/zs1jki8t.default) is empty.

The "import/backup" option (in Manage Bookmarks) offers nothing to choose. There is no 'list of dated automatic backups.'

Firefox did not create an "Old Firefox Data" folder on the desktop.

Browser privacy "strict". "Never remember history" was selected.

Running Firefox in Manjaro (Linux)

Help.

Asked by Wayn58 1 year ago

Answered by Terry 1 year ago

  • Solved
  • Archived

Unable to play Videos on Reddit

Hi, I am running Firefox 108.0 on Ubuntu 20.04.5 and videos on Reddit don't play, they just buffer (?). Youtube works fine. I've tried the suggestions on this page: http… (read more)

Hi,

I am running Firefox 108.0 on Ubuntu 20.04.5 and videos on Reddit don't play, they just buffer (?). Youtube works fine. I've tried the suggestions on this page: https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues#search but nothing seems to work.

Thanks

Asked by ghostsview 1 year ago

Answered by ghostsview 1 year ago

  • Solved
  • Archived

Firefox loads at startup for no apparent reason

I'm running Firefox 116.0.2 on Xubuntu 20.04.6. A day ago, it started loading at startup for no apparent reason. I don't want it to that. It's not my default browser, and… (read more)

I'm running Firefox 116.0.2 on Xubuntu 20.04.6. A day ago, it started loading at startup for no apparent reason. I don't want it to that. It's not my default browser, and it is not selected as such. It is not listed in any startup folders or in application autostart in system settings. I tried the winregister and auto update fixes using about:config, and no joy.

Does anyone have any suggestions? It's past annoying.

Asked by Wine_Curmudgeon 10 months ago

Answered by Wine_Curmudgeon 10 months ago

  • Solved
  • Archived

Kubuntu Firefox keeps crashing upon opening

Hi. About System: yodamin@who-r-u:~$ inxi -v 2 System: Host: who-r-u Kernel: 5.15.0-52-generic x86_64 bits: 64 Desktop: KDE Plasma 5.18.8 Distro: Ubuntu 20.04.5 L… (read more)

Hi.

About System:


yodamin@who-r-u:~$ inxi -v 2 System: Host: who-r-u Kernel: 5.15.0-52-generic x86_64 bits: 64 Desktop: KDE Plasma 5.18.8 Distro: Ubuntu 20.04.5 LTS (Focal Fossa) Machine: Type: Desktop System: Micro-Star product: Z370 Gaming Infinite X(MS-B916) v: 1.0 serial: <superuser/root required> Mobo: Micro-Star model: Z370M GAMING PRO AC (MS-7B44) v: 1.0 serial: <superuser/root required> UEFI: American Megatrends v: 9.40 date: 12/27/2017 CPU: 6-Core: Intel Core i7-8700K type: MT MCP speed: 4416 MHz min/max: 800/5000 MHz Graphics: Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 515.65.01 Display: x11 server: X.Org 1.20.13 driver: nvidia tty: N/A OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 515.65.01 Network: Device-1: Intel Ethernet I219-V driver: e1000e Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi Drives: Local Storage: total: 10.35 TiB used: 64.30 GiB (0.6%) Info: Processes: 289 Uptime: 37m Memory: 31.29 GiB used: 4.35 GiB (13.9%) Shell: bash inxi: 3.0.38


I got sick of Winblows and it's been awhile since I ran Linux so I am now on my third flavour in about 2 months - Manjaro, Debian Bullseye [Mate] and my current daily driver Kubuntu. I think Kubuntu is a keeper (until I re-familiarise myself with the Linux OS - maybe a year or two) but still testing.

My issue is that on everyone of the 3 flavours I have tried Firefox is the main browser by default and I use it as my default on Winblows also for about 25 years or so in it's various incarnations (IE Netscape)

My issue with this is Firefox on Winblows rarely if ever crashes ()I can't recall the last time Firefox on Winblows crashed it was that long ago) but on Linux this is a completely different story.

ON Manjaro it crash 4-10 times randomly per hour. ON Mate it as fairly stable but still crashed 4-10 times per evening session (usually 5PM to about 11 or 12 PM) On Kubuntu it as unstable at first but then I got some updates and thing became stable for about a week or so - and by stable I mean 1-2 crashes every few days - so not stable but stabler. I just installed the nvidia driver version 515.x.x for my Nvidia 1070 and immediately after the reboot Firefox started crashing on every single tab I opened. I would re-open it and 10-30 seconds later it crashes again.

After 5 minutes or os of crashing a firefox update magically appeared to upgrade to version 106.x.x. and so I took it thinking it might make things better. It did not make things better. It made things MUCH worse, now it crashes everytime I try to open it.

I ALWAYS have at least 2 browsers installed just because of BS like this. I opened up Vivaldi 5.5.2805.42 and it opened, did not crash and is still open. I am tying this post for help using it.

Firefox extensions installed : ublock, newtab URL redirector,WebRTC(permanently disables WEbRTC and = keeps it disabled through updates, download helper and that's it.

Vivaldi extensions installed: uBlock, download helper - vivaldi doesn't need a new tab URL redirector because it has a configuration for newtab URL - as all browsers should (hear me Mozilla!), doesn't need WebRTC as it also has a configuration for this to turn it on or off and upgrading Vivaldi retains all config settings always and everytime I use it and update it - which admittedly is not nearly as much as Firefox and I am going to keep an eye on that one configuration for sure.

I want to use firefox, I really do, I love it - even through all the changes over the past few years I still love it -even though I HATE some of the changes. That being said it needs to be stable on my OS of choice.

I donate to the Mozilla foundation because I like their efforts on net neutrality and privacy. I also donate to varios net neutrality and privacy orgs such as the EFF and openmedia to mention 2 more. I am going to try to downgrade my firefox version because in my short Linux experience that usually does the trick. However the minute I decide Firefox is not stable enough on linux and swap out to Vivaldi instead my donation money goes from Mozilla foundation to the Vivaldi developers. NOW thats not a threat, I am sure the Mozilla foundation wont miss my $60.00 yearly but, it can;t just be me thats disappointed with Firefox on Linux and in fact google searches shwo me it is not.

Are politics more important than the MAIN PRODUCT of the Mozilla foundation? If not you gotta show Firefox on Linux some more loving because there are millions of firefox users round the world who are disappointed by my basic non-scientific search results and reasoning - which cannot be far off.

I mean - it won't even start and it constantly crashes when it does start.

Asked by Yodamin 1 year ago

Answered by Yodamin 1 year ago

  • Solved
  • Archived

Password generator does not appear on some sites firefox

Idk why but sometimes firefox just doesn't prompt to generate secure password, I even have to download some extensions to generate secure password (Secure Password Genera… (read more)

Idk why but sometimes firefox just doesn't prompt to generate secure password, I even have to download some extensions to generate secure password (Secure Password Generator) meaning more secure issues.

My guess is that you guys probably hardcoded something like {if "type: password" then prompt}, but it's still partly fault at developers too for bringing these huge chunks of javascript.

In screenshot there's element examaple in which i input password but no prompt whatsoever.

Asked by astyd637 1 year ago

Answered by astyd637 1 year ago

  • Solved
  • Archived

SNAP has made Firefox useless.

When is SNAP going to either be fixed, or abandoned? I can no longer save files. or export bookmarks (to another browser that works) since implementation. I hate abandoni… (read more)

When is SNAP going to either be fixed, or abandoned? I can no longer save files. or export bookmarks (to another browser that works) since implementation. I hate abandoning you.

Asked by gagorecki 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Sites (youtube) Crashing often

Hi, Various Sites (sometimes firefox as a whole) keep crashing regularly. I am running Arch Linux (6.4.12, default kernel) with Hyprland WM on an old i7-7700K with a Nvi… (read more)

Hi, Various Sites (sometimes firefox as a whole) keep crashing regularly. I am running Arch Linux (6.4.12, default kernel) with Hyprland WM on an old i7-7700K with a Nvidia GTX980TI. Apart from Firefox the system runs stable. When doing research, or just browsing text based sites, firefox is also very stable, but on some sites like twitch, youtube, or idle games like "Antimatter Dimensions" (ivark.github.io) the browser (or page) crashes regularly. It also happens in Troubleshoot mode, also after a clean re-install (including deleting /.mozilla in /home) and since various versions over the last couple of month. The latest crash report ID is bp-67ed2673-4ed2-452b-bc63-dc1060230831. I know I'm running a niche system, but I really like my setup and apart from those crashes it's amazing, so I hope you can help and point me in the right direction as to what could cause the crashes. Thanks for your time. KR, rehajel

Asked by rehajel 9 months ago

Answered by jonzn4SUSE 9 months ago

  • Solved
  • Archived

Recover account (bookmarks and saved logins) with lost password after computer crash

Dear, I need to recover my Mozilla (Firefox) account on my computer after this latter crashed. Unfortunately, apparently I don't have the good password. Probably I used… (read more)

Dear,

I need to recover my Mozilla (Firefox) account on my computer after this latter crashed. Unfortunately, apparently I don't have the good password. Probably I used an automatically generated password which I don't remember.

I still have my account connected on my Android smartphone, but I can't access the account details (no way to recover my password or change through this device?!), and I can't export my bookmarks. Also, apparently all my identifiers and passwords were not synced on my smartphone :-( Hence somewhere all my precious information are available, but stupidly enough I can't access it anymore and resetting the password warns me that I might (is it even a certainty or a possibility?) lose everything. It seems that I cannot even produce a revovery key (to reset pwd without losing data as mentioned in the Help pages) as I can't connect on a desktop browser anymore (but well on my Android version). I am lost and just stupidly blocked - this is SO frustrating, I initially thought it would be a good idea to put everything in Mozilla - well...

Is there ANY way to actually recover my account without losing data on my desktop Firefox, given I still have access to the email account associated to the Mozilla account (and to the original emails from the creation of my accounts) and I still have access to my Firefox account on the Android app but this one doesn't seem to allow to do anything interesting in my case??

Thanks a lot!

Asked by n.terseleer.lillo 1 year ago

Answered by n.terseleer.lillo 1 year ago

  • Solved
  • Archived

small numbered boxes started appearing on webpages behind each element on a page

Today, web pages started showing small numbered boxes behind each element on a webpage. As you move down the page, the numbers are in sequence. I tried the font settings.… (read more)

Today, web pages started showing small numbered boxes behind each element on a webpage. As you move down the page, the numbers are in sequence. I tried the font settings. They are all set at what they should be. I also tried the config settings, no joy. If I restart in troubleshooting mode, the boxes go away. Note: I am using Linux Mint, and Firefox just updated yesterday to V103.0.2. Any help would be appreciated.

Asked by bawlmer23 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Urdu text do not appear correct in search results

Hello, I have seen a clear difference on the text that appears on the website (e.g. BBC Urdu) and same text in search results. I have tried different search engines (Goog… (read more)

Hello, I have seen a clear difference on the text that appears on the website (e.g. BBC Urdu) and same text in search results. I have tried different search engines (Google, Bing) and different browsers (Edge, Vivaldi) but same issue. Attached are the SS of the issue.

I am not sure if this has to do something with my DeepinOS. But would be thankful if can some guidance what to do? Thanks!

Asked by minajahan 1 year ago

Answered by cor-el 1 year ago

  • Solved

bug returning from hibernation: open firefox is ignored

In case anyone's interested, under Debian 12, when I resume from hibernation, if I have Firefox running as well as Tbird, if I click on a link in an email, the existing i… (read more)

In case anyone's interested, under Debian 12, when I resume from hibernation, if I have Firefox running as well as Tbird, if I click on a link in an email, the existing instance of Firefox is ignored and a new instance is opened. The first instance is in fact frozen -- it looks as it should but trying to change tabs or open a new tab is inactive. Seems I have to kill the open instance of FF, then if I click on a link in an email, FF pops up as it should with a new tab for the link, but the existing tabs are all there and all functional. It feels like a bug -- Tbird seems not to know that FF is already running.

Asked by rayandrews 2 months ago

Answered by zeroknight 2 months ago

  • Solved
  • Archived

Disable tab animations (FF 102)

An old question but seems like the about:config parameters have changed recently. the following don't exist anymore : toolkit.cosmeticAnimations.enabled ui.prefersRe… (read more)

An old question but seems like the about:config parameters have changed recently. the following don't exist anymore : toolkit.cosmeticAnimations.enabled ui.prefersReducedMotion

I've searched with other keywords but couldn't find the new one.

Asked by caetano1 1 year ago

Answered by Terry 1 year ago

  • Solved
  • Archived

links don't work in some sites with v116.0.3

Using MX-21.3_ahs_x64 Wildflower. Since upgrading Firefox to version 116.0.3 all links within www.onlinetvrecorder.com do not work anymore. No messages, no hints what hap… (read more)

Using MX-21.3_ahs_x64 Wildflower. Since upgrading Firefox to version 116.0.3 all links within www.onlinetvrecorder.com do not work anymore. No messages, no hints what happened, just not working. Vivaldi has the same problem, Chrome works. I have asked in mozillazine, but did not get an answer.

Asked by hako2 10 months ago

Answered by jonzn4SUSE 10 months ago

  • Solved
  • Archived

Twitter videos and some other sites not working.

Since i have my new laptop, i do not get twitter videos, bbc news working. Youtube and vimeo does work! Guess its about html5? Have checked mediasource and javascript set… (read more)

Since i have my new laptop, i do not get twitter videos, bbc news working. Youtube and vimeo does work! Guess its about html5? Have checked mediasource and javascript settings in about:config and they are okay. Do not have this problem in brave browser.

Anyone has an answer?

Thanks in advance!

Asked by peter.terpstra7 1 year ago

Answered by peter.terpstra7 1 year ago

  • Solved
  • Archived

Firefox and Thunderbird crash on startup

On my computer, I run Mageia Cauldron with a GNOME environment. After a recent update of my system, both Firefox and Thunderbird have stopped working. They crash constan… (read more)

On my computer, I run Mageia Cauldron with a GNOME environment. After a recent update of my system, both Firefox and Thunderbird have stopped working. They crash constantly when I try to launch either of them. In both cases, when I try to launch them from the command line, I get the following message: ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. Segmentation fault (core dumped)

For basic info, my system is: OS: Linux Mageia Cauldron Environment: GNOME Shell 43.1 Display server: X11 Kernel: 6.1.8-desktop-1.mga9 x86_64 Firefox: 102.7.0esr Thunderbird: 102.6.1

Looking around, it seems to be a bug with Firefox and Thunderbird, but besides waiting for a new update that might fix itself, I wonder if there is something I can do to make them work now.

Thank you.

Asked by imbeault.regis 1 year ago

Answered by imbeault.regis 1 year ago

  • Solved
  • Archived

Double space is back in firefox for me firefox 99.0

There is a specific challenge that i am facing with Firefox and some of the solutions that i have tried is not helping me to resolve the issue. What's the issue: There a… (read more)

There is a specific challenge that i am facing with Firefox and some of the solutions that i have tried is not helping me to resolve the issue.

What's the issue: There are double spaces issue in Firefox

Where is it : 1) Menu 1.1) It's in the Menu New Tab is seen to me as New Tab (more spaces are for demonstration only) 1.2) All the Menu items which have space are show with more then one space including

  1.2.1) File Menu -> New   Window (and all the drop down menus with spaces)
  1.2.2) Edit Menu -> Select     All (and all the drop down menus with spaces)
  1.2.3) View-> Page     Style (and all the drop down menus with spaces)
   1.2.4) All the rest of the menus where ever there is a space there is a double space

2) URL : I type something in the URL and they are double spaced "this is test" will look like "this is test"

   THIS URL looks to be double spaced on firefox https://support.mozilla.org/en-US/questions/1338204?page=2
   like below

3) Numbers in the browser :

   Any number displayed is double spaced in the browser output (most of the times, most of the web pages)
   
   

4) Bookmarks : All bookmarks are double spaced

5) Settings:

Settings: I have tried some suggestions below and they did not work for me.

browser.proton.contextmenus.enabled browser.proton.contextmenus.enabled is still set to false but seems to have no effect toolkit.legacyUserProfileCustomizations.stylesheets=true browser.proton.contextmenus.enabled=false


6) Reference: I have tried some suggestions below and they did not work for me.

 https://support.mozilla.org/bm/questions/1350754
 https://support.mozilla.org/en-US/questions/1186601
 https://support.mozilla.org/en-US/questions/1338204?page=2
 https://superuser.com/questions/1654597/firefox-menus-became-double-spaced-in-latest-update-i-want-to-return-to-single

Asked by Nataraj 2 years ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Backup/Exported Bookmarks files (.json/.html) aren't the same (checksum) between Synced devices

Hi, thanks a lot in advance and sorry to bother. :) I have a couple of desktop/laptop devices synced with the same account. When I make a backup/export of my bookma… (read more)

Hi, thanks a lot in advance and sorry to bother. :)

I have a couple of desktop/laptop devices synced with the same account. When I make a backup/export of my bookmarks in each device (.json/.html files) the checksums of those files don't coincide between devices. Nevertheless, if I open the exported HTMLs in Firefox and save them as Text Files, the resultant files have all the same checksum (sha256sum), i.e., are all the same.

Is this how it is supposed to be? Or should my bookmarks JSON/HTML files be exactly the same in all devices and something is wrong?

Thanks a lot in advance.

Asked by rv 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Change spell checker language when context menu is stolen by the web site

Hi, I have Firefox 102 ESR in Debian 11 (LXC in Chrome OS). It is the en_US version with Czech spell checking dictionary installed as an add-on. I can switch the spell c… (read more)

Hi,

I have Firefox 102 ESR in Debian 11 (LXC in Chrome OS). It is the en_US version with Czech spell checking dictionary installed as an add-on. I can switch the spell checker from English to Czech in ordinary text areas by accessing the context menu via a right mouse click.

However, I'm using a proprietary e-commerce system (Shoptet) with a WYSIWIG editor that has its own context menu, overriding the default one in the browser. I can't switch the language for that reason. Is there a way to switch the spell checker language for a particular text area without access to the context menu? Thank you very much.

Petr

Asked by petrbren 11 months ago

Answered by cor-el 11 months ago

  • Solved
  • Archived

Profiles Vanished

I have a linux debian 11 o/s with up-to-date Firefox I don’t know which version at the moment it is whatever debian repo pushes down. I have 5 profiles on this particula… (read more)

I have a linux debian 11 o/s with up-to-date Firefox I don’t know which version at the moment it is whatever debian repo pushes down. I have 5 profiles on this particular computer with no previous issues. I decided to create another profile to be used for some test work and when I created it I then launched it and opened a few tabs to make sure it worked then closed. I planned on copying the profile files from another profile into this one so I went to the profile folder - /home/user/.mozilla/firefox/profile.names

Once there I saw my other profiles but could not locate this one so I went back to an open browser where I had the about:profiles page open and decided to delete that new profile and start over I figured maybe I accidentally saved it to a different directory. I hit remove it and it gave me the box asking if I wanted to remove files I chose yes I then go back to - /home/user/.mozilla/firefox but folder firefox was gone with all of my profiles all that was left in .mozilla was - /home/user/.mozilla/extensions and - /home/user/.mozilla/systemextensionsdev. Both of these folders - “extensions” as well as “systemextensionsdev” are empty. I go to the local directory for each profile and the data is still there for each of the profiles - /home/user/.cache/mozilla/firefox/profile.name.

The recycle bin is empty. A system-wide search for the profiles comes up with just the ones in the .cache folder. Back at the about:profiles page any attempt to open the preexisting profile results in a prompt asking me to create a new profile. I still have the one profile open and the addons are not working correctly. I did a bookmark export on this profile and doing so generated the “firefox” folder that had disappeared plus a profile folder using the same name of this open profile - /home/user/.mozilla/firefox'profile.name - it created a profile folder for this open profile using the correct name.

Any ideas on how this happened? Can the local profiles still in .cache be used to somehow restore the full profiles?

Asked by komms.tb 1 year ago

Answered by komms.tb 1 year ago