Showing questions tagged: Show all questions
  • Solved
  • Archived

pulseaudio high CPU with no audio playing

Hey there, I have the following issue with Firefox, is this maybe something I should report to the Ubuntu support or directly to Bugzilla? Steps to reproduce: --- Open … (read more)

Hey there,

I have the following issue with Firefox, is this maybe something I should report to the Ubuntu support or directly to Bugzilla?

Steps to reproduce: ---

  1. Open Firefox
  2. Go to a page that contains an embedded video that is not playing automatically, e.g. https://www.rottentomatoes.com/m/sound_of_metal
  3. Do not play the video

Environment --- User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0 Firefox version: 83.0 (64-bit) pulseaudio version: 13.99.2 OS: Ubuntu 20.10 64-bit Gnome version: 3.38.1 Windowing system: Wayland CPU: Intel® Core™ i7-8565U CPU @ 1.80GHz × 8 RAM: 15,5 GiB GPU: Mesa Intel® UHD Graphics 620 (WHL GT2)

Actual results --- pulseaudio process is spawned and rapidly becomes the most CPU consuming process on my machine (especially after a few seconds, when the Web Content ones start to cool down). Even though no sound is actually played! When switching to another tab with no embedded video, pulseaudio keeps overloading the CPU. This only stops after closing Firefox.

Expected results --- I'm not sure this is what should be expected, but I'll give it a shot:

  • pulseaudio process should only be spawned when actually playing a media that requires audio
  • pulseaudio should not be the #1 CPU consuming process
  • pulseaudio process should at the very least not massively use CPU when no sound is playing

Asked by yarma22 6 months ago

Answered by jonzn4SUSE 5 months ago

  • Solved

Remove bottom line on active tab

Can someone help me customize the appearance of the active tab? I was able to remove the borders and separators, however I'm now left with a thin white line at the bottom… (read more)

Can someone help me customize the appearance of the active tab? I was able to remove the borders and separators, however I'm now left with a thin white line at the bottom of the active tab and I don't know how to get rid of it. I have tried changing the border and padding, but nothing really helped:

Anyone with an idea? Any help would be appreciated.

Asked by schlawiener 3 weeks ago

Answered by schlawiener 3 weeks ago

  • Solved

No compatible source was found for this media.

I upgraded SuSE leap 15.1 to 15.2 two days ago and still can't play videos or live streams on most of websites. Works only on youtube and rumble. On twich, netflix,odysee… (read more)

I upgraded SuSE leap 15.1 to 15.2 two days ago and still can't play videos or live streams on most of websites. Works only on youtube and rumble. On twich, netflix,odysee and several others is no go. With other web browsers is just a same, I tried Cromium and Opera I have and love Firefox 78.10.0, ffmpeg is installed , Leap is updated via Yast ... what is that I'm forgetting?

Thanks,

Asked by cmdr.glenel 3 weeks ago

Answered by cmdr.glenel 3 weeks ago

  • Solved

too long right click menu is driving me crazy and costing me time

There are only a few things that I need on right click. Open in New Tab, save image as, copy link, copy link location. Only rarely do I use the developer functions, so … (read more)

There are only a few things that I need on right click. Open in New Tab, save image as, copy link, copy link location. Only rarely do I use the developer functions, so that over time I am accustomed to accessing the Developer Tools from the Tools tab on the main menu. The fact that many of these tools that I do not use are now on the right-click menu are causing me to make errors. I subscribe to an online newspaper that is the first item I read in the day. I go through the front page of the newspaper, I right click on articles I want to read in a new tab. I am so used to doing this efficiently from older versions of Firefox in which the right-click menu always opened where I right-clicked and therefore at the "open link in new tab" selection. Now, what happen is that I react by instinct and find myself clicking the middle of the menu and not the top. This results in errors that waste my time and cost me time and frustration.

Having read a few other problems that other people have had with updates of Firefox, I have to add my voice here. I realize that there are legitimate reasons to change some things - but these things are technical and deal with internet security - not style. It seems to me that constantly moving things around (like menu bars and the like) interrupts a user's accustomed work flows and therefore not a benefit.

It seems to me that there are two possible solutions: One is to make every aspect of user preferences editable by the user. For me, that means the main menu bar is on the top, followed by the tabs, and the right-click or context menus are editable by the user. The other solution is to create two Firefox browsers - one for the traditionalist (I'm 82) and a new browser called "Firefox Superuser".

For now, I'd just appreciate it if someone could tell me how I can get the stuff I don't use off the right-click menu.

I apologize for my grumpiness, I realize you're all volunteers. But, first thing in the morning, having to try to remember that the right click menu might not be opening with "open link in new tab" right next to my cursor is more than I can manage. I automatically click and at least 80% of the time, I'm clicking the wrong thing.

Asked by bdjim 4 weeks ago

Answered by jscher2000 3 weeks ago

  • Solved

Cannot update secondary email

Hi forum The email provider for my preferred secondary email address uses greylisting. It works, very well. The confirming email from firefox is sent from a random amazo… (read more)

Hi forum The email provider for my preferred secondary email address uses greylisting. It works, very well. The confirming email from firefox is sent from a random amazon address, which gets greylisted as intended. There's a 5 minute limit for entering the confirmation code, but greylisting slows delivery of the email to around 15 minutes, waiting for the amazon sending server to try multiple times. Is there another way to update the secondary email address ?

Asked by b.g.roper 4 weeks ago

Answered by cor-el 4 weeks ago

  • Solved

Firefox (linux) not rendering anything

The firefox installation on my desktop is not able to render anything. Even the about:preferences window is not able to show anything both under my account and a new acc… (read more)

The firefox installation on my desktop is not able to render anything.

Even the about:preferences window is not able to show anything both under my account and a new account I made. I even attempted to update to a new version of my distro (Pop OS) in an attempt to fix it.

My Firefox account is able to do a sync (shows up in the dropdown) so it does not have to do with proxies. Chromium also works fine.

I would rather not have to use Chromium so any help will be appreciated. I have tried running firefox in safe mode and doing a "Refresh".

Asked by kojoadams 4 weeks ago

Answered by cor-el 4 weeks ago

  • Solved

Display problem of my blog in Firefox 88.0

Hi all, since I set up my blog I am sometimes & very infrequently experiencing the problem that either the style sheets are not supported (see attachment), or I am ge… (read more)

Hi all,

since I set up my blog I am sometimes & very infrequently experiencing the problem that either the style sheets are not supported (see attachment), or I am getting an error message to the effect that the address of my blog can't be reached. I already posted in the WordPress forum, and a user took a look at my blog, but couldn't replicate the error. So I came to the conclusion that this is maybe an issue with Firefox. My question: Can anybody replicate this error, and may--if possible--be post a solution here?

TIA,

Claus

Asked by Claus Cyrny 1 month ago

Answered by jscher2000 1 month ago

  • Solved

Is it possible to have the Startup cache cleared automatically before opening a session?

Using FF 88.0.1 in both Linux Mint and Windows 10 and without syncing add-ons, The "New Tab Override" looses my granted permission and opens a new tab on it's own Options… (read more)

Using FF 88.0.1 in both Linux Mint and Windows 10 and without syncing add-ons, The "New Tab Override" looses my granted permission and opens a new tab on it's own Options/Preferences page, where it shows that permission is granted.

The simple solution I found that clearing the Startup cache restores functionality.

Already reported this on the add-on's Github site, which directed me back here.

Asked by ineuw 1 month ago

Answered by cor-el 1 month ago

  • Solved

Error code: SSL_ERROR_NO_CYPHER_OVERLAP

My ISP is Plusnet. When I try to access their website using Firefox browser I get the following error: ===== Secure Connection Failed An error occurred during a connecti… (read more)

My ISP is Plusnet. When I try to access their website using Firefox browser I get the following error:

=====

Secure Connection Failed

An error occurred during a connection to webmail.plus.net. Cannot communicate securely with peer: no common encryption algorithm(s).

Error code: SSL_ERROR_NO_CYPHER_OVERLAP

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the web site owners to inform them of this problem.
=======

I have reported the problem to Plusnet but they say 'not our problem'. Their reason being that the problem does not occur using Google Chrome.

Can you help please?

Asked by scm999 1 month ago

Answered by cor-el 1 month ago

  • Solved

Issues viewing local .DOCX

I got an email with a .docx attachment, and when clicked attachment I can view in FF. Downloaded, and clicking file and open in FF ends in endless loop asking to open, if… (read more)

I got an email with a .docx attachment, and when clicked attachment I can view in FF.

Downloaded, and clicking file and open in FF ends in endless loop asking to open, if FF selected. Seems like mime type not being detected and processed from FF directly but does from webmail.

Same action with a PDF, image files works great.

Asked by mikwei 1 month ago

Answered by mikwei 1 month ago

  • Solved

FF profile choice problem on Linux Mint with Claws email

I have three FF profiles on my Linux Mint 19.3 system (work, not-work and one for e-tail). Somehow the problem only appeared after I added that last one. All profiles hav… (read more)

I have three FF profiles on my Linux Mint 19.3 system (work, not-work and one for e-tail). Somehow the problem only appeared after I added that last one. All profiles have the same syntax; I checked the files. Neither one is set to be the dominant one. Typically, I don't use more than one at a time.

I also use Claws mail. Whenever I get any mail with a link I want to check out, I just used to click on that link and it opened in a new tab in the FF browser profile that was currently open. Similarly, whenever I wanted to see the HTML version of a mail, I right-clicked on the html-icon and chose open. Again, it picked the open browser.

Now, though, whenever I pick either one of those options above, I get the "Choose User Profile" box. If I pick the profile that is currently open, I get an error telling me that it's already running.

Since I mostly read email when I use the no-work FF profile, I tried to add "firefox -P NotWork -no-remote --class NotWorkProfile" but that also resulted in the choose user profile box to open.

My current work-around is to copy the link and open it in a new tab, or pull the whole mail into the tab to see the HTML version. Quite annoying.

Is there any way to get it to ignore all other profiles but the currently open one? Thank you for anyone who has an idea. Let me know if there's anything else I may add to explain the situation.

[My apologies if this isn't the right forum; I'm also attempting to ask this question in the Linux Mint and Claws forums, if those exist.]

Asked by addicted2h 2 months ago

Answered by cor-el 2 months ago

  • Solved

Exceptions for the HTTPS-only mode?

Moin, I activated the HTTPS-only mode as I used the "https everywhere" plugin so far. But, in a very special network segment for radio amateurs, the 44-network (ampr.org)… (read more)

Moin, I activated the HTTPS-only mode as I used the "https everywhere" plugin so far.

But, in a very special network segment for radio amateurs, the 44-network (ampr.org) encryption is not allowed. So is there a way to configure the HTTPS-only mode in a way to say ".... but not for 44.0.0.0/8?

i prefer one configuration than constantly clicking the "continue to http site" button for the next few years.

Thanks in advanced

Asked by michael.renner@gmx.de 1 month ago

Answered by cor-el 1 month ago

  • Solved

Unable to watch live YouTube videos

Ever since installed Ubuntu 18.04.5 LTS (& latter upgraded to Ubuntu 20.04.2 LTS), I am unable to watch YT live videos! Below are the screenshots of the issue & a… (read more)

Ever since installed Ubuntu 18.04.5 LTS (& latter upgraded to Ubuntu 20.04.2 LTS), I am unable to watch YT live videos! Below are the screenshots of the issue & a test page report.

Asked by contact.rishikmr 1 month ago

Answered by jonzn4SUSE 1 month ago

  • Solved

Can't complete two-step authentication enabling process

I have a problem with enabling two-step authentication for my Mozilla account. There have been several questions regarding issues with two-step authentication, but none o… (read more)

I have a problem with enabling two-step authentication for my Mozilla account. There have been several questions regarding issues with two-step authentication, but none of them applies to my case, so I started another one.

When I try to enable 2SA, there are seemingly no problems. When I scan the QR code and enter the 6-digit security code, I don't get the "invalid two-step authentication code" message. I do get the 8 10-digit recovery codes. After I enter one of them I get a prompt saying "Two-step authentication enabled" (see attachment), but nothing else happens. It seems like the process is stuck here and isn't completed.

I have tried setting 2SA from my profile settings (https://accounts.firefox.com/settings) too, but when I logout and login again, it says Not Set.

I wouldn't normally use 2SA at all if it hasn't been made mandatory for logging into Add-ons (addons.mozilla.org). Now, I'm locked out of my Add-ons account and can't access my extensions!

Asked by dimithrandir 1 month ago

Answered by dimithrandir 1 month ago

  • Solved

How do I change the font for my menu and toolbar?

Hello, I am a dyslexic user and I am trying to change the font of my menu to open-dyslexic, however i cant figureout how and most of the answers here only answer for chan… (read more)

Hello, I am a dyslexic user and I am trying to change the font of my menu to open-dyslexic, however i cant figureout how and most of the answers here only answer for changing the size, but not the actual font for the menu bar. How do I change the font of my tabs, bookmarks, and ect? thank you

Asked by Nafeesa 1 month ago

Answered by cor-el 1 month ago

  • Solved

Firefox built-in PDF viewer's display bug on Japanese and Chinese

My firefox version is 78.9-esr As attachment, Japanese and Chinese character will be messed up. I have tried to install different fonts like fonts-arphic-ukai and fonts-a… (read more)

My firefox version is 78.9-esr As attachment, Japanese and Chinese character will be messed up. I have tried to install different fonts like fonts-arphic-ukai and fonts-arphic-uming, but it still displays improperly. By the way, it can displays Japanese and Chinese in html correctly.

Asked by wyt94yx 1 month ago

Answered by cor-el 1 month ago

  • Solved

Fonts too bold on certain sites

Introduction So I learned the hard way to never run sudo apt remove python3 on an ubuntu system. I'm running Linuxlite (Ubuntu 20.04.2 LTS) on a dell desktop (unsure of t… (read more)

Introduction So I learned the hard way to never run sudo apt remove python3 on an ubuntu system. I'm running Linuxlite (Ubuntu 20.04.2 LTS) on a dell desktop (unsure of the model).

The Problem After looking at some guides and upgrading the operating system, I managed to get most of the fonts to display correctly. Sites with certain kinds of text still appear to be "too bold" (see images).

""What I've tried"" The command actually removed Mozilla, so I had to reinstall it. Updating it also didn't fix the problem. I have messed around with the font settings and nothing changed. It seems that only Mozilla is doing this because the Brave browser displays the fonts correctly. Other than that, I haven't really done all that much. Also the font as I write this is normal.

Thanks for your consideration!

Asked by maximorainwater9 1 month ago

Answered by cor-el 1 month ago

  • Solved

WebGL stopped working after the Firefox 88 upgrade

Per the title, webgl suddenly stopped working a couple days ago. The error seems to be: WebGL creation failed: * WebglAllowWindowsNativeGl:false restricts context creatio… (read more)

Per the title, webgl suddenly stopped working a couple days ago. The error seems to be:

WebGL creation failed: * WebglAllowWindowsNativeGl:false restricts context creation on this system.

I'm on Ubuntu 21.04 (X, not wayland) with an nvidia graphics card. The "share data" below seems comprehensive, but let me know if any other info will help.

Asked by john588 1 month ago

Answered by cor-el 1 month ago