Showing questions tagged: Show all questions
  • Solved

FF ESR 91.5.0esr 32-bit does not load page www.spectrum.net

Raspberry Pi 400 running: cat /etc/os-release PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)" NAME="Raspbian GNU/Linux" VERSION_ID="11" VERSION="11 (bullseye)" VERSION_CO… (read more)

Raspberry Pi 400 running:

cat /etc/os-release

PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)" NAME="Raspbian GNU/Linux" VERSION_ID="11" VERSION="11 (bullseye)" VERSION_CODENAME=bullseye ID=raspbian ID_LIKE=debian HOME_URL="http://www.raspbian.org/" SUPPORT_URL="http://www.raspbian.org/RaspbianForums" BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

https://www.spectrum.net

loads a 100% white window except for a "FEEDBACK" floating button that does nothing. Tried with a Private Window .... same thing.

Asked by WacoJohn 2 days ago

Answered by FredMcD 2 days ago

  • Solved

Firefox restoring sessions on startup despite "Restore previous sessions" being unchecked in startup

Possible bug: I cannot stop Firefox from restoring sessions after restarting computer. Restore previous session is not checked in Settings, browser.sessionstore.resuming_… (read more)

Possible bug: I cannot stop Firefox from restoring sessions after restarting computer. Restore previous session is not checked in Settings, browser.sessionstore.resuming_after_os_restart is false, and browser.sessionstore.resume_from_crash is false as well. Ubuntu 20.04, Firefox 91.0.2, only add-on is TreeStyleTabs, but this behavior displays with add-ons disabled.

Asked by william.harryman 4 months ago

Answered by FredMcD 4 months ago

  • Solved

Stack firefox logo on top of wordmark on newtab page

I am trying to stack the firefox logo on top of the wordmark on the newtab page. I've tried doing using "display: block;" in my userContent.css, but it doesn't work. I'm… (read more)

I am trying to stack the firefox logo on top of the wordmark on the newtab page. I've tried doing using "display: block;" in my userContent.css, but it doesn't work. I'm not super good at CSS, so any ideas?

Asked by æ 3 days ago

Answered by jscher2000 3 days ago

  • Solved

Bookmark toolbar sync is out of order

Hi, when I use Firefox on this machine, the bookmark sync doesn't work as expected. Instead of maintaining the order of the other devices' bookmark toolbar, it is orderin… (read more)

Hi, when I use Firefox on this machine, the bookmark sync doesn't work as expected. Instead of maintaining the order of the other devices' bookmark toolbar, it is ordering the non-folder bookmarks before the foldered bookmarks. How can I make it so the bookmark toolbar is the same across all devices? I have tried deleted places.sqlite and backupbookmarks folder.

OS: Debian 11

Thank you!

Asked by zanovis 4 days ago

Answered by zanovis 4 days ago

  • Solved

Addons automatically re-enable themselves

I want to disable some addons to debug a problem with opening Slack in Firefox (works in private mode, doesn't work with my profile). I have four addons installed, and wh… (read more)

I want to disable some addons to debug a problem with opening Slack in Firefox (works in private mode, doesn't work with my profile). I have four addons installed, and when I disable any of them, it will automatically be re-enabled after some seconds. How can I stop that?

Asked by jan.heidbrink 4 days ago

Answered by jonzn4SUSE 4 days ago

  • Solved

Bookmarks tab bookmark spacing

Ubuntu 20.04, Unity 7 After upgrading from FF 91.0.2 to FF 92.0 it looks like the vertical spacing between the bookmarks in my bookmark tab folders increased. The bookmar… (read more)

Ubuntu 20.04, Unity 7

After upgrading from FF 91.0.2 to FF 92.0 it looks like the vertical spacing between the bookmarks in my bookmark tab folders increased. The bookmarks are less useful now. Is there a way to decrease this spacing?

Asked by pulnimar 4 months ago

Answered by cor-el 4 months ago

  • Solved

Firefox saving to /run/user/1000/docs

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, pur… (read more)

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, purged and reinstalled from Ubuntu Software and everything seemed ok. However, whenever I now try to save something, for instance images, the save to directory will default to /run/user/1000/docs even though I have my downloads folder selected in settings. I can change to the directory I want to save to and it will save there, but when I next save something it will again want to go to the /run/user/1000/docs folder. Further, I find that a copy of anything I save has also been saved into that folder, creating a new sub-directory to do so. I tried clear data in settings but that didn't delete those files and they are protected in file manager so I can't delete them myself. This will fill my hard drive pretty quickly as well as being really annoying having to change the save directory every time. What can I do to rectify this? I've now got version 96.0 (64 bit) installed.

Asked by paulhurford 1 week ago

Answered by jonzn4SUSE 1 week ago

  • Solved

Some extensions not working after update to 96.0 on Linux

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning. uBlock Origin: 1) Not blocking content. All ads appear. I see… (read more)

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning.

uBlock Origin: 1) Not blocking content. All ads appear. I see this error message in the console: Error: Could not establish connection. Receiving end does not exist. | content_script.js

2) Toolbar icon does not show blocked items count (probably due to above)

3) Clicking toolbar icon causes resulting popup to appear as a vertical line (normal height but just a couple of pixels wide) with no content.

4) Going to Add-on settings and choosing "Preferences" from the add-on's 3-dot menu, the resulting tab crashes.

5) After removing and re-installing the add-on, its button does not appear on the toolbar.

6) After creating a blank profile and installing the add-on, all the above still happens.

7) After downgrading to firefox-bin-95.0.1, all the above still happens.

Ghostery: 1) Works on first install (did not previously have this installed); but after restarting Firefox, no longer works.

2) Breakage symptoms similar to uBlock Origin: No blocked items counter (and no blocking). Preferences tab still works though.

Multi-Account Containers: 1) Clicking on toolbar icon opens normally-sized but empty popup.

2) Opening a site that's configured to open in a container from a New Tab page tile, the site opens but *not* in the configured container (tab edge is not highlighed in container's colour-code).

Asked by ffx3 1 week ago

Answered by ffx3 1 week ago

  • Solved

An extension installed globally for all users (in /usr/share/mozilla/extensions) does not load for an unobvious reason

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozil… (read more)

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/. All extensions load normally, except Auto Tab Discard. When running firefox with the -jsconsole option, I see what the screenshot shows (the message "Invalid addon ID"). But the installation to user profile is successful. I add the extension ID to manifest.json, and get the following output in the console: addons.xpi-utils WARN addMetadata: Add-on {c2c003ee-bd69-42a2-b0e9-6f34222cb046} is invalid: Error: File /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{c2c003ee-bd69-42a2-b0e9-6f34222cb046} does not contain a valid manifest(resource://gre/modules/addons/XPIInstall.jsm:669:11) What can go wrong?

System: Debian 11 (bullseye) Firefox version: 91.4.1esr (amd64)

If you need any other information, please ask, I will write it down.

Asked by zostajekni 1 week ago

Answered by zostajekni 1 week ago

  • Solved

Firefox seemed to "sync" the DisableAppUpdate policy from a Windows public comp to my Linux personal comp. I don't want that.

I normally use Firefox desktop on my Linux computer. Last week, I started using it on a public computer running Windows. I installed Firefox Portable and then logged/sync… (read more)

I normally use Firefox desktop on my Linux computer.

Last week, I started using it on a public computer running Windows. I installed Firefox Portable and then logged/synced into my Firefox account on this Win computer. I noticed that in the Firefox Portable Windows “about:preferences” page, it says “Your browser is being managed by your organization”, which links to about:policies. In that “about:policies” page, it shows this https://i.imgur.com/JmD8nXg.png Policy Name: DisableAppUpdate Policy Value: true. Now I’m back on my Linux desktop computer and it also has this “managed by your organization” message in “about:preferences” and the same “about:policies” stuff. In other words, it appears that this policy was copied from the Windows public computer to my personal Linux computer. I don’t want that.

How can I undo this? And how can I block this sort of policy syncing?

Asked by Mozilla cheese 1 week ago

Answered by jscher2000 1 week ago

  • Solved

The bookmark I tried to open in the new tab is suddenly deleted.

I've been dealing with the error I wrote in the title in the Linux version of your web browser for a while. When I "right click + open in new tab" on any bookmark, that b… (read more)

I've been dealing with the error I wrote in the title in the Linux version of your web browser for a while. When I "right click + open in new tab" on any bookmark, that bookmark is deleted.

Asked by mozilla-account 1 week ago

Answered by FredMcD 1 week ago

  • Solved

Firefox inconsistent, Session leaks data.

By fixing the very first option you come across as soon as you go into General Under "Startup" The setting called "Restore previous Session" Usually, a checkbox, is a b… (read more)

By fixing the very first option you come across as soon as you go into General Under "Startup" The setting called "Restore previous Session"

Usually, a checkbox, is a boolean ON OFF.

Once more, this leaks data. For instance, logging into my webmail rebooting the machine, next time i launch firefox it spawns the same session again. This contradicts with the very first option under "General" -> Startup

If this was a public machine, some one would now have access to my email.

It seems that this is OS specific. But really, i don't care. My complaint stays the same. The option is broken, and firefox leaks data therefor. I no longer trust Firefox. This sort of stuff is not done deliberately.

Once more. perhaps bit logic is too complicated for you UI designers and a quantum gyro is more to your liking? Cause this is NOT normal.

Asked by syncsync 2 weeks ago

Answered by syncsync 1 week ago

  • Solved

Firefox 95 no longer changes focus in Ubuntu

Recently started that Firefox 95 no longer changes focus in Ubuntu 20.4 when mouse click is applied. Another Firefox window can be selected through taskbar mouseover on t… (read more)

Recently started that Firefox 95 no longer changes focus in Ubuntu 20.4 when mouse click is applied. Another Firefox window can be selected through taskbar mouseover on the logo or by minimizing one Firefox window to get to another Firefox window. A simple mouseover, no click, changes focus from Firefox to a window from another application and back to Firefox. This too is a new behavior. But, neither mouseover nor mouse click will change focus to another Firefox window.

Asked by Bulbman 2 weeks ago

Answered by Bulbman 2 weeks ago

  • Solved

Using Firefox via Linux Ubuntu 20.4 for Crypto trading

Receiving the following message when trying to log onto well know and compliant crypto website: 403 ERROR The request could not be satisfied. Request blocked. We can't co… (read more)

Receiving the following message when trying to log onto well know and compliant crypto website:

403 ERROR The request could not be satisfied. Request blocked. We can't connect to the server for this app or website at this time. There might be too much traffic or a configuration error. Try again later, or contact the app or website owner. If you provide content to customers through CloudFront, you can find steps to troubleshoot and help prevent this error by reviewing the CloudFront documentation.

Never had this problem in recent past, only after updating Firefox to 93 (64-bit) Linux Ubuntu 20.4. I DON'T USE CLOUDFRONT. So what else may be the issue? Thank you.

Asked by starseed99 2 weeks ago

Answered by FredMcD 2 weeks ago

  • Solved

Addons Seem to be Broken Lately

I have been unable to figure out how I've managed to make my addons no work properly. I've tried running them in debug mode, but I'm not particularly adept in debugging a… (read more)

I have been unable to figure out how I've managed to make my addons no work properly.

I've tried running them in debug mode, but I'm not particularly adept in debugging addons.

I've reset Firefox back to default a few times, addons seem okay, and then as soon as my Firefox account syncs and installs my installed addons they go back to wonky.

I can't seem to attach images RN, Firefox (Nightly) crashes every time I click on the button.

The behavior can be described as the addons when clicked have a blank page as their contents, and some addons (Like Dark Reader) just have like a sliver of a drop down with no contents.

If you'd like me to grab some debug data from wherever just let me know.

Asked by aaron.nixon 1 month ago

Answered by aaron.nixon 2 weeks ago

  • Locked

Youtube Message For Rented Video "! Sorry, there was an error licensing this video" Fix Needed

Cannot get rented/paid Youtube or Netflix video to run. Message "! Sorry, there was an error licensing this video" pops up onYoutube screen every time when hitting play … (read more)

Cannot get rented/paid Youtube or Netflix video to run. Message "! Sorry, there was an error licensing this video" pops up onYoutube screen every time when hitting play button. "Free" Youtube videos work just fine, paid content gets this message. Have firefox-9.5.0.2.ta.bz2, use Linux updated software. Followed all previous suggested Support, cannot seem to find fixes that included DRM, Safemode switch, etc. Thanks for previous help, still stuck... anymore ideas appreciated. Also, difference between running "normal and beta", please explain, and how to know "differences?"

Asked by Gerb 2 weeks ago

Last reply by jscher2000 2 weeks ago

  • Solved

Tab title causes resizing of tab content

When video/audio starts playing on a browser, the tab title displays 'playing' text. This additional line resizes the window height and causes the tab content to resize t… (read more)

When video/audio starts playing on a browser, the tab title displays 'playing' text. This additional line resizes the window height and causes the tab content to resize too. For example youtube starts resizing video window height and width - and this is very annoying. How do I remove 'playing' text from tab FOREVER?

Asked by smalex9 4 months ago

Answered by jonzn4SUSE 4 months ago

  • Solved

Firefox doesn't recognize FQDN when saving password for website

Hello, I've had this issue for a long time but now it actually bugged me enough to ask about it. Let's say I have an app with one set of credentials at https://website1.x… (read more)

Hello, I've had this issue for a long time but now it actually bugged me enough to ask about it.

Let's say I have an app with one set of credentials at https://website1.xyz.com

I also have another web app at https://webmail.xyz.com

Firefox only offers to remember credentials for xyz.com so whenever i access any of those websites above i have to juggle between credentials.

Is it possible for firefox to remember passwords separate for whole FQDN?

Asked by fabulousmcc 2 weeks ago

Answered by TyDraniu 2 weeks ago