Showing questions tagged: Show all questions
  • Solved
  • Archived

always open link from history library in new tab

I like to open all urls and links in a new tab because then I don't loose the original tab's contents. So I have set browser.tabs.loadBookmarksInTabs to true. Alas if I c… (read more)

I like to open all urls and links in a new tab because then I don't loose the original tab's contents. So I have set browser.tabs.loadBookmarksInTabs to true. Alas if I click on a link in the history library it still replaces the actual tab. I know that I can do a middle click or a right click to get a new tab but I would appreciate if I could set the standard behavior to open a new tab. Is there a setting for this?

Asked by ffsync5 6 months ago

Answered by the-edmeister 6 months ago

  • Solved

Help debugging popup windows

Not sure what the right place for this is; I wasn't able to find a Firefox support forum specifically for web developers. If anybody knows of a more appropriate forum, pl… (read more)

Not sure what the right place for this is; I wasn't able to find a Firefox support forum specifically for web developers. If anybody knows of a more appropriate forum, please let me know.

I'm trying to intercept the opening of a popup window from JavaScript, but I can't find any way to trigger the debugger on this condition, and I don't want to set the breakpoint manually because the source I'm working with is obfuscated and it would take a lot of work to track it down manually. I currently have Firefox 68 ESR, but I could upgrade if needed. Does any version of Firefox have a way to set a breakpoint on new tabs/windows opened from JavaScript, or is there a way to break on the `window.open` function which I suppose is what is being used?

Asked by jakob6 2 weeks ago

Answered by jakob6 2 weeks ago

  • Solved

Firefox Profile Compatibility

I am setting up a new desktop and want to copy my Firefox profile from one Linux desktop to another. In the past I have just used sync and then had to go thru the process… (read more)

I am setting up a new desktop and want to copy my Firefox profile from one Linux desktop to another. In the past I have just used sync and then had to go thru the process of making all the config adjustments and tweaking other settings that are not part of sync. I just copied over my Thunderbird profile and it was a perfect copy and paste. Unfortunately I have tried twice with FF and its not working. Keep getting the message that the profile being copied in is from an older version. That's not true however the one being copied in is from 77.0.1 and the new desktop being pasted into is 71.0. Any idea what I am doing wrong that's an easy fix? Thanks.

Asked by spur4 1 month ago

Answered by cor-el 1 month ago

Youtube says "Your browser does not currently recognize any of the video formats available." / Amazon Prime "Video Unavailable" on Linux (Centos 8.1)

Some Youtube videos say "Your browser does not currently recognize any of the video formats available. " and Amazon Prime "Video Unavailable" is also fixed by this. I fix… (read more)

Some Youtube videos say "Your browser does not currently recognize any of the video formats available. "

and Amazon Prime "Video Unavailable" is also fixed by this.

I fixed this by installing FFMPEG which installs libavcodec.so.58

DRM Playback is enabled under preferences.

Asked by FirefoxBob 3 weeks ago

Last reply by James 3 weeks ago

Firefox will system prevent to hibernate

I am using Windows 7 64bit. For some time I have noticed that in about 50% of cases Firefox prevents the system from shutting down in hibernate mode. Instead, the Windows… (read more)

I am using Windows 7 64bit. For some time I have noticed that in about 50% of cases Firefox prevents the system from shutting down in hibernate mode. Instead, the Windows login dialog appears again. If I terminate Firefox before shutting down the system, the system will shut down correctly in hibernate mode. Any idea what that could be?

Best regards,

Walter Hahn

Asked by walter.hahn 3 weeks ago

Open JPEG picture in Firefox with Paint

Hi everyone, When I open a PDF file on Firefox, it is opening with Adobe Reader. But when I click in a link of a picture in JPEG format en Firefox, it is opening in a new… (read more)

Hi everyone,

When I open a PDF file on Firefox, it is opening with Adobe Reader. But when I click in a link of a picture in JPEG format en Firefox, it is opening in a new tab in the browser. I would like to set by default paint. How can I change that please ?

Best regards,

NK

Asked by najith.kalairuban 3 weeks ago

Last reply by cor-el 3 weeks ago

How do I fix my orxy settings?

I get this error message: The proxy server is refusing connections Firefox is configured to use a proxy server that is refusing connections. Check the proxy settings t… (read more)

I get this error message:

The proxy server is refusing connections

Firefox is configured to use a proxy server that is refusing connections.

   Check the proxy settings to make sure that they are correct.
   Contact your network administrator to make sure the proxy server is working.

What do I have to do to fix this?

Asked by L. Kent Lederer 3 weeks ago

Last reply by cor-el 3 weeks ago

WebRTC with Janus Websockets and Asterisk no sound, 78esr

We have a server running Debian Buster with Janus and Asterisk installed using the standard Debian packages. Using the standard Janus test page to make calls through our … (read more)

We have a server running Debian Buster with Janus and Asterisk installed using the standard Debian packages. Using the standard Janus test page to make calls through our server via the Websockets interface, we have no problems with any of the Firefox 68esr browsers, but after upgrading to the latest 78esr browser, we have no audio after the call connects if we initiate the call from Windows 10. Using Linux or Mac 78esr (or any OS with Chrome) to initiate the call audio is working, even if the answering browser is 78esr on Windows 10.

Looking in the Asterisk and Janus logs for working and silent calls, they appear identical (opus codec selected in all cases), and there are no errors in the Web Console after upgrading adapter.js to 7.4.0.

Is there a known problem with websockets and 78esr?

Asked by raymond.field 3 weeks ago

nothing loads

Firefox won't load any pages at all, the home page is blank and I've tried several things to try and fix it such as restarting my laptop and reinstalling Firefox. I've tr… (read more)

Firefox won't load any pages at all, the home page is blank and I've tried several things to try and fix it such as restarting my laptop and reinstalling Firefox. I've tried safe mode but everything's still blank on there so I know it isn't my addons. Any help is appreciated!

Asked by crammitjammit 3 weeks ago

Will not permit me to load an old profile. Your instructions on the recovering data page just feed me into an endless loop of prompts to create a new profile.

Will not permit me to load an old profile. Your instructions on the recovering data page just feed me into an endless loop of prompts to create a new profile. The old pr… (read more)

Will not permit me to load an old profile. Your instructions on the recovering data page just feed me into an endless loop of prompts to create a new profile.


The old profiles had my logins for work. I would prefer not to have to spend hours resetting something like 15-20 logins and profiles and then the next two months forgetting what the new ones are.

Asked by andrewchalk88 4 weeks ago

Last reply by cor-el 3 weeks ago

Compiling FF78: "Could not find artifacts for ... "win32-minidump-stackwalk""

So I'm trying to compile the newest FF78 (W7x64). hg pull && hg update Now as usual, "mach" annoyingly complains about some compiler being outdated, so as ev… (read more)

So I'm trying to compile the newest FF78 (W7x64).

   hg pull && hg update


Now as usual, "mach" annoyingly complains about some compiler being outdated, so as every month I have to

   mach bootstrap


I select 2 (normal FF), it downloads "node.tar.bz2", then "fix-stacks.tar.bz2" and then crashes with "Could not find artifacts for a toolchain build named `win32-minidump-stackwalk`".

So what exactly does it want me to do and why does this happen?

"mach clobber python" does not work.


Thank you


Full log:

    0:05.83 Setting up artifact node.tar.bz2
    0:05.84 Using artifact from local cache: ...\mozbuild\toolchains\97a30da439a065e2-node.tar.bz2
    0:05.93 rm tree: ...\mozbuild\node
    0:09.68 untarring "...\mozbuild\node.tar.bz2"
    0:05.72 Setting up artifact fix-stacks.tar.bz2
    0:05.73 Using artifact from local cache: ...\mozbuild\toolchains\7857866b42f45825-fix-stacks.tar.bz2
    0:05.79 rm tree: ...\mozbuild\fix-stacks
    0:05.79 untarring "...\mozbuild\fix-stacks.tar.bz2"
    0:05.53 Could not find artifacts for a toolchain build named `win32-minidump-stackwalk`. Local commits, dirty/stale files, and other changes in your checkout may cause this error. Make sure you are on a fresh, current checkout of mozilla-central. If you are already, you may be able to avoid this error by running `mach clobber python`. Beware that commands like `mach bootstrap` and `mach artifact` are unlikely to work on any versions of the code besides recent revisions of mozilla-central.
   Error running mach:
       ['bootstrap']
   The error occurred in code that was called by the mach command. This is either
   a bug in the called code itself or in the way that mach is calling it.
   You can invoke |./mach busted| to check if this issue is already on file. If it
   isn't, please use |./mach busted file| to report it. If |./mach busted| is
   misbehaving, you can also inspect the dependencies of bug 1543241.
   If filing a bug, please include the full output of mach, including this error
   message.
   The details of the failure are as follows:
   subprocess.CalledProcessError: Command '['...\\mozilla-build\\python3\\python3.exe', '...\\mozilla-source\\mozilla-relea
   se\\mach', 'artifact', 'toolchain', '--from-build', 'win32-minidump-stackwalk']' returned non-zero exit status 1.
     File "...\mozilla-release\python/mozboot/mozboot/mach_commands.py", line 44, in bootstrap
       bootstrapper.bootstrap()
     File "...\mozilla-release\python/mozboot\mozboot\bootstrap.py", line 544, in bootstrap
       checkout_root)
     File "...\mozilla-release\python/mozboot\mozboot\bootstrap.py", line 400, in maybe_install_private_packages_or_exit
       self.instance.ensure_minidump_stackwalk_packages(state_dir, checkout_root)
     File "...\mozilla-release\python/mozboot\mozboot\mozillabuild.py", line 156, in ensure_minidump_stackwalk_packages
       minidump_stackwalk.WINDOWS_MINIDUMP_STACKWALK)
     File "...\mozilla-release\python/mozboot\mozboot\base.py", line 358, in install_toolchain_artifact
       subprocess.check_call(cmd, cwd=state_dir)
     File "...\mozilla-build\python3\lib\subprocess.py", line 291, in check_call
       raise CalledProcessError(retcode, cmd)

Asked by sdagfk 1 month ago

Last reply by sdagfk 1 month ago

Not prompted for master password

Hi, For some unknown reason, Firefox does not prompt me for the master password. This started happening after I opened quite a lot of tabs few weeks back. The prompt used… (read more)

Hi,

For some unknown reason, Firefox does not prompt me for the master password. This started happening after I opened quite a lot of tabs few weeks back. The prompt used to pop up on Firefox start up. But now it doesn't. I would have to do something to manually pop up the prompt. By something I mean, trying to save a password on a site, go to login page of a site, click on view logins etc. I'm not sure why this odd behavior is been shown. Any clues on how I could debug the issue?

Asked by ninostephen.dev 1 month ago

Last reply by ninostephen.dev 1 month ago

  • Solved

Is it possible to change the settings for the auto-selection of the URL in the address bar?

Hi all, I just changed to Firefox ESR since some websites are not being correctly displayed in the "normal" firefox, this version works much better but I don't like that … (read more)

Hi all, I just changed to Firefox ESR since some websites are not being correctly displayed in the "normal" firefox, this version works much better but I don't like that when I click in the address bar I have to double-click to select the URL, not like in the "normal" firefox, so, I just want to know if there is a way to change to when I click it automatically the URL gets selected. Thanks!

I am using Firefox Extended Support Release 68.10.0esr (64-bit) in MX Linux 19.2

Asked by TheGhost 1 month ago

Answered by ARMAN KHAN 1 month ago

Pop up appears in 1st Display when the firefox is in second display

Hello, I am using SAP CRM using Firefox. I always open my Firefox in second display and always i need the pop up to appear on the second display where my Firefox is opene… (read more)

Hello,

I am using SAP CRM using Firefox. I always open my Firefox in second display and always i need the pop up to appear on the second display where my Firefox is opened.

But the pop up just shifts to the first screen each time

I don't have this issue in Chrome or the edge

Asked by sudheerkrishnan85 1 month ago