Showing questions tagged: Show all questions
  • Solved
  • Archived

Browser Console

Trying to debug very simple javascript in a small web page. I turned on the chrome javascript console when I run my file and then ctrl-shift-j I get an error report o… (read more)

Trying to debug very simple javascript in a small web page. I turned on the chrome javascript console when I run my file and then ctrl-shift-j I get an error report on code that is not mine -- lots of references to recipebox -- and dont get any help with my own page.

Asked by jean01 2 years ago

Answered by Shadow110 2 years ago

  • Solved
  • Archived

How can I view what the cookie content is?

I am a new developer and I'm trying to learn how cookies work, but I don't know how to view what the actual cookie value is, so that I can check if I did it correctly. … (read more)

I am a new developer and I'm trying to learn how cookies work, but I don't know how to view what the actual cookie value is, so that I can check if I did it correctly. I see where you can set the defaults you want and enable or disable cookies, but where can you view the content in FireFox browser? I know in Google Chrome you can see all the cookies and their values in settings, content, cookies, view all. Thanx, Gil

Asked by gilbert2097 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

None of the "sha256" hashes in the integrity attribute match the content of the subresource

We created a web site that uses resources from cdnjs. This site has been live for a couple of months but we have sporadic issues with resources from this CDN and FireFox.… (read more)

We created a web site that uses resources from cdnjs. This site has been live for a couple of months but we have sporadic issues with resources from this CDN and FireFox.

  • The error in the console for each script/style CDN resource is: None of the "sha256" hashes in the integrity attribute match the content of the subresource.
  • The error message in the network tab for each resource is: The connection used to fetch this resource was not secure

Resources that I have had issues with include these elements (as they appear in our web page):

Steps to reproduce

You can reproduce the problem with one of the above URLs and place it directly in the URL of the FireFox browser. The resource should load in the browser window but after pressing CTRL+F5 at least one time (could be up to 5 times) an error will appear. I can duplicate this from multiple PCs although we are located in the Netherlands so maybe a timing issue or something? This does not happen with any other resources from other CDNs that we are using like (we use integrity checks with these as well):

My environment:

  • Windows 10 Pro 64bit patched to latest
  • FireFox 60.0.1 (64-bit)

My question

Is this an issue that is specific to cdnjs and they must resolve this or is this an issue with FireFox or is this an issue with how we are requesting the resource? Is there anything else that we can do to get the ball rolling on fixing this (depending on the actual source of the problem)?

As a side note we also test our software on Google Chrome, MS Internet Explorer, MS Internet Explorer 11, MS Edge, and Opera and we have

Thank you in advance!

-Igor

Asked by igorw 2 years ago

Answered by igorw 2 years ago

  • Solved
  • Archived

Firefox fails to start with any version newer than 57.04, Dozens of my users are affected.

Hi There, We have an issue with any version of Firefox after 57.04. It affects a few dozen of our users. It appears to be specific to our environment, but we need help tr… (read more)

Hi There,

We have an issue with any version of Firefox after 57.04. It affects a few dozen of our users. It appears to be specific to our environment, but we need help tracking the source of the issue. The issue in on Windows 10 and Windows 2016 operating systems.

Firefox appears to update successfully, but when we attempt to run it the process appears in task manager using 2.5mb of ram. Nothing else happens. No visible errors, and no windows open. After killing the process we can run the 57.04 installer to revert, which results in a perfectly functional Firefox.

The issue seems to be specific to our environment, but not specific to hardware platform.

We have tried many things: -Various installers and update paths/methods -Safe Mode -Removing addons prior to upgrade -Clean uninstall/install (including deleting firefox profiles) -Disable and uninstalled AV softwares. -Disabled Group Policy Objects.

Please let us know what troubleshooting steps we can take to locate the source of the problem.

Any help is appreciated!

Asked by ionymem 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

My website homepage displays fine in all other browsers including IE but not firefox 60.0.1. Not sure what to do!

First off, I am an analyst and not a professional web dev person. I'm using Divi on wordpress at Bluehost. I have a website that I'm building that displays fine in all ot… (read more)

First off, I am an analyst and not a professional web dev person. I'm using Divi on wordpress at Bluehost. I have a website that I'm building that displays fine in all other browsers including IE but not firefox 60.0.1.

I've tried safe mode and disabling acceleration with no luck. I've also tried simplifying the website to no avail as well. It's displaying fine in every other browser, but not here.

The About Us page also displays fine everywhere including firefox. There's something about the homepage that's not working. I've noticed that if I try to select all, it's treating text as an image or at least it doesn't let me select it. If I click and drag, the entire element moves.

Thank you in advance!

Asked by msawyer1 2 years ago

Answered by msawyer1 2 years ago

  • Solved
  • Archived

Change Firefox icon

I love Firefox, however it's missing a feature that would help me a lot. I'm a developer and I switch between the Development and Production web site a lot. I'm worried I… (read more)

I love Firefox, however it's missing a feature that would help me a lot.

I'm a developer and I switch between the Development and Production web site a lot.

I'm worried I do some action in Production thinking I'm in the Develop one. To minimize the risk there are some measures I take. 1- I use a different user in the Development version 2- The Development version as a different color 3- I use a different browser for Production (Chromium)

I would like to start using Firefox in Production too, but in order to make it safe I need to be able to change the Firefox icon in the Operating system status bar. This way I always see with icon in the Operation System status bar I should click to go to the Production Browser. If for security reasons the Firefox icon can not be changed for each profile, then if you add a "save to desktop" chrome like feature it should do the trick. In my particular use case, since the Development version does not have the favicon, It would be enough to Firefox display the favicon of the current selected tab instead of the Firefox icon.

Thanks

Asked by antcasq 2 years ago

Answered by TyDraniu 2 years ago

  • Solved
  • Archived

How To Log A Webpage Out Of A Site?

I am testing my own site. Where I need to log in with different User Accounts in order to check that aspect of IIS. Firefox only allows me to log in with one account - v… (read more)

I am testing my own site. Where I need to log in with different User Accounts in order to check that aspect of IIS.

Firefox only allows me to log in with one account - visiting that site again just automatically logs in with that same account. It doesn't present me with the log in fields. And, of course, a browser doesn't have a 'log out' button does it?

I want to be presented with the log in fields each time I go there, so's I can log in as a different user.

So I found a thread here that was similar, talking about someone with the opposite problem - constantly being logged out. And the answer was in about:preferences and such. Well I couldn't follow that trail because about:preferences didn't bring up the options that thread talked about.

I suppose the answer is a cookies thing. I'd like to resolve this without having to delete all cookies. If I can.



edit: removed spaces before each paragraph which caused horizontal scroll-bars.

Asked by abrogard 3 years ago

Answered by cor-el 3 years ago

  • Solved
  • Archived

Header image and text for website does not load properly on Firefox - image partially visible, some text squished.

First off, thanks to everyone who pitches in to help resolve this headache. Sheesh! Problem: The Header image and text do not display properly in Firefox: The content doe… (read more)

First off, thanks to everyone who pitches in to help resolve this headache. Sheesh!

Problem: The Header image and text do not display properly in Firefox: The content does displays properly in Chrome, Opera and Safari. By the way: I have read and attempted all the applicable troubleshooting suggestions Firefox has supplied without success.

Website: www.twoworlds.ca The page in question is www.twoworlds.ca/other-world.html

Note: I coded the site myself using largely a w3.css framework. Admittedly, the source code is messy. I'm still chimpin' around (experimenting) with things.

Incredibly, am unable to upload two 137 kb screen captures of the problem for visual reference - an endless spin wheel for 12-minutes. Wha..? In that case, please visit my site in Chrome and then Firefox to see the difference. the site again: www.twoworlds.ca/other-world.html

Thanks.

Asked by lance-uppercut 3 years ago

Answered by TyDraniu 3 years ago

  • Solved
  • Archived

Migrate Firefox 59.0.1 profiles/user data to ESR using account sync

We have a client that used to run on local computers running the latest ESR version, they recently changed to a terminal server environment and during the setup 59.0.1 ma… (read more)

We have a client that used to run on local computers running the latest ESR version, they recently changed to a terminal server environment and during the setup 59.0.1 made it onto their new setup. Multiple issues have arisen that were not present on the old system and we need to move them back to the ESR version on the terminal server environment. I read online that you cannot just directly import any profile versions 55.0 and up to earlier versions so I am asking if I can instead use a mozilla account to sync over their data instead without causing a catastrophe, and if anyone happens to know what I might expect afterwards if this could potentially work.

Asked by stacheman 3 years ago

Answered by cor-el 3 years ago

  • Solved
  • Archived

How do I install an unsigned addon on the Developer edition?

I want to install an unsigned addon that I made. I can load it temporarily via about:debugging, but I can't actually install it. Maybe I'm doing it wrong, I couldn't actu… (read more)

I want to install an unsigned addon that I made. I can load it temporarily via about:debugging, but I can't actually install it. Maybe I'm doing it wrong, I couldn't actually find any explicit instructions online, so I packed the files into a zip with a .xpi extension, and tried dragging it into the about:addons page. I get a "the addon could not be installed because it appears to be corrupt" error.

After reading this thread: https://support.mozilla.org/en-US/questions/1134589, I went and installed the developer version of Firefox Quantum, but I'm having the same problem.

Asked by Gaiajack 3 years ago

Answered by Gaiajack 3 years ago

  • Solved
  • Archived

Shopify login locks up Firefox developer edition on MacOS

I am running 59.0b13 (64-bit) on a MacBook Pro (Retina, 15-inch, Mid 2015) with MacOS 10.13.3 I develop a Shopify app and anytime I try to login to a Shopify stores admin… (read more)

I am running 59.0b13 (64-bit) on a MacBook Pro (Retina, 15-inch, Mid 2015) with MacOS 10.13.3

I develop a Shopify app and anytime I try to login to a Shopify stores admin panel. Firefox locks up and spins the CPU all the way up. I then have to force quit.

To replicate go to any Shopify store and add "/admin" to the domain.

Asked by corbinu 3 years ago

Answered by corbinu 3 years ago

  • Solved
  • Archived

sidebar

Using firefox developer edition, aurora update channel, 60.0b2 (64-bit), macOS 10.13.3. The functionality of the bookmarks sidebar has changed recently: command-clicking … (read more)

Using firefox developer edition, aurora update channel, 60.0b2 (64-bit), macOS 10.13.3. The functionality of the bookmarks sidebar has changed recently: command-clicking folders in the side bar used to be a shortcut to "open all in tabs" for that folder. Now command-clicking selects that folder for multiple selection. Additionally the new behaviour is inconsistent with command-clicking a leaf node, which opens that specific bookmark in a new tab.

The old behaviour was incredibly useful for having categories of folders to open while still being able to select specific bookmarks. I think the new behaviour would be much better for this use case if you could multiple select a combination of folders and bookmarks, and additionally if after multiple selection there was an option for "open all in tabs". Currently having multiple folders selected does not have this option. Was the change intended? Is the only alternative (outside of enabling bookmarks toolbar) individually clicking bookmarks?

Asked by fudgekk 3 years ago

Answered by philipp 3 years ago

  • Solved
  • Archived

Firefox Dev can’t establish a connection to local server

I'm a web developer that setup a local environment under Linux Mint. For some reason, Firefox Developer Edition (59.0b7 64-bit) cannot access sites on my localhost. The i… (read more)

I'm a web developer that setup a local environment under Linux Mint.

For some reason, Firefox Developer Edition (59.0b7 64-bit) cannot access sites on my localhost. The interesting thing is that Firefox Quantum 58.0.1 (64-bit) is showing these local sites perfectly fine. I've tested other browsers, including Konqueror and Lynx, and these work fine also.

I've setup my environment so that apache2 can serve pages from a 'wildcard' virtual host. Using symlinks, I can link my project files to another directory that functions as the web root. Thus:

/home/me/business/projects/client/index.html => /home/me/business/www/client/index.html

Navigating to http://client.dev brings up the page perfectly in Firefox 58, Konqueror, and Lynx.

However, Firefox Developer Edition, AND Google Chrome, both fail to load the page. The URL changes from http://client.dev to https://client.dev and throws this message:

"Unable to connect

Firefox can’t establish a connection to the server at client.dev."

I've played around with the about:config settings for Network.dns.* but nothing seems to help. Also, the apache logs do not produce anything useful.

Your input will be greatly appreciated.

Asked by Alan W 3 years ago

Answered by Alan W 3 years ago

  • Solved
  • Archived

Can't enter login details on a website

Dear all On of the websites I have editors right on doesn't have SSL installed. Since I upgraded to Firefox Quantum, when I go to the login page, I can't enter my login d… (read more)

Dear all

On of the websites I have editors right on doesn't have SSL installed.

Since I upgraded to Firefox Quantum, when I go to the login page, I can't enter my login details anymore. The field is not clickable. It works on other browsers.

Firefox does warn me that the website is insecure, but how can I go through anyway ?

Thank you !

Asked by manoucho 3 years ago

Answered by FredMcD 3 years ago

  • Solved
  • Archived

unable to register service worker

I am developing a web application that requires the use of service worker from firebase messaging, before updating to firefox quantum version this was working fine, local… (read more)

I am developing a web application that requires the use of service worker from firebase messaging, before updating to firefox quantum version this was working fine, localhost was the url for testing and i also saw the correct results on the production url site, just after doing the update for quantum this stopped working and i don't quite know why it isn't working as firebase only throws a messaging saying that it is unable to register.

OS: Linux Debian/Ubuntu 16.04 x64 Browser: Firefox quantum 57.0 (64-bit)

Asked by nosthertus 3 years ago

Answered by nosthertus 3 years ago

  • Solved
  • Archived

FF 57.0.1 does not uninstall FF 57.0

When installiing FF 57.0.1: FF 57.0 stays installed (Program and functions - Windows 7 Pro 64 Bit) What to do (for plenty of clients)? Thanks - Michael … (read more)

When installiing FF 57.0.1: FF 57.0 stays installed (Program and functions - Windows 7 Pro 64 Bit)

What to do (for plenty of clients)?

Thanks - Michael

Asked by sg08234 3 years ago

Answered by cor-el 3 years ago

  • Solved
  • Archived

Firefox quantum wrong window behavior in windows 10

I have Windows 10 in my work pc and installed firefox quantum however the browser window does not act properly like other OS windows, the following issues I've noticed. 1… (read more)

I have Windows 10 in my work pc and installed firefox quantum however the browser window does not act properly like other OS windows, the following issues I've noticed.

1. I cannot grab the window from the top bar to drag into another screen or move around when fully maximized 2. If I not fully maximize the windows I do not get the arrow to adjust it from the borders. 3. Sometimes If i fully maximize the minimize and maximize buttons disappear. 3. Sometimes if I minimize it I cannot maximize it back ever I have to kill the browser.

I have removed all my extensions and customizations from the browser. Tested in private window mode with same results. Checked the prevent accessibility services from accessing your browser and nothing changed.

Asked by Manuel 3 years ago

Answered by Manuel 3 years ago

  • Locked
  • Archived

When firefox says: a web page is slowing down your browser what do you want to do? >wait >stop it, does it let the page continue by default?

I created a javascript script that generates the mandlebrot set using P5.JS . It's worked fine for smaller versions, but now I want to try creating a large version to sav… (read more)

I created a javascript script that generates the mandlebrot set using P5.JS . It's worked fine for smaller versions, but now I want to try creating a large version to save as my desktop image, however Firefox keeps telling me: "a web page is slowing down your browser what do you want to do?" then giving me the choice between "wait" and "stop it". If I click wait, it will shortly ask me again. This is annoying for two reasons: I don't know if the script will continue if I don't click wait, and I want to just leave my computer for a few hours while it works stuff out, which I can't do if I constantly have to click wait and I don't need telling the browser is being slowed down, I know that will happen as a result of my script.

Is there anything I can do to get rid of this message for my specific page? Will Firefox continue to run my script if I don't click wait.

Asked by biltimi 3 years ago

Last reply by Rafael Lecuona 3 years ago

  • Solved
  • Archived

mp4 color is different on Firefox

We're experiencing a strange bug. We created a page with an embedded mp4. Both of them have the same background color. On Chrome and IE the background color stays the sam… (read more)

We're experiencing a strange bug. We created a page with an embedded mp4. Both of them have the same background color. On Chrome and IE the background color stays the same, but on Firefox, the video has different colors.

We created this demo so you can view the bug as well: http://downloads.perplex.eu/firefox/index.html


Hope you can help.

Kind regards,

Henk van der Velden

Asked by henkvandervelden 3 years ago

Answered by henkvandervelden 3 years ago