Commit view on GitHub with FireFox broken

Hello, First let me thank Mozilla again for a great experience. I've been using Firefox as my main browser for many years and since some time I also started supporting Mo… (read more)

Hello, First let me thank Mozilla again for a great experience. I've been using Firefox as my main browser for many years and since some time I also started supporting Mozilla financially with whatever little I can with recurring payments. To the problem: since some time patch / commit view on HitHub with Firefox is broken. I guess many @mozilla have github accounts so you can open and read https://support.github.com/ticket/1318472 but to summarise: my first entry there was: ``` When viewing Linux kernel style Pull Requests on GitHub, using Firefox, TABs are displayed as 4 spaces, which is confusing, since the default is 8 spaces, which is also what is displayed in chrome and chromium. E.g. https://github.com/thesofproject/sof/pull/4747/commits/e9cc9312841a9329797b0b676335c8cb1a0dc779 ``` then a screenshot (attached) and a clarification to it: ``` As you can see there the patch area between lines 238 and 245 is wrongly indented by 4 spaces, whereas areas above and below are correctly indented by 8 spaces. ``` Then more: ``` No, space isn't used for indentation in that code. They can download raw code and verify, I'm sure they know how to do that. Why don't they just reproduce that themselves? Start Firefox, navigate to any PR commit like https://github.com/thesofproject/sof/pull/4884/commits/b19a64df2c2fcd63d7407ef500fd3312287c8995 and click arrows above and below the diff to display surrounding code. Then navigate to or download the raw patch https://github.com/thesofproject/sof/commit/b19a64df2c2fcd63d7407ef500fd3312287c8995.patch to see TABs used everywhere. Should be very easy to verify. ``` and their last reply was ``` From a technical standpoint this is not a regression. It's a problem with the way firefox interprets the combination of the tab-size css and the particular markdown we use for our diffs.

After reviewing the Issue in more detail there it has not been prioritized and will most likely not be addressed in the near future. ``` This is a deal-breaker for me. I spend hours daily reviewing GitHub pull requests. And I'd really not want to use a different browser just because of this... Please help! Thanks Guennadi

Asked by lyakh 1 day ago

Windows 10 hiding taskbar not working when Firefox is "over" the taskbar.

Whenever Firefox is over the taskbar or maximized, with the "Automatically hide the taskbar in desktop mode" option enabled on Windows 10; the taskbar doesn't 'unhide' wh… (read more)

Whenever Firefox is over the taskbar or maximized, with the "Automatically hide the taskbar in desktop mode" option enabled on Windows 10; the taskbar doesn't 'unhide' whenever you hover over it.

This screenshot shows Firefox maximized with the 'taskbar' (the 1px high white bar): https://i.imgur.com/Ys63fGN.png This recording shows Firefox not allowing the taskbar to 'unhide' when it's over it: https://i.imgur.com/G4Vy3r5.gif

I should also add that I am using Firefox Nightly, this does not seem to be happening on the stable release of Firefox.

Asked by walter 2 days ago

Firefox on Raspberry Pi 4 with Raspbian

Firefox crashes on my Raspberry Pi 4 while it is trying to sync my account data. How to sync and no crashes? I Have installed the latest updates and the version of firefo… (read more)

Firefox crashes on my Raspberry Pi 4 while it is trying to sync my account data. How to sync and no crashes? I Have installed the latest updates and the version of firefox is 91.5.0esr. The browser crashes nearly immediatly after the start, so I am not able to retrieve more data from the crash.

Asked by wpasman 2 days ago

Firefox & Chrome Do Not Open Website Horizontally but Dropdown or Vertically

I have Firefox Browser 96.0.2 (64-bit) and Google Chrome Version 97.0.4692.99 (Official Build) (x86_64). installed in my MacBook Pro early 2013 macOS Catalina Version 10.… (read more)

I have Firefox Browser 96.0.2 (64-bit) and Google Chrome Version 97.0.4692.99 (Official Build) (x86_64). installed in my MacBook Pro early 2013 macOS Catalina Version 10.15.7. And I've got this error message, "Warning! Internet Explorer should not be used for proper operation of the Administrator Backend" when I opened my website, ulattime.com/ulattime/administrator," which opens vertically or downward or dropdown, instead of "horizontally" and I don't have "Internet Explorer" browser. Please see screenshot, https://imgur.com/zNMVSSf. I used FireFox and Chrome either as default and had now removed it as default as the same error message happened when I used these browsers. I went to “Network Setting” of Firefox and tried “Manual proxy configuration” and I also enabled “DNS over HTTPS” and “Use Provider” “Cloudfare”(Default) and “NextDNS” and “Custom” but nothing happened. But in Safari, my website opens "horizontally" so I am keeping Safari as my default browser for now. If Firefox or Chrome opens "horizontally," I can restore either of them as my default browser again. Thank you.

Joseph Lariosa [removed email from public]

Asked by ontherecord 4 days ago

Last reply by ontherecord 2 days ago

Some bookmarks cannot display icons

For example, https://whatismyipaddress.com/ https://www.quora.com/ https://mail.protonmail.com/ The site's icons display normally on chrome and edge, but not on Firefox, … (read more)

For example, https://whatismyipaddress.com/

https://www.quora.com/

https://mail.protonmail.com/

The site's icons display normally on chrome and edge, but not on Firefox, either by readding the bookmark or reloading Firefox

Version: Windows 64bit Release 96.0.2

Asked by 一眼丁真 2 days ago

Last reply by 一眼丁真 2 days ago

setting to warn before closing multiple tabs didn't work!

I accidentally clicked on the x in private mode. It didn't warn me before closing the many many open tabs in private mode!!! What the heck?! Firefox is updated to the lat… (read more)

I accidentally clicked on the x in private mode. It didn't warn me before closing the many many open tabs in private mode!!!

What the heck?!

Firefox is updated to the latest version that was offered.

I'm using an ancient" machine but that shouldn't matter. If the box is checked to warn me first, then it always should, regardless what operating system or mode I'm in.

Very disappointed. Please fix or advise a solution I might try to prevent something similar in the future.

But I don't know what in the world I could have possibly done differently.

One checkbox being checked that claims to be to receive a warning before closing multiple tabs at once should be enough.

Asked by God so loved 2 days ago

Last reply by God so loved 2 days ago

Devtools inspector, right mouse click on menu, freezes Firefox.

Win 7 64 bit. Latest FF update, 96.0.2 Right mouse click on open page brings up menu box. Clicking on devtools inspector and screen grays out. FF locks up. ctrl-alt-del … (read more)

Win 7 64 bit. Latest FF update, 96.0.2 Right mouse click on open page brings up menu box. Clicking on devtools inspector and screen grays out. FF locks up. ctrl-alt-del and kill the process the only remedy

Asked by RyanT 2 days ago

Weird red logo showing in some websites on Firefox

Hi there! For the past 3 days, my browser has started to show in some websites a weird red window (kinda reminds me of the youtube logo with inverted colors!). I've alre… (read more)

Hi there! For the past 3 days, my browser has started to show in some websites a weird red window (kinda reminds me of the youtube logo with inverted colors!). I've already tried 4 antiviruses, 3 antimalware, and I've tried reinstalling the browser cleanly but the issue keeps happening. The other browsers (Chrome, Opera, Edge) are working just fine. The issue happens only on some websites and not at all of them. What should I do now? Thank you!

Asked by ligiaflg 3 days ago

Last reply by ligiaflg 2 days ago

Your system has run out of application memory

On a MacBook Air with MacOS Monterey 12.1, I use Firefox 96.0.2 and Thunderbird 91.5.0. I bought this MacBook in October 2021, with 16 GB of unified RAM and 1 TB of main … (read more)

On a MacBook Air with MacOS Monterey 12.1, I use Firefox 96.0.2 and Thunderbird 91.5.0. I bought this MacBook in October 2021, with 16 GB of unified RAM and 1 TB of main memory, of which 380 GB are available. Annoyingly, I get the message "Your system has run out of application memory." regularly, seriously interrupting my work, because I have to force quit Firefox and/or Thunderbird. This even happens about a day after restart.

In a typical instance, memory usage is: DeepL 67.7 MB Firefox 2.03 GB Preview 334.1 MB Thunderbird 907.4 MB Finder 75.0 MB

The answers I see on Mozilla Support do not solve my problem. In ~/Library/Application\ Support/Firefox/Profiles/aurrzm6j.default and in ~/Library/Caches/Firefox/Profiles/aurrzm6j.default, I see nothing whose name relates to Firefox.

After many and long telephone sessions with Apple Support, they conclude that my hardware, in particular the RAM module, is perfectly fine and the problem lies with lacking adaptation of the Mozilla software to the system I use.

My questions to Mozilla: Is this a known problem? Does it occur with other users as well? What is Mozilla's stand on Apple's assessment?

Sincerely, Joachim von zur Gathen

Asked by gathen 2 days ago

Cannot stream verizon tv on pc after recent firefox updates

When I try to launch Verizon TV on my computer, all I see is a red spinning circle. This started happening two or 3 days ago after a firefox update. I was hoping that tod… (read more)

When I try to launch Verizon TV on my computer, all I see is a red spinning circle. This started happening two or 3 days ago after a firefox update. I was hoping that today's update would fix this but it did not.

As suggested, I un-checked the DRM Content box but that did not resolve the issue. Nor did disabling the Widevine plug-in. When I did that, I receive the message, "You must enable DRM to play some audio or video on this page.. When I click the Enable DRM button, I see the same spinning red circle.

Since I have no issues watching Verizon TV on Chrome, this appears to be a Firefox/Widevine issue. Hopefully, it will be resolved shortly.

Asked by jddempsey88 4 days ago

Last reply by jddempsey88 2 days ago

Full Screen Mode - Strange Gap between Tabs/Windows Bar and Apple Menu Bar

Dear Firefox Team, Would really need your help regarding an issue I am facing with the MacBook Pro 14inch... I have noticed in Full Screen Mode, there seems to be a gap … (read more)

Dear Firefox Team,

Would really need your help regarding an issue I am facing with the MacBook Pro 14inch...

I have noticed in Full Screen Mode, there seems to be a gap between the Windows Bar and the Apple Menu Bar. Please let me know how I can solve this.

Asked by Sean John 2 days ago

The background colour for some parts of the webpages has changed making it hard to read.

I know and admit I stuffed up. One day a long time ago I was prompted for my master password. When I clicked in that area/field a requester popped up asking me to pick a … (read more)

I know and admit I stuffed up.

One day a long time ago I was prompted for my master password.

When I clicked in that area/field a requester popped up asking me to pick a colour. Confused I picked one - and a bad one I now see.

So now when certain parts of a web page are opened the background colour is this horrible colour and I can't really read what is there.

I don't understand what I did or HOW I did it.

This is a cropped example of the bad contrast I am seeing.

file:///home/me/Pictures/Screenshot%20from%202022-01-22%2010-09-48.png

As I said, I admit I stuffed up. But this seems to all have happened since that one time with the main password requester.

Asked by teeny_weeny 5 days ago

Last reply by teeny_weeny 2 days ago

Trust Manager

I'd like to enable the Trust Manager for a series of PDF files. However, even though I've tried several times to do so through the Edit/Preferences function, I've not be… (read more)

I'd like to enable the Trust Manager for a series of PDF files. However, even though I've tried several times to do so through the Edit/Preferences function, I've not been able to do so. Nothing changes. I remain unable to access the docs.

Please help to enable this function?

Asked by gloriathiessen 5 days ago

Last reply by gloriathiessen 2 days ago

Images not populating in tabs

The images or symbols for different websites are not loading in tabs. I have reset several times. I have closed out of the widows and nothing. Is there a fix to have tab … (read more)

The images or symbols for different websites are not loading in tabs. I have reset several times. I have closed out of the widows and nothing. Is there a fix to have tab images populate normally? I attached a snip of 4 different websites all had images in 2021 and now they will not load.

Asked by szbradfo 3 days ago

Last reply by szbradfo 2 days ago

Need old account login either revived or deleted.

I have a login but didn't want to have sync issues with an old desktop so turned it off. Now I want to use it again to sync phone and new laptop. I have an email/password… (read more)

I have a login but didn't want to have sync issues with an old desktop so turned it off. Now I want to use it again to sync phone and new laptop. I have an email/password but it won't let me in and sets me on a long goose chase ending up with something I need to scan but that scan never shows up. I now have a new account, but can't add a secondary email because "account exists". I need my old account either revived (most preferred option, in that case I want the current account deleted) or, if that is too much to ask for, I want the old account deleted, and I can add a secondary email added to this account. Hope this is clear. Thanks for the help.

Asked by receptionist4 2 days ago

Can't print PDFs

I have been trying to print a PDF to my HP 7800 series printer from Firefox, but I can't get the PDF to print. The PDF appears briefly in my printer queue, then disappear… (read more)

I have been trying to print a PDF to my HP 7800 series printer from Firefox, but I can't get the PDF to print. The PDF appears briefly in my printer queue, then disappears.

I can print regular webpages just fine, and I can print the PDF using Acrobat. But printing from Firefox's print dialog or the system dialog doesn't work. Locally-saved PDFs, as well as those on a web server, don't print either.

I've tried:

Thanks in advance for your help!

Asked by ben_393 2 days ago

How can I stop Windows 8.1 system processes from using Internet Explorer instead of Firefox

I'm still running Windows 8.1 Pro and Firefox ESR is my default (& only other) installed browser. Internet Explorer Version 11.0.9600.20139 is still installed and tig… (read more)

I'm still running Windows 8.1 Pro and Firefox ESR is my default (& only other) installed browser. Internet Explorer Version 11.0.9600.20139 is still installed and tightly integrated in this version of Windows. Various application code seems to call Internet Explorer, creating a slew of cookies and temporary files, particularly during such operations as installing updates. Other code (such as "view this email in browser") ONLY works with Internet Explorer because it uses *.mht temporary space that Firefox is not permitted to access. Is there a way configure the system for many of these tasks so that Firefox is called instead? Or is this one of those "don't go there" ideas that only SEEMS like it would enhance security, but would really break the smooth running of my PC? Thanks!

Asked by brucequick 2 days ago

Menu Bar animation error and white blankbar appearace in full screen mode on 2021 M1 max macbook pro

I recently updated to the 2021 MacBook Pro with the notch. In full screen mode earlier, firefox lowers the tab bar when the menu bar was made visible. In the newer notch … (read more)

I recently updated to the 2021 MacBook Pro with the notch. In full screen mode earlier, firefox lowers the tab bar when the menu bar was made visible. In the newer notch models, themenu bas resides besides the notch, so a blank abr appears in place of it. I have tried messing in the config page but coulnt fix it. Any help?

Asked by ashesh8500 2 days ago