Showing questions tagged: Show all questions
  • Solved
  • Archived

Microphone Broken in latest update (109.0)

I recently updated my system (OpenSuse15.4) which included a Firefox update to version 109.0. I regularly use my mic for google voice, however even though I can select m… (read more)

I recently updated my system (OpenSuse15.4) which included a Firefox update to version 109.0.

I regularly use my mic for google voice, however even though I can select my microphone in Google voice, It never shows any input.

I tested my mic in other apps and it works fine. When I pull up my systems pulse audio volume control (pavucontrol), it does not show firefox in the recording tab like it used to when using Google Voice.

To test to see if it was a Google Voice error, I also tried testing my mic at https://mictests.com/, and zoom.com, but after selecting my desired input device, mictests.com was also unable to record anything, and again, pavucontrol did not show anything being recorded.

I have attached an image of pavucontrol that shows audacity recording audio. Normally, I would also see Firefox in this window when using the mic.

Asked by gnac 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Archived

slow opening of external links

Using firefox version 102.3.0esr (64-bit) on openSUSE Leap. Since a couple of weeks the opening of external links by clicking a link from any application or when running … (read more)

Using firefox version 102.3.0esr (64-bit) on openSUSE Leap. Since a couple of weeks the opening of external links by clicking a link from any application or when running firefox <url> is taking about 5 seconds when the browser is already open. This was always instantly and still is on same setup on laptop machine, both are updated to the most recent OS packages.

I've tried safe-mode, new profile, copied profile from the laptop, searched online for references but so far I can't pinpoint what the issue seems to be.

Any kind of information as to resolving this issue would be greatly appreciated.

Asked by dutchguy69 1 year ago

Last reply by jonzn4SUSE 1 year ago

  • Archived

after booting opensuse leap 15.4 firefox displays splashscreen instead of web pages

I have this ennoying issue since some months and didn't find a way of fixing it, even by completely deleting the app and removing all remnants of profiles before re-insta… (read more)

I have this ennoying issue since some months and didn't find a way of fixing it, even by completely deleting the app and removing all remnants of profiles before re-installing it. If I leave Firefox open when I shut down my computer, most of the time (but not every time!) instead of opening the last window with its tabs, Firefox displays the KDE Plasma's or OpenSuse's splash screen (which is a lamp bulb on a black background) and no menu). If I minimize the window, and maximize it again, it displays a screenshot of my desktop!... I can't do anything but close the window and re-launch firefox, but then the history of last closed windows is gone.

I have the same version of FF and the same version of OpenSuse on two other computers and never had this issue on them.

I would be grateful to anybody who could give me some tips to solve it or even investigate!

Thanks for reading. Erik

Asked by Erik 1 year ago

Last reply by Erik 1 year ago

  • Solved
  • Archived

Videos freeze when scrubbing back

For a few months, I have encountered an issue with videos playback on my browser. On most websites (including Reddit, Dailymotion, and even some videos on YouTube), whene… (read more)

For a few months, I have encountered an issue with videos playback on my browser. On most websites (including Reddit, Dailymotion, and even some videos on YouTube), whenever I scrub back a video, it will stop for about ten seconds, while the audio keeps playing.

My current extensions are: Metamask, Bionic Reader, uBlock Origin, Return Youtube Dislike, and TWP Translate Web Pages. I have tried using Troubleshooting mode, but the problem persisted, so I think it's not because of my extension.

My OS is Opensuse Tumbleweed, with Firefox version 155.0.3. I didn't have this issue with Firefox ESR on my previous Debian 11 installation. I hope someone can find a solution for this, as it is extremely troublesome switching to Chrome whenever I want to watch videos.

Asked by xuantung.trinh.63 11 months ago

Answered by zeroknight 11 months ago

my web browser always crashin firefox all distro gnome kde and xfce

I disabled graphics acceleration and I have the same problem. I tried several distros, it's the same thing each time, Firefox crashes and it's impossible to surf. could s… (read more)

I disabled graphics acceleration and I have the same problem. I tried several distros, it's the same thing each time, Firefox crashes and it's impossible to surf. could someone help me? I'm on opensuse thunbelweed




Signature core::option::expect_failed | webrender::scene_building::NodeIdToIndexMapper::get_spatial_node_index More Reports Search UUID 319ba611-fc97-439f-9456-a9e8d0240613 Date Processed 2024-06-13 05:28:23 UTC Uptime 78 seconds (1 minute and 18 seconds) Install Age 47,424 seconds since version was first installed (13 hours, 10 minutes and 24 seconds) Install Time 2024-06-12 16:15:12 Product Firefox Release Channel release Version 126.0 Build ID 20240509170740 (2024-05-09) Buildhub data OS openSUSE Tumbleweed OS Version 6.9.1-1-default #1 SMP PREEMPT_DYNAMIC Fri May 17 11:59:46 UTC 2024 (0c0b0b5) Build Architecture amd64 CPU Info family 23 model 24 stepping 1 CPU Count 8 Adapter Vendor ID

Advanced Micro Devices, Inc. [AMD/ATI] (0x1002)

Adapter Device ID

Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile Series] (0x15d8)

Startup Crash

False

Process Type parent MOZ_CRASH Reason (Sanitized)

no entry found for key

Crash Reason SIGSEGV / SEGV_MAPERR Crash Address 0x0000000000000000 Available Virtual Memory 4,520,636,416 bytes (4.52 GB) Available Page File 59,609,088 bytes (59.61 MB) Available Physical Memory 2,234,359,808 bytes (2.23 GB) EMCheckCompatibility

True

App Notes

openSUSE TumbleweedFP(D00-L1000-W0000000-T010) WR? WR+ libGL.so.1? libGL.so.1+ EGL? EGL- GL Context? GL Context+ WebGL? WebGL+

Crashing Thread (75), Name: WRScene~ilder#1 Frame Module Signature Source Trust 0 libxul.so RustMozCrash context 1 libxul.so mozglue_static::panic_hook /usr/src/debug/firefox-126.0/mozglue/static/rust/lib.rs:98 inlined 1 libxul.so core::ops::function::Fn::call /usr/src/debug/rustc-1.76.0-src/library/core/src/ops/function.rs:79 cfi 2 libxul.so std::panicking::rust_panic_with_hook cfi 3 libxul.so std::panicking::begin_panic_handler::{{closure}} cfi 4 libxul.so std::sys_common::backtrace::__rust_end_short_backtrace cfi 5 libxul.so rust_begin_unwind cfi 6 libxul.so core::panicking::panic_fmt cfi 7 libxul.so core::option::expect_failed cfi 8 libxul.so core::option::Option<T>::expect /usr/src/debug/rustc-1.76.0-src/library/core/src/option.rs:894 inlined 8 libxul.so <std::collections::hash::map::HashMap<K, V, S> as core::ops::index::Index<&Q>>::index /usr/src/debug/rustc-1.76.0-src/library/std/src/collections/hash/map.rs:1338 inlined 8 libxul.so webrender::scene_building::NodeIdToIndexMapper::get_spatial_node_index /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:141 inlined 8 libxul.so webrender::scene_building::SceneBuilder::get_space /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:1258 cfi 9 libxul.so webrender::scene_building::SceneBuilder::process_common_properties /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:1275 cfi 10 libxul.so webrender::scene_building::SceneBuilder::process_common_properties_with_bounds /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:1320 inlined 10 libxul.so webrender::scene_building::SceneBuilder::build_item /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:1435 cfi 11 libxul.so webrender::scene_building::SceneBuilder::build_all /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:977 inlined 11 libxul.so webrender::scene_building::SceneBuilder::build /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_building.rs:588 cfi 12 libxul.so webrender::scene_builder_thread::SceneBuilderThread::process_transaction /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_builder_thread.rs:593 inlined 12 libxul.so webrender::scene_builder_thread::SceneBuilderThread::run::{{closure}} /usr/src/debug/firefox-126.0/gfx/wr/webrender/src/scene_builder_thread.rs:314 inlined 12 libxul.so core::iter::adapters::map::map_try_fold::{{closure}} /usr/src/debug/rustc-1.76.0-src/library/core/src/iter/adapters/map.rs:92 inlined 12 libxul.so core::iter::traits::iterator::Iterator::try_fold /usr/src/debug/rustc-1.76.0-src/library/core/src/iter/traits/iterator.rs:2462 inlined 12 libxul.so <core::iter::adapters::map::Map<i> as core::iter::traits::iterator::Iterator>::try_fold /usr/src/debug/rustc-1.76.0-src/library/core/src/iter/adapters/map.rs:118 inlined 12 libxul.so >::call_once /usr/src/debug/rustc-1.76.0-src/library/core/src/panic/unwind_safe.rs:272 inlined 14 libxul.so std::panicking::try::do_call /usr/src/debug/rustc-1.76.0-src/library/std/src/panicking.rs:552 inlined 14 libxul.so std::panicking::try /usr/src/debug/rustc-1.76.0-src/library/std/src/panicking.rs:516 inlined 14 libxul.so std::panic::catch_unwind /usr/src/debug/rustc-1.76.0-src/library/std/src/panic.rs:142 inlined 14 libxul.so std::thread::Builder::spawn_unchecked_::{{closure}} /usr/src/debug/rustc-1.76.0-src/library/std/src/thread/mod.rs:528 inlined 14 libxul.so core::ops::function::FnOnce::call_once{{vtable.shim}} /usr/src/debug/rustc-1.76.0-src/library/core/src/ops/function.rs:250 cfi 15 libxul.so std::sys::unix::thread::Thread::new::thread_start cfi 16 firefox set_alt_signal_stack_and_start(PthreadCreateParams*) cfi 17 libc.so.6 start_thread /usr/src/debug/glibc-2.39/nptl/pthread_create.c:447 cfi 18 libc.so.6 __clone3

Asked by Abdelmalik 1 month ago

Last reply by jonzn4SUSE 4 weeks ago

  • Archived

Radar site of the weather network has stopped working

I noticed this morning that the radar site of theweathernetwork.com has stopped working on Firefox. I am running the latest Firefox from OpenSuse Tumbleweed. The strange … (read more)

I noticed this morning that the radar site of theweathernetwork.com has stopped working on Firefox. I am running the latest Firefox from OpenSuse Tumbleweed. The strange thing is Vivaldi also has the same problem so I suspected it's not a Firefox problem. So I logged into Firefox on my two other Linux distros, Debian and Fedora and Firefox has the same problem on them!!. Strange that Vivaldi suffers the same problem, the radar site never loads in Firefox, and in Vivaldi it sort of loads but runs VERY slowly. I tried restarting Firefox in troubleshoot mode and it got as far as a page saying some browsers don't support the site and suggested I update my browser. It appears the radar site has made some sort of change which two browsers under Linux cannot cope with. Unfortunately the radar site of theweathernetwork.com is the best of all the sites available.

Asked by mccfrank 1 year ago

Last reply by mccfrank 1 year ago

  • Solved
  • Archived

i can't play some (but not all) youtube videos with firefox 106.0.3

i can't play some (but not all) youtube videos. they do play on other web browsers. the message is "an error occured, please try again later. playback ID is ... " i'… (read more)

i can't play some (but not all) youtube videos. they do play on other web browsers.

the message is "an error occured, please try again later. playback ID is ... " 

i'm using firefox 106.0.3 on linux suse tumbleweed. Before I upgraded to both of these the same videos were playing ok.

Asked by ruthtoby 1 year ago

Answered by ruthtoby 1 year ago

  • Solved
  • Archived

Google Maps pegs CPU

Firefox 120.0 on openSUSE Tumbleweed. Google Maps (https://www.google.com/maps) results in CPU being pegged at 100%. No other tabs open. All I have to do is load the… (read more)

Firefox 120.0 on openSUSE Tumbleweed.

Google Maps (https://www.google.com/maps) results in CPU being pegged at 100%. No other tabs open. All I have to do is load the URL and do nothing else. This behavior is repeatable. CPU stays at 100% until tab is closed or browser is shut down. Sometimes the browser will hang and its PID has to be killed.

Offending process:

username 4501 4416 76 11:40 ? 00:05:13 /usr/lib64/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 27513 -prefMapSize 244227 -jsInitLen 228948 -parentBuildID 20231116134553 -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appDir /usr/lib64/firefox/browser {659a1e89-c5da-416d-b720-558c24187847} 4416 true tab

Asked by DMW 7 months ago

Answered by DMW 6 months ago

  • Archived

Cannot autofill Credit Card Info

Got sick and tired of having to enter payment card info every time, so I decided to RTFM and follow instructions. I worked my way thru all the instructions on found on t… (read more)

Got sick and tired of having to enter payment card info every time, so I decided to RTFM and follow instructions. I worked my way thru all the instructions on found on the forum pages, and was entering the information via about:config, and got to the popup where I was asked to confirm, and clicked the button, then clicked it harder, but nothing happened.

My guess is that my Firefox and/or my Leap15.3 installation has left some file permission read-only and Firefox is unable to save this bit of data, but I really don't want to run Firefox as root. I can say more, but I see there are more boxes to fill.

So, I included a screenshot of what I hope will be the useful part of my config file.

Asked by The Singer Man 2 years ago

Last reply by jonzn4SUSE 2 years ago

  • Solved
  • Archived

honey shopping app - drop down boxes wont open

If i am on amazon for example and an item has more than 1 option, Honey presents drop down selection box so you can choose which one to drop list The issue is the drop d… (read more)

If i am on amazon for example and an item has more than 1 option, Honey presents drop down selection box so you can choose which one to drop list The issue is the drop down box never opens when you click on it, doesn't matter where on it you click, it wont open. I have cleared cache, reinstalled honey and nothing helps. I have multiple desktop pc's all running tumbleweed and they all have this issue. If i load Chromium that works ok, but i use Firefox and not Chromium. I'm using openSuse Tumbleweed (latest update).

Asked by Cat22 6 months ago

Answered by Cat22 6 months ago

  • Solved

Firefox 122 Linux Tumbleweed

Firefox 122 can't display at least one site I found today. www.dominos.ca. Only part of the page loads many elements are missing. I have disabled all extensions and the p… (read more)

Firefox 122 can't display at least one site I found today. www.dominos.ca. Only part of the page loads many elements are missing. I have disabled all extensions and the problem still exists. This page never gave me problems before this latest Firefox.

Asked by mccfrank 5 months ago

Answered by jonzn4SUSE 5 months ago

  • Solved

How to get rid of unrequested invasive rendered area debugging overlay?

After updating my openSUSE Firefox package from version 122 to 123 every frame inside each window started to have weird grey overlay of scrollable area. I failed to find … (read more)

After updating my openSUSE Firefox package from version 122 to 123 every frame inside each window started to have weird grey overlay of scrollable area. I failed to find any description of such a thing happening, let alone how to get rid of it. I tried removing build-in distro-default preferences and had complete audit of all my custom preferences in about:config but none changed that behavior. I even updated to 124b4 but this also haven't changed anything. Naturally, nuking entire profile is not an option, I might as well replace the whole browser. So, how do I get rid of this thing?

Asked by F0X 4 months ago

Answered by zeroknight 4 months ago

Many major websites play video frames out of sequence.

The video from most websites plays out of sequence. It appears that approximately every one second plays its frames in reverse order. This occurs with most video streamin… (read more)

The video from most websites plays out of sequence. It appears that approximately every one second plays its frames in reverse order. This occurs with most video streaming services and major sites. For example, all Amazon, Sam's Club, Walmart and other website product videos. Occasionally, Amazon product videos just say not compatible. However, YouTube videos with very rare excepts play fine in Firefox. Those problem sites play the videos fine under Edge for Linux. But, I would much rather use Firefox. I'm sure this a codec related issue. Possibly related to the NVIDIA GeForce GT 1030 video card in this computer running openSUSE 15.5. But after much searching, I'm at a loss on how to resolve the problem.

Asked by jerome24 3 months ago

Last reply by cor-el 3 months ago

  • Solved
  • Archived

rumble video is not visible on a webpage

The rumble video interview of Jonathan Cahn by Greg Hunter is NOT visible in my linux version 91.12.0esr(64-bit) of Mozilla Firefox, straight from an openSuse software re… (read more)

The rumble video interview of Jonathan Cahn by Greg Hunter is NOT visible in my linux version 91.12.0esr(64-bit) of Mozilla Firefox, straight from an openSuse software repository and directly installable under yast, which is their administrator program over the linux software including the software manager

The web page in question is https://usawatchdog.com/only-way-to-save-america-is-turn-back-to-god-jonathan-cahn/ but the java script code is grayed out on this page

!function(r,u,m,b,l,e){r._Rumble=b,r[b]||(r[b]=function(){(r[b]._=r[b]._||[]).push(arguments);if(r[b]._.length==1){l=u.createElement(m),e=u.getElementsByTagName(m)[0],l.async=1,l.src="https://rumble.com/embedJS/ugdmvn"+(arguments[1].video?'.'+arguments[1].video:)+"/?url="+encodeURIComponent(location.href)+"&args="+encodeURIComponent(JSON.stringify([].slice.apply(arguments))),e.parentNode.insertBefore(l,e)}})}(window, document, "script", "Rumble");

I have used other browsers, such as Opera, Brave, Google Chrome and the rumble video is clearly visible and playable.

What do I have to change in Firefox so that this video becomes visible on the page?

Randall

p.s. Greg Hunter is interested in this reply too

Asked by website.reader3 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved

Choppy video on some sites after update to Firefox 115.8.0esr

Video on some websites is choppy after updating to a newer version of Firefox (115.8.0esr). I have attempted to upload a video of the problem but it seems only still imag… (read more)

Video on some websites is choppy after updating to a newer version of Firefox (115.8.0esr). I have attempted to upload a video of the problem but it seems only still images are allowed and this doesn't illustrate the problem. An example website where this occurs is https://www.fiat.it but there are plenty of other examples. It looks as if the playback is jumping forwards and backwards between frames. Strangely Youtube videos seem OK.

Some information which may be of use

OS: OpenSuse Leap 15.5 HW: Dell Precision 7510 with Nvidia Quadro M2000M video card and driver version 550.54.14

I have also noticed that when starting Firefox from the command line I see frequent messages like

Sandbox: attempt to open unexpected file /sys/devices/system/cpu/cpu0/cache/index2/size Sandbox: attempt to open unexpected file /sys/devices/system/cpu/cpu0/cache/index3/size Sandbox: attempt to open unexpected file /sys/devices/system/cpu/present Sandbox: attempt to open unexpected file /sys/devices/system/cpu Sandbox: unexpected multiple open of file /proc/cpuinfo

Probably not relevant but I included it just in case it is useful

Any help you can offer with debugging would be much appreciated, thanks

Asked by Nigel.Woolaway 4 months ago

Answered by jonzn4SUSE 4 months ago

  • Archived

Flatpak Firefox not displaying some pdfs correctly

Hello, Am using Mozilla Firefox installed via flatpak on openSUSE. Certain pdfs display correctly but other pdfs displayed with Firefox (either locally or online) are di… (read more)

Hello,

Am using Mozilla Firefox installed via flatpak on openSUSE. Certain pdfs display correctly but other pdfs displayed with Firefox (either locally or online) are displayed badly: spaces are replaced with a lower half block character, fonts not sharp. I installed Firefox from the openSUSE repos (not from flathub) and opened the same pdf and it displayed correctly. I downloaded the pdf and opened it using Okular and no problems. I also opened the “troublesome” pdfs on Firefox in Windows and it displays correctly. I conclude that the flatpak version of Firefox is causing some pdfs to display incorrectly but I don’t know why.

I installed flatseal to tweak the flatpak Firefox’s settings but nothing seemed to fix the pdf display issue. Please see screenshot below of how Firefox (from openSUSE repos, on the left hand side) and Firefox (from flathub, on the right hand side) display the same pdf from the internet. The online pdf in the screenshot and used as an example of the issue can be found at:

https://www.jrf.org.uk/sites/default/files/jrf/files-research/international_cities_rotterdam.pdf

Not sure why some pdfs display correctly in Firefox from flathub and others display incorrectly. I’d prefer to use flatpak’s sandboxed Firefox if possible. Is there anyone else with the same problem or someone who who found a solution to this issue?

Thanks

Dad4Linux

Asked by Dad4Linux 1 year ago

Last reply by jonzn4SUSE 1 year ago

  • Archived

FireFox crashes - Crash Report Screen start everytime

Computer: Linux Opensuse Firefox up to date Recent restart created a firefox crash. THe dialog box appears each time. Cannot close, cannot open, cannot restart. The f… (read more)

Computer: Linux Opensuse Firefox up to date

Recent restart created a firefox crash.

THe dialog box appears each time.

Cannot close, cannot open, cannot restart.

The firefox crash report stays on.

Please help.

Attached> [Wed 14 Jun 2023 09:12:18 PM EDT] Crash report submitted successfully Crash ID: bp-bbc1898e-f068-48db-91e8-e4dfd0230615

Several crash reports are in the pending folder.

Thank You Anthony

Asked by anthony91 1 year ago

Last reply by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Media title not showing up in linux

I have been using Firefox on OpenSuse Tumbleweed. When media is playing in Firefox, the media player widget says, "Firefox is playing Media". There is no thumbnail or tit… (read more)

I have been using Firefox on OpenSuse Tumbleweed. When media is playing in Firefox, the media player widget says, "Firefox is playing Media". There is no thumbnail or title. I have tried on multiple websites, and all are the same.

media.hardwaremediakeys.enabled is set to true.

Chromium on the same system shows the title and progress bar, but no thumbnail.

Asked by ow.behr 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Large mouse cursor (scaled to 48px) when using >200% display scaling

The desktop mouse cursor becomes large when using Firefox with >200% display scaling. It doesn't matter if it's 250% or 300%, the result is the same. My system configu… (read more)

The desktop mouse cursor becomes large when using Firefox with >200% display scaling. It doesn't matter if it's 250% or 300%, the result is the same. My system configuration is as follows:

Opensuse Tumbleweed (up-to-date) Firefox 112.0.2 64bit KDE Plasma running Wayland

I've included 2 screenshots that show the difference in the mouse pointer size when outside of a Firefox window and inside it. Also, this issue is only present with Firefox; no other application produces this result. Any help or suggestions would be greatly appreciated!

Asked by Donnie 1 year ago

Answered by Donnie 1 year ago

  • Solved
  • Archived

Error "content not available in a compatible codec" when trying to play video clips in websites

I am using Firefox 102.8.0esr on openSUSE Leap 15.4. Two days ago Firefox stopped playing video clips on websites, notably BBC News and Facebook. On BBC News I get the er… (read more)

I am using Firefox 102.8.0esr on openSUSE Leap 15.4. Two days ago Firefox stopped playing video clips on websites, notably BBC News and Facebook. On BBC News I get the error message "The content is not available in a compatible codec" but elsewhere just "video cannot be played". I have checked that the same video clips can be played without a problem in Google Chrome

Asked by piano.macvean 1 year ago

Answered by piano.macvean 1 year ago