Firefox takes 10+ times longer to load websites than Edge or Chrome

I'm at my wits end. I've tried every fix I could find and Firefox is dramatically slower then Edge or Chrome. This happens with loading sites, like Amazon. Also, it of… (read more)

I'm at my wits end. I've tried every fix I could find and Firefox is dramatically slower then Edge or Chrome. This happens with loading sites, like Amazon. Also, it often locks up/stops when typing (like right now) and it takes about 15 seconds for it to repond again.

First, I doubt it's a hardware or network issue, since it's happened on both my old archaic PC and now on my new PC (i9 CPU, Nvidia 2070 graphics card, 64gb RAM).

Here's some highlights of what I've tried so far: • Refreshing multiple times • Rebooting the PC • Doing all the Quick Tips on this website • Eliminating all extensions • Clearing all cookies and cash • ...

Also, I don't get any error codes. The tab icon just spins for a long time.

I'm hoping I'm missing something obvious, since I love Firefox.

Thanks and any help!

Asked by Olliesshop 2 weeks ago

Last reply by Olliesshop 6 days ago

Some text is covered with black diamonds and question marks

On FoxNews.com, some articles include a section at the bottom for user comments. First-level comments frequently receive additional second- and third-level comments. Fir… (read more)

On FoxNews.com, some articles include a section at the bottom for user comments. First-level comments frequently receive additional second- and third-level comments.

First-level comments are working fine, but lower-level comments are partially obliterated with a string of black diamonds with question marks �?U��N�@?�.

This is not an issue when I use Safari, but it is on Firefox.

Asked by Prentice3 2 weeks ago

Last reply by Prentice3 3 days ago

Cannot change color of tabs

Firefox - Add Colored tabs I had Firefox version 81 and after installing version 82 in a new install on a new hard drive, I cannot change the color of my tabs anymore. I … (read more)

Firefox - Add Colored tabs

I had Firefox version 81 and after installing version 82 in a new install on a new hard drive, I cannot change the color of my tabs anymore. I should see white tabs for the current tab but no longer when I added my userChrome.css file. I see instead a thin blue color strip along the top of the tab and the rest is grey. This shows up without any userChrome.css file.

In Firefox address field type: about:support It shows my Profile. vwy0y5ix.default-release I also have under the Profile folder this: jcueuz5y.default

I put the userChrome.css file here in my Chrome folder: C:\Users\David\AppData\Roaming\Mozilla\Firefox\Profiles\vwy0y5ix.default-release

What it contains: /* USE THIS ONE. It works in version 65 https://github.com/Aris-t2/CustomCSSforFx/releases/tag/2.3.4

  • /

@import "./css/tabs/tabs_below_navigation_toolbar_fx65.css"; /**/ /* <-- tabs not on top - Fx65+ - Windows/Linux */

/* Colored tab */ .tab-background:not([selected]) {

   background-color: #E3E0DB !important;

}

.tab-background[selected="true"] {

   background-color: white!important;

}

/*** Sidebar Color / Font Size Formatting ***/ /* 14px black text */ .sidebar-placesTree treechildren::-moz-tree-cell-text {

 font-size: 14px !important;
 color: #000 !important;

} /* Pale blue background on hover or selected */ .sidebar-placesTree treechildren::-moz-tree-row(hover), .sidebar-placesTree treechildren::-moz-tree-row(selected) {

 background-color: #bdf !important;

}

/* Main Toolbar */

  1. nav-bar {
 font-size: 14px !important;

Asked by davidhelp 2 weeks ago

Last reply by davidhelp 6 days ago

Jagged fonts after 83 update.

Installed 83.0 update for my Firefox a few days ago and noticed that fonts in browser looks worse. It bacame jagged (sharp) as if Clear Type was disabled in my system but… (read more)

Installed 83.0 update for my Firefox a few days ago and noticed that fonts in browser looks worse. It bacame jagged (sharp) as if Clear Type was disabled in my system but I checked it and it is turned on. Also I don't see this problem in other browsers, Edge or IE, only in Firefox. Could it be a bug with latest update or what is it?

Asked by Vitaliy1993 1 week ago

Last reply by Vitaliy1993 6 days ago

How do I get obsolete info out of a typing box?

Recently, I had to change my username at my bank's website because somebody was trying a brute force attack on my password. Now, the site still shows my old username, al… (read more)

Recently, I had to change my username at my bank's website because somebody was trying a brute force attack on my password. Now, the site still shows my old username, although I've gone to my Saved Logons in Preference and removed all logons for that site except for the correct one. I have to delete the old username from the typing box every time I log in there, after which I can select the correct (and only) saved username/password.

Asked by sideburns 1 week ago

Last reply by sideburns 5 days ago

Dual boot (Win7 & openSUSE TW) ZBook-17-G2-Tumbleweed

The machine name ZBook-17-G2-Tumbleweed is not showing in Sync Tabs. Firefox has lost all my tabs a few time in the past 2 weeks and when I opened the sync tab to bring … (read more)

The machine name ZBook-17-G2-Tumbleweed is not showing in Sync Tabs. Firefox has lost all my tabs a few time in the past 2 weeks and when I opened the sync tab to bring the tabs back the machine name is not there and all my open tabs are gone.

Firefox 82.0 (64-bit) Operating System: openSUSE Tumbleweed 20201104 KDE Plasma Version: 5.20.2 KDE Frameworks Version: 5.75.0 Qt Version: 5.15.1 Kernel Version: 5.9.1-1-default OS Type: 64-bit Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Asked by jonzn4SUSE 4 weeks ago

Last reply by jonzn4SUSE 4 days ago

Anyway to disable "A script from the extension" "is running on this page"

I am getting sick of the message "A script from the extension...is running on this page" It relates to Adblock Plus which is the extension. I watch a YouTube video and th… (read more)

I am getting sick of the message "A script from the extension...is running on this page" It relates to Adblock Plus which is the extension. I watch a YouTube video and then this message comes up on another YouTube tab I have open and Firefox switches to that tab and ruins my watching the video I was watching.

Is there anyway of disabling the message from ever coming up? I increased the values in dom.max_script_run_time and dom.max_script_run_time_without_important_user_input which was a possible solution I read but that does nothing.

Asked by davebesag 2 weeks ago

Last reply by davebesag 5 days ago

YouTube player preferences not being saved.

Just recently I noticed that Firefox 83.0 is no longer retaining my viewer settings in YouTube. Specifically the theater mode and autoplay settings. I can set it to theat… (read more)

Just recently I noticed that Firefox 83.0 is no longer retaining my viewer settings in YouTube. Specifically the theater mode and autoplay settings. I can set it to theater mode, and turn off autoplay, and the next time I start Firefox, they are back to their defaults (autoplay on, compact viewer). At first I thought it was a YouTube issue but have tried it on Chrome and Chromium and both browsers save my settings. I'm running ArcoLinux 5.9.10 with I3 WM on both my desktop and laptop. I have both reset and re-installed FF with no change.

Asked by erik45 1 week ago

Last reply by erik45 4 days ago

Saved logins and passwords for websites.

Hi, I am wondering why Firefox removed all logins and passwords. It used to be all in settings, now I am getting message: No logins found When you save a password in Fi… (read more)

Hi, I am wondering why Firefox removed all logins and passwords. It used to be all in settings, now I am getting message: No logins found When you save a password in Firefox, it will show up here Any help, thanks in advance.

Asked by Dziambis 1 week ago

Last reply by Dziambis 2 days ago

Firefox no longer allowing me to access some log in windows eg PayPal

I hardly know how to describe the problem I've been having but I'm fed up with it! Just now I was in a site to purchase an item and clicked to go through PayPal. I could … (read more)

I hardly know how to describe the problem I've been having but I'm fed up with it! Just now I was in a site to purchase an item and clicked to go through PayPal. I could enter all my log in details for PayPal but it would not open the PayPal site. This has happened every time I've tried to use PayPal lately. I then have to go and use Edge and do my purchase through there, no problem at all.

Often when I've tried to open a log in window that opens in a separate pop up style window, that window will only open as a tiny window in the top left corner. I have to drag the bottom and sides to get it big enough to fill out. Then when you enter that info ready for the next section, it reverts right back to the tiny window once more. I've done all sorts of things in my settings and mostly no change. I did however get the bank log in window to stop doing it and work properly.

Another issue is the correct time for me here in Aust is no longer being recognised in some cases. One is the Track My Hours App. I enter 'Start now' and it says 6:55 AM when it's actually 4:55 PM on my computer clock! It is not the App as I now use it in Edge as well and it is fine there. I never used to have this problem with the much earlier versions of Firefox, it only started a month or so ago when I got a new computer with the latest version installed, at that stage I think it was 72 and I had other problems as well that finally got sorted.

I really want to continue using Firefox but can't do so with several sites and then waste a lot of time swapping over to another browser. I have version 83 now.

Can anyone please help!!! Thanks.

Asked by CH 1 week ago

Last reply by CH 3 days ago

Usually cannot access Yahoo unless delete yahoo cookies

Yahoo.com is my home page. Most times (but not always) I cannot access it unless I go into privacy and security and delete the yahoo cookies. (Just sits at new page wit… (read more)

Yahoo.com is my home page. Most times (but not always) I cannot access it unless I go into privacy and security and delete the yahoo cookies. (Just sits at new page with 3 dots moving.) I mean won't open yahoo when firefox starts, if I use the home button, or type yahoo.com in address bar. Am on Windows 10 using Firefox 83.0 64-bit. I don't want to delete all my cookies on exit, so am at a loss.

Asked by cohnveno 6 days ago

Last reply by cohnveno 6 days ago

SEC_ERROR_UNKNOWN_ISSUER error

Hi For some reasons im unable to access these websites zoopla.co.uk, rightmove.couk, mouseprice.com, primelocation.com, ebay.co.uk on my firefox 78.4.0esr and get the err… (read more)

Hi For some reasons im unable to access these websites zoopla.co.uk, rightmove.couk, mouseprice.com, primelocation.com, ebay.co.uk on my firefox 78.4.0esr and get the error SEC_ERROR_UNKNOWN_ISSUER with no option to advance. I can access these sites on Internet explorer & chrome but weird why Firefox is blocking it. Is there a workaround this please


Ps: i have no 3rd party anti virus and tried using this article https://support.mozilla.org/en-US/kb/error-codes-secure-websites but no joy

Thanks

Asked by subomidavid 1 week ago

Last reply by subomidavid 3 days ago

Firefox Save As and Open Navigation / Explorer Pane Reset?

Hello, I have been writing a .bat file, as well as experimenting with ShellBags in order to default Windows Explorer navigation pane settings and folder views / types to … (read more)

Hello,

I have been writing a .bat file, as well as experimenting with ShellBags in order to default Windows Explorer navigation pane settings and folder views / types to default.

Currently, I have the .bat file configured to remove the NavPane (HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Modules\NavPane) and Sizer (HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Modules\GlobalSettings\Sizer) registry folders / items (As these are automatically regenerated with default values by Windows), as well as myriad ShellBag items and Desktop.ini files. It then restarts Windows Explorer.

This .bat script, however, does not seem to default any customization made within Firefox's Save As window(s).

For example, if I right-click an image, then select Save Image As, and then proceed to drag the explorer panes to be excessively wide, then exit Firefox, upon running the .bat file, the excessively wide navigation / explorer panes remain excessively wide. They do not default.

Does Firefox store this pane customization information somewhere else? Can this be defaulted?

Thank you!

Asked by puddlecheese 6 days ago

Print Edit hangs in Suspend mode

Whenever I click on Print Edit WE button the edit page opens but all the buttons are inactive and the PE button in the toolbar shows SUS for suspend. Nothing I do fixes i… (read more)

Whenever I click on Print Edit WE button the edit page opens but all the buttons are inactive and the PE button in the toolbar shows SUS for suspend. Nothing I do fixes it. I've removed and reinstalled the lastest version of PE from the add-on web page 3 or 4 times. A right click on the PE button drops down a menu but the one I need, Edit, puts PE into suspend mode. What could be causing this? I'm running FF 83.0, 64 bit, Windows 10 Pro. Print Edit has always worked before. Does the latest version have a bug? Or does FF maybe have a bug?

Asked by idahouser 6 days ago

Last reply by idahouser 6 days ago

speeding up Firefox

I clicked on a popup link from Firefox to speed up my browser. Came back to my computer and everything's gone, all my fast links that I had at the top of my screen, like … (read more)

I clicked on a popup link from Firefox to speed up my browser. Came back to my computer and everything's gone, all my fast links that I had at the top of my screen, like Facebook, Gmail, everything I've saved for quick links over the past 2 years. I want my computer back, just the way I had it. This is a nightmare. I'd much rather my browser run slow (it really wasn't running slow). I tried a system restore, but it didn't restore things the way I had them. Please, what do I do to reverse this nightmare, and please don't ever offer to speed up my browser again.

Asked by ginchinchili 6 days ago

Last reply by ginchinchili 5 days ago

Does restoro part of firefox download?

Not sure why this page deleted my question while trying to share data but I'll start again. I'm getting Malwarebyte alerts from something in firefox.exe, it's called rest… (read more)

Not sure why this page deleted my question while trying to share data but I'll start again.

I'm getting Malwarebyte alerts from something in firefox.exe, it's called restoro. It's not a program that's in my control panel so I can't delete it. It was quarantined but seconds later it was trying again. I included an image of the last scan done Nov. 28. I've deleted firefox before but it came back when I installed again. Is it something that firefox is supposed to have or is it some trojan that's latched onto firefox?

Asked by colemyst 6 days ago

Last reply by colemyst 4 days ago

json files

I do not know what json files are. I have only seen them in the profile. However, whatever their purpose, firefox is no longer processing json files. Instead, it wants… (read more)

I do not know what json files are. I have only seen them in the profile. However, whatever their purpose, firefox is no longer processing json files. Instead, it wants to download json.txt when I make some selections.

Example: on Youtube when signed into my account, I select "notification" and instead of the menu opening, the download box appears wanting to download json.txt. This has happened in numerous places - not only youtube, so it looks like a Firefox problem.

Firefox used to process json files and now wants to download them. I tried to configure json in options, and when I select "other" Firefox shows up as a choice it it not possible to select it. I select it, but it does not change the ONLY options for json files which are "always ask" or "save".

This is clearly not something I can fix, not something I caused. I need the features that are not functional, and apparently they have become dysfunctional because they apparently access json files but no longer process them as intended.

Would appreciate knowing what the problem is, if there is an explanation. Is there a fix? Do I need to configure something? Thanks. Mary

Using Windows 7 and the latest Firefox for Windows 7 64bit Mary

Asked by gosfordsyke 1 week ago

Last reply by gosfordsyke 9 hours ago

Firefox

Windows 10 - Après une réinstallation de windows 10, Firefox ne fonctionne pas, Edge, Comodo dragon, vivaldi etc... fonctionnent. Firefox s'ouvre mais se limite à cela. I… (read more)

Windows 10 - Après une réinstallation de windows 10, Firefox ne fonctionne pas, Edge, Comodo dragon, vivaldi etc... fonctionnent. Firefox s'ouvre mais se limite à cela. Il importe mes marque pages et j'ai accès au menu mais rien ne fonctionne. J'ai essayé aussi del'ouvrir avec les droits d'administrateur mais rien... Je vous remercie de m'aider car j'utilise Firefox depuis des années.

Jean-Claude Houart xxxxxxxxx@xxxxxx.xx


(email address removed by moderator; please do not post personal information on a public website; Forum rules and guidelines)

Asked by jchouart 6 days ago

Firefox removes last letters when searching through address bar.

I didn't mind this bug in about a week ago, but it is sufficiently annoying enough. The firefox is deleting last letter consists of my locale, hangul, when I search it th… (read more)

I didn't mind this bug in about a week ago, but it is sufficiently annoying enough. The firefox is deleting last letter consists of my locale, hangul, when I search it through address bar.

It occurs when searching more than 2 words. Precisely, conditions are two. 1. one or more space bar between two words. 2. the last word has more than one letter.

ex) ㄱ ㄴㄷ(enter) --(when searching through address bar)--> ㄱ ㄴ

It is resolved by adding space bar or move the cursor to the right of the letter. So you can't reproduce it with just copying that words. You need to search with korean locale keyboard to reproduce that bug. Anyway, it's still annoying doing things what I should not do with the previous version.

Asked by sexydoveo2jam 6 days ago