Showing questions tagged: Show all questions

PDF print issues

Hi, in recent Firefox updates in debian testing (and in recent developer edition), when I try to print a PDF the page number is just in border and don't get printed. I tr… (read more)

Hi, in recent Firefox updates in debian testing (and in recent developer edition), when I try to print a PDF the page number is just in border and don't get printed. I try almost all things i found related in about:config.

Also in export to file, now don't strore previous location and always point to ~/mozilla.pdf is a problem, user need to change for a path each print to pdf. Also in debian the file explorer opened dont show recent files can help.

Thanks so much for your help.

Asked by jabiertxof 3 days ago

Last reply by jonzn4SUSE 4 hours ago

turn off enterprise control on Linux os

I am a retired person trying to use Firefox on a Linux os computer i OWN. To day, Firefox has become unstable. I see in my settles that an "enterprise" now controls my … (read more)

I am a retired person trying to use Firefox on a Linux os computer i OWN. To day, Firefox has become unstable. I see in my settles that an "enterprise" now controls my copy of firefox.

How can I eliminate this obstruction?

Most discussion of this problem discusses Windows os and is useless to me.

My os is LinuxMint 19 (Tara)

Please advise!

Asked by rholcomb786 8 hours ago

Last reply by cor-el 7 hours ago

Mobile Bookmarks folder not stored using 'Export bookmarks to HTML' (but JSON ok)

Firefox version: 95.0.1 x64 on Linux Mint 19.1, running in safe-mode As title says, the 'Mobile Bookmarks' folder synced from a Firefox Android aren't saved when exportin… (read more)

Firefox version: 95.0.1 x64 on Linux Mint 19.1, running in safe-mode

As title says, the 'Mobile Bookmarks' folder synced from a Firefox Android aren't saved when exporting the bookmarks to an HTML file. They ARE saved during 'Backup to a JSON' but HTML with 20,000 bookmarks is much easier to edit than a JSON (unless anyone has a handy and quick JSON editor recommendation?).

So bug, or notbug?

Asked by martin_mozillasupport 7 hours ago

Firefox has upgraded in the background and needs to restart - dealbreaker.

This is a dealbreaker and I'm quiting firefox because of it. Event: "Firefox has upgraded in the background and needs to restart. You will be able to continue where you l… (read more)

This is a dealbreaker and I'm quiting firefox because of it.

Event: "Firefox has upgraded in the background and needs to restart.

You will be able to continue where you left off..."

Infuriatingly, there is no option to postpone. All browsing is immediately prevented and there is no option to do anything other than restart. Furthermore, there is no option to turn off automatic updates or even to get a notification that one might be happening until it is too late.

Problem: The restart does not return to "where I left off" with a) only one tab re-opening (plus all private tabs lost); and b) many logins and much form-filling progress lost. For example, I was in the process of submitting a government form in a private tab when, on the last step, instead of the final confirmation page, I got the dreaded "Firefox has upgraded and needs to restart" message. Upon restart, the tab didn't reopen, and I lost the session and had to start again from the beginning with the form filling process. Utterly infuriating and completely unnecessary.

I was putting up with Firefox's other annoying quirks, but this is ridiculous.

Asked by mozilla306 1 day ago

Last reply by jonzn4SUSE 8 hours ago

How do i get rid of this aweful UI

i am using manjaro gnome and to get rid of ui i need to reset firefox but after restart of the system i again get this bad ui. i dont know if this is an extension or what… (read more)

i am using manjaro gnome and to get rid of ui i need to reset firefox but after restart of the system i again get this bad ui. i dont know if this is an extension or what.. i have checked all the active extensions but none have any customization effect on firefox

Asked by Scilent Assasin 13 hours ago

Last reply by Seburo 12 hours ago

The Bullet screen of bilibili.com is always choppy in firefox compared to chrome or edge

I found that the Bullet screen of bilibili.com is always choppy in firefox compared to chrome or edge. My firefox version is 96.0 and OS is linux (opensuse tumbleweed). s… (read more)

I found that the Bullet screen of bilibili.com is always choppy in firefox compared to chrome or edge. My firefox version is 96.0 and OS is linux (opensuse tumbleweed).

sample page: https://www.bilibili.com/video/BV13b4y1B7qR

Asked by Russell Bie 19 hours ago

Last reply by FredMcD 18 hours ago

Browser Cache caching regardless of change in options

Hi from a short time back I've noticed my local pages (vdeveloping on localhost) are being cached regardless of my config which is not caching anything at all. This is p… (read more)

Hi from a short time back I've noticed my local pages (vdeveloping on localhost) are being cached regardless of my config which is not caching anything at all. This is particularly annoying when you make small changes and they're not reflected at once but instead they are only after 5,6,... 10 reloading calls.

I've searched for help and followed the instructions of changing options in about:config with no results

I'm using Linux and 96 version of the browser.

Thanks in advance

Asked by Paulino Pardo 2 days ago

Last reply by andmagdo 1 day ago

Firefox color themes move container indicator in current tab

Hello since the update to FF 96 I noticed that the container indicator for the current tab was a few pixel lower than the indicator for other tabs. Since this was not ha… (read more)

Hello since the update to FF 96 I noticed that the container indicator for the current tab was a few pixel lower than the indicator for other tabs.

Since this was not happening in troubleshoot mode I tried disabling my addons one by one and found that the problem was caused by Firefox Color: any change from the default FF theme (including selecting one of the FF Colors preset themes) moves the container indicator downward.

I also tested this on a new browser profile, installing only Multi-account Containers and FF Color and it looks the same, so this is not caused by other customizations on my browser.

Is this a bug in FF Color? Or something I can solve changing a configuration?

Asked by lusiani.enrico 1 day ago

Repeatedly crashes . but only on this machine.

First of all , Hello  :) FF is a great wb and i use it everywhere i got a machine. Works fine everywhere .. but here on this computer. Why only on this machine ? Same d… (read more)

First of all , Hello  :) FF is a great wb and i use it everywhere i got a machine. Works fine everywhere .. but here on this computer. Why only on this machine ? Same distros ( linux mint 20.3 ) radeon video cards , amd family cpu's This machine is AMD FX(tm)-6300 Six-Core Processor × 6 the video card atm is AMD PITCAIRN (DRM 2.50.0, 5.4.0-94-generic, LLVM 12.0.0) though i had the same crash issue with a nVidia graphics card. Memory is Corsair and the memtest86 reports no errors. This is where i get a bit lost. Memory issues or hardware defects might explain this but where's one to begin ? Trouble is , no other application ever crashes and it's rock solid. So is FF to point a finger at or something else ? That's the objective of me submitting this report. Try to find out what's really at fault here and fix it.

The crashes happen at all times. It can also be right at starting FF and never even reaching the main window. I tried with and without the --safe-mode and it's the same that also happens.

So i submitted one of the crash reports ID: 656264f4-7867-4c55-8b36-0637e0220114

The report can be found here : https://crash-stats.mozilla.org/report/index/656264f4-7867-4c55-8b36-0637e0220114

Since there's so many i hesitate to put them all up , there's dozens since the system reinstall yesterday , i reinstalled the whole OS again yesterday to try to get rid of the bug. Any help to solve this once and for all will be highly appreciated . :) thanks for reading

FuzzyTheBear

Asked by FuzzyTheBear 2 days ago

Last reply by jonzn4SUSE 1 day ago

History Feed Changed by Mistakenly Clicking Wrong Menu Selection

How do I reverse what happened to 'History' when I accidentally clicked 'Forget About This Site' instead of 'Delete Page' on the drop-down menu for the highlighted page i… (read more)

How do I reverse what happened to 'History' when I accidentally clicked 'Forget About This Site' instead of 'Delete Page' on the drop-down menu for the highlighted page in the history feed.

I realise that I caused this problem last night when I clicked the wrong option in the drop-down menu but only became aware of what I had done when I went to my history feed this afternoon. I was looking in my history feed to find a site that I visited yesterday and noticed that a website that I have visited several times earlier today is not appearing in the feed. It is the same site that I clicked the wrong selection in the drop-down menu for last night.

How do I get 'History' to start showing that site in the feed again?

Asked by Mark Henry 1 day ago

Last reply by jscher2000 1 day ago

  • Solved

Firefox saving to /run/user/1000/docs

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, pur… (read more)

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, purged and reinstalled from Ubuntu Software and everything seemed ok. However, whenever I now try to save something, for instance images, the save to directory will default to /run/user/1000/docs even though I have my downloads folder selected in settings. I can change to the directory I want to save to and it will save there, but when I next save something it will again want to go to the /run/user/1000/docs folder. Further, I find that a copy of anything I save has also been saved into that folder, creating a new sub-directory to do so. I tried clear data in settings but that didn't delete those files and they are protected in file manager so I can't delete them myself. This will fill my hard drive pretty quickly as well as being really annoying having to change the save directory every time. What can I do to rectify this? I've now got version 96.0 (64 bit) installed.

Asked by paulhurford 3 days ago

Answered by jonzn4SUSE 1 day ago

The display turns on when a push notification is received

When a push notification is received, the display turns on (via DPMS). Is it possible to get rid of this behavior? Is there some configuration option in Firefox in about:… (read more)

When a push notification is received, the display turns on (via DPMS). Is it possible to get rid of this behavior? Is there some configuration option in Firefox in about:config? I can't exclude that it's not Firefox doing this, but I'm guessing it is.

Asked by zostajekni 2 days ago

Last reply by zostajekni 1 day ago

Please stop forcing me to restart firefox on Linux

This is pissing me off so much! I'm working and in the middle of everything I have no other option than to completely restart my browser, which can easily resolve into lo… (read more)

This is pissing me off so much! I'm working and in the middle of everything I have no other option than to completely restart my browser, which can easily resolve into losing what I was doing, not to mention that it completely kills my workflow. STOP DOING THIS! I don't care what the reason is, you're severely hindering the usage of the app. I will decide when to restart, not the app! I have a fresh start of my system every single day, I'm sure whatever unimportant update it was this time can wait a few hours.

Asked by Lynn 2 days ago

Last reply by jscher2000 1 day ago

Firefox dark mode

Please I just have read lots of people here with the same problem: I want to get rid of this dark mode and there's no help at all to solve this....how can this be possib… (read more)

Please I just have read lots of people here with the same problem: I want to get rid of this dark mode and there's no help at all to solve this....how can this be possible? Help me please, please, please !!!!

Asked by giuseppeaquino 2 days ago

Last reply by cor-el 2 days ago

HTTPS-Only mode setting using admx file

Hello, I am deploying Firefox to Windows 10 devices using Mozilla's latest template and I want to enable HTTPS-Only mode under "Privacy & Security" when I deploy Fire… (read more)

Hello,

I am deploying Firefox to Windows 10 devices using Mozilla's latest template and I want to enable HTTPS-Only mode under "Privacy & Security" when I deploy Firefox using Intune. I have gone through all the options available here, but I did not find such an option.

Firefox is deployed and it takes other customization and settings changes I make. Which means my admx file is working fine.

If the option to enable HTTPS-Only mode via Intune using admx is not yet possible, I would like to know if there is a way to deploy HTTPS-Everywhere with the option "Encrypt All Sites Eligible" ON.

Thanks.

Asked by redmkzpf 2 days ago

Last reply by redmkzpf 2 days ago

Firefox always connected to an amazonaws server

Firefox on ubuntu 20.04 Whenever firefox is running it's always connected to some amazonaws server lsof -i GeckoMain 450324 shi 199u IPv4 5430371 0t0 TCP 10.10.10… (read more)

Firefox on ubuntu 20.04

Whenever firefox is running it's always connected to some amazonaws server

lsof -i

GeckoMain 450324 shi 199u IPv4 5430371 0t0 TCP 10.10.100.6:39824->ec2-35-161-207-165.us-west-2.compute.amazonaws.com:https (ESTABLISHED)

I created a new profile and it's still there. I have never used sync.

Asked by extra692-red 3 days ago

Last reply by extra692-red 2 days ago

  • Solved

Some extensions not working after update to 96.0 on Linux

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning. uBlock Origin: 1) Not blocking content. All ads appear. I see… (read more)

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning.

uBlock Origin: 1) Not blocking content. All ads appear. I see this error message in the console: Error: Could not establish connection. Receiving end does not exist. | content_script.js

2) Toolbar icon does not show blocked items count (probably due to above)

3) Clicking toolbar icon causes resulting popup to appear as a vertical line (normal height but just a couple of pixels wide) with no content.

4) Going to Add-on settings and choosing "Preferences" from the add-on's 3-dot menu, the resulting tab crashes.

5) After removing and re-installing the add-on, its button does not appear on the toolbar.

6) After creating a blank profile and installing the add-on, all the above still happens.

7) After downgrading to firefox-bin-95.0.1, all the above still happens.

Ghostery: 1) Works on first install (did not previously have this installed); but after restarting Firefox, no longer works.

2) Breakage symptoms similar to uBlock Origin: No blocked items counter (and no blocking). Preferences tab still works though.

Multi-Account Containers: 1) Clicking on toolbar icon opens normally-sized but empty popup.

2) Opening a site that's configured to open in a container from a New Tab page tile, the site opens but *not* in the configured container (tab edge is not highlighed in container's colour-code).

Asked by ffx3 3 days ago

Answered by ffx3 3 days ago

  • Solved

An extension installed globally for all users (in /usr/share/mozilla/extensions) does not load for an unobvious reason

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozil… (read more)

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/. All extensions load normally, except Auto Tab Discard. When running firefox with the -jsconsole option, I see what the screenshot shows (the message "Invalid addon ID"). But the installation to user profile is successful. I add the extension ID to manifest.json, and get the following output in the console: addons.xpi-utils WARN addMetadata: Add-on {c2c003ee-bd69-42a2-b0e9-6f34222cb046} is invalid: Error: File /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{c2c003ee-bd69-42a2-b0e9-6f34222cb046} does not contain a valid manifest(resource://gre/modules/addons/XPIInstall.jsm:669:11) What can go wrong?

System: Debian 11 (bullseye) Firefox version: 91.4.1esr (amd64)

If you need any other information, please ask, I will write it down.

Asked by zostajekni 3 days ago

Answered by zostajekni 2 days ago