Showing questions tagged: Show all questions
  • Solved

Firefox saving to /run/user/1000/docs

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, pur… (read more)

This morning there was an Ubuntu software update and afterwards Firefox wouldn't work, it just opened and hung without ever connecting to a website. So I uninstalled, purged and reinstalled from Ubuntu Software and everything seemed ok. However, whenever I now try to save something, for instance images, the save to directory will default to /run/user/1000/docs even though I have my downloads folder selected in settings. I can change to the directory I want to save to and it will save there, but when I next save something it will again want to go to the /run/user/1000/docs folder. Further, I find that a copy of anything I save has also been saved into that folder, creating a new sub-directory to do so. I tried clear data in settings but that didn't delete those files and they are protected in file manager so I can't delete them myself. This will fill my hard drive pretty quickly as well as being really annoying having to change the save directory every time. What can I do to rectify this? I've now got version 96.0 (64 bit) installed.

Asked by paulhurford 4 days ago

Answered by jonzn4SUSE 3 days ago

  • Solved

The bookmark I tried to open in the new tab is suddenly deleted.

I've been dealing with the error I wrote in the title in the Linux version of your web browser for a while. When I "right click + open in new tab" on any bookmark, that b… (read more)

I've been dealing with the error I wrote in the title in the Linux version of your web browser for a while. When I "right click + open in new tab" on any bookmark, that bookmark is deleted.

Asked by mozilla-account 1 week ago

Answered by FredMcD 1 week ago

  • Solved

Firefox seemed to "sync" the DisableAppUpdate policy from a Windows public comp to my Linux personal comp. I don't want that.

I normally use Firefox desktop on my Linux computer. Last week, I started using it on a public computer running Windows. I installed Firefox Portable and then logged/sync… (read more)

I normally use Firefox desktop on my Linux computer.

Last week, I started using it on a public computer running Windows. I installed Firefox Portable and then logged/synced into my Firefox account on this Win computer. I noticed that in the Firefox Portable Windows “about:preferences” page, it says “Your browser is being managed by your organization”, which links to about:policies. In that “about:policies” page, it shows this https://i.imgur.com/JmD8nXg.png Policy Name: DisableAppUpdate Policy Value: true. Now I’m back on my Linux desktop computer and it also has this “managed by your organization” message in “about:preferences” and the same “about:policies” stuff. In other words, it appears that this policy was copied from the Windows public computer to my personal Linux computer. I don’t want that.

How can I undo this? And how can I block this sort of policy syncing?

Asked by Mozilla cheese 1 week ago

Answered by jscher2000 6 days ago

  • Solved

An extension installed globally for all users (in /usr/share/mozilla/extensions) does not load for an unobvious reason

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozil… (read more)

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/. All extensions load normally, except Auto Tab Discard. When running firefox with the -jsconsole option, I see what the screenshot shows (the message "Invalid addon ID"). But the installation to user profile is successful. I add the extension ID to manifest.json, and get the following output in the console: addons.xpi-utils WARN addMetadata: Add-on {c2c003ee-bd69-42a2-b0e9-6f34222cb046} is invalid: Error: File /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{c2c003ee-bd69-42a2-b0e9-6f34222cb046} does not contain a valid manifest(resource://gre/modules/addons/XPIInstall.jsm:669:11) What can go wrong?

System: Debian 11 (bullseye) Firefox version: 91.4.1esr (amd64)

If you need any other information, please ask, I will write it down.

Asked by zostajekni 5 days ago

Answered by zostajekni 3 days ago

  • Solved

Some extensions not working after update to 96.0 on Linux

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning. uBlock Origin: 1) Not blocking content. All ads appear. I see… (read more)

After upgrading to firefox-bin-96.0 on Gentoo Linux, I found that a number of extensions are malfunctioning.

uBlock Origin: 1) Not blocking content. All ads appear. I see this error message in the console: Error: Could not establish connection. Receiving end does not exist. | content_script.js

2) Toolbar icon does not show blocked items count (probably due to above)

3) Clicking toolbar icon causes resulting popup to appear as a vertical line (normal height but just a couple of pixels wide) with no content.

4) Going to Add-on settings and choosing "Preferences" from the add-on's 3-dot menu, the resulting tab crashes.

5) After removing and re-installing the add-on, its button does not appear on the toolbar.

6) After creating a blank profile and installing the add-on, all the above still happens.

7) After downgrading to firefox-bin-95.0.1, all the above still happens.

Ghostery: 1) Works on first install (did not previously have this installed); but after restarting Firefox, no longer works.

2) Breakage symptoms similar to uBlock Origin: No blocked items counter (and no blocking). Preferences tab still works though.

Multi-Account Containers: 1) Clicking on toolbar icon opens normally-sized but empty popup.

2) Opening a site that's configured to open in a container from a New Tab page tile, the site opens but *not* in the configured container (tab edge is not highlighed in container's colour-code).

Asked by ffx3 4 days ago

Answered by ffx3 4 days ago

  • Solved
  • Archived

How can the 5 minute timeout on sync verification code be increased to 10 minutes in view of delay receiving code by email?

Due to problems with upgrading my Ubuntu to 18.04, I've been forced to use a LIVE DVD for the last 8 months instead of a properly installed Ubuntu. This LIVE DVD crashe… (read more)

Due to problems with upgrading my Ubuntu to 18.04, I've been forced to use a LIVE DVD for the last 8 months instead of a properly installed Ubuntu. This LIVE DVD crashes or drops out from time to time so each time this happens I have to re-sync the Firefox it brings up. This re-sync requires a verification code to be sent by email, but because that email has to go through my Google filtering process, it usually takes longer than the code's 5 minute validity before I receive it. When I do finally get it and enter the received code back in Firefox, I'm told the code is invalid or expired. This is because 5 minutes validity is just too short a time for my setup. If it were 10 minutes, that would allow me to go into Gmail -> Settings -> Accounts & Import -> Check email from other accounts -> and then order Gmail to perform a special immediate mailcheck on my selected account. As a slow elderly old codger myself, I find it too hard to do all this within 5 minutes. Why can't we make it 10 mins?

Asked by advt 2 years ago

Answered by advt 2 years ago

  • Solved
  • Archived

Make custom search engine the default one

I added several custom search engines to Firefox on Linux by right-clicking their search bar and clicking "Add a Keyword for this search". Now I want to set one of them a… (read more)

I added several custom search engines to Firefox on Linux by right-clicking their search bar and clicking "Add a Keyword for this search". Now I want to set one of them as my default search engine. However, despite the custom ones are working flawlessly with a keyword, I can't find them in the Firefox settings. I know that there are Plugins for several search engines available, and it is even possible to create an own one, but I don't want to install a plugin just for a search engine I already have. Any suggestions?

Asked by userL 2 years ago

Answered by jscher2000 2 years ago

  • Solved
  • Archived

I sometimes can't put a check mark for "Do this automatically for files like this from now on", when I'm downloading some files. Why not? How to fix?

Most files I click on, I want Firefox to download a copy to my laptop. I often have the option to put a check mark for "Do this automatically for files like this from no… (read more)

Most files I click on, I want Firefox to download a copy to my laptop. I often have the option to put a check mark for "Do this automatically for files like this from now on". But sometimes, I can't. Why is that?

Asked by tailonfire 2 years ago

Answered by tailonfire 1 year ago

  • Solved
  • Archived

firefox interface font is to small for me to read, how to make it larger

the theme and font interface is terribly small, it is barely readable for me without straining my eyes. I am to to point where I have to guess where to click in the drop … (read more)

the theme and font interface is terribly small, it is barely readable for me without straining my eyes. I am to to point where I have to guess where to click in the drop down menus because the print is so small . there addon theme and font changer does not work. it has not work for a couple of years now there was a "userChrome.css" script that I was using that also no longer works. I have been a firefox user since it's beginning. from my online reading other users are having this same problem. I have not been able to find a online solution whet can be done to help or is there any help coming if the future

Asked by rowlandsushi 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

Font rendering on a specific website

Hello, I have a trouble with font rendering on one specific website - https://www.checkpoint.com. Text on this site looks quite ugly (see font01.png). But if I open "Web … (read more)

Hello,

I have a trouble with font rendering on one specific website - https://www.checkpoint.com.

Text on this site looks quite ugly (see font01.png).

But if I open "Web Developer" -> "Inspector" -> "Fonts" -> "All fonts on page", then I can see the text renderred correctly in the preview field (see font02.png).

So text uses "DIN WXX Regular" font, but I do not understand, why Firefox cannot render it on the web page in the same manner as in the Developer tools?

Any clue how to fix it?

Browser: Firefox 68.2.0esr (64-bit) OS: Debian Bullseye

Thanks Zbynek

Asked by Zbynek Michl 2 years ago

Answered by Zbynek Michl 1 year ago

  • Solved
  • Archived

How do I get firefox to stop rediecting my tab trhough my old university library account?

I am trying to access an academic article through my new university. Firefox opens the link through my old university, which was convenient for years, but can't find how… (read more)

I am trying to access an academic article through my new university. Firefox opens the link through my old university, which was convenient for years, but can't find how to change it.

Asked by d-carriere 2 years ago

Answered by d-carriere 2 years ago

  • Solved
  • Archived

Firefox crashes Ubuntu when running pluto.tv

While using Ubuntu 18.04.03 LTS and FF 71 When I go to www.Pluto.tv a free TV site and leave it running for about 40 minutes or more the message " a script on this page m… (read more)

While using Ubuntu 18.04.03 LTS and FF 71 When I go to www.Pluto.tv a free TV site and leave it running for about 40 minutes or more the message " a script on this page may be busy" this always happens both on Ubuntu and another Linux system. this problem does not occur on my Mac OS. the problem when left alone the CPU goes very high on the Linux system preventing any usefull usage of FF until it is closed and reopened.

The message that pops up suggests FF is interuppting something incorrectly. Anyone with a suggestion to stop this problem? Keeping in mind FF plays with no flawas for more than 40 minutes

Asked by Mace2 2 years ago

Answered by Mace2 1 year ago

  • Solved
  • Archived

prime video error

I've used prime video since 3 years without problems. From 2 days (14 Jan 2020) the prime video player gives me the error 4315 when I try to start a playback and it does … (read more)

I've used prime video since 3 years without problems. From 2 days (14 Jan 2020) the prime video player gives me the error 4315 when I try to start a playback and it does not work. I've tried on different linux machine with the latest upgrade istalled (both SO and browser) and the problem is the same. I've disabled all addons and also the tracking protection of firefox without success. Does someone have the same issue? Any ideas on how to solve? Probably an Amazon problem? Please help me if you can, thanks !

Asked by Davide 2 years ago

Answered by Davide 1 year ago

  • Solved
  • Archived

When I click on a link in an email, Firefox opens it in a new tab instead of in the current tab.

I use Thunderbird for my email and Firefox for my browser. Both are the latest versions for Linux, just updated. When I click on a link in an email, I want it to open i… (read more)

I use Thunderbird for my email and Firefox for my browser. Both are the latest versions for Linux, just updated. When I click on a link in an email, I want it to open in the current tab as it always has, not a new one. How can I get this back to the way it's always been?

Asked by sideburns 2 years ago

Answered by crankygoat 1 year ago

  • Solved
  • Archived

My userChrome.css that hides the top tabs has stopped working

I use the tree style tabs addon, so I prefer to hide the tabs along the top of the firefox window. For over a year I've used this userChrome.css file to hide them: https:… (read more)

I use the tree style tabs addon, so I prefer to hide the tabs along the top of the firefox window. For over a year I've used this userChrome.css file to hide them: https://github.com/eriknelson/dotfiles/blob/master/firefox/userChrome.css

Suddenly across all of my machines this has stopped working, and the tabs are still shown. I normally install it by navigating to the troubleshooting information to get my user profile location (ex: /home/ernelson/.mozilla/firefox/<profile>), creating a "chrome" directory, and copy the file there.

Has something changed with the API that would cause this sheet to be ignored? How can I troubleshoot this?

Firefox version: 72.0.1 OS: This occurs on all my systems; Windows, Arch Linux, and Fedora 31

Asked by eriknelson 2 years ago

Answered by crankygoat 2 years ago

  • Solved
  • Archived

FF Nightly offers userid(s) and password(s) that I want to remove. How can I do this?

When I begin to login to some sites I get a list of userids. Some are misspelled and I would like to remove them. I left button poke in the userid box in the form and get… (read more)

When I begin to login to some sites I get a list of userids. Some are misspelled and I would like to remove them.

I left button poke in the userid box in the form and get a list of userids.

I'm using this version of FF Nightly: 74.0a1 (2020-01-18) (64-bit)

Asked by George 1 year ago

Answered by FredMcD 1 year ago