Showing questions tagged: Show all questions

Getting a Unicode glyph to show correctly - specifically U+2A75

I am working on a website that uses Unicode extensively. Some glyphs do not show correctly. In particular U+2A75, which is double equals. I am using Ubuntu, and I have i… (read more)

I am working on a website that uses Unicode extensively. Some glyphs do not show correctly. In particular U+2A75, which is double equals. I am using Ubuntu, and I have installed Unifont. In the image, I have opened Firefox on the right and Chromium on the left, the URL is https://www.compart.com/en/unicode/U+2A75 Chromium is displaying the page correctly, Firefox is not. However, in both cases, the character is correctly displayed in the text in the Tab header after the favicon. browser.display.use_document_fonts is set to 1 I have read the Support page on editing fonts. Inspecting the element as suggested in the 'Editing Fonts' page, (see 2nd image uploaded), I see - in the source pane on the left, the character is correctly displayed (as in the tab text) - the Font being used to display the character in the rendered HTML is 'Source Sans Pro', which probably does not have the glyph for U+2A75. - the Font supplied by the website (presumably it does have the glyph) is list as a font, but I can't find a way to have it display the element.

I have tried to change the font family for the selected element in the Rules pane, but that does not work.

I have tried a variety of other changes in about:config but nothing seems to work.

I have two thoughts - the Font family for some Unicode ranges may be set for security reasons, and so U+2A75 is forced to some other Font - the fallback mechanism is not working to select a font when the glyph is not in the first family.

Asked by Richard Hainsworth 5 months ago

Last reply by zeroknight 4 months ago

Firefox could not download the search plugin from amazon.co.uk

The Amazon.co.uk search plugin was working but now its not and when i try to click "add search engine" a box pops up with Firefox could not download the search plugin f… (read more)

The Amazon.co.uk search plugin was working but now its not and when i try to click "add search engine" a box pops up with

Firefox could not download the search plugin from: https://d2lo25i6d3q8zm.cloudfront.net/browser-plugins/AmazonSearchSuggestionsOSD.Firefox.xml

another post suggested checking the about:config browser.search.region mine says "GB" which would be correct for .co.uk

All other search plugins work fine. Any suggestions?

Asked by JackDinn 2 months ago

Last reply by Terry 2 months ago

Why is the address bar gray, now? Why doesn't tiling using the super+arrow keys work quite right anymore?

I just updated Firefox. That's supposed to improve things, right? Now the address bar is gray most of the time. It looks normal when I'm entering a search, or editing a … (read more)

I just updated Firefox. That's supposed to improve things, right?

Now the address bar is gray most of the time. It looks normal when I'm entering a search, or editing a URL, the rest of the time, it's just ugly now. I don't like things to be changed arbitrarily like that. What is the rationale for changing the way that looks? How can I change it back? Please give me a setting, or about:config preference, and please don't get direct file editing involved, okay?

Why doesn't tiling the windows work as well as it used to? Yesterday, I could hit super+left, or super+right, from a maximized window, and it'd tile to the left or right side of the screen perfectly, the first time, every time, no problems. Now it has an intermediate stage where there's a gap all the way around the window. It seems to improve by clicking on a different window, then back into the Firefox window, but that intermediate step just shouldn't happen! What's a fix for this?

I also hit the button at the bottom to include optional troubleshooting information, but it said instead, "We can't automatically get your browser's troubleshooting data, please try these manual steps." No, I'm not doing that, get that thing working right, too!

Asked by Sterrence 2 months ago

Last reply by jscher2000 - Support Volunteer 2 months ago

How do I add the new bookmarks at top of the list in their folder?

When you add a new bookmark to a folder it's added at the end of the existing list. Is there a way to make Firefox add it at the top of the list, instead? I found an ol… (read more)

When you add a new bookmark to a folder it's added at the end of the existing list.

Is there a way to make Firefox add it at the top of the list, instead?

I found an old answer, but, sadly, the extension granting my wish is no longer.

Also, I already know about sorting, but it's not what I need, because I'm doing a lot of manual bookmarks reordering and sorting will nullify it.

Thank you :)

Asked by G 2 months ago

Last reply by jscher2000 - Support Volunteer 2 months ago

Integrated Webcam not working

The integrated webcam (IMC Networks Integrated Camera, according to lsusb) on my linux laptop does not work in firefox (v124). It works in desktop apps (eg webcamoid), an… (read more)

The integrated webcam (IMC Networks Integrated Camera, according to lsusb) on my linux laptop does not work in firefox (v124). It works in desktop apps (eg webcamoid), and chromium. I've checked the permissions (about:preferences#privacy), and that is not the problem. about:support does not list the device in the input at all. I've tried using LD_PRELOAD=/usr/lib64/libv4l/libv4l1compat.so, but that has not helped. Does anyone have any suggestions?

Asked by Mike Benson 1 month ago

Last reply by zeroknight 1 month ago

disruption forced restart

Reopening https://support.mozilla.org/en-US/questions/1412054 As you can see from https://github.com/linuxmint/linuxmint/issues/577 this issue is caused by Mozilla not c… (read more)

Reopening https://support.mozilla.org/en-US/questions/1412054

As you can see from https://github.com/linuxmint/linuxmint/issues/577 this issue is caused by Mozilla not caused by Linux Mint as accused in questions/1412054

Can you be honest and address this?

Asked by jmss 5 months ago

Last reply by zeroknight 5 months ago

frequent crashes of firefox running on fedora 38 workstation

As the title says, after a certain update(I'm not sure which, probably within the last few months or so), firefox on my machine starts crashing randomly. Some crash repor… (read more)

Asked by Bee Rath 3 months ago

Last reply by cor-el 3 months ago

Firefox-esr/ Firefox jumps back to page beginning while scrolling, not solved

I have followed the troubleshooting suggestions with no avail. I am currently in troubleshooting mode with all add-ons disabled. The problem persists. The only way to han… (read more)

I have followed the troubleshooting suggestions with no avail. I am currently in troubleshooting mode with all add-ons disabled. The problem persists. The only way to handle the problem is to depress the scroll wheel on the mouse and start scrolling. However, the problem returns with the next page. The problem shows up on Windows 10 as well as Debian bullseye.

I have used Firefox and Firefox-esr for years on the same platforms. This problem started about six months ago with no resolution. So what has changed? On Win 10 Firefox keeps getting updates whereas Firefox-esr never gets updates. The problem persists on both platforms. More than one mouse has been used with the same results. I have removed Firefox and Firefox-esr and re loaded them, no joy here either.

Asked by meparsons 1 month ago

Last reply by zeroknight 1 month ago

Super + key behavior

Hello there. I'm used to pressing Super(Win key) + Grave(`) to type "`" because the Grave key itself is a global shortcut for opening the terminal window. It works as exp… (read more)

Hello there. I'm used to pressing Super(Win key) + Grave(`) to type "`" because the Grave key itself is a global shortcut for opening the terminal window. It works as expected in the other applications, but not in Firefox input fields. If the site is capturing the key presses, it will handle the super + key as usual. For example, GitHub will surround the selected word with ` symbols on grave key press. This problem is not limited to super + grave, but any other letter. For example, Super + q is expected to produce the letter "q", but in Firefox it produces nothing.

I'm trying to identify why the Super + key behavior in Firefox is different from other systems and if I should open a bug or not. Maybe this is the same bug as https://bugzilla.mozilla.org/show_bug.cgi?id=1626609. Thunderbird has the same problem.

Firefox: 123.0.1

Asked by tenor 2 months ago

Last reply by cor-el 2 months ago

Won't connect to the internet and doesn't load pages at all

Hello, this is a problem I've been dealing with for nearly 2 months now. Currently using Linux Mint Cinnamon The browser won't connect to any websites or even try to loa… (read more)

Hello, this is a problem I've been dealing with for nearly 2 months now. Currently using Linux Mint Cinnamon

The browser won't connect to any websites or even try to load them, anytime I search for something it immediately goes to the error page. I've been struggling with internet on my PC for months and all was fixed when I hooked up ethernet, except for Firefox.

I've gone into about:config countless times. I've restarted it twice, I've tried installing the flatpak version and it's exactly the same result. I've deleted it and reinstalled, nothing. I've unchecked everything I've changed in about:config, once again nothing.

I can't update it as for some reason it says it's disabled by system administrator, which I don't remember enabling. I checked the firewall and it's perfectly fine. No infections were found when I scanned as well.

It's starting to become frustrating and I can't even do anything on my PC because it's acting up. Any and all help is more than appreciated and welcome. Thank you.

Asked by lotzzzzzzz 4 months ago

Last reply by jonzn4SUSE 4 months ago

Linux-ESR

Linux-ESR versions 115.8 and 115.9 are constantly crashing in my Acer CB514-2H chromebook. Previous versions of Linux-ESR have worked without any problems. It does work… (read more)

Linux-ESR versions 115.8 and 115.9 are constantly crashing in my Acer CB514-2H chromebook. Previous versions of Linux-ESR have worked without any problems. It does work in "safe mode", but not in normal mode with all extensions and plugins disabled. Appears to be related to something that is also disabled in the "safe mode" besides extensions and plugins.

This computer is running a MediaTek Kompanio 828 processor, 8 GB RAM and 64 GB eMMC.

I appreciate any help and advice that you can give me. If I can provide any info, let me know.


This is a link to a recent crash report.

https://crash-stats.mozilla.org/report/index/bp-d7586af4-bf78-4716-a102-8b2500240408

Asked by charlesw3571 1 month ago

Last reply by cor-el 1 month ago

Video playback freezing randomly and audio continues to play

The title describes the problem I'm facing. I don't really use other sites that have videos other than Youtube. But I notice that the videos freeze quite often and audio … (read more)

The title describes the problem I'm facing. I don't really use other sites that have videos other than Youtube. But I notice that the videos freeze quite often and audio just continues to play. The videos then unfreeze and skip multiple frames. I've noticed clearing browser cache seems to help but it doesn't help for longer than a 2 min video at best. At worst, it doesn't affect it at all.

Asked by playergamespro 4 months ago

Last reply by zeroknight 4 months ago

Firefox on Linux- Forward mouse button works, but back button does not

I'm running firefox 124.0.2 on Linux Mint and am having the most bizarre issue. I've got a logitech M560 mouse, and when I press the mouse button for Forward it functions… (read more)

I'm running firefox 124.0.2 on Linux Mint and am having the most bizarre issue. I've got a logitech M560 mouse, and when I press the mouse button for Forward it functions normally. However when I press the mouse button for Back, Firefox ignores it.

I've already confirmed that the OS is registering the button click as 'Back' using Input-Remapper, and the extra mouse buttons are enabled in the Firefox configuration. I've also used the mouse on another PC with no issues so this one is kind of boggling the mind.

Asked by tom_mcdermott 1 month ago

Last reply by jonzn4SUSE 1 month ago

upgrade without package manager

The Debian Firefox packages available are only 115.6. Thought it would be nice to have the latest. Grabbed all the dependencies according to the Mozilla web site. Instal… (read more)

The Debian Firefox packages available are only 115.6. Thought it would be nice to have the latest. Grabbed all the dependencies according to the Mozilla web site.

Installed Firefox 121.0 as root and placed folder into /opt, as instructed. Went through all the settings and imported my bookmarks.

Now there is a 121.0.1 upgrade available but my browser won't automagically install the upgrade. Says click here to download. So I do. I get the entire tar.bz2 bundle, which creates a full directory structure, as if I was starting over.

Can I just move a few files from that into the existing /opt/firefox directory to get the upgrade? If so, which ones?

Or, can I move few files from the existing directory into the new version, and replace the whole lot? If so, which ones?

Thanks in advance.

Asked by Scottzzz 4 months ago

Last reply by zeroknight 4 months ago

firefox keeps on crashing since the snap system

Since snap firefox keeps crashing somehow, it just hangs.. i cleared cache and all, reinstalled it, but still.. ? They say linux is a broken system (: … (read more)

Since snap firefox keeps crashing somehow, it just hangs.. i cleared cache and all, reinstalled it, but still.. ?

They say linux is a broken system (:

Asked by tclc 5 months ago

Last reply by zeroknight 5 months ago

Japanese Input not appearing

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works ever… (read more)

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works everywhere else on my computer (i.e. terminal, thunderbird, other browsers, etc.). Furthermore, I uninstalled fcitx and everything associated with it and reinstalled it according to this thread: https://support.mozilla.org/en-US/questions/1367181 (just with mocz for Japanese). This also didn't change anything. Any help is appreciated! My system: Operating System: Linux Mint 20.3 Kernel: Linux 5.15.0-91-generic Architecture: x86-64 fcitx version: 4.2.9.7 Mozilla Firefox 121.0

Asked by Paracelsus 4 months ago

Last reply by zeroknight 1 month ago

Is ff123 unstable?

With first boot after installing ff223, my HP laptop failed, insisting internal had does not exist. Internal had is 1/2 gig, external had is 2 gig, but completely ignore… (read more)

With first boot after installing ff223, my HP laptop failed, insisting internal had does not exist. Internal had is 1/2 gig, external had is 2 gig, but completely ignored now. No thumb drive or alternate device recognized. Laptop has Linux Mint 64 but.

Asked by cmdr.ronald 2 months ago

Last reply by jonzn4SUSE 2 months ago

Problem downloading anything in Firefox (Linux Mint 21 - System Package/Flatpak)

Hello everyone. Well, I've been using Firefox for a few months, maybe a semester now, I don't remember. But the point is that since yesterday I have been facing a seriou… (read more)

Hello everyone. Well, I've been using Firefox for a few months, maybe a semester now, I don't remember. But the point is that since yesterday I have been facing a serious problem of not being able to download any type of file (MP4, PDF, .JSON, ISO, etc.). I've already used the troubleshooting mode and I've also restarted my laptop, but it didn't help. I've also gone to the advanced settings (see 'about:config > browser.download') and reset/deleted the data for each command but the problem still persists.

What happens is the following: I click to download the file in question, however, nothing happens other than the page loading that commonly occurs when downloading something. Still, the file does not appear in the downloads tab and there is not even the option to choose where to save the file (e.g. Downloads folder, Documents folder). The download simply appears to have failed.

Exactly, it 'appears', because today I discovered that all my downloads were being directed without my permission/action to the 'downloads' folder (And that's not where I want them to go). The problem would be smaller if only this happened, as I would then just get the files downloaded there and then change to the desired folder, thus trying to move forward despite the problem. But the downloaded files themselves are not operational, they have the icon when a file is still downloading, in addition to not having a name, everything being just a cluster of codes.

In the end, there are files, large and small, that have no use and that I don't even have control over where to direct them. Which is still a huge problem because I still technically can't download anything from the browser. Please, I really need your help on how to resolve this problem.

Note: Also, when I close and open the browser, the first download I try appears in the downloads tab, but it fails instantly and cannot be resumed, making it an eternal failure.

Asked by Tragoudo 4 months ago

Last reply by jonzn4SUSE 4 months ago