Showing questions tagged: Show all questions
  • Solved
  • Archived

Bottom ~20% of each firefox window is just a blank white bar

Just (~20 minutes ago) updated 102.0.1 (64 bit) and now there are white bars across the bottom of each firefox window (see screenshots) except for support.mozilla.org or… (read more)

Just (~20 minutes ago) updated 102.0.1 (64 bit) and now there are white bars across the bottom of each firefox window (see screenshots) except for support.mozilla.org or mozilla.org addresses. Any idea what is going on and/or how to fix it?

Asked by bc13 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

How to easily disable annoying PKCS#11 pop-up when Yubikey is plugged in

Hi, I am using Firefox for Linux, and whenever my yubikey is plugged in, firefox will start bothering me for a pkcs#11 password. It always happens on start-up but it get… (read more)

Hi,

I am using Firefox for Linux, and whenever my yubikey is plugged in, firefox will start bothering me for a pkcs#11 password. It always happens on start-up but it gets relentlessly annoying if I happen to be on a site which potentially utilizes certificate auth, which I do not use this yubikey for.

I do however use it for 2fa, which does work perfectly fine.

How do I permanently stop whatever Firefox process keeps bothering me about this PKCS#11 password for functionality that I never use?

Asked by Dave 11 months ago

Answered by Dave 11 months ago

  • Solved
  • Archived

Firefox does not sync

Hi, I create an account to sync Bookmarks, Passwords, Add-ons, History etc from one computer to an other. I successfully created the account, verify mails, checkbox all f… (read more)

Hi, I create an account to sync Bookmarks, Passwords, Add-ons, History etc from one computer to an other. I successfully created the account, verify mails, checkbox all features to sync in settings, and click on "sync' multiple times. But nothing is synced on my new computer. On the log I saw (about:sync-log):ab

    1. On new computer side

1674839909897 FirefoxAccounts ERROR FxA rejecting with error UNVERIFIED_ACCOUNT, details: undefined 1674839909897 FirefoxAccounts ERROR Background refresh of initial profile failed: Error: UNVERIFIED_ACCOUNT(resource://gre/modules/FxAccounts.jsm:1561:18) JS Stack trace: _error@FxAccounts.jsm:1561:18


1675070999227 FirefoxAccounts ERROR Background refresh of profile failed: {"name":"FxAccountsProfileClientError","code":null,"errno":998,"error":"NETWORK_ERROR","message":"[Exception... \"NS_ERROR_ABORT\" nsresult: \"0x80004004 (NS_ERROR_ABORT)\" location: \"JS frame :: resource://services-common/rest.js :: onStopRequest :: line 491\" data: no]"}

    1. On previous computer side

Sync.ErrorHandler ERROR Sync encountered a login error Sync.Service DEBUG Not syncing:login returned false

Can you help me please ? Mrs RICHTER

Asked by Cannelle 1 year ago

Answered by Cannelle 1 year ago

  • Solved
  • Archived

Backup & restore information in Firefox profiles

Hi there! I'm attempting to migrate my Firefox (106.0.3) profile from the Linux Mint V20.3 on one SSD to a new installation of Linux Mint V21 on a separate SSD. I'm usi… (read more)

Hi there!

I'm attempting to migrate my Firefox (106.0.3) profile from the Linux Mint V20.3 on one SSD to a new installation of Linux Mint V21 on a separate SSD. I'm using the information supplied on this page:

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Step 4, under Backing up your profile says: Right-click on your profile folder (e.g. xxxxxxxx.default), and select Copy.

This folder, qspfoqtl.default, contains 1 file, named times.json, the contents of which are:

{ "created": 1618792039414, "firstUse": null }

Clearly, not my Firefox profile.

There is, however, a folder named nnob5aww.default-release that contains a bunch of directories and files (505.4MB) with names like bookmarkbackups, browser-extension-data... storage, weave.

Is this documentation incorrect as of this release of Firefox? And, should I be using the nnob5aww.default-release folder as the profile? I'm a little confused. (Most often, I'm a lot confused.) Any help would be appreciated.

Thanks in advance,

- Ralph

Asked by Mandelbrot1 1 year ago

Answered by Mandelbrot1 1 year ago

  • Solved
  • Archived

wide spacing between words as well as odd-looking numbers in Firefox

Since a recent update the spacing of words in Firefox's UI as well as on some websites seems to be wider than normal (instead of a singular space it seems as if each spac… (read more)

Since a recent update the spacing of words in Firefox's UI as well as on some websites seems to be wider than normal (instead of a singular space it seems as if each space is now a tab wide). Additionally the numbers have also suffered and are now not presented in a normal font anymore but instead seem bigger and grey instead of white or black. Both of these issues occurred at the same time and appear on the normal User Interface of Firefox (e.g. in the bookmarks or in Firefox's settings and preferences) as well as on some websites/search engines. However when copying the text and numbers from Firefox into a regular text editor everything seems normal and no appearance issues can be noticed. What I've already tried: I've restarted my system multiple times since the issue first occurred. I've removed all contents from /home/user/.mozilla/firefox. I've reinstalled Firefox. I've deleted my cache. I've changed my font preferences in Firefox back to Default(Roboto) after having used Inter before. None of my actions above have changed anything. However, when I log into a different user on my computer and open Firefox there everything seems to be normal, so it seems as if this is a user-specific problem.

Thanks in advance, Emma.

OS: opensuseTumbleweed 20220507 Firefox version: 100.0 (issue has occurred since version 98.0)

Asked by emma.6.62607015e-34 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

mysignins.microsoft.com

Hello I'm trying to sign into a Microsoft 365 email account but can't get beyond a screen saying "To use this site, you need to change your browser settings to enable DO… (read more)

Hello

I'm trying to sign into a Microsoft 365 email account but can't get beyond a screen saying "To use this site, you need to change your browser settings to enable DOM storage or cookies."

I've enabled DOM storage and cookies but no difference. I've cleared cookies and no help. I'm running Firefox 115.0.2 and Linux Mint.

Is part of the problem that I hate Microsoft and they know it?

Thanks

Asked by arthurjackson 9 months ago

Answered by jonzn4SUSE 9 months ago

  • Solved
  • Archived

Customize Firefox: unable to add extension into toolbar

Hello, I have more than 30 extensions, but I cannot add an extension shortcut into my toolbar and no extension appears in the “Customize Firefox” view. I tried “Restore … (read more)

Hello,

I have more than 30 extensions, but I cannot add an extension shortcut into my toolbar and no extension appears in the “Customize Firefox” view. I tried “Restore defaults” without any effects...

There is a way to fix this issue or run Firefox in verbose mode to more information why my extensions don't appear here? (Other than restart from a new fresh profile if it's possible…). I confirm that all the extensions are functional and activated. Thanks,

Emeric

Asked by Emeric Verschuur 1 year ago

Answered by TyDraniu 1 year ago

  • Solved
  • Archived

Impossible to use an unusual port number in local URL

Hi all :) From a fresh Linux Debian Bullseye I try to connect to a local machine with Firefox (v97 64-bits) by its hostname (avahi server with default domain "local… (read more)

Hi all :)

From a fresh Linux Debian Bullseye I try to connect to a local machine with Firefox (v97 64-bits) by its hostname (avahi server with default domain "local") with the port 6180 bound to a remote web service port (61 is the distant machine IP and 80 is the forwarded port).

When I want to open this URL : http://bionic.local:6180/ FF displays "We can't find this site ... Unable to connect to server at bionic.local ... check your network connection and firewall"

BUT ping bionic.local works perfectly and resolve the good IP address from the Chromium navigator the same URL works without a problem, I can open the distant web site.

This workaround works : add a static resolution in the /etc/hosts file : 192.168.0.71 bionic bionic.local => so FF works in the expected way for now ! But as I said this a workaround and a bad solution.

I supposed too the port was blocked because I accessed an unusual port. So I tried this without success.

How the hell make that FF v97 allows me to use an unusual port ? Or is it bound to the domain "local" which is no more accepted by FF ?

Thank you in advance for your help. With adelphity, lnj

How to do

Asked by estebann 2 years ago

Answered by estebann 2 years ago

  • Solved
  • Archived

google password utility

Hi, No matter what I do, a google dialogue box encouraging me to use google for password management, pops up every time I go to a site, new or existant. I've gone into … (read more)

Hi,

No matter what I do, a google dialogue box encouraging me to use google for password management, pops up every time I go to a site, new or existant.

I've gone into my google account to disable such requests, and, indeed, otherwise use google for nothing....not even search............but they keep coming anyway.

am using ubuntu 20.04, and no other utility or code is giving me this trouble.

I want to stop this dialogue box and eliminate any code in firefox or ubuntu which supports it.....as I have no idea why this box showed up....one day it just started.

Many thanks!

oliver

Asked by olivermaz 1 year ago

Answered by olivermaz 1 year ago

  • Solved
  • Archived

[SOLVED] cannot save page/file to local drive

Hi, I'm using version 101.0.1 (64 bit) for Ubuntu 22.04. When I open a link of a pdf file, the file is displayed in the built-in viewer, since I chose "Open in Firefox" i… (read more)

Hi, I'm using version 101.0.1 (64 bit) for Ubuntu 22.04. When I open a link of a pdf file, the file is displayed in the built-in viewer, since I chose "Open in Firefox" in my settings. But then if I click the download icon nothing happens. If I click the print icon and choose "print to pdf" in the popup, then clicking on "save" does nothing and I have to click "cancel" to dismiss the popup.

Actually there is no way to save a pdf file but setting PDF app to "Ask always" and then open it with "System handler", but then the file is saved into the default download folder, even though I selected the checkbox "Always ask me where to save files" in my settings.

EDIT: the issue was solved by installing the following packages, as shown in this question :

xdg-desktop-portal xdg-desktop-portal-gtk

Asked by gi4c0ph 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Firefox snap app does not recognize custom cursor.

I can't get Firefox to use some custom cursors. Firefox is only recognizing the cursors that came installed with Ubuntu. Any of the cursors I installed will default to DM… (read more)

I can't get Firefox to use some custom cursors. Firefox is only recognizing the cursors that came installed with Ubuntu. Any of the cursors I installed will default to DMZ-White, but Firefox is using those cursors that came installed with Ubuntu. I tried defining the default cursor in /usr/share/icons/default/index.theme but did nothing as well. Also I tried with the cursor in /usr/share/icons and in /home/name/.icons and firefox cannot get in any of those.

I don't know if it's something wrong with my cursors or it's some inner thing with Firefox, any one has a guess? Incompatibility or something missing from the cursor?

Asked by tisppereira 11 months ago

Answered by cor-el 11 months ago

  • Solved
  • Archived

private browsing window is a different color now

After an update today, private browsing windows now are a different color than the other windows. I don't want them to be a different color. How do I change them back to … (read more)

After an update today, private browsing windows now are a different color than the other windows. I don't want them to be a different color. How do I change them back to the same as the other windows?

Also, how do I remove the extra text label next to the private mode icon, and just generally put things back to the way they used to look?

Asked by Sterrence 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Login not possible anymore on Letterboxd.com and other websites since update to FF 104

Hello, This issue might or might not be related to [other issue] I have since I updated Ubuntu 20.04 to 22.04 and therefore updated my Firefox to 104. I can't login anym… (read more)

Hello, This issue might or might not be related to [other issue] I have since I updated Ubuntu 20.04 to 22.04 and therefore updated my Firefox to 104. I can't login anymore on Letterboxd since the update. It's not a problem of username or password. When I click "Sign in", nothing happens except a page refresh, but I'm still not logged in. Other strange behaviour on that site since the update: most of the images don't appear. For example on this page : https://letterboxd.com/films/# all the movie covers are just blank.

The website does work properly when using Firefox in private mode though (both login and images work fine), so this makes me think it's related to my other issue mentioned above.

OS: Ubuntu 22.04 Firefox 104.0.2

EDIT after posting this question: I just found out that I can't login on Google either. I enter my username, password, then it asks me to validate on another apparel that it's really me, which I do, and nothing happens so I can't login. It works normally in private mode.

Asked by vanecx 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Duckduckgo opens links as https://html.duckduckgo.com/html

Hi, I'm using Duckduckgo as my search engine, but when I type in a search string, it Firefox prepends it with https://html.duckduckgo.com/html/... This opens a search p… (read more)

Hi,

I'm using Duckduckgo as my search engine, but when I type in a search string, it Firefox prepends it with https://html.duckduckgo.com/html/... This opens a search page that doesn't follow my dark theme. When I click on a link, another link is added that creates a link back to the same URL, causing a loop. This never happened before I upgraded to Ubuntu 22.04 & the latest version of Firefox, 100.0.2. How can I change this back?

Thanks!

   -John

Asked by jlcenter 1 year ago

Answered by jlcenter 1 year ago

  • Solved
  • Archived

Disable Ctrl + Shift + C shortcut

I really often need to copy/paste from a terminal opened in my browser. Because the shortcut for copying in a terminal is always Ctrl+Shift+C, it's a mess to have instea… (read more)

I really often need to copy/paste from a terminal opened in my browser. Because the shortcut for copying in a terminal is always Ctrl+Shift+C, it's a mess to have instead Firefox opening Inspector from devtools.

How can I disable this shortcut ?

I've tried to update some about:config settings but it doesn't seem to be helpful and old working correctives add-ons are not supported anymore.

Asked by alexandre.huet7 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

rumble video is not visible on a webpage

The rumble video interview of Jonathan Cahn by Greg Hunter is NOT visible in my linux version 91.12.0esr(64-bit) of Mozilla Firefox, straight from an openSuse software re… (read more)

The rumble video interview of Jonathan Cahn by Greg Hunter is NOT visible in my linux version 91.12.0esr(64-bit) of Mozilla Firefox, straight from an openSuse software repository and directly installable under yast, which is their administrator program over the linux software including the software manager

The web page in question is https://usawatchdog.com/only-way-to-save-america-is-turn-back-to-god-jonathan-cahn/ but the java script code is grayed out on this page

!function(r,u,m,b,l,e){r._Rumble=b,r[b]||(r[b]=function(){(r[b]._=r[b]._||[]).push(arguments);if(r[b]._.length==1){l=u.createElement(m),e=u.getElementsByTagName(m)[0],l.async=1,l.src="https://rumble.com/embedJS/ugdmvn"+(arguments[1].video?'.'+arguments[1].video:)+"/?url="+encodeURIComponent(location.href)+"&args="+encodeURIComponent(JSON.stringify([].slice.apply(arguments))),e.parentNode.insertBefore(l,e)}})}(window, document, "script", "Rumble");

I have used other browsers, such as Opera, Brave, Google Chrome and the rumble video is clearly visible and playable.

What do I have to change in Firefox so that this video becomes visible on the page?

Randall

p.s. Greg Hunter is interested in this reply too

Asked by website.reader3 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Force download of mp4 files ?

When clicking on a link to an .mp4 file, Firefox navigates to a builtin video player, streaming the remote video file. When Firefox is unable to stream or display a file … (read more)

When clicking on a link to an .mp4 file, Firefox navigates to a builtin video player, streaming the remote video file. When Firefox is unable to stream or display a file (as is the case with .mkv or .txt for example), it is downloaded instead.

I simply want .mp4 files to be downloaded when I navigate to them. I tried setting `media.mp4.enabled` to `false`, and that worked, but it also disabled most embedded media players.

Asked by thibautguenedal 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Cloudflare hosted site complains about Firefox but works with Chrome

This site, Costco Instacart, worked perfectly with Firefox as recently as April 15, 2023 but today fails (see attached image): https://sameday.costco.com/store/costco/sto… (read more)

This site, Costco Instacart, worked perfectly with Firefox as recently as April 15, 2023 but today fails (see attached image): https://sameday.costco.com/store/costco/storefront?zipcode=11021

Cloudflare believes it is protecting itself from online attacks when accessed by Firefox. The same site worked perfectly today, on the same computer, using Google Chrome.

Cloudflare is a major CDN and many important commercial sites, like Costco Instacart, have their content delivered by Cloudflare so this is a major issue with Firefox. For the moment there is a work-around, use Chrome instead, but it would be better to have Firefox address issues with Cloudflare.

Asked by em2jacks 11 months ago

Answered by em2jacks 11 months ago

  • Solved

Permission denied when opening file from another drive

When opening a file from another drive, I get an error: Access to the file was denied I know this can happen on the Snap version, but I have Firefox installed from a deb… (read more)

When opening a file from another drive, I get an error: Access to the file was denied

I know this can happen on the Snap version, but I have Firefox installed from a deb!

Asked by Bic 6 months ago

Answered by zeroknight 5 months ago

  • Solved
  • Archived

MP4 videos encoded with H264 say "Video can't be played because the file is corrupt"

I routinely record short screencasts with Kazam, and I can't watch my own videos after posting them on sites like GitHub because Firefox says "Video can't be played becau… (read more)

I routinely record short screencasts with Kazam, and I can't watch my own videos after posting them on sites like GitHub because Firefox says "Video can't be played because the file is corrupt". Or for example when I upload them to sites like ezgif to convert them to a GIF, which works just fine because, well, the file is not corrupt. Other browsers like Chromium play them just fine.

Apparently the "OpenH264 Video Codec provided by Cisco Systems, Inc" is properly enabled in my system. This has been happening to me for months or years, but only today I decided to open a thread here.

There are two things here:

1. Firefox can't play the file. I'm sure there's some sort of misconfiguration on my side, or bad defaults, or a missing plugin, or similar. 2. Firefox shows a misleading message. The file is not corrupt! The root cause is something else.

Any advice on how to fix the first one?

Asked by astrojuanlu 1 year ago

Answered by Denis 1 year ago