"Performing a TLS handshake" -> Sites don't load

Running v 60 ESR, downgraded from v 68, with zero problems for 3 weeks. I've had this problem all of a sudden since last week. Steps I've taken so far: Changed "securi… (read more)

Running v 60 ESR, downgraded from v 68, with zero problems for 3 weeks.

I've had this problem all of a sudden since last week. Steps I've taken so far:

  • Changed "security.tls.version.min" to 3 from 1 (didn't work)
  • Deleted cert8.db (didn't work)
  • Changed to Google DNS (not sure)
  • Changed to "auto-detect proxy" from "system proxy" (not sure, maybe)
  • Disabled IPV6 (not sure, maybe)
  • Turned off/on wifi hotspot, rebooted laptop (not sure, maybe)

The last 3 steps I took at the same time and they worked. On reboot the problem went away, albeit for 2 days!

It just came back, now it's performing a TLS handshake on about half the sites, with loading after 30-60 seconds or not at all. From searching, I see that solutions are all over the place on this and it's specific to FF. A post clearly identifies a Symantec certificates issue.

This is probably the toughest issue I've come across on FF.

Asked by elzach 10 minutes ago

How to delete data from Browser

Hello... I'm using the latest version of Firefox and the latest version of Windows 10 ... I'm curious when I do the following with the browser, click History, select from… (read more)

Hello... I'm using the latest version of Firefox and the latest version of Windows 10 ... I'm curious when I do the following with the browser, click History, select from Clear Recent History, have it set for Everything and have all the boxes checked, how is it when I visit a certain website it still show me log into there website? I thought if I delete the everything( cookies, cache ) this wouldn't be the case. Is there a way for the browser to be completely clean from all? thanks

Asked by email4321 1 day ago

Last reply by email4321 19 minutes ago

Text Coming Up as Boxed ?s or Gobbly Goop

Current preference settings are increased font size to 14pt and zoom 110%. Since I set those preferences some websites, mainly ones with form fields, come up as a boxed q… (read more)

Current preference settings are increased font size to 14pt and zoom 110%. Since I set those preferences some websites, mainly ones with form fields, come up as a boxed question mark. Also when I do an internet search is comes out crazy alien like text / weird code. See attached screen shot of a basic search for 'books'. I prefer using Firefox over Safari and would love to remedy this.

Using current version 83 on Mac OS 10.15.7.

Thank you

Asked by bba3littlebirds 30 minutes ago

HTML5 not working

I've just installed the latest Ubuntu OS on my computer and when starting Firefox i get this problem while trying to play the latest YouTube videos where they say "Your … (read more)

I've just installed the latest Ubuntu OS on my computer and when starting Firefox i get this problem while trying to play the latest YouTube videos where they say "Your browser does not currently recognize any of the video formats available. Click here to visit our frequently asked questions about HTML5 video." so I've tried to click on the link but then Firefox said my browser was already up to date. I've then tried to disable my adds on and try in safe mode but that did not help. I've tried installing some adds on, that didn't help either. I've tried uninstalling and installing back Firefox, that didn't work. every media.mediasource config are enabled, that didn't work. and when i try using another browser, the media can be played just fine (i used chromium). So if someone has any idea as to what might be causing this issue i'd be grateful (also, older video seems to be working just fine)

Asked by guillaumemannone 58 minutes ago

Unable to restore session from file

Hey! First time I get that, I usually lose my tabs due to my mistake but this morning after starting my PC all the tabs were gone with no option to restore or any error … (read more)

Hey!

First time I get that, I usually lose my tabs due to my mistake but this morning after starting my PC all the tabs were gone with no option to restore or any error message. I backed up my previous session json and other files by hand but every time i copy it back into my profile folder and rename it sessionstore.jsonlz4 it just gets deleted after I open firefox and none of my old tabs get loaded. I scrounged the files before and saw that they contain my lost tabs, I just can't seem to restore them. I tried reinstalling firefox too but that didn't help.

Did the restore system change or is the backup corrupt ? Thanks!

Fred

Asked by ftarabout 3 hours ago

Last reply by ftarabout 1 hour ago

I have updated my O/S from Ubuntu 18.04 to 20.10. Nothing else. Now Firefox is nearly useless

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it. Originally I was using Ubuntu 18.04 LTS. I thought it woul… (read more)

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it.

Originally I was using Ubuntu 18.04 LTS.

I thought it would be good to update to GG (20.10) though I did briefly try FF (20.04).

As the install was done on an existing 18.04 version things remained the same for programs, book marks, etc.

Ok, now the crunch: I USE Firefox ""A LOT"". When it loads, there are...... 8 x 6 windows of FireFox and each of those have anywhere from one to ""THIRTY"" tabs loading.

Believe me: ""It worked!!""

I could use it, also run other tasks as well - though a VM was pushing it with the RAM. But the entire machine worked.

Now, I am lucky if FireFox loads at all. Let alone let me browse.

When it loads some of the window's tops are flashing. A screen shot does not really show this. (I tried)

All that has changed is the O/S from 18.04 and Firefox from (what ever it was) to 83.0

I don't want this to be a finger pointing exercise between Mozilla and Ubuntu. I would prefer it is helpful to all.

What have I tried? I've tried starting FireFox with all addons disabled. Still happens.

I am going to try to remember to (next time) launch FireFox from a Terminal and pipe the output to a file to look for things.

The machine I am using has shown it is well up to being able to have this running. I have had it working for a few years like this.

This post is (for now) to establish there is a problem. I will post more information when I get it, rather than waiting to get it then post, as I feel there are a lot of people who have very similar problems and I want it known: ""You are not alone!""


Now a bit of extra stuff.

Other things which are weird: When I am watching stuff - youtube for example - the playback is/WAS jerky. I hadn't touched anything in the settings.

After digging around, I discovered that I had to turn ""OFF"" the hardware acceleration for the graphics. Question: How did it get turned on? (Semi rhetorical)

I have a lot of local pages I open with passwords. When I load them the CPU load goes through the roof and nearly invariably the program just exits. No crash report.

Which is a good 50% of how it happens. The other 50% is the machine just locks up and I have to power it down.

Asked by teeny_weeny 1 day ago

Last reply by teeny_weeny 1 hour ago

  • Solved

Firefox upload window for choosing files is full screen, and cannot resize!

For the last few versions of Firefox (up to date on Windows 10 64-bit) the file upload window always opens full screen, and cannot be resized. This is annoying! AND can b… (read more)

For the last few versions of Firefox (up to date on Windows 10 64-bit) the file upload window always opens full screen, and cannot be resized. This is annoying! AND can be totally disfunctional when another bug in Windows leaves an artifact popup in the lower right of my screen that covers the upload window action buttons (Open & Cancel).

I used to get a more normal file chooser window that could be resized...

Asked by PTArtist 5 hours ago

Answered by cor-el 4 hours ago

How to use 'This time search with' with one click instead of two?

When I do a search using the address bar, clicking a search engine won't take me to the result directly. Instead a blue box (e.g. @Google) pops up in the address bar, and… (read more)

When I do a search using the address bar, clicking a search engine won't take me to the result directly. Instead a blue box (e.g. @Google) pops up in the address bar, and I have to click one more time to do the search. But the Firefox installed in my office needs one click only (i.e. no blue box pop-up). Is there a way to prevent the blue box from appearing?

(Both versions of Firefox are up to date, 83.0 64bit)

Asked by Reguna 10 hours ago

Last reply by cor-el 2 hours ago

Dev Tools -> Inline stylesheet doesn't update after making changes to styles or adding styles

When using the dev tools, I'll frequently update the style on a page I'm editing, then switch over to the inline stylesheet to copy and paste the changes I've made into m… (read more)

When using the dev tools, I'll frequently update the style on a page I'm editing, then switch over to the inline stylesheet to copy and paste the changes I've made into my .CSS file. For some reason when I make updates, they don't show up in the inline stylesheet.

When I make changes and write styles here: https://prnt.sc/vt6mvv

I don't see them here: https://prnt.sc/vt6n97

I used to use this feature all the time in Firefox, but then it stopped working for me some point years ago. I think it was just broken by an update, or some local issue. But it's followed me across versions of Firefox and across machines.

Which makes me wonder if I just don't understand the way this is supposed to work, of if this actually is an issue.

I use this same workflow in Chrome all the time and it works just as I expect. I'd like to come back to Firefox because I like some of the dev tools better, but I just can't work in Firefox without this working.

Any help would be appreciated.

Asked by bellalexander 2 hours ago

Locked Enterprise roots

I have "the Enterprise Roots preference" problem. I followed the solution and changed the "security.certerrors.mitm.auto_enable_enterprise_roots " toggle without a proble… (read more)

I have "the Enterprise Roots preference" problem. I followed the solution and changed the "security.certerrors.mitm.auto_enable_enterprise_roots " toggle without a problem. However, when it came to the "security.enterprise_roots.enabled" line in config... I show a lock and I am unable to highlight that function. Thanks for the help!!

Asked by BuffaloGary 3 hours ago

Last reply by cor-el 2 hours ago

YouTube player preferences not being saved.

Just recently I noticed that Firefox 83.0 is no longer retaining my viewer settings in YouTube. Specifically the theater mode and autoplay settings. I can set it to theat… (read more)

Just recently I noticed that Firefox 83.0 is no longer retaining my viewer settings in YouTube. Specifically the theater mode and autoplay settings. I can set it to theater mode, and turn off autoplay, and the next time I start Firefox, they are back to their defaults (autoplay on, compact viewer). At first I thought it was a YouTube issue but have tried it on Chrome and Chromium and both browsers save my settings. I'm running ArcoLinux 5.9.10 with I3 WM on both my desktop and laptop. I have both reset and re-installed FF with no change.

Asked by erik45 3 days ago

Last reply by erik45 2 hours ago

Can I suspend Firefox asking for Primary Password?

I'd like to easily be able to suspend Firefox from constantly asking for my Primary Password. There are often times when I don't need to enable Firefox Password from fil… (read more)

I'd like to easily be able to suspend Firefox from constantly asking for my Primary Password. There are often times when I don't need to enable Firefox Password from filling in passwords and don't need to login to my account at any particular website, but want to lookup information. For example, I may want to see if an item is available on Amazon and what the options are without having to login to my account. But as soon as I go to Amazon -- and for every, single page I access while there -- the "Enter Primary Password" box pops up and I can't continue without clicking "cancel". If I enter my Primary Password just once it stops asking. But I'd prefer to be able to easily tell Firefox to not enable Firefox Password and ask for my Primary Password until I want it enabled; perhaps by having a toggle button in the menu bar? I see there's what sort of looks like a method for this if you search for "Firefox keeps asking for Primary Password", but it state that it applies when using AVG and another security software, but I'm not using either of those. Maybe it continues to ask after entering it when using one of these software? I tried it anyway and it didn't make any difference. Is there a way to do this? Thanks.

Asked by blumarble 4 days ago

Last reply by jscher2000 2 hours ago

How to disable Firefox address bar in v83

So I've recently updated to v83 and find out that that annoying address bar is back. I don't really want to use Chrome.css because I'm not good at programming or anything… (read more)

So I've recently updated to v83 and find out that that annoying address bar is back. I don't really want to use Chrome.css because I'm not good at programming or anything like that and I am afraid I might break my browser.

I have the solutions for v77 on my about:config and tried toggling them true/false and restarting my computer but I think Firefox "fixed" those workarounds.

Anybody have any new suggestions? Or am I stuck with this (I wouldn't mind it so much but it goes to it automatically when I open a new tab and that annoys me. I'm happy the history part of the workaround is still working cause I do NOT want anyone knowing my history. That's my business not theirs).

Asked by susannah121088 3 hours ago

Last reply by jscher2000 2 hours ago

Get virus/spywae msg when trying to access file online from trusted site

I keep getting this error message: Virus/Spyware Download Blocked Download of the virus/spyware has been blocked in accordance with company policy. Please contact your s… (read more)

I keep getting this error message:

Virus/Spyware Download Blocked

Download of the virus/spyware has been blocked in accordance with company policy. Please contact your system administrator if you believe this is in error.

File name: abcrs.resources.ca.gov/guidelines/guideline_655.pdf

Asked by brettgbaker 3 hours ago

Last reply by jscher2000 2 hours ago

Keyboard Audio Control?

Pressing any key while in a tab that has audio playing/loaded causes it to begin playing again (multiple key presses cause layered audio playing). I've already disabled m… (read more)

Pressing any key while in a tab that has audio playing/loaded causes it to begin playing again (multiple key presses cause layered audio playing). I've already disabled media control via keyboard in options and uninstalled and reinstalled firefox. Any ideas?

Asked by jordan.chambers3791 3 hours ago

Does restoro part of firefox download?

Not sure why this page deleted my question while trying to share data but I'll start again. I'm getting Malwarebyte alerts from something in firefox.exe, it's called rest… (read more)

Not sure why this page deleted my question while trying to share data but I'll start again.

I'm getting Malwarebyte alerts from something in firefox.exe, it's called restoro. It's not a program that's in my control panel so I can't delete it. It was quarantined but seconds later it was trying again. I included an image of the last scan done Nov. 28. I've deleted firefox before but it came back when I installed again. Is it something that firefox is supposed to have or is it some trojan that's latched onto firefox?

Asked by colemyst 2 days ago

Last reply by colemyst 3 hours ago