Showing questions tagged: Show all questions

Proxy Settings

we have installed Firefox 85.0.2 (esr). we are working in home office with a vpn connection (citrix gateway). the system is set to use proxy settings with a script - ever… (read more)

we have installed Firefox 85.0.2 (esr). we are working in home office with a vpn connection (citrix gateway). the system is set to use proxy settings with a script - every time I start firefox new, it is set to "auto-detect proxy setting for this network" and I have no internet. Also with disabled vpn connection - i have to set the proxy setting to "no proxy" or "use system proxy settings" who sets the setting default to "auto-detect ..."? why is this not working in home-office

Asked by stefan.luik 2 months ago

Last reply by stefan.luik 2 months ago

Print Preview takes two minutes to load

When I try to print anything in Firefox, the print preview window comes up with a spinning cursor where the page preview belongs, and it takes two minutes before it goes … (read more)

When I try to print anything in Firefox, the print preview window comes up with a spinning cursor where the page preview belongs, and it takes two minutes before it goes away and the actual preview appears. Only then can I actually print. Whatever process is taking two minutes even prevents me from quitting Firefox -- if I try to quit within that two minutes the FF window does close, bu* Bulleted list itemt the app itself doesn't shut down (as seen from the icon in the dock) until those two minutes have elapsed.

I can bypass the wait by clicking Print Using System Dialogue at the bottom right of the preview window, so I have a workaround. (Although whatever process it's waiting for is still going on, since I still can't quit FF until those two minutes elapse!)

Thanks for any help!

Asked by jimmosk 2 months ago

Last reply by jimmosk 2 months ago

Strange behaviour when copying images on Mac

Long time listener, first time caller... :) [Seriously have been using and loving Firefox/Mozilla since 2004-2005, before that was Netscape Navigator, this is the first t… (read more)

Long time listener, first time caller... :) [Seriously have been using and loving Firefox/Mozilla since 2004-2005, before that was Netscape Navigator, this is the first time I can recall having an issue that I can't find already written up and solved. Hence, this post.]

I've been having some odd issues with Firefox (85.0.2 64-bit) on my Intel Mac (Big Sur 11.2.1) for the past few months, and this morning decided to dig in deeper.

The backstory: When I’ve wanted to copy and image and paste it into Apple Messages, the images sometimes don’t send because Messages doesn’t support TIFF, WEBP, or PNG formats when sending to someone who doesn’t have an iMessage account (aka using standard MMS like to Android phones). So, I then have to convert the failed image to JPG, delete the failed message, and drag the saved JPG image file into Messages and can then resend it.

The issue: Today, I discovered that when I copy a JPG image from Firefox, and paste it into Apple messages, it seems that it doesn’t send because it appears to be either copied or pasted as a different format than the original image?

To reproduce:

  1. Go to a web site with a JPG image ( http://www.lunarbaboon.com for example)
  2. Right-Click on the JPEG image ( comicorder038.jpg for example) and select “View Image Info”
  3. Right-Click on the JPEG image and select “Copy Image”
  4. Paste into Messages to send to someone who doesn’t have an iMessage account
  5. Hit enter to send
  6. Wait a few seconds for failure
  7. Click on failure Info
  8. Right-Click on image and select Open
  9. Preview shows the file as TIFF not JPG

To simplify:

  1. Go to a web site with a JPG image ( http://www.lunarbaboon.com for example)
  2. Right-Click on the JPEG image ( comicorder038.jpg for example) and select “Copy Image”
  3. Open Preview and select “New from Clipboard”
  4. Select “Tools -> Show Inspector”
  5. Preview shows the file as PNG not JPG

What I’ve tried: Copy & paste of same image from Firefox - Safe Mode fails - So, doubt it is something in my Firefox config Copy & paste of same image from Safari works - So, doubt it is something MacOS related However, copy & paste of same image from Chrome fails too - So, maybe it is something MacOS related?

Any suggestions on what to try next?

Asked by sck626 2 months ago

Last reply by cor-el 2 months ago

  • Solved

Firefox 64 bit default & shortcut conflicts

Windows 10 update: Existing FF shortcut is not default (that can not be changed) and new FF shortcut is required default but will not launch with open tabs and book marks… (read more)

Windows 10 update: Existing FF shortcut is not default (that can not be changed) and new FF shortcut is required default but will not launch with open tabs and book marks as older shortcut.

Windows update mess: Totally confusing. I am on a 64 bit lap top.

Conflict: Two FF shortcuts launch the same 64 bit version of FF from two different start directories but only the old one retains my book marks or open research tabs. Launch that and I get error 'not the default browser" and that can not be changed. Launch FF from any web link or email and same 64 bit program launches with no open tabs or book marks. Can not set old (BEST) shortcut as the default it always previously was.

First: After a recent Windows 10 upgrade, when I now launch the Firefox from the icon shortcut pinned to my task bar, it now says “Firefox is not your default browser” and I am given the choice to use FF as my default browser. But no matter what I do I can not stop that default browser error AND Windows tells me the FF IS selected as the default.

The properties of the Original shortcut on my task bar short cut are”

Target: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" Start in "C:\Program Files (x86)\Mozilla Firefox"

Ths is puzzling for that appears to be correct for 32 bit and not 64 bit program. I have ALWAYS been using that shortcut for years not with no problem. I prefer to keep that because I currently have about 25 open tabs for a research project and dozens of favorites in my tool bar. That is what launched whenever I clicked a link in my email or in any web document. BUT not any more!

Second: Since the Win 10 upgrade, even if the original shortcut is open, if I click on a link in my email or any web site, FF does not launch in a new tab from with that launched shortcut and opened FF page but instead opens a new window. In that instance I do not get the message "Fire Fox is not your default browser” of in that instance it IS my default! But I am getting an entirely different FF page: no open tabs and no bookmarks.

As I sleuthed about I discover that from any emial or a web link FF is not launching from that original task bar shortcut but different a different shortcut new to my desk top which has the same properties as the FF in my list of programs . The properties of those shortcuts are:

NEW Shortcut: Target "C:\Program Files\Mozilla Firefox\firefox.exe" Start in "C:\Program Files\Mozilla Firefox"

It does not appear that I am running two versions of FF. No matter which shortcut I launch About FF tells me I am running FF version 85.0.2 (65 bit) so there even though it is launched from a different “Start” location.

So the new shortcut after Win 10 upgrade launches FF version 85.0.2 (65 bit) from Target "C:\Program Files\Mozilla Firefox\firefox.exe" with no open tabs and no Book marks and appears to be the dafault

And the OLD preferred shortcut launches FF version 85.0.2 (65 bit) from Target: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" (which should have been reserve for 32 bit?) and that shortcut launch tells me FF is not my default browner however but it IS the default as launched from Target "C:\Program Files\Mozilla Firefox\firefox.exe"

This may explain why the original old shortcut tells me FF is not my default browser and I can not change it since that already is selected as the default in the new shortcut. It may also expiation why launching from the new shortcut does not me give me that error.

Maddening! What do I do? I dare not uninstall FF because there is apparently only one 64 bit version running.

If I change the NEW shortcut properties so the same as the old original shortcut properties that does not help. Widows still insists that FF Target "C:\Program Files\Mozilla Firefox\firefox.exe" is/must the default and I can not modify that in path in programs and apps.

Windows seems to insist that FF can only be the default if lanced from "C:\Program Files\Mozilla Firefox\firefox.exe". A launch from "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" will insostg it is not the default and I can not change that.

So how to I get FF version 85.0.2 (65 bit) to launch from Target "C:\Program Files\Mozilla Firefox\firefox.exe" BUT with all the open tabs and book marks it launches from Target: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

I think this means Windows 10 will no longer allow FF to be the default if launched from "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

As far as email or web links I can not make FF to launch from "C:\Program Files (x86)\Mozilla Firefox\firefox.exe".

So, somehow we I must accept Target "C:\Program Files\Mozilla Firefox\firefox.exe" as the default path. So how do I import all my open tabs and book marks into the FF that launches from Target "C:\Program Files\Mozilla Firefox\firefox.exe"

Asked by jpjrsf 2 months ago

Answered by jscher2000 2 months ago

Firefox does not load, opening briefly and then closing

I have had Firefox downloaded for a considerable amount of time and had begun to use it as my daily browser, until I started experiencing issues, concerning the loading. … (read more)

I have had Firefox downloaded for a considerable amount of time and had begun to use it as my daily browser, until I started experiencing issues, concerning the loading. I have experienced this issue in all cases when trying to open the browser through the desktop shortcut, other icons, and even the .exe file, and typically I will see a brief white screen of Firefox before it immediately closes again. Frustrating to say the least and a quick google provides no insight. I have attempted on multiple occasions to uninstall and reinstall, however to no avail, and have even tried to create a new profile, via the Run (Firefox.exe -P) but again with no success. Running the browser in Safe Mode (Shift) will also work for a split second with the dialogue opening and then instantly shutting. Any suggestion on a potential fix would be great.

Asked by Elliot Grayston 2 months ago

Last reply by FredMcD 2 weeks ago

Cookies exception list

Hi everyone, I created a "positive list" of websites, I want cookies to stay, any other should be deleted after browser shutdown. I have a problem with the website de.pon… (read more)

Hi everyone, I created a "positive list" of websites, I want cookies to stay, any other should be deleted after browser shutdown. I have a problem with the website de.pons.com It is in the exception list but everytime, I go to that website the cookie accept procedure starts again.

Could you add the exception list to the things to sync?

How can I make a backup of this list?

Thanks for all comments.

Benno

Asked by BZappenduster 2 months ago

Last reply by BZappenduster 2 months ago

Firefox freezes after sleep mode

What can I do if Firefox freezes when my MacBook returns from sleep mode? I recently bought a MacBook Pro with the new M1 chip. It runs macOS 11.2.1. Firefox runs with so… (read more)

What can I do if Firefox freezes when my MacBook returns from sleep mode?

I recently bought a MacBook Pro with the new M1 chip. It runs macOS 11.2.1. Firefox runs with software version 85.0.2 (64-bit). I have now noticed that Firefox sometimes freezes when I wake up the MacBook from sleep mode after some time of inactivity. I can then no longer click on anything in Firefox (Nothing happens when I click). In order to use Firefox again, I have to quit it completely. This also causes me to lose all open tabs.

There are no recent reports under about:crashes. The most recent report is from 2019.

Asked by fabyious 2 months ago

  • Solved

Firefox Bookmarked All My Tabs Thousands of Times

So uh. This is bizarre. This has been going on for a couple weeks now - since the unremovable Other Bookmarks button appeared, though I *have* since removed that - but ba… (read more)

So uh. This is bizarre. This has been going on for a couple weeks now - since the unremovable Other Bookmarks button appeared, though I *have* since removed that - but basically, I've had a lot of tabs open for a while now. Well over 100 of them. 99% of them were unloaded and just there for me to go back to whenever, that's not usually a problem for me, it doesn't lag my browser.

What *does* lag my browser is opening my bookmarks. Because Firefox has taken these 100+ tabs and bookmarked all of them. Thousands of times. There are over 170,000 bookmarks bogging down my browser and they're all these exact same tabs, over and over and over and over and over again. Obviously, I never did this. This just up and happened one day.

I managed to scroll through all of them, and couldn't find *any* of my *actual* bookmarks whatsoever. They're all gone. All I have are these tabs, over and over. What the hell is going on, and how do I fix this?

Asked by werefallingup 2 months ago

Answered by cor-el 2 months ago

BarTender Software No Longer Shows Printer Status

I know this is a longshot. I used Firefox for the last couple of years with Seagull Scientific's BarTender software on my Windows 7 pc. Now my PC was wiped out and Wind… (read more)

I know this is a longshot. I used Firefox for the last couple of years with Seagull Scientific's BarTender software on my Windows 7 pc. Now my PC was wiped out and Windows 10 as part of my company's initiative to get everyone up to Windows 10. BarTender uses a driver to talk to your print drivers and provide a status back to the BarTender server and webpage that we use. After the move to Windows 10 Firefox will not work with BarTender. It works in MS Edge and Chrome.

 I've got a ticket into Seagull Scientific and I can foresee how this will go.  They will point me back to Firefox and then I'll get pointed back to the vendor.   I know it will be hard to find someone with a similar issue.  But maybe someone had some issue with another driver, etc that stopped talking to Firefox.   
I've tried to turn off all of Firefox's protection stuff that might be interfering and still not working. 
I have used Firefox and prefer it over any others.   But I also don't like the idea of having to change browsers depending on what I'm doing.   Besides, this software I have to regularly use.   So if I can't find a solution I may have to abandon use of Firefox.

Asked by Michael 2 months ago

Last reply by Michael 2 months ago

history in search bar not updating

Running FF for Mac 85.0.2 but has issue in previous version. The history on the search bar is not updating. Previously, the list of sites would appear depending on how of… (read more)

Running FF for Mac 85.0.2 but has issue in previous version. The history on the search bar is not updating. Previously, the list of sites would appear depending on how often they were accessed. i.e. most popular would be first on the list and the order would change depending on usage. That list no longer updates. There is still a list but it never changes. I have cleared forms and search history but the same list keeps coming back.

Asked by ed71 2 months ago

Last reply by jscher2000 2 months ago

  • Solved

Firefox won't load any pages

I tried to install the Snapchat filters after watching "Cat Lawyer" - and I got a VC++ Runtime error. Firefox stopped loading too with the same error. I removed the Sn… (read more)

I tried to install the Snapchat filters after watching "Cat Lawyer" - and I got a VC++ Runtime error. Firefox stopped loading too with the same error.

I removed the Snapchat filters app; repaired the VC++ Runtime error in add/remove programs - and now I see the symptoms as follows:

1. Launch Firefox from FF Icon.

    a) Bookmark clicks do nothing.  
    b) Type in a URL and nothing happens.

2. Launch Firefox from a ZOOM meeting link (and presumably other links) works - the page loads. And , once I have done that , the firefox browser works normally.

I can probably just uninstall/reinstall - but if anyone knows how to solve this I'd rather not lose all my saved pwd and history.

Running: MS Surface, Windows 10.


Mike

Asked by mike402 2 months ago

Answered by mike402 2 months ago

Firefox occasionally crashes

Hey, on one of my notebooks (Thinkpad E495) FF occasionally crashes. This started happening a few months ago. Before I've been using FF on the same machine for years with… (read more)

Hey,

on one of my notebooks (Thinkpad E495) FF occasionally crashes. This started happening a few months ago. Before I've been using FF on the same machine for years without any issues. It's pretty random but usually happens at least once a day, usually shortly after startup or wakeup from hibernate mode. A while ago it used to even crash back to back twice in a row meaning after I reopened it, it immediately closed again and only worked after I selected to restore the previous session after the 2nd reopen. Nothing is registered under about:crashes and I don't see any errors in the system event log.

I already tried to disable hardware acceleration and reinstalled FF completely without any addons besides a different adblocker. I cannot really reproduce the crash in safe-mode but don't really want to browse the web for possibly hours without an adblocker.

Any ideas what this could be or what else I could try? Maybe downgrade to a previous version?

Asked by banshee999 2 months ago

Last reply by FredMcD 1 month ago

videos not loading

Question for community. Here in Seattle KOMO is the local ABC affiliate. Since the last Firefox upgrade videos like the one I am offerring here from their site will not… (read more)

Question for community. Here in Seattle KOMO is the local ABC affiliate. Since the last Firefox upgrade videos like the one I am offerring here from their site will not load and I end up having to go to another browser. Even in safe mode videos will not load? Any thoughts?


https://komonews.com/weather/scotts-weather-blog/convergence-zone-puts-on-a-show-for-seattle

Asked by codetalker 2 months ago

Last reply by TyDraniu 2 months ago

Firefox keeps randomly resetting

Every 2 to 3 days sometimes longer, Firefox will randomly reset itself and close out all windows and tabs to a single window and different search engine. Restore last ses… (read more)

Every 2 to 3 days sometimes longer, Firefox will randomly reset itself and close out all windows and tabs to a single window and different search engine. Restore last session is never available when this happens even though I have that selected and checked and it does work when I manually close out windows and tabs myself so i know that preference is selected. My search engine preferences are always reset and have to restore defaults as well. Mac os Big Sur 11.2

Thanks to anyone who can help me solve this sudden mystery. Long time user of firefox on macbook pro and mac towers.

Ronnie DiCicco

Asked by dicicc 2 months ago

Last reply by dicicc 2 months ago

Firefox doesn't open a lot of big sites

Since a few weeks Firefox doesn't load/open some websites. For example, when I go to twitter.com it doesn't open, it doesn't even load. The same for Pinterest and a lot o… (read more)

Since a few weeks Firefox doesn't load/open some websites. For example, when I go to twitter.com it doesn't open, it doesn't even load. The same for Pinterest and a lot of other websites. When I open wetransfer.com for example there's no problem like you can see in the screen record.

I've uploaded a screen record at WeTransfer: https://we.tl/t-uQBibmptTK

Hope you guys could help me out.

Thanks Luuk

Asked by luukgervink 2 months ago

Last reply by luukgervink 2 months ago

  • Solved

userChrome.css not working

I'm trying to take off this "Extension (Tabliss)" tag on my url. I have followed the instructions down below from another Firefox support forum: https://discourse.mozill… (read more)

I'm trying to take off this "Extension (Tabliss)" tag on my url. I have followed the instructions down below from another Firefox support forum: https://discourse.mozilla.org/t/make-addressbar-text-extension-name-of-the-extension-shorter-or-hide/28026/3

The instructions I followed are listed below:

"Users can apply custom style rules to modify Firefox’s toolbar area by creating a userChrome.css file. This takes about 10 minutes so when you have time to take it slowly and carefully:

(1) Set up your chrome folder and userChrome.css file following the five six steps in this article:

https://www.userchrome.org/how-create-userchrome-css.html 45

I have a boring video there if you like demonstrations.

(2) This is the code to paste into the file. You can edit the file using Notepad or a better editor. Make sure to keep it in a plain text format with a .css file extension (not .css.txt).

See improved rule down in: Make addressbar text "Extension (Name Of The Extension)" shorter or hide

/*

  Hide Extension Name in the identity area unless
  hovered for half a second (updated for Fx80)
  • /
  1. identity-box.extensionPage #identity-icon-labels,
  2. identity-box.extensionPage #identity-icon-label {
 visibility: collapse !important;
 transition: visibility 250ms ease-in-out;

}

  1. identity-box.extensionPage:hover #identity-icon-labels,
  2. identity-box.extensionPage:hover #identity-icon-label {
 visibility: visible !important;
 transition: visibility 250ms ease-in-out 500ms;

}

(3) Firefox should read the file at its next startup and apply it to every extension page you load."

Edit: So, yeah, I need help getting this tag off. I'm new to Firefox so it could be something obvious I'm missing. I have also tried CTRL+SHIFT+R to reload the page for changes and also closed and reopened my Firefox entirely.

Thanks in advance.

Asked by MaxwellQ 2 months ago

Answered by Wesley Branton 2 months ago

  • Solved

Firefox keep redirecting localhost to www or www.localhost:8000

Hi, I'm using Firefox 85.0.2(64-bit) Windows 10 While I'm testing local testing for website, whenever I typed/entered localhost OR localhost:8000 Firefox keep redirecting… (read more)

Hi, I'm using Firefox 85.0.2(64-bit) Windows 10

While I'm testing local testing for website, whenever I typed/entered localhost OR localhost:8000 Firefox keep redirecting/guesing subdomain for it(which="www"). Made my testing messed up.

There's same issue on https://support.mozilla.org/en-US/questions/1216065 None of those work.

set: browser.fixup.alternate.enabled to false or Connection Settings with No proxy

Please, stop. Chrome and Edge behave normally. This site need darkmode :/

Asked by prothegee 2 months ago

Answered by prothegee 2 months ago

  • Solved

Firefox is the only browser which fails to display colours correctly

So I've recently noticed that Firefox is the only browser which has problems displaying colours effectively. I've searched this issue on Google and to be quite honest, th… (read more)

So I've recently noticed that Firefox is the only browser which has problems displaying colours effectively.

I've searched this issue on Google and to be quite honest, the archived responses to this issue which I've read have been rather bad-faith and evasive, blaming either driver issues or Windows settings - neither of which get in the way of other browsers' correctly displaying a webpage. And why should I fiddle with my Windows or driver settings to make a browser happy, anyway? That seems more like a sign of browser problems for obvious, logical reasons.

I have attached screenshots of the same webpage snippet on Chrome, Edge, Opera, and Firefox. The Firefox image is the last, bluest, and incorrect rendering of the webpage colour.

I have tried going into the Color menu and cancelling the override option (selecting "Never" in the drop-down menu). I've even gone into advanced settings and set gfx.color_management.mode to 0 - nothing works.

If anyone can help with this it would be much appreciated.

Asked by liquidfractal 2 months ago

Answered by vande1 2 months ago