Showing questions tagged: Show all questions

Firefox Crashing, trying to find out why

Hi there, first time posting. I have Firefox 82.0.3 64-bit and I am on Windows 10. The only add-ons I have are Ublock Origin and Adblocker. This morning I was having some… (read more)

Hi there, first time posting. I have Firefox 82.0.3 64-bit and I am on Windows 10. The only add-ons I have are Ublock Origin and Adblocker.

This morning I was having some internet trouble and it turns out my ISP needs to send someone out to my house to fix it. While my internet was going in and out, Firefox seemed very sensitive to this because it would continue to crash.

I was wondering if your internet connection going in and out can cause Firefox to crash (I need to the end the process because it is unresponsive type of crashing). I don't usually have any problems with Firefox and just wanted to ask.

Thanks.

Asked by Dr.Strange 2 weeks ago

Last reply by FredMcD 5 days ago

e10s is making using my computer a nightmare

I have win 7, 64 bit, FF version 82.0.2. My computer is on the older side, but with ram upgrade to 8 gigs and a new larger hard drive I got it running nicely. Then along… (read more)

I have win 7, 64 bit, FF version 82.0.2. My computer is on the older side, but with ram upgrade to 8 gigs and a new larger hard drive I got it running nicely. Then along came e10s, and, well, now it's a nightmare. The sluggishness is frustrating to say the least, especially when I play my favorite on line game. I used to be able to apply all the fixes out there and remedy the situation, but now nothing works anymore to disable e10s, or is there a way still? The latest remedy, from about a year ago, was to set an environment variable, and some folks reported this working for them, but not so for me. I always make sure not to have a bunch of stuff running in the background, nor do I have a bunch of add-ons and such. Simple, bare bones...Can someone out there help please?

Asked by Miss Chris 3 weeks ago

Last reply by Miss Chris 3 weeks ago

  • Solved

Firefox 78.0.1 does not remove closed pages from memory - lags and high RAM usage

After updating from 77 (I think it was 77.0.2?) to 78.0.1 I started noticing terrible firefox performance after a few minutes of browsing. My standard browsing habit cons… (read more)

After updating from 77 (I think it was 77.0.2?) to 78.0.1 I started noticing terrible firefox performance after a few minutes of browsing. My standard browsing habit consists of launching browser with 1 pinned tab and 1 home page (so 2 tabs only), then opening 5-10 tabs from my bookmarks, checking pages then closing them and leaving only 1 pinned page open. In firefox 78.0.1 after doing this (opening and then closing multiple tabs "to the right" using new context menu added in 78) my ram usage does not drop. It goes from 2.4GB (system only usage) to 5.0GB and does not drop after closing tabs. However when I open 10-20 tabs again RAM usage does not rise (maybe slightly, like 5.3GB). So it looks like firefox has multiple tabs stored in ram and opening new tabs just rewrites that memory instead of allocating new one. I have 8GB of ram so 3GB of usage from 1 open tab is crazy. I think it was 500-900MB before. I also have terrible lags because of this - browser hangs up every few seconds for few seconds. I had trouble writing this post with 2 tabs open because of 3.3GB ram usage! Restarting browser helps - ram uasge rises from 2.4GB to 3.2GB only (800MB for 2 tabs) but every new opened and closed tab seems to stay in memory. For example if I open 10 more tabs except for 2 that always open so I have 12 tabs I have 3.6GB memory usage. After I close them it slowly drops to 3.5GB instead of returning to 3.2GB. It does not matter how I close tabs - using right click context menu (close other tabs, close tabs to the right), using X on tabs, or using add-on to close all tabs except for pinned ones. They always remain in memory somehow. PLS fix this ASAP.

P.S. I also tried checking about:performance menu but there is nothing interesting here. It says that 2 opened tabs and addons use 100MB of memory which is not true because browser at this moment uses 1060MB.

Update 1: I also tested safe mode. 3,4GB of PC RAM usage on firefox safe mode start. Opened few tabs, ram usage goes to 4.2GB. After closing all tabs except for 1 ram usage start to SLOWLY decrease but it stops at 3,7GB. Ram usage drop was really slow like 10-30 seconds. It should be instant after closing tabs.

Asked by Piterk 5 months ago

Answered by Piterk 2 months ago

Firefox Muili-process constantly hanging due to wait-chaining on another Firefox process

relatively recently (within the last month), Firefox has become prone to hanging. It seems to happen with randomly, and can be trigger by just about anything, e.g. scrol… (read more)

relatively recently (within the last month), Firefox has become prone to hanging. It seems to happen with randomly, and can be trigger by just about anything, e.g. scrolling a window, clicking on anywhere in the window. It appears that even with content process limit = 1, it still runs with a minimum of 5 process threads. Don't know how these are ordered, but the 'last' of these, as displayed in Task Manager (yes Windows 10 2004), seems to be the one with a wait chain.

This is quite frustrating, but although I am willing to help collect relevant diagnostics, I do not know sufficient to know which and how.

All helpful suggestions welcome. The laptop is not CPU, Memory, nor disk bound when these waits occur.

Asked by virtual-hp-b1y 4 months ago

Last reply by FredMcD 4 months ago

  • Solved
  • Archived

Version 77 big problem

Today when I started Firefox it auto-updated to version 77, and all web-pages looked like a mess of weird symbols like the ones in the screenshot I attached. I tried disa… (read more)

Today when I started Firefox it auto-updated to version 77, and all web-pages looked like a mess of weird symbols like the ones in the screenshot I attached.

I tried disabling all addons and plugins, and some other stuff but nothing worked.

So I downgraded to 76.0.1 and everything works fine, it's definetly a problem with version 77.

I guess I won't be updating until I know this problem was adressed.

Asked by bayus.firestorm 6 months ago

Answered by bayus.firestorm 5 months ago

  • Solved
  • Archived

All webpages show up as garbage text

I was using Firefox and my system was low on resources so it killed the process using the most memory which was Firefox. When it restarted every page showed up as garbage… (read more)

I was using Firefox and my system was low on resources so it killed the process using the most memory which was Firefox. When it restarted every page showed up as garbage. I've cleared cache. I've refreshed Firefox. I've reinstalled. I've rebooted. Nothing seems to work. mozilla.org appears to work but every other site I try looks like the attached image. When I view the source of a page that looks like garbage, the source looks perfectly fine. I'm running 77.0.1 64 bit on Windows 7. Any ideas?

Asked by Brian 6 months ago

Answered by cor-el 6 months ago

Websites load only gibberish text since latest update (78.04b)

Websites since this morning load only random text - see attached. Somehow gmail worked while everything else didnt, so I manage to send myself via the phone a direct down… (read more)

Websites since this morning load only random text - see attached. Somehow gmail worked while everything else didnt, so I manage to send myself via the phone a direct download link for chrome. Since then gmail has also crashed. The only website that I found working so far that loads is https://www.mozilla.org/en-US/ I am on the beta FF update channel and my version is 78.0b4 Cleared the cache but it did not resolve anything. Any ideas what could be causing this? Chrome runs obviously fine and avg found no obvious threats. Thank you so much for your help!

Asked by sha.jomantas 5 months ago

Last reply by McCoy 5 months ago

  • Solved
  • Archived

Firefox 77 showing gibberish character can't browse any site

I have upgraded firefox to 77 and now i can' browse any site. Every site showing gibberish character. Tried reinstalling firefox several time. still same! Even when i ope… (read more)

I have upgraded firefox to 77 and now i can' browse any site. Every site showing gibberish character. Tried reinstalling firefox several time. still same! Even when i open a new tab it shows a white empty tab. No top page or highlight section.

here is the snapshot for better understanding tried  other solutions from Firefox support . Firefox 76 worked properly.

Asked by Riyad 6 months ago

Answered by cor-el 6 months ago

  • Solved
  • Archived

Latest update turns all pages (except mozilla) to gobbledy gook

Hello all...When I restarted my machine tonight Firefox installed a new update. now all of my pages show this (see attachment) my passwords have disappeared to be replace… (read more)

Hello all...When I restarted my machine tonight Firefox installed a new update. now all of my pages show this (see attachment) my passwords have disappeared to be replaced by lockwise which has no passwords in it at all (I had reset that a few months ago back to the old password manager) the only pages I can see clearly are mozilla pages. all else is this gobbledy gook. help!

carrie

Asked by solutions7 6 months ago

Answered by jscher2000 6 months ago

  • Archived

the about:logins page shows no logins at all

I have several logins/passwords stored in my firefox profile. Ever since the new "about:logins" page was introduced, I can't get at them any more. The about:logins page s… (read more)

I have several logins/passwords stored in my firefox profile.

Ever since the new "about:logins" page was introduced, I can't get at them any more. The about:logins page simply shows no information. The part where I expect them to be shown is empty. Even the "Create New Login" doesn't cause anything to appear where I could see or enter login names or passwords.

Asked by firefox0011 7 months ago

Last reply by firefox0011 7 months ago

  • Archived

Task manager shows 12 instances of firefox when 1 browser is open

I only have 1 browser open, but in my task manager, it shows 11 instances. some times when downloading, it came to a complete stop and it jams the internet. I can't eve… (read more)

I only have 1 browser open, but in my task manager, it shows 11 instances. some times when downloading, it came to a complete stop and it jams the internet. I can't even get Chrome and Edge to browse anything. I had to force Firefox to stop and it kills my downloads. it did not do this on the previous version of Firefox, but this latest version, it does that. currently on 74.0 (64-bit). 2 questions: why do I have this man instances opened? Why is Firefox freezing and blocked the internet connection? Once Firefox is force to end task, other browser is moving.

Asked by swon888 8 months ago

Last reply by FredMcD 8 months ago

  • Archived

List of saved logins disappeared

Using Ubuntu 18.04 and Firefox 72.0.2 (via Ubuntu repos). My list of "Saved Logins" has disappeared. Whether I get to the list via Preferences or about:logins, the list i… (read more)

Using Ubuntu 18.04 and Firefox 72.0.2 (via Ubuntu repos). My list of "Saved Logins" has disappeared. Whether I get to the list via Preferences or about:logins, the list is empty. I should have 100s of logins saved. But when I go to a website that had a saved login, the fields are auto populated.

No I don't have logins.json.corrupt. I only have logins.json No I don't have AVG. I'm on Ubuntu Linux. No I don't have multiple profiles. Just one. Default profile.

Firefox has really become insufferable lately. Forced update restarts, forced multiprocess mode and now bugs like this.

I want my list of logins back please.

And funny enough, the mozilla support site seems broken on Firefox. Kept getting "access denied" when trying to post with Firefox, so here I'm posting this via Chromium.

Asked by stop-messing-with-firefox 9 months ago

Last reply by cor-el 9 months ago

  • Solved
  • Archived

Firefox is making multiple processes again

Once again, Firefox is making multiple processes in the task manager. I've already set both browser.tabs.remote.autostart.2 and browser.tabs.remote.autostart to false, ye… (read more)

Once again, Firefox is making multiple processes in the task manager. I've already set both browser.tabs.remote.autostart.2 and browser.tabs.remote.autostart to false, yet I still have multiple processes anyway, and setting the content process limit to 1 doesn't seem to do anything. I'm using Firefox version 68.0 and running Window 7.

Asked by Tathamet 1 year ago

Answered by cor-el 1 year ago

  • Archived

Multiprocess can't be stopped via about:config. Why not?

Latest version of FF 68.0 has re-enabled multiprocess and won't allow me to disable via about:config. I've been with FF since pretty much the beginning, it's the only br… (read more)

Latest version of FF 68.0 has re-enabled multiprocess and won't allow me to disable via about:config.

I've been with FF since pretty much the beginning, it's the only browser I recommend to friends, family or clients. Since 10e and the whole multiprocess roll out, I've "fixed" peoples slow and unresponsive FF experience by disabling this useless feature and H/W acceleration.

Now my mailbox is full of complaints about slow unresponsive browsing, plus it using more system resources leaving clients with less powerful machines with real problems.

C'mon Moz, we've been mates for decades, stood by you when everyone was looking at whatever MS was waiving at them, laughed at Google when they tried to play with the big boy, but now I'm feeling sheepish about my claims of Mozilla putting its users needs first, not forcing features on users, giving its users a choice enabling a freedom that you don't have with Edge or Chrome

Please give us back one of the remaining freedoms we have left, don't be MICROSOFT!

Asked by Wizlon 1 year ago

Last reply by McCoy 1 year ago

  • Archived

How to Disable E10s using Environment Variable MOZ_FORCE_DISABLE_E10S - 1

I need to disable E10s. It causes Firefox 68,0 (32bit) to display a Blank Page when Firefox is closed and I launch a Web Page from my Email Client. I have to have Firefox… (read more)

I need to disable E10s. It causes Firefox 68,0 (32bit) to display a Blank Page when Firefox is closed and I launch a Web Page from my Email Client. I have to have Firefox open first now before clicking on a Website url from the Email Client. This was the same problem I had two or more years ago when E10s was first implemented. I disabled it back then in about:config but Mozilla have disabled that option in Firefox 68. It's stated you can disable E10s using Environment Variable MOZ_FORCE_DISABLE_E10S - 1 but I'm not sure where to use that. I put it in my Windows 10 Environment Variables (System Properties/Environment Variables) but it did not work. I am using Windows 10 32-bit (Both Pro and Home) and the problem exists on all computers since upgrading to Firefox 68.0. I need to disable E10s again.

Asked by motox22a 1 year ago

Last reply by cor-el 1 year ago

  • Archived

Multiples in task manager

Fired up the computer this AM and notice it was running slow and seems messed up, everything's lagging, so I opened up Task manager and saw all these multiple entries for… (read more)

Fired up the computer this AM and notice it was running slow and seems messed up, everything's lagging, so I opened up Task manager and saw all these multiple entries for

Seven FireFox.exe

Three NVidia Share,exe Three Dropbox.exe

and a few more multiples

Please, what should I do about this??

Asked by JoeFromSD 1 year ago

Last reply by FredMcD 1 year ago

  • Solved
  • Archived

restore previous session not working

I have Windows 7 Ultimate 64-bit PC. Start Firefox and open up 4 tabs with different websites for each tab. With the 4th tab displaying, close Firefox Wait until all in… (read more)

I have Windows 7 Ultimate 64-bit PC.

Start Firefox and open up 4 tabs with different websites for each tab.

With the 4th tab displaying, close Firefox

Wait until all instances of Firefox in Task Manager have ended

Restart Firefox

The restore previous session loads the 4 tabs but does not display tab 4 being the last tab showing when closed. It displays a blank page and is totally unresponsive. Starting a new tab (5) is also unresponsive. Yet the other 3 tabs work fine.

Steps taken – uninstalled Firefox and deleted existing profile then reinstalled Firefox with a new profile but no change. No add-ons, bookmarks, history or settings changed.

Please help.

Asked by FFoxUser01 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Archived

How do I REMOVE the updates after they're installed?

Firefox has been opening multiple processes and is slowing down my computer. I have read that this is because of an update. So, I want to completely remove all of my upda… (read more)

Firefox has been opening multiple processes and is slowing down my computer.

I have read that this is because of an update. So, I want to completely remove all of my updates back to the one which caused the problem, and prevent Firefox from harassing me to install the new ones.

How do I do this?

Thanks for any help.

Asked by benmillan 1 year ago

Answered by McCoy 1 year ago

  • Archived

Still problem with FF 57

Tried upgrading to latest version. Think 57.4 or 57.0.4. Same issues reported before. Reviewing Task Manager I see multiple FF processes. One of them consuming 95%+ of C… (read more)

Tried upgrading to latest version. Think 57.4 or 57.0.4. Same issues reported before. Reviewing Task Manager I see multiple FF processes. One of them consuming 95%+ of CPU. Response disappears. Unable for any other task to respond. Returned to using ESR. Still not clear what ESR is and its support lifetime. Reviews several post regarding changing various options. Not had much luck getting even the option screen to appear after CPU hogging starts.

Any ideas are appreciated.

Asked by MasterHarp 2 years ago

Last reply by MasterHarp 2 years ago