Firefox on Windows 10 Loads Multiple Versions of the Same Tab, Limiting Memory (RAM)

Several weeks ago, because it seemed to be a Gmail-tab-only problem, Firefox Support advised us to contact Gmail Support. It is now clear that the problem is with the Fir… (read more)

Several weeks ago, because it seemed to be a Gmail-tab-only problem, Firefox Support advised us to contact Gmail Support.

It is now clear that the problem is with the Firefox browser. The attached screenshot shows an example of an affected tab.

Please fix this. Multiple versions of the same tab waste RAM and other memory, especially on a limited-memory device such as a laptop.

Asked by JandNL 2 months ago

Last reply by JandNL 1 day ago

List of Cookie exceptions keeps getting deleted, despite "Allow" for each

The List of Cookie exceptions under Security Setting, the ones I want to retain, keeps getting deleted. I select ALLOW for each one. What is causing the list to get del… (read more)

The List of Cookie exceptions under Security Setting, the ones I want to retain, keeps getting deleted. I select ALLOW for each one. What is causing the list to get deleted?

Asked by kjsles444 1 week ago

Last reply by kjsles444 5 days ago

Soundcloud won't load after the first time visited

I've been having an interesting problem with Firefox for the past couple of months regarding only Soundcloud, where after the first visit to the website it won't load, gi… (read more)

I've been having an interesting problem with Firefox for the past couple of months regarding only Soundcloud, where after the first visit to the website it won't load, giving a generic "Sorry! Something went wrong" screen. Firefox will continue to not load the site correctly until I clear the cookies and the cache, which works but only for one visit, and as soon as I close the tab and open soundcloud again or refresh the tab the problem comes back. I have disabled all of my extensions as well as enhanced tracking protection when testing. A firefox refresh also did not solve the problem. The only way I can get the site to behave normally is when using private browsing.

The console is filled with errors regarding javascript files (source URI is not allowed in this document).

Thanks

Asked by marriaga158 3 months ago

Last reply by marriaga158 3 days ago

Lost All Quick Access Bookmarks and later all Bookmarks except 5!!!!

After creating a new Windows User account and switching back to original account, I lost ALL of my Quick Access Bookmarks! Then I did a Bookmark Restore using the most re… (read more)

After creating a new Windows User account and switching back to original account, I lost ALL of my Quick Access Bookmarks! Then I did a Bookmark Restore using the most recent saved Bookmark file and I lost around 64,050 bookmarks!!! Now, the latest saved Bookmark file lists 5 items. This is a ridiculous and a very serious issue!!!

What is going on? I spend a lot of time getting important Bookmarks for research, and etc. How can I get all of my Bookmarks back? Apparently, I cannot get them all back. See attached file.

Asked by Wayne Carpenter 1 week ago

Last reply by Wayne Carpenter 4 days ago

How to disable the giant "Search with DuckDuckGo" banner that appears on typing "d" in the URL bar?

Firefox 91 See screenshot. I've been a Firefox user since the days of 2.0. I know what DuckDuckGo is, what search is, what it does and how to use it. I've set this sear… (read more)

Firefox 91

See screenshot.

I've been a Firefox user since the days of 2.0. I know what DuckDuckGo is, what search is, what it does and how to use it. I've set this search engine up myself! I don't need a tutorial.

How can I disable this misfeature?

Thanks, Alex

Asked by Alex 1 month ago

Last reply by Alex 2 days ago

Proton and userchrome

It took years to perfect my userchrome to make FF look exactly how I want. Once 91+ came out it wasn't even a question of fixing the floating tabs and condensing the heig… (read more)

It took years to perfect my userchrome to make FF look exactly how I want. Once 91+ came out it wasn't even a question of fixing the floating tabs and condensing the height and menu spacing (though I tried all of it) but my own codes stopped working properly - I had code to set the background colour of menus/bookmark menus and when I upgrade they were the right colour but with thick white borders around them. This was more important to me than the floating tabs and I immediately downgraded to 90 where I've stayed. Can anyone help me figure out how to get MY codes to work with 91+ and/or to work together with the other fixes out there (tabs, condensed menus etc)??

Below is how my userchrome looks and attached is how my current set up looks. ANY advice is appreciated. THANK YOU.

@import url(userChrome_Fx56_bookmark_icons.css);
*/

/* Standard folder -- on Toolbar and Menus */
#PlacesToolbarItems toolbarbutton[container="true"] > .toolbarbutton-icon,
#PlacesToolbarItems menu[container="true"] .menu-iconic-left,
:-moz-any(
#PlacesToolbarItems,
#PlacesChevronPopup,
#BMB_bookmarksPopup,
#bookmarksMenu) menu[container="true"]:not([tagContainer="true"]) > .menu-iconic-left,
/* Standard folder -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList) treechildren::-moz-tree-image(container), 
#editBMPanel_folderMenuList > .menulist-label-box > .menulist-icon,
#editBMPanel_folderMenuList menupopup menuitem {
  list-style-image: url(Fx56-yellow-folder.png) !important;
}

/* THIS WAS REMOVED BECAUSE IT CAUSES YELLOW FOLDER ICONS FOR BLANK 
   COLUMNS. AS A RESULT, FOLDERS ON THE RIGHT SIDE REMAIN GRAY.
  #placeContent treechildren::-moz-tree-image(container) {
    list-style-image: url(Fx56-yellow-folder.png) !important;
  }
*/

/* Live Bookmark -- on Toolbar and Menus */ /* REMOVED */

/* Smart bookmark folder -- on Toolbar and Menus */
#PlacesToolbarItems toolbarbutton[container="true"][query="true"] > .toolbarbutton-icon,
#PlacesToolbarItems menu[container="true"][query="true"] .menu-iconic-left,
:-moz-any(
#PlacesToolbarItems,
#PlacesChevronPopup,
#BMB_bookmarksPopup,
#bookmarksMenu) menu[container="true"][query="true"]:not([tagContainer="true"]) > .menu-iconic-left > .menu-iconic-icon,
/* Smart bookmark folder -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, query) {
  list-style-image: url(Fx56-query.png) !important;
}

/* Tag containers (preserve the built-in icon) */
#PlacesToolbarItems toolbarbutton[container="true"][tagContainer="true"] > .toolbarbutton-icon,
#PlacesToolbarItems menu[container="true"][tagContainer="true"] .menu-iconic-left,
:-moz-any(
#PlacesToolbarItems,
#PlacesChevronPopup,
#BMB_bookmarksPopup,
#bookmarksMenu) menu[container="true"][tagContainer="true"] > .menu-iconic-left > .menu-iconic-icon,
/* Smart bookmark folder -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, query, tagContainer) {
  list-style-image: url(chrome://browser/skin/places/tag.svg) !important;
}

/*** Top-level "container" icons (otherwise would be Standard folder color) ***/
/* Bookmarks Menu -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, OrganizerQuery_BookmarksMenu),
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, queryFolder_menu________),
#editBMPanel_bmRootItem > .menu-iconic-left, 
#editBMPanel_folderMenuList[selectedIndex="1"] > .menulist-label-box > .menulist-icon {
  list-style-image: url(Fx56-bookmarksMenu.png) !important;
}

/* Bookmarks Toolbar -- on Menus */
#BMB_bookmarksPopup #BMB_bookmarksToolbar > .menu-iconic-left > .menu-iconic-icon,
#bookmarksMenuPopup #bookmarksToolbarFolderMenu  > .menu-iconic-left > .menu-iconic-icon,
/* Bookmarks Toolbar -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, OrganizerQuery_BookmarksToolbar),
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, queryFolder_toolbar_____),
#editBMPanel_toolbarFolderItem > .menu-iconic-left, 
#editBMPanel_folderMenuList[selectedIndex="0"] > .menulist-label-box > .menulist-icon {
  list-style-image: url(Fx56-bookmarksToolbar.png) !important;
}

/* Other Bookmarks -- on Menus */
#BMB_bookmarksPopup #BMB_unsortedBookmarks > .menu-iconic-left > .menu-iconic-icon,
#bookmarksMenuPopup #menu_unsortedBookmarks  > .menu-iconic-left > .menu-iconic-icon,
/* Other Bookmarks -- in Sidebar, Library, Add/Edit Bookmark dialog */
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, OrganizerQuery_UnfiledBookmarks),
:-moz-any(
#bookmarks-view, 
#editBMPanel_folderTree, 
#placesList, 
#placeContent) treechildren::-moz-tree-image(container, queryFolder_unfiled_____),
#editBMPanel_unfiledRootItem > .menu-iconic-left, 
#editBMPanel_folderMenuList[selectedIndex="2"] > .menulist-label-box > .menulist-icon {
  list-style-image: url(Fx56-unsortedBookmarks.png) !important;
}  

/* Preserve Built-in History/Tags/All Bookmarks Icons in Library */
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(query, OrganizerQuery_history____v), 
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(title, query, dayContainer) {
  list-style-image: url("chrome://browser/skin/places/history.svg") !important;
}
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(title, query, tagContainer),
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(query, OrganizerQuery_tags_______v) {
  list-style-image: url("chrome://browser/skin/places/tag.svg") !important;
}
:-moz-any(
#placesList, 
#placeContent) treechildren::-moz-tree-image(query, OrganizerQuery_allbms_____v) {
  list-style-image: url(Fx56-allBookmarks.png) !important;
}


}

menupopup {
-moz-appearance: none !important;
background-color: #e7d9ad !important }


#urlbar[breakout],
#urlbar[breakout][breakout-extend] {
  --urlbar-height: 28px !important;
  --urlbar-toolbar-height: 30px !important;

  width: 100% !important;
  top: calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2) !important;
  left: 0 !important;
}

#urlbar[breakout][breakout-extend] > #urlbar-input-container,
#urlbar-input-container {
  height: var(--urlbar-height) !important;
  width: 100% !important;
  padding-block: unset !important;
  padding-inline: unset !important;
  transition: none !important;
}

#urlbar[breakout][breakout-extend] > #urlbar-background {
  box-shadow: 0 1px 4px rgba(0,0,0,.05) !important;
  animation: none !important;
}


}
/* REMOVE MEGABAR END */

Asked by M 2 weeks ago

Last reply by M 1 day ago

CompositionEvent is not getting triggered for non input field

Dear All, We are working on a project where the page will have a canvas element and page focus will be on canvas element and when users interact, all the key input will b… (read more)

Dear All,

We are working on a project where the page will have a canvas element and page focus will be on canvas element and when users interact, all the key input will be captured using keydown and keyup event and will be sent to the server.

All the normal characters work but composition keys are not working. Even composition events are not getting fired. I tried below example

https://developer.mozilla.org/en-US/docs/Web/API/Element/compositionstart_event

Any help on this will be appreciated.

Thanks

Asked by rangeshgupta 4 days ago

Where have my passwords gone?

I have always been able to access my stored passwords on Firefox but recently they have all disappeared. They are available on my phone browser but on the desktop browser… (read more)

I have always been able to access my stored passwords on Firefox but recently they have all disappeared. They are available on my phone browser but on the desktop browser the list is empty. Sync is working and it claims to have synced but the passwords are just not there.

Asked by JonBonJimBob 1 week ago

Last reply by JonBonJimBob 6 days ago

How to change or disable default keyboard shortcuts

I want to disable the F12 shortcuts that open the developer tools, because I use this shortcuts to open a different application (yakuake) How do we change the default key… (read more)

I want to disable the F12 shortcuts that open the developer tools, because I use this shortcuts to open a different application (yakuake)

How do we change the default key bindings?

Asked by hello_world 1 week ago

Last reply by hello_world 4 days ago

Leaking DNS!

Hi, I tried checking if my DNS is leaking and it is! My Firefox is a fresh installed. See image below for reference. Is there any fix on this? PS. I already checked into… (read more)

Hi,

I tried checking if my DNS is leaking and it is! My Firefox is a fresh installed. See image below for reference. Is there any fix on this?


PS. I already checked into the Network Settings and found that the DNS over HTTPS is Enabled (Cloudflare as Provider)

Asked by Adriel 3 days ago

Last reply by Adriel 2 days ago

video doesn't load and/or play

(Firefox 94.0; Fedora 34; Gnome) When I go to some video websites and click the play button, I see the little circular thing in the image are spinning, indicating that th… (read more)

(Firefox 94.0; Fedora 34; Gnome)

When I go to some video websites and click the play button, I see the little circular thing in the image are spinning, indicating that the video is loading. But it never stops and it never plays. Also, the pause button does not have any effect; the loading indicator keeps spinning. Example website: "https://proclassictv.com/" (both with "The Rifleman" and "My Favorite Martian" episodes. I've tried this on a few of the videos available there. Same result. I've tried this with add-ons enabled and with add-ons disabled (current session). I've seen this in a few other websites also. I don't know if the problem is my system, Firefox, or the host website.

I am able to view youtube videos with no problems.

How do I get the videos to play?

Thank-you.

Asked by home user 1 week ago

Last reply by home user 3 days ago

Cannot save or move around bookmarks by drag&drop anymore

I use the bookmark bar very heavily and my workflow was to just "drag" the tab with the mouse to folder in the bookmark bar, which would unfold and I drop the tab/bookmar… (read more)

I use the bookmark bar very heavily and my workflow was to just "drag" the tab with the mouse to folder in the bookmark bar, which would unfold and I drop the tab/bookmark in the desired sub-folder.

This worked really well for me, and was fast.

Recently, this stopped working. I can still drop a bookmark in one of the main folders in the bookmark bar. But not in any sub-folder, since the main folder closes as soon as I move the mouse inside it. It is also not possible anymore to move the already-saved bookmarks around via drag&drop.

System: Linux (Manjaro Gnome 41.1) Firefox for Arch Linux 94.0.2 (64bit)

Asked by jochenstehle 1 week ago

Last reply by jochenstehle 2 days ago

Firefox use 100% RAM (32 RAM - 128 GB RAM) not matter always FULL (Total Memory Leak)

Firefox uses all RAM, all RAM + High CPU (I have 20 GB and it showed 17 GB RAM usage and crash) always when using Facebook Page (e.g. several hours of using Facebook). … (read more)

Firefox uses all RAM, all RAM + High CPU (I have 20 GB and it showed 17 GB RAM usage and crash) always when using Facebook Page (e.g. several hours of using Facebook).

Asked by nnina084 5 days ago

Last reply by nnina084 5 days ago

does copy/paste from inside linux container to google calendar or email?

I'm exploring the potential problems working inside & outside Linux container on Chromebook. I realize that there are generous app options within Linux, but am conce… (read more)

I'm exploring the potential problems working inside & outside Linux container on Chromebook. I realize that there are generous app options within Linux, but am concerned that switching over to linux would complicate my life, working with my non-Linux collaborators.

Asked by poliakof 1 week ago

Last reply by poliakof 3 days ago

Can I have two Firefox windows open when I start firefox with all the tabs I want pre-loaded?

Hi all I would like some help if possible please. When I start Windows 10 on my laptop and I open Firefox I open two separate windows (personal and professional) and the… (read more)

Hi all

I would like some help if possible please. When I start Windows 10 on my laptop and I open Firefox I open two separate windows (personal and professional) and then I open a pre detirmined set of tabs in each window to start my day.

Is there a way I can press open Firefox and I can have 2 windows open with all my pre set tabs?

Is this possible? If not, how close can I come to this?

Thanks,

Asked by Matt 1 week ago

Last reply by Matt 5 days ago

PDF access

I cannot find any way to report problems, this seems to be the only way. When I try to open any PDF file, I have to Browse to find my pdf viewer (Flexipdf 2022). I do th… (read more)

I cannot find any way to report problems, this seems to be the only way. When I try to open any PDF file, I have to Browse to find my pdf viewer (Flexipdf 2022). I do that and also check your "Do this automatically" option. Every time I try to open a pdf after that I still have to go through all the same Browse steps. I also set up Flexipdf 2022 in the Applications section of General Settings (Portable Document Format (PDF) (application/pdf)) and it is just deleted or never saved. The next time I look or try to use it, it’s gone. This is obviously a bug in your system, please correct. Thank You.

Asked by DLD 2 weeks ago

Last reply by DLD 5 days ago

How to make "mailto" default to Microsoft Outlook (https://outlook.live.com/owa/) through Firefox browser in Windows 11.

I have a new PC with Windows 11. Setting default programs in 11 is very complicated. My email client is Microsoft Outlook (https://outlook.live.com/owa/), which is acce… (read more)

I have a new PC with Windows 11. Setting default programs in 11 is very complicated. My email client is Microsoft Outlook (https://outlook.live.com/owa/), which is accessed through the Firefox browser. When I get an email with an email link it defaults to "mailto", which defaults to the Windows Mail app, which I do not use. How can I make "mailto" default to Microsoft Outlook (https://outlook.live.com/owa/) running through Firefox?

Thanks, Jerry

Asked by gomurchu 3 days ago

Last reply by gomurchu 2 days ago

Enabling facebook microphone permissions

Okay so I am trying to use facebook messenger's "audio clip" function, but it says it does not have permissions to do so. I verified that my microphone(on my computers en… (read more)

Okay so I am trying to use facebook messenger's "audio clip" function, but it says it does not have permissions to do so. I verified that my microphone(on my computers end) is enabled and able to be accessed, but when I go to firefox settings there is no option to allow or block facebook from having access. The Tab is just empty entirely with no option to "add a website" or remove one. I attached a screenshot of the error Im getting and the settings page. I reviewed the page "https://support.mozilla.org/en-US/kb/how-manage-your-camera-and-microphone-permissions" and it shows that the website should be listed and I should be able to choose "allow or block" but the website is clearly not listed. Additionally that page references a button that does not seem to exist in my browser which was referenced as "the permissions icon". That icon is not anywhere on my browser or in the settings.

I attached 3 images that hopefully breakdown what I am trying to describe as its difficult to explain without directly referencing the images.

Asked by camelwrangler 1 week ago

Last reply by camelwrangler 4 days ago

Keyboard shortcut Alt+1 doesn't switch to first tab, but it works normally with other numbers

I got extremely used to switching between tabs with Ctrl+(number) when I was on Windows, and now this feature is kind of broken for me on Linux. I have checked and can co… (read more)

I got extremely used to switching between tabs with Ctrl+(number) when I was on Windows, and now this feature is kind of broken for me on Linux. I have checked and can confirm that I don't have a shortcut already set to this key binding, so there is no conflicting going on.

The weird thing is that I am able to use all the other numbers (2-9) with no problem, and they work as intended. If anyone knows how to fix this problem, I'll be happy to hear the solution.

Asked by norasora 1 month ago

Last reply by norasora 2 days ago