Lost multiple firefox windows, and tabs, after doing REFRESH, and after CRASH. Is my profile, sessionstore gone?

Firefox was hanging up. I got frustrated and I ended the session using task manager. On restart my windows came back, but the tabs were missing the page information. I en… (read more)

Firefox was hanging up. I got frustrated and I ended the session using task manager. On restart my windows came back, but the tabs were missing the page information. I ended the firefox session again, and did a restart of windows for good measure, hoping to get everything restored.

Then, when windows restarted, I restarted firefox, and I was presented two options - SAFE MODE, or REFRESH. I did SAFE MODE. Things looked ok, so I ended that session, and tried restarting again, hoping to restart normally, without SAFE MODE on. I got the same two options again - SAFE MODE or REFRESH. So, I thought REFRESH would get me back to my prior session. Nope. That reloaded a bunch of things, like bookmarks, etc. and gave me a new session.

So, I looked under the three line menu. No ability to RESTORE PREVIOUS SESSION!

I also looked in my profile as found in ABOUT:SUPPORT - PROFILE FOLDER, and in my SESSIONSTORE-BACKUPS folder in my profile folder my RECOVERY.baklz4, and my RECOVERY.jsonlz4 have todays date as DATE MODIFIED, but only are 33kb each - way to small for the hundreds of tabs I had open in multiple windows - I believe.

So, do I have any other recovery session folders available that I might be able to use?

Asked by mnalep 1 week ago

Last reply by mnalep 5 hours ago

I can't open a site. Problem is persisting a long time ago and never solved

I can't open a site via https://<ip-address>. How is this possible using one of the most popular browser in the world? In google chrome, edge, internet explorer, sa… (read more)

I can't open a site via https://<ip-address>. How is this possible using one of the most popular browser in the world? In google chrome, edge, internet explorer, safari are working normally. Below the information about the error.

I'm trying to connect to a particular webbrowser tool. So we have two servers installed one is 36 and the other is 37 as the image attached.

Secure Connection Failed

An error occurred during a connection to 10.32.209.36. You are attempting to import a cert with the same issuer/serial as an existing cert, but that is not the same cert.

Error code: SEC_ERROR_REUSED_ISSUER_AND_SERIAL

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Asked by polli.luiz 2 days ago

Last reply by polli.luiz 11 hours ago

Firefox MegaBar

I don't like the megabar, and I have looked around to see if there are any fixes for the most recent Firefox 77 update that forces that user to have it (like at least one… (read more)

I don't like the megabar, and I have looked around to see if there are any fixes for the most recent Firefox 77 update that forces that user to have it (like at least one other update, it just assumes that people like it). I have tried using the userChrome.css file, but that didn't work. I have also tried going into about:config, which also didn't work. Is there any possible way to say 'I never want to see this megabar again in my life'? Or a way to tell the devs that it should NOT be a default option on new updates? Or a way to turn it off that will always be around, unlike the about:config deal? Any help would be great. I attached an image of the megabar.

Asked by cdr5of8 2 days ago

Last reply by cdr5of8 1 day ago

custom homepage as new tab page doesnt open automatically

hi guys and girls of mozilla, ive a little issue with a custom homepage i made which i want to use as my new tab page. im on linux and use firefox 76.0.1 (64bit). i set … (read more)

hi guys and girls of mozilla,

ive a little issue with a custom homepage i made which i want to use as my new tab page. im on linux and use firefox 76.0.1 (64bit).

i set up a autoconfig.cfg file with this code:

// var {classes:Cc,interfaces:Ci,utils:Cu} = Components;

  • set new tab page */

try { Cu.import("resource:///modules/AboutNewTab.jsm"); var newTabURL = "/home/joe/.mozilla/firefox/h75u1z1z.default/startpage/index.html"; AboutNewTab.newTabURL = newTabURL; } catch(e){Cu.reportError(e);} // report errors in the Browser Console

i also set up a autoconfig.js file with this code:

// First line should be a comment pref("general.config.filename", "autoconfig.cfg"); pref("general.config.obscure_value", 0); pref("general.config.sandbox_enabled", false);

theyre saved in lib/firefox and lib/firefox/defaults/prefs

i then put firefox to open new tabs with a blank page. now it works like this. when i click open a new tab i get a blank page. but in the urlbar is the file selected. now i only need to press enter and i have my new tab page.

the question now is- how can i force firefox to press enter for me. that it opens the file directly and doesnt need me to press enter.

can u spot any errors in the code i copied from a thread in reddits/r/firefox CSS forum?

or is there a setting i can change which makes it the page opens by itself?

ill add two pics- one when i just opend the new tab and one after i clicked enter

Asked by joe23reptiles 1 week ago

Last reply by joe23reptiles 6 days ago

How can I optimize my pages for reader view?

I have a website, a typical three column design, with NAV, MAIN and ASIDE elements. A reader view option appears in Firefox, but ironically, only the ads in my ASIDE elem… (read more)

I have a website, a typical three column design, with NAV, MAIN and ASIDE elements. A reader view option appears in Firefox, but ironically, only the ads in my ASIDE element show up when I click it.

The MAIN content uses SUMMARY/DETAILS to group things. Personally, I would think this combination would scream reader view content, yet MAIN is ignored entirely. It has some links, but so does my ASIDE (advert) content.

My ads are simple blurbs and links, no pictures, for my own ebooks, and are not served by a third party, so I can see how they could get picked up and I'm fine with that. What puzzles me is why the MAIN content is being ignored.

The site in question is: https://waxphilosophic.sdf.org/erotica/ It is marginally safe for work provided you do not click any of the links. No explicit images.

As a test, I even tried changing the SUMMARY/DETAIL of my "What's New" section to ARTICLE followed by an H2 heading. No change in behavior. https://waxphilosophic.sdf.org/erotica/test.html

The HTML passes the W3 validator. I searched Firefox Help / Stack Exchange. Any suggestions would be greatly appreciated.

Asked by Davina Lee 1 week ago

Last reply by Davina Lee 11 hours ago

FF slow, jittery and sometimes freezes (uses loads of RAM)

FF didn't used to be so slow. It now get really slow and uses a lot of RAM to the extend that my disk is full and I have to shutdown FF. I do have like 30 tabs open, with… (read more)

FF didn't used to be so slow. It now get really slow and uses a lot of RAM to the extend that my disk is full and I have to shutdown FF.

I do have like 30 tabs open, with one or two Slack-like web apps. However, I'm not using them all at the same time. In the first couple of quantum releases it didn't used to be this slow, never mind pre-quantum performance. Oh and I'm not gonna compare to Chrome or Chromium.

Any help with this? Is it the extensions causing it?

  • Also I never found a proper replacement to legacy Tab Session Manager (the quantum one is no where near as good).

Asked by lookintolearn 5 days ago

Last reply by lookintolearn 3 days ago

Page refreshes to top of page

I have a web site page that I wish to refresh, but not go to the top of the page. Currently whenever I refresh a page it goes to the top of the page. Thanks, Uncle Dewe… (read more)

I have a web site page that I wish to refresh, but not go to the top of the page. Currently whenever I refresh a page it goes to the top of the page.

Thanks, Uncle Dewey

Asked by Uncle Dewey 1 week ago

Last reply by Uncle Dewey 6 days ago

Change theme with user.js file

Hi, I'm trying to change the theme (only using standard dark and light themes) from a linux terminal. My attempted routes include changing a user.js file (the rest of the… (read more)

Hi,

I'm trying to change the theme (only using standard dark and light themes) from a linux terminal. My attempted routes include changing a user.js file (the rest of the file works), in particular setting extensions.activeThemeID (I've also attempted doing this in about:config, as well as editing the extensions.json file).

I can change the theme by going to add-ons in a browser. This works fine. I was hoping to automate it (it's not the 1980's - clicking three times to change to a default theme seems unnecessary).

Am I missing something that must be changed in about:config or any other file to change the theme? The extensions.activeThemeID changes when changing the theme in add-ons and seems the likely option but does nothing if I change this value myself.

Asked by eddiewh 5 days ago

Last reply by eddiewh 5 days ago

Crash at startup if Firefox not properly quit before shutdown Debian Buster

Hello, One of my last Crash ID report : 49e3c347-5deb-4659-b9d1-281b00200514 I experiment this problem on two of my computers. Both are running Debian Buster. If I don't … (read more)

Hello,

One of my last Crash ID report : 49e3c347-5deb-4659-b9d1-281b00200514

I experiment this problem on two of my computers. Both are running Debian Buster. If I don't forget to quit Firefox before shutting down my computer, then I believe I won't have problem the next time I switch on my computer and launch Firefox.

However, as most of the time, if I shutdown my computer with Firefox still being open, it seems that Debian Buster doesn't close properly Firefox. In fact, if Firefox was still open when I switch off my computer, I can be sure (100% of the time) that at the next startup, Firefox won't be able to launch the previous session and I'll have to "restore my last tabs".

No other software seem to suffer from the way Debian Buster switch off. Only Firefox.

Thank you for any help one could give me,

Regards, Thatoo

Asked by Thatoo 2 weeks ago

Last reply by Thatoo 11 hours ago

Close Multiple Tabs sub-menu in context menu

In the new version of the Developer Edition the options "close tabs to the right" and "close other tabs" are in a sub-menu named "Close Multiple Tabs" inside the context … (read more)

In the new version of the Developer Edition the options "close tabs to the right" and "close other tabs" are in a sub-menu named "Close Multiple Tabs" inside the context menu. Is there's a way to change this so that they will appear directly in the main context menu? I use "close tabs to the right" often and I find this very annoying.

Asked by gershonido 1 day ago

Last reply by gershonido 4 minutes ago

Browser.urlbar.maxRichResults command not work at new URL bar?

So this value at my settings is 10. But when i click in the url bar shows only 8 saved page. Changing this value no effect anymore. How can i set to show again 10 saved p… (read more)

So this value at my settings is 10. But when i click in the url bar shows only 8 saved page. Changing this value no effect anymore. How can i set to show again 10 saved page?

Asked by dency01 20 hours ago

Last reply by dency01 12 hours ago

youtube videos not loading, only spinning circle || issue after latest update

since update I can't open you tube videos, site is working & can search get previews but when click to open it don't play only try to load & keeps spinning circle… (read more)

since update I can't open you tube videos, site is working & can search get previews but when click to open it don't play only try to load & keeps spinning circle on black background. Cleared cache & cookies, deleted temp files, refresh Firefox but no help. Not using any add-on other than anti virus (updated), no plug-in used. No issue with other sites only concern is you tube video not playing. However, in private window video is playing without any problem. Other browser working fine, facing this issue after latest update - 77.0.1 (64-bit). No issue before update.

Asked by Sunil Kinra 1 day ago

Last reply by Sunil Kinra 11 minutes ago

Sync error 500

I am having problem with sync. When ever I try to login I get 500 error. Its been 3 days . This problem occurs in phone too. I tried disconnecting the account and login f… (read more)

I am having problem with sync. When ever I try to login I get 500 error. Its been 3 days . This problem occurs in phone too. I tried disconnecting the account and login few times but same error.

Asked by kd 5 days ago

Last reply by kd 2 days ago

Crashing constantly since 76 update

Hi, I'm really annoyed and even think about dropping firefox completely... There's nothing much to add: it simply crashing randomly. Sites crashing as well as entire brow… (read more)

Hi, I'm really annoyed and even think about dropping firefox completely...

There's nothing much to add: it simply crashing randomly. Sites crashing as well as entire browser...

bp-30cb2b8f-70e2-444a-8f41-5f6760200531 bp-15c4dee4-1917-4e03-bb64-558a60200531

Asked by cyberpooh 4 days ago

Last reply by cyberpooh 13 hours ago

Problem with my fire fox browser

HI there I hope you can help me. when I type something on the search bar on the top this what I get ( please look at the attachment ) at the bottom of my page. It is ver… (read more)

HI there I hope you can help me. when I type something on the search bar on the top this what I get ( please look at the attachment ) at the bottom of my page. It is very annoying. I have to reinstall the Firefox 2time in safe mode and without and lastly restart my computer and it is not working, any idea? Please look at the attachment

Asked by ranaz123 1 week ago

Last reply by ranaz123 5 days ago

All webpages continue scrolling after I've taken my fingers off the touchpad

I've just switched to Firefox as Chrome keeps lagging. I'm running Fedora 31 and the latest version of Firefox 76.0.1. When I use the 2 fingered scrolling and take my fin… (read more)

I've just switched to Firefox as Chrome keeps lagging. I'm running Fedora 31 and the latest version of Firefox 76.0.1.

When I use the 2 fingered scrolling and take my fingers off the touchpad, the page keeps scrolling until it slowly slows down and eventually stops or hits the end of the page. It doesn't then stop when I place my fingers back on the touchpad, so it just carries on regardless to another part of the page. It's ludicrous as it just goes past whatever I'm trying to look at! If I keep my fingers on the touchpad it stays put but as soon as I take them off, it's off on it's jollies again.

Is there anyway to disable this? I've unchecked smooth scrolling and autoscrolling. I've never had Firefox behave like this before on any Linux distro.

Asked by firefox739 16 hours ago

Last reply by firefox739 11 hours ago

My user-safety css stopped working, how can I diagnose it and get it working again?

Hi, I have a strobe sensitivity and visual motion sensitivity. Flashing and certain animations can screw with my brain and leave me with awful migraines afterwards. I hav… (read more)

Hi,

I have a strobe sensitivity and visual motion sensitivity. Flashing and certain animations can screw with my brain and leave me with awful migraines afterwards.

I have been using userContent.css to try to block a lot of the animation online, such as zoom on mouseover and jump on mouseover, but it's stopped blocking that. Other user css is still switching fonts, though. How can I figure out what has changed and what could fix the code?

Relevant section of my usercontent.css:

/* block some transitions */

  • {transition-duration:1ms !important; animation-duration: 1ms !important}

@-moz-document [various other domains], domain("threadreaderapp.com"), [various other domains] {

  • { transform: none !important; }
  • { -moz-transform: none !important; }
  • { -webkit-transform: none !important; }
  • { animation: none !important; }
  • { transition: none !important; }
  • {-moz-transition: none !important; }
  • {-webkit-transition: none !important; }
    hover { transform: none !important; }
  • { background-image: none ! important }

body {

 -webkit-transition-property: none!important;
 transition-property: none!important;
 -webkit-animation: none!important;
 animation: none!important;

}}

Asked by MarjaE 9 hours ago

Last reply by MarjaE 3 hours ago

Computer crashed, Firefox history is gone and will not be saved

Hi everybody, I'm running Firefox 77.0 on my 2014 rMBP with OSX 10.11.6. A few hours ago my OS crashed and I reset my computer. Once I did this, I opened everything back … (read more)

Hi everybody, I'm running Firefox 77.0 on my 2014 rMBP with OSX 10.11.6. A few hours ago my OS crashed and I reset my computer. Once I did this, I opened everything back as it was pre-crash and all my Firefox tabs and absolutely everything else loaded correctly except for my history.

Every time I type a word, no previously visited URLs will load up in my URL field, I checked my History and it seems to have deleted 99% of every site I've visited. The recently closed tabs and windows are still there, and I can reload them if I press cmd+shift+t, however the rest of my actual history seems to be gone. I've reset (normally) my computer a couple more times, repaired disk permissions and whatnot and for some reason it won't even save whatever other sites I've now visited since it was wiped. Am I screwed here?

Asked by nodigits 2 days ago

Last reply by nodigits 2 days ago

Firefox stops working whenever i connect my bluetooth headphones

I just need a answer please as to why Firefox wont work whenever I connect my Bluetooth headphones. Every time i connect my Bluetooth headphones to my laptop i try to pla… (read more)

I just need a answer please as to why Firefox wont work whenever I connect my Bluetooth headphones. Every time i connect my Bluetooth headphones to my laptop i try to play a video and it doesn't work and if i try to open a new tab it wont load or if i try to play a video on Youtube or even look something up it just doesn't it just sits there loading and I've waited long amounts of time but it just won't load.the video will say its played and i'll give you an example it'll be in the middle of the video and i connect my bluetooth headphones and its just stays at the 10 minute mark and its not on paused but it never plays.

Asked by jai2the 1 week ago

Last reply by jai2the 16 hours ago