Showing questions tagged: Show all questions

20 GB RAM usage, pagefile takes up all space on C: - 300 tabs in Tree Tabs

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works wel… (read more)

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works well. (which is unexpected but makes me _very_ happy :-)) Firefox exits properly without any exceptions, no matter how long it runs, or how many times the PC is sent to STR mode meanwhile.

Second, everything is fine, except RAM usage. No matter how many RAM is installed, Firefox takes up all of it after a few days of normal operation. I have recently upgraded my PC from 16 to 24 GB of RAM only for this sole reason to see if anything changes, but it did not produce any noticable change, except that it takes 5-7 days for Firefox to fill up all the RAM instead of the 3-4 days before. Disk space on C: drive was nullified by Firefox as the paging file went up to 50 GB.

I want to hunt down this thing. I have approx. 300 tabs, 2 addons, and Hardware Acceleration is disabled since otherwise Fox hangs several times a day (have to be killed from outside). Pics are attached. https://addons.mozilla.org/hu/firefox/addon/tree-tabs/ https://gitlab.com/kroppy/TreeTabs

I'd like to get suggestions where to start.

  1. Disabling or replacing the adblocker ?
  2. Inspecting memory usage on Process Manager (about:processes) and Task Manager (about:performance) pages ?
  3. Installing some external tools like Firemin ?

Please don't suggest neither safe mode nor disabling all addons, since that makes it impossible to reproduce this amount of load, which is the primary reason behind the symptom.

I PrtScr'ed Process Manager and Task Manager, see that RAM sizes per page are normal in Task Manager, but not in Process Manager (10 times more).

CPU usage is totally normal for this load, even when memory is in the heaven. See the TaskMan pic. (I suppose that's because of ad blocking)

Thanks for any ideas,

Peter B. (I'm PC enthusiast)

-- Windows 7 Ultimate SP1 64 bit Firefox 106.0.5 (latest autoupdated) no firewall nor any antivirus - since 20 years with no infection ... AMD FX-6350 Six-core ASUS M5A99FX PRO R2.0 24 GB DDR3 1600 MHz Sapphire Radeon HD 5750 1GB (AMD Catalyst 15.11.1, Nov 18, 2015)

Asked by Peter B. 2 weeks ago

Last reply by Peter B. 2 days ago

Your system has run out of application memory

I am using the latest version of Firefox with Mojave on a Mac. Lately I have experienced slowness despite the fact that I didn't add any software and I have Norton checki… (read more)

I am using the latest version of Firefox with Mojave on a Mac.

Lately I have experienced slowness despite the fact that I didn't add any software and I have Norton checking for viruses. Recently I got a message "Your system has run out of application memory" when I had 5 tabs open in Firefox. I checked Activity Monitor and it showed Firefox using 1.16 GB. 7 other apps were open, the next one with the highest memory usage was Mail (465 MB). Activity Monitor showed 30 instances of FirefoxCP Isolated Web Content entries.

I attached a screen capture showing what Firefox was using in one of these instances. Is this "normal" with 5 tabs open?

I closed the open tabs and quit Firefox. Memory usage by Firefox went down, but after a short time the problem happened again.

A search on the internet showed lots of similar complaints about FirefoxCP Isolated Web Content. Is this a known bug? Any way to avoid this problem?

Thanks.

Asked by Sue 1 month ago

Last reply by Sue 11 minutes ago

Picture-in-picture not showing

When on youtube or any video website, when I click the PiP button on the side of the video, instead of having the video popup on the screen I have a new windows (only vis… (read more)

When on youtube or any video website, when I click the PiP button on the side of the video, instead of having the video popup on the screen I have a new windows (only visible in the windows taskbar) which is invisible.

If I try to hover the (empty) preview in windows, it should hide everything else and show the window, but nothing happens as if the popup create a window but stops in the middle.

I tried with Firefox (v107.0 64-bit) and Firefox dev edition (v108.0b6 64-bit), same problem. I tried disabling every addon/theme, same problem. I tried disabling hardware acceleration, same problem. I tried Troubleshoot mode, works correctly.

Before re-installing Windows it worked normally. What could be the problem ?

Asked by EdgelordMcTeabag 2 days ago

Last reply by EdgelordMcTeabag 1 day ago

Back button doesn't work, only changes the URL

Hello there! I have a strange issue where only the URL changes when I press the back button, it seems to happen randomly, but it isn't only happening to me, I was in a di… (read more)

Hello there! I have a strange issue where only the URL changes when I press the back button, it seems to happen randomly, but it isn't only happening to me, I was in a discord call yesterday when I saw it happen for my friend too. See attached gif for an example. Any idea what could cause this, or how to fix it? I haven't found any other threads about this, but I haven't looked very hard.

Asked by Jani 4 days ago

Last reply by Jani 4 days ago

Titlebar and tabs missing in full screen mode (literally missing)

From time to time when maximising the Firefox window, the top 20-80 pixels or so are replaced with a white bar. It is usually possible to grab the window by clicking som… (read more)

From time to time when maximising the Firefox window, the top 20-80 pixels or so are replaced with a white bar.

It is usually possible to grab the window by clicking somewhere next to the address field, and thereby move the window downwards, alt double clicking there which set the window to "not full screen".


Right-click in any of the "white" areas - which is located inside the FF window - opens the Windows desktop menu.

screenshot 1 - "not full screen" (all is fine) screenshot 2 - FF in full screen mode (title bar vanished - replaced by white space) screenshot 6 - right-click in white space opens Windows desktop menu

Found a few reports that seem similar but not identical to this one. Rebooting the computer usually helps but after a while the problem returns. It is a rather old machine, and quite possible that this is not caused by FF, however, only FF suffers from this behaviour - any other application works "normally" (i.e. you see the title bar and buttons when the window is maximised).

Asked by branpet 3 days ago

Last reply by branpet 2 days ago

Unable to upload attachments in outlook/OneDrive from Firefox

Hi, I'm using Firefox 107.0 (64-bit) version and I'm unable to upload attachments in outlook online, One drive using Firefox browser. Tried with chrome, edge etc.. and th… (read more)

Hi,

I'm using Firefox 107.0 (64-bit) version and I'm unable to upload attachments in outlook online, One drive using Firefox browser. Tried with chrome, edge etc.. and the files are uploading without any errors.. Kindly advise to solve this issue.

Asked by joemon.thomas 1 week ago

Last reply by joemon.thomas 4 days ago

Picture-in-picture is not working

I am using firefox on a Macbook pro M1 using Ventura. The picture-in-picture feature is not working. When I click on the popup button for p-i-p, it only pauses the video,… (read more)

I am using firefox on a Macbook pro M1 using Ventura. The picture-in-picture feature is not working. When I click on the popup button for p-i-p, it only pauses the video, it does not start the picture-in-picture.

I've uploaded a .gif of me clicking on the button in YouTube.

Asked by cmm225 4 days ago

Last reply by cmm225 1 day ago

Firefox will not open amazon.com

I can't open amazon.com. I've disabled my antivirus and have tried in 'troubleshoot' mode. I have cleared my cache. I have flushed my DNS. It's been going on for days… (read more)

I can't open amazon.com. I've disabled my antivirus and have tried in 'troubleshoot' mode. I have cleared my cache. I have flushed my DNS. It's been going on for days. I keep timing out. Other sites do not exhibit problems. Chrome DOES open amazon.com quickly.

Asked by jjjerdee 13 hours ago

Last reply by jjjerdee 3 hours ago

some pages dont load proprely

Hi Firefox, my https://castbox.fm and https://linkedin.com/ aren't loading properly in my Firefox. Please see the images in attach. Can you please explain why this is ha… (read more)

Hi Firefox, my https://castbox.fm and https://linkedin.com/ aren't loading properly in my Firefox. Please see the images in attach. Can you please explain why this is happening ?

Thanks Gonçalo

Asked by Gonçalo 3 days ago

Last reply by Gonçalo 3 days ago

Resolving link issue

for example: navigation to firefox.com works instantly trying to get there from a search result https://www.google.com/search?client=firefox-b-1-d&q=firefox+forums ha… (read more)

for example: navigation to firefox.com works instantly

trying to get there from a search result https://www.google.com/search?client=firefox-b-1-d&q=firefox+forums

hangs the browser.

new tabs wont work correctly. I have to close the browser and start over. It will always hang again.

This is a new windows 10 and browser installation (about 10 days old). I had to replace my boot drive due to hw failure.

Asked by axw 5 days ago

Warum startet Firefox nicht mehr?

Guten Tag! Seit einiger Zeit startet Firefox nicht mehr. Wenn ich ihn als Admin starte, startet er zwar, friert aber sofort wieder ein und rührt sich nicht mehr. Ich habe… (read more)

Guten Tag! Seit einiger Zeit startet Firefox nicht mehr. Wenn ich ihn als Admin starte, startet er zwar, friert aber sofort wieder ein und rührt sich nicht mehr. Ich habe ihn mehrfach deinstalliert und wieder sauber installiert und aktualisiert. Nichts hilt. Was läuft da falsch? Danke! klaus1003

Asked by klaus1003 3 days ago

YouTube Wont Play In Private Window

Firefox 103.0.2 (64 bit) doesn't play YouTube videso in Private Window. The same videso play in s statdrad new window. Try: https://www.youtube.com/watch?v=0fiVciCs8zU wh… (read more)

Firefox 103.0.2 (64 bit) doesn't play YouTube videso in Private Window. The same videso play in s statdrad new window. Try: https://www.youtube.com/watch?v=0fiVciCs8zU which ironically won't play in private! Every time you press the play button you get about half a second of play before pausing. In standard mode it plays just fine.

Asked by Les 5 days ago

Loading Firefox is slow and lagging, crashing often

it is taking over 30 seconds, sometimes several minutes to load firefox, especially first thing in the day. Rebooting computer only makes it worse. Any thought's on how… (read more)

it is taking over 30 seconds, sometimes several minutes to load firefox, especially first thing in the day. Rebooting computer only makes it worse. Any thought's on how to speed up responsiveness?

Asked by chris-nancy 5 days ago

Firefox opens websites and follow links only after retry

I'm on macOS's Firefox Developer Edition 108.0b3 right now (arm64/M1 CPU). Though my current version is a bit outdated, this problem appeared several months ago and still… (read more)

I'm on macOS's Firefox Developer Edition 108.0b3 right now (arm64/M1 CPU). Though my current version is a bit outdated, this problem appeared several months ago and still bothers me to this day.

When I, or any another application, opens a new link in Firefox, the browser _doesn't initiate the request_. So the address bar changes, new tab opens, but absolutely nothing happens afterwards, I'm just getting blank page. In order to get site opened, I have to click the address bar and press enter. Rarely, even that does not help and I have to press enter one more time again. The same applies to the basic links too - on this support website I practically had to click every link twice to get it opened. The click even is clearly registered: I see the :active state for a second. But afterwards, nothing happens, just like event got canceled in browser (clearly not JS error since it not only happens with links). It doesn't matter which site I'm using, where I am (even start page has this bug), and don't really seem to be connected to the extensions I'm using (recently I had high RAM usage by extension, and being unable to determine which extension uses RAM I disabled most of the untrusted extensions, which do not have cup icon given by Mozilla or not very popular), so I practically use _mostly_ clean Firefox now.

Before going full reset, I wonder if anyone happen to have the same issue?

Asked by dantaeusb 2 days ago

Firefox (v107.0 64 bits) fails to connect to an IIS website that has Extended Protection configured

Dear team I'm trying to use firefox to connect OWA on an Exchange server where Extended Protection (EP) is configured. OWA website is configured to use basic and windows… (read more)

Dear team I'm trying to use firefox to connect OWA on an Exchange server where Extended Protection (EP) is configured. OWA website is configured to use basic and windows authentication. When EP is off, it works fine, meaning it connects automatically. When EP is set to require, then I get a credential prompt, that loops prompting me for the credentials Strange thing is if the 1st time I get prompted I press Escape key, and at the 2nd prompt I enter my credentials, then I connect the webmail.

These settings were configured in the about:config with the webmail URL "network.automatic-ntlm-auth.trusted-uris" "network.negotiate-auth.delegation-uris" "network.negotiate-auth.trusted-uris" and this one "signon.autologin.proxy" has been set to true

If I use Chrome or Edge, I do not face this issue I found this website https://www.synacktiv.com/en/publications/dissecting-ntlm-epa-with-love-building-a-mitm-proxy.html which seems to explain the issue I'm facing but it talks about Firefox v93.

Anyone knows how to fix this issue?

Regards

Asked by Seb 2 days ago

firefox hangs whenever i open tumblr

afternoon, my keyboard is missing several keys so please bear with me. I have been having issues opening Tumblr in firefox for about a month now. I have been clearing my … (read more)

afternoon, my keyboard is missing several keys so please bear with me. I have been having issues opening Tumblr in firefox for about a month now. I have been clearing my cache, i deleted all of my browser history and cookies to the beginning of time, and tumblr still hangs whenever i open it, going unresponsive until I forcequit from the task manager. sometimes, if I grab the scrollbar and get it away from the top of the page before it hangs, itll let me browse no issue, but most of the time it takes about 2 seconds to become hanging/unresponsive. I have not experienced this issue on any other site with the frequency that Tumblr experiences, and I cannot find any help desk information about a problem like this. I would really like to avoid moving to a different browser but its getting kind of insane how hard it is to live around it. if I have music/video going in the background, it will continue to play while Im forced to hang on tumblr, until I forcequit.

Asked by littlebluecolor 4 days ago

Firefox won't close properly

Everytime I try to close my Firefox browser window, it just stops. There are multiple processes taking in excess of 200 or 300K in memory that seem to be causing the pro… (read more)

Everytime I try to close my Firefox browser window, it just stops. There are multiple processes taking in excess of 200 or 300K in memory that seem to be causing the problem. I have to manually end the process just to close Firefox, and it is quite annoying.

I just checked, my Firefox is up to date. Yesterday I deleted and re-installed Firefox, but it's still doing the same thing.

This is kind of driving me nuts to be honest. I have Chrome, Opera, and Edge also installed on my computer so I'm ready to jetisson Firefox but thought I'd see what the community has to say first.

Asked by phil.schreiber9664@gmail.com 4 days ago