Showing questions tagged: Show all questions
  • Solved
  • Archived

Disabling DRM completely

I have disabled DRM content, why is firefox annoying me to enable it each time I load a website that requires it. What seems to be now the general topic, even for a simpl… (read more)

I have disabled DRM content, why is firefox annoying me to enable it each time I load a website that requires it. What seems to be now the general topic, even for a simple blog... If I disabled it, I do not want to be prompted to enable it back. I know how to enable it.

Asked by david636 1 year ago

Answered by cor-el 1 year ago

  • Archived

Intrusive VPN popup pushing Firefox VPN

Today Firefox stopped altogether and dimmed the entire window and popped up a "Try the Firefox VPN" message. I use Firefox specifically to get away from disruptive, intru… (read more)

Today Firefox stopped altogether and dimmed the entire window and popped up a "Try the Firefox VPN" message. I use Firefox specifically to get away from disruptive, intrusive violations like that. This needs to be removed immediately and never ever happen again. It's completely antithetical to the core values of Firefox.

Furthermore, several users have reported it breaking their browsing. See this Reddit thread:

https://www.reddit.com/r/firefox/comments/13rnt88/why_is_firefox_windows_11_version_showing_me/

This affected me on Windows 10 running Firefox 113.0.2 64 bit.

Asked by ben153 9 months ago

Last reply by a.mpoygiatiwths 9 months ago

  • Solved
  • Archived

Credit Card info does not autofill

Firefox has my credit card information and it shows up in a window when I go to pay for something, but when I click on the credit card I want to pay with, it won't autofi… (read more)

Firefox has my credit card information and it shows up in a window when I go to pay for something, but when I click on the credit card I want to pay with, it won't autofill. In Settings, the box to autofill is checked. This has worked a hundred times before, but stopped working a few months ago. Also, I've checked the 2 relevant items in about:config an they are enabled. How do I get the autofill to start working again?

Asked by Steve Ediger 1 year ago

Answered by Steve Ediger 1 year ago

  • Solved
  • Archived

How to allow clipboard access, for a specific website?

Hello. I can't copy and paste in Figma in Firefox whatsoever, both plain text and images. Tried doing it in Vivaldi and that browser showed a dialog prompt asking whethe… (read more)

Hello. I can't copy and paste in Figma in Firefox whatsoever, both plain text and images. Tried doing it in Vivaldi and that browser showed a dialog prompt asking whether or not I want to allow the page to access the clipboard. I granted the permission and it's working there now. Can I do the same in Firefox somehow?

Firefox 114.0.1 on Windows

Asked by TarkBike 8 months ago

Answered by Terry 8 months ago

  • Solved
  • Archived

Import Certificates button not functioning

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our serv… (read more)

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our server certificates into the Authorities section.

Ubuntu 22.04 Firefox installed through snap. Version 104.0 just upgraded this afternoon.

Thank you, James

Asked by James Finnall 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Red striped address bar?

Why is my browsers address bar red striped? From what I have found online, dev tools has something to do with it; something about the browser being remote controlled. … (read more)

Why is my browsers address bar red striped? From what I have found online, dev tools has something to do with it; something about the browser being remote controlled.

How to I remedy this?

Asked by jeffcren 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Default TLS values in About:Config

Hello everyone! I have a question concerning what the default value settings are for the two below security.tls.versions in About:Config. Mine are currently set at 4 for… (read more)

Hello everyone! I have a question concerning what the default value settings are for the two below security.tls.versions in About:Config. Mine are currently set at 4 for version.max and 3 for version.min. The reason I ask is that I have gotten two Event 36871 errors since updating Firefox to 100.0.1 stating "A fatal error occurred while creating a TLS client credential. The internal error state is 10013." I was using no other program besides Firefox at the time I received the errors.


security.tls.version.max security.tls.version.min

Respectfully, Don

Asked by new_aged2perfection 1 year ago

Answered by Terry 1 year ago

  • Solved
  • Archived

trying to access Facebook error

An error occurred during a connection to www.facebook.com. SSL_ERROR_DC_EXPIRED What in the world? does Facebook not keep up with its own security? or is this a Firefox t… (read more)

An error occurred during a connection to www.facebook.com. SSL_ERROR_DC_EXPIRED What in the world? does Facebook not keep up with its own security? or is this a Firefox thing?

Asked by judgeraye 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Firefox using FIDO2 Security Keys

Firefox seems to have a problem on Linux using USB Security Keys. I have two Yubico Security Keys which I use for 2FA. The problem seems to be that Firefox cannot communi… (read more)

Firefox seems to have a problem on Linux using USB Security Keys. I have two Yubico Security Keys which I use for 2FA. The problem seems to be that Firefox cannot communicate with the USB port, as it doesn't make any difference whether the USB Security Key is plugged in or not, the error returned is always the same and the Security Key does not light up.

I believe Firefox's WebAuth code must be fine, as it works on Windows, which is why I think it's some kind of permissions problem. Chrome works perfectly with the Security Keys on my computer.

I've used a number of sites (I've listed a couple below) where you can test your Security Key with Firefox on KDE Neon and the error is always "UnknownError: The operation failed for an unknown transient reason":

https://www.token2.com/tools/fido2-test/ https://demo.yubico.com/webauthn-technical/registration

I cannot log into Bugzilla with GitHub as my GitHub login uses a Security Key as the second factor.

Asked by dave353 10 months ago

Answered by cor-el 10 months ago

  • Solved
  • Archived

Firefox not saving cookies for websites with exceptions

Firefox is not remembering the cookies and data of websites that I have saved under Exceptions. These sites are saved under Exceptions but I still have to log in every si… (read more)

Firefox is not remembering the cookies and data of websites that I have saved under Exceptions. These sites are saved under Exceptions but I still have to log in every single time I access those sites, regardless of the fact that are saved to the list.

Asked by cvwest 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

How to disable Enhanced Tracking Protection on all sites and for every FF session. Choosing Custom, and deselecting all check boxes doesn't work.

I have tried the suggestions as described in the following article: https://support.mozilla.org/bm/questions/1273784 However, am still having the issue. It's as if the s… (read more)

I have tried the suggestions as described in the following article: https://support.mozilla.org/bm/questions/1273784 However, am still having the issue. It's as if the settings are totally ignored. I am using version 108.0a1 of Firefox developer edition. Ideally what am trying to achieve is away to disable all features of ETP. I figured setting it to custom with all values unchecked would have done the trick but it's not working. What works is if I add the site to the list of Exceptions for Enhanced Tracking Protection, then I will see all Ads loaded just fine on the page. However, this is not viable for me as I have a large list of sites that I visit, and I need to see the ads on them.

Does anyone know of a way to get around this feature in FF?

Is there another setting am missing from the previous article?

Asked by bjorn22 1 year ago

Answered by James 1 year ago

  • Solved
  • Archived

can not access web interface with router

Up until the last update of Firefox I was able to access my router, 192.168.1.1, enter password and check it. Now I get an error message "connection not secure" "Your co… (read more)

Up until the last update of Firefox I was able to access my router, 192.168.1.1, enter password and check it.

Now I get an error message "connection not secure" "Your connection to this site is not private. Information you submit could be viewed by others (like passwords, messages, credit cards, etc.)

None of this is part of looking at my router, Asus GT-AX11000.

Asked by focuspuller 1 year ago

Answered by focuspuller 1 year ago

  • Solved
  • Archived

Local domain brings up search results

When entering a local domain in the URL bar Firefox sends the request to a search engine instead of the DNS server. How can I stop this behaviour and switch back to how i… (read more)

When entering a local domain in the URL bar Firefox sends the request to a search engine instead of the DNS server. How can I stop this behaviour and switch back to how it was before?

Asked by menext 1 year ago

Answered by menext 1 year ago

  • Solved
  • Archived

Password generator does not appear on some sites firefox

Idk why but sometimes firefox just doesn't prompt to generate secure password, I even have to download some extensions to generate secure password (Secure Password Genera… (read more)

Idk why but sometimes firefox just doesn't prompt to generate secure password, I even have to download some extensions to generate secure password (Secure Password Generator) meaning more secure issues.

My guess is that you guys probably hardcoded something like {if "type: password" then prompt}, but it's still partly fault at developers too for bringing these huge chunks of javascript.

In screenshot there's element examaple in which i input password but no prompt whatsoever.

Asked by astyd637 1 year ago

Answered by astyd637 1 year ago

  • Solved
  • Archived

How to recover passwords from logins.json-1.corrupt?

I opened Firefox as usually, but passwords are missing, only logins are available. There is also a file called logins.json-1.corrupt in the profile folder. Renaming it … (read more)

I opened Firefox as usually, but passwords are missing, only logins are available. There is also a file called logins.json-1.corrupt in the profile folder.

Renaming it back to logins.json with restarting the computer does not work.

There are no previous versions of these two files available in the system.

Please let me know how I can recover passwords, may be with a special software.

Thank you!

Asked by DVS75 1 year ago

Answered by DVS75 1 year ago

  • Archived

Is Google Safe Browsing Service Potentially Bad For Privacy?

Hi, Some privacy experts recommend disabling the configs starting with browser.safebrowsing.provider.google... for increased privacy. For this reason, I would like to … (read more)

Hi,

Some privacy experts recommend disabling the configs starting with browser.safebrowsing.provider.google... for increased privacy.

For this reason, I would like to know what type of data is sent to Google.

Does Firefox send my IP to Google?

Asked by IT Mania 1 year ago

Last reply by TyDraniu 1 year ago

  • Solved
  • Archived

Firefox suggesting usernames - saved logins off

Firefox is suggesting usernames on multiple websites that I access regularly. However, I have the saved logins feature turned off in Firefox. When I access Settings >… (read more)

Firefox is suggesting usernames on multiple websites that I access regularly. However, I have the saved logins feature turned off in Firefox.

When I access Settings > Privacy & Security > Logins and Passwords - it shows all of these options turned off.

When I access Settings > Privacy & Security > Logins and Passwords > Saved Logins... - it indicates No Logins Found / No Synced Logins found.

I do have Firefox Sync turned on to sync between devices, but since it indicates "No Synced Logins" it doesn't appear this is coming from another device. I have checked multiple devices and found they all show "No Synced Logins"

Only happening in Firefox. I am not getting these suggested logins in Edge or Chrome.

Happening across all my Windows 10 and 11 devices that have Firefox sync enabled. 2 x Windows 11 Pro 22H2 (build 22621.819) 1 x Windows 10 Pro 22H2 (build 19045.2364)

Firefox 108.0 on all Windows devices, but it started before updating to 108.

I have not yet tried resetting Firefox - hoping to use that as a last resort.

Any suggestions on where else to look or what I should try?

Asked by bumgarb 1 year ago

Answered by bumgarb 1 year ago

  • Solved
  • Archived

2FA login on web sites does not work with Firefox (Linux)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux) Present setup: Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox … (read more)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux)

Present setup:

Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox 110.0 on Ubuntu MATE 22.04 LTS 5.15.0-58 (x86-64)

Works chromium 109.0.5414.119 on debian 11.6 bullseye 5.10.162-1 (x86-64)

I am able to register and authenticate with security devices Yubikey NEO (without FIDO2) and Yubikey 5 NFC (FIDO2 compliant) on several sites (eg. pypi, google..) using Chrome or Chromium but now not with Firefox at all. It has not worked for at least the last few updates. Changing settings in about:config or plugging/unplugging keys, stopping every Firefox plugin etc. don't help. Neither does a fresh Firefox install without any super-security-settings.

Testing sites like Yubico's own or Okta's works fine using Chromium but not Firefox.

From what I can see this is not especially related to FIDO2 (Webauthn). pypi seems to use U2F which should work just fine with Firefox since way back.

I haven't tested Firefox for Windows but Chrome browser for Windows 10 works fine (which I tested first when Firefox didn't cut the mustard), I therefore expect it to work also on Chrome browser for Linux. Just to check if this was related to a debian bullseye package, I tested it on Ubuntu MATE too, which didn't do the trick. Haven't done any more testing than that on MATE.

This seems like a strictly firefox problem. -What to do?

Yours, Kaare

Asked by kaare 1 year ago

Answered by kaare 1 year ago