Showing questions tagged: Show all questions
  • Archived

Bricked ZTE Open C quite hard

Hello, I've received my ZTE Open C (EU version) this Wednesday. Since I ran into some issues with Gaia in ff 1.3, I wanted to update it. I've followed guide from mdn ( h… (read more)

Hello, I've received my ZTE Open C (EU version) this Wednesday. Since I ran into some issues with Gaia in ff 1.3, I wanted to update it. I've followed guide from mdn ( https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/ZTE_OPEN_C ) and updated from git successfully. I've also created backup /system and /data dirs with adb pull. Problems arose today, when ff hung up on some application. I had to restart it, unfortunately by taking off battery. After restart, ff couldn't detect my sim card. It didnt change after more restarts (I tried to move sim a bit, no luck) so I decided it has to be software issue rather than hardware. I did device reset (or whatever it is called there). The process lasted for more than two hours and there was no progress bar. So I pulled battery out. Of course, device got "soft bricked". I was able to access bootloader, but trying to update from official update.zip on my SD card resulted in verification error, although it was ok last evening. I read a few article with people being in similar situation. I decided to go for https://github.com/martensms/zte-openc-rootkit . I followed the (pretty simple) guide. Unfortunately, after reboot zte lagged on Firefox OS screen. Now I can't access phone by adb. When I try to start bootloader, after a 5 seconds of FFOS logo I get white screen, which won't go away. My last remaining hope is that booting with VOL_DOWN pressed still works - I AM ABLE to connect with fastboot. I feel like I am only one mistake away from turning this phone into complete brick. Please, help me find the light.

Update ======================== I tried first step from the last link again, so I can provide you with output - http://pastebin.com/AM3e4Pu1. After executing script (flashing system.img and booting into recovery.img), I am now in system recovery. Adb can NOT detect my device. Aside from menu I get usual errors (which I had before it got bricked) + 1 extra (about /system) - http://pastebin.com/DwkCBvp0 Trying to "apply update from sdcard" (official update.zip which has worked once) adds following lines - http://pastebin.com/aLfk1CT0

Update ======================== I found this link http://download.ztedevices.com/UpLoadFiles/product/643/3598/soft/2014012010220351.zip (somewhere, I have probably closed the source tab already). File inside was called EU_DEV_FFOS_V1.1.0B06_UNFUS_SD_For_V1.1.zip, so I copied it on my sd card, put it back into zte and tried to apply update. Output was something I have expected - http://pastebin.com/4MQGNaF1

Update ======================== Phone won't boot now with battery. It doesn't do a thing. (OK, it boots, after 5 minutes) With battery removed I tried `fastboot flash system system.img` - system.img is from FFOS_EU_EBAY_P821A10V1.0.0B06_LOG_DL.zip package. Unfortunately, the process of flashing hangs. I gave it 5 hours while I slept. - http://pastebin.com/H1by22Qa

Asked by amfg 6 years ago

Last reply by amfg 6 years ago

  • Archived

selecting html input type=file in web form does not open a file browser on ZTE Open

While trying to files from ZTE Open, I browsed to a web page with a file upload form. When I selected the file input, the input behaved as a text input and the on screen … (read more)

While trying to files from ZTE Open, I browsed to a web page with a file upload form. When I selected the file input, the input behaved as a text input and the on screen keyboard appeared.

Asked by jezra 7 years ago

Last reply by jezra 7 years ago

  • Archived

update problems, no space left on device (ZTE Open)

I just received a ZTE Open device in the mail today, and after playing around with it a bit, I noticed that every time I tried to check for system updates, it would show … (read more)

I just received a ZTE Open device in the mail today, and after playing around with it a bit, I noticed that every time I tried to check for system updates, it would show me one 13.xx MB update, which I downloaded, apparently applied, and the phone seemed to restart itself, but then I would be shown the same (??) update available. The phone is without a SIM card, just playing with it connected via Wifi, with the 4GB microSD card installed. Then, this evening, I got an error message, which apparently was recorded on the SD card, a file called recovery.log (contents follow):

Starting recovery on Fri Aug 23 07:29:21 2013
framebuffer: fd 4 (320 x 480)
recovery filesystem table
=========================
  0 /tmp ramdisk (null) (null) 0
  1 /boot mtd boot (null) 0
  2 /amss mtd amss (null) 0
  3 /appsbl mtd appsbl (null) 0
  4 /mibib mtd mibib (null) 0
  5 /qcsbl mtd qcsbl (null) 0
  6 /oemsbl1 mtd oemsbl1 (null) 0
  7 /oemsbl2 mtd oemsbl2 (null) 0
  8 /splash mtd splash (null) 0
  9 /cache yaffs2 cache (null) 0
  10 /data yaffs2 userdata (null) 0
  11 /misc mtd misc (null) 0
  12 /recovery mtd recovery (null) 0
  13 /sdcard vfat /dev/block/mmcblk0p1 /dev/block/mmcblk0 0
  14 /system yaffs2 system (null) 0

I:Got arguments from /cache/recovery/command
mtd: successfully wrote block at 0
I:Set boot command "boot-recovery"
Command: "/sbin/recovery"

ro.secure=1
ro.allow.mock.location=0
ro.debuggable=0
ro.build.id=IMM76D
ro.build.display.id=OPEN_US_DEV_FFOS_V1.0.0B01
ro.build.version.incremental=eng..20130724.030603
ro.build.version.sdk=15
ro.build.version.codename=REL
ro.build.version.release=4.0.4
ro.build.sw_internal_version=US_DEV_FFOS_V1.0.0B01
ro.build.baseband_version=P752D04B02
ro.build.firmware_revision=V1.01.00.01.019.144
ro.build.date=2013年 07月 24日 星期三 03:06:47 CST
ro.build.date.utc=1374606407
ro.build.type=user
ro.build.user=
ro.build.host=ThinkCentre2-XXXX
ro.build.tags=test-keys
ro.product.model=roamer2
ro.product.external_model=ZTE OPEN
ro.product.brand=ZTE
ro.product.name=roamer2
ro.product.device=roamer2
ro.product.board=roamer2
ro.product.cpu.abi=armeabi-v7a
ro.product.cpu.abi2=armeabi
ro.product.manufacturer=ZTE
ro.product.locale.language=en
ro.product.locale.region=US
ro.wifi.channels=
ro.board.platform=msm7627a
ro.build.product=roamer2
ro.build.description=roamer2-user 4.0.4 IMM76D eng..20130724.030603 test-keys
ro.build.fingerprint=ZTE/roamer2/roamer2:4.0.4/IMM76D/eng..20130724.030603:user/test-keys
ro.build.characteristics=default
rild.libpath=/system/lib/libril-qc-1.so
rild.libargs=-d /dev/smd0
persist.rild.nitz_plmn=
persist.rild.nitz_long_ons_0=
persist.rild.nitz_long_ons_1=
persist.rild.nitz_long_ons_2=
persist.rild.nitz_long_ons_3=
persist.rild.nitz_short_ons_0=
persist.rild.nitz_short_ons_1=
persist.rild.nitz_short_ons_2=
persist.rild.nitz_short_ons_3=
ril.subscription.types=NV,RUIM
DEVICE_PROVISIONED=1
debug.sf.hw=1
debug.composition.7x27A.type=mdp
debug.composition.7x25A.type=mdp
dalvik.vm.heapsize=128m
persist.cne.UseCne=none
persist.cne.bat.range.low.med=30
persist.cne.bat.range.med.high=60
persist.cne.loc.policy.op=/system/etc/OperatorPolicy.xml
persist.cne.loc.policy.user=/system/etc/UserPolicy.xml
persist.cne.bwbased.rat.sel=false
persist.cne.snsr.based.rat.mgt=false
persist.cne.bat.based.rat.mgt=false
persist.cne.rat.acq.time.out=30000
persist.cne.rat.acq.retry.tout=0
persist.cne.fmc.mode=false
persist.cne.fmc.init.time.out=30
persist.cne.fmc.comm.time.out=130
persist.cne.fmc.retry=false
media.stagefright.enable-player=true
media.stagefright.enable-meta=false
media.stagefright.enable-scan=true
media.stagefright.enable-http=true
media.stagefright.enable-fma2dp=true
media.stagefright.enable-aac=true
media.stagefright.enable-qcp=true
ro.opengles.version=131072
ro.use_data_netmgrd=true
persist.data.ds_fmc_app.mode=0
persist.ims.regmanager.mode=0
ro.bluetooth.request.master=true
ro.qualcomm.bluetooth.sap=false
ro.bluetooth.remote.autoconnect=true
persist.sys.strictmode.visual=false
persist.omh.enabled=1
ro.config.ehrpd=true
ro.qualcomm.cabl=1
ro.fm.analogpath.supported=true
ro.fm.transmitter=false
ro.fm.mulinst.recording.support=false
ro.hw_plat=7x27a
ro.emmc.sdcard.partition=18
ro.screen.layout=normal
debug.enabletr=false
debug.camcorder.disablemeta=0
persist.fuse_sdcard=false
debug.camera.landscape=true
ro.max.fling_velocity=4000
hwui.render_dirty_regions=false
httplive.enable.discontinuity=true
power.webview.DM=false
dalvik.vm.heapstartsize=5m
dalvik.vm.heapgrowthlimit=36m
org.bluez.device.conn.type=boolean
keyguard.no_require_sim=true
ro.com.android.dataroaming=false
ro.com.android.dateformat=MM-dd-yyyy
ro.config.ringtone=Ring_Synth_04.ogg
ro.config.notification_sound=pixiedust.ogg
ro.config.alarm_alert=Alarm_Classic.ogg
ro.vendor.extension_library=/system/lib/libqc-opt.so
ro.display.colorfill=1
ro.moz.ril.emergency_by_default=true
ro.moz.omx.hw.max_width=640
ro.moz.omx.hw.max_height=480
ro.moz.cam.0.sensor_offset=270
ro.moz.ril.simstate_extra_field=true
persist.sys.ztelog.enable=1
persist.radio.add_power_save=1
ro.sensor.arch.type=new
net.bt.name=Android
net.change=net.bt.name
dalvik.vm.stack-trace-file=/data/anr/traces.txt
ro.factorytest=0
ro.serialno=ROAMER2
ro.bootmode=unknown
ro.baseband=msm
ro.carrier=unknown
ro.bootloader=unknown
ro.hardware=roamer2
ro.revision=0
ro.emmc=0
init.svc.recovery=running

E:Error in /cache/recovery/log
(No space left on device)
E:Error in /cache/recovery/last_log
(No space left on device)
mtd: successfully wrote block at 0
I:Set boot command ""
E:Error in /cache/recovery/log
(No space left on device)
E:Error in /cache/recovery/last_log
(No space left on device)

The SD card also contains a zip file in updates/fota/update.zip, which in turn contains patch/system/P752D04_DEV_US_20130726.zip, which contains: amss.mbn (about 20 meg) and boot.img (about 4 meg).

Asked by russell-- 7 years ago

Last reply by Andrew 7 years ago

  • Solved
  • Archived

ZTE Open hangs most of the times

I've been using ZTE Open for months now but i have a problem. It hangs most of the times. First of all i thought it was an early build(1.0) so i installed 1.1(stable), 1.… (read more)

I've been using ZTE Open for months now but i have a problem. It hangs most of the times. First of all i thought it was an early build(1.0) so i installed 1.1(stable), 1.2, 1.3 and running 1.4 now but the problem is same. It hangs! and when it does i have to lock the phone and wait for sometime to unlock it or just direct remove the battery(sometimes it doesn't solve the problem but sometimes it does). I can't now know for sure that will i be able to receive my incoming call or not? It just freezes most of the times. Tried so many things like clearing cache installing different ROMs(1.2, 1.3) etc but same problem Anyone having the same problem?

Any suggestions?

Asked by linuxholic 6 years ago

Answered by linuxholic 6 years ago

  • Archived

Gmail zte open

Hi, not going to rant as I really like my ZTE Open, I've managed to update it to v1.1 via the ZTE update files, however, I now seem to have a real issue with my gmail, th… (read more)

Hi, not going to rant as I really like my ZTE Open, I've managed to update it to v1.1 via the ZTE update files, however, I now seem to have a real issue with my gmail, the emails download however, opening them can be very sporadic, sometimes they will open after about 10 minutes, sometimes not at all. I have tried all the previous suggestions, but they do not seem to resolve the issue, please could you help? The only other issue I have is that the latest update to marketplace fails, is there a work around for this?

Thanks.

Asked by BobbyOrange 6 years ago

Last reply by guigs 6 years ago

  • Solved
  • Archived

Does the Alcatel and ZTE Firefox OS phones come with a network lock ?

I plan to buy one of the two new phones from Spain / Poland running Firefox OS and I'm curios to know if they come with a network lock that will prevent me to use it from… (read more)

I plan to buy one of the two new phones from Spain / Poland running Firefox OS and I'm curios to know if they come with a network lock that will prevent me to use it from Romania, or will they come unlocked?

Thank you!

Asked by postal2600 7 years ago

Answered by ssemotom 7 years ago

  • Archived

how do I permanently disable being asked if I would like to install the "app" associated with a website I visit?

I visited a website in the browser; a full screen alert asked me if I wanted to install the "app" for the website (which I don't want to do), so I clicked cancel. I would… (read more)

I visited a website in the browser; a full screen alert asked me if I wanted to install the "app" for the website (which I don't want to do), so I clicked cancel. I would like to know how to permanently disable being asked if I want to install an app when I visit a website.

Asked by jezra 6 years ago

Last reply by jezra 6 years ago

  • Archived

Caldav and SSL

Does Firefox OS support SSL connections for caldav accounts? My calendar used to work fine on the ZTE (v1.1), but after I turned on SSL the calendar doesn't update anymor… (read more)

Does Firefox OS support SSL connections for caldav accounts? My calendar used to work fine on the ZTE (v1.1), but after I turned on SSL the calendar doesn't update anymore.

Asked by Michael 6 years ago

Last reply by guigs 6 years ago

  • Solved
  • Archived

Update operating system

I have a ZTE Open C running Firefox OS 1.3. I like the version 1.4 found at http://ftp.mozilla.org/pub/mozilla.org/labs/fxos-simulator How can I update to this version? … (read more)

I have a ZTE Open C running Firefox OS 1.3. I like the version 1.4 found at

http://ftp.mozilla.org/pub/mozilla.org/labs/fxos-simulator

How can I update to this version?

Asked by svnpenn 6 years ago

Answered by svnpenn 6 years ago

  • Archived

Any way to update marketplace app?

Hi, I'm using Intex Cloud FX in India. One thing I noticed that the preinstalled Marketplace app is outdated. Latest apps are not appearing in the search result. Also the… (read more)

Hi, I'm using Intex Cloud FX in India. One thing I noticed that the preinstalled Marketplace app is outdated. Latest apps are not appearing in the search result. Also there is no update to the Marketplace app. I'm using Marketplace website on browser as a workaround but I would like to know whether it is possible to update Marketplace by any means. Thanks in advance. :)

Asked by Pomsky 6 years ago

Last reply by Pomsky 6 years ago

  • Archived

browser stuck at large webpage

for a $80 device, ZTE open works great, however, the browser kept stuck at webpages that is too complex, such as WSJ, etc. I am unsure if this can be solved due to small… (read more)

for a $80 device, ZTE open works great, however, the browser kept stuck at webpages that is too complex, such as WSJ, etc.

I am unsure if this can be solved due to small RAM on the device, however, wsj does have a mobile site, which is not called by the browser. If the browser can be fixed to call mobile website whenever possible, or if it has a function to re-arrange complex website into simple version. That would be perfect.

Asked by crislevin 7 years ago

Last reply by Andrew 7 years ago

  • Archived

ZTE Mail app no longer working

I've used the e-mail app successfully for most of the time I've had my ZTE. In the last two weeks it stopped working. It displays all the messages in my inbox, but when I… (read more)

I've used the e-mail app successfully for most of the time I've had my ZTE. In the last two weeks it stopped working. It displays all the messages in my inbox, but when I tap on a message it hangs and I get the eternal blue arrow circling.

Yes, I have restarted, I have taken the battery, the SD card and the SIM card out to reset the device. And, yes, I have devolved and installed the older version of the OS from the ZTE download site.

Does anyone know what's going on?

Asked by Michael 7 years ago

Last reply by mb_ffm 7 years ago

  • Archived

wifi redirected login page "The address isn't valid"

I just got the latest ZTE Open, with FFOS_V1.0.0B02 . There are several wifi SSIDs in my university operate like this: first connect to AP without authentication; visit a… (read more)

I just got the latest ZTE Open, with FFOS_V1.0.0B02 . There are several wifi SSIDs in my university operate like this: first connect to AP without authentication; visit any web page; get redirected to the web login page; after authentication, can communicate with other sites. It turns out none of them works. Firefox complains "The address isn't valid" when get redirected. My other devices work find with those SSIDs.

Also note that 802.1x is not supported yet.

Get wifi connection is the first thing to do. Then I can try update the system and install apps. It's frustrating to get stuck at the very beginning. Please advise what should I try...

Asked by hupili 6 years ago

Last reply by hupili 6 years ago

  • Locked
  • Archived

This phone is garbage I can't believe I was suckered into thinking it was better than my cheap cricket Android phone... It really sucks!!!!!!!!!!!!!!!

You Cant do anything with it. I cant customize my ringtones. cant get my contacts. Cant even send or receive a picture!!!! cant get a sms messenger app.. Oh ya did I s… (read more)

You Cant do anything with it. I cant customize my ringtones. cant get my contacts. Cant even send or receive a picture!!!! cant get a sms messenger app.. Oh ya did I say IT SUCKS!!!!!!!!!!!!!!!!!!!!!!!!!

Asked by RenegadeOfFunk 7 years ago

Last reply by Andrew 6 years ago

  • Solved
  • Archived

Phone does not respond.

Phone zte open c. Firefoz os 1.3 Procedure error: 1. Insert sim card 2. Power on phone 3. The phone is not used for 1-5 minutes. The screen does not light up. 4. To wake … (read more)

Phone zte open c. Firefoz os 1.3 Procedure error: 1. Insert sim card 2. Power on phone 3. The phone is not used for 1-5 minutes. The screen does not light up. 4. To wake the phone, push the button Power. Phone does not respond. 5. I have to remove the battery to become operational again. 6. As I leave the phone without the use of, the situation repeats itself.

Asked by kadkarol 6 years ago

Answered by kadkarol 6 years ago

  • Solved
  • Archived

How to uninstall system applications? I want to uninstall pinterest.

I love minimalist systems (like archlinux). This is why I buy a firefox os phone, who gives me more control over to wich applications may I have or not. I believe pintere… (read more)

I love minimalist systems (like archlinux). This is why I buy a firefox os phone, who gives me more control over to wich applications may I have or not.

I believe pinterest is not a essential system application (as some others), so I want to uninstall it. Is it possible?

Thanks!

Asked by lecarrera 5 years ago

Answered by Ralph Daub 5 years ago

  • Solved
  • Archived

channel notifications on firefox v 1.1

My device is Zte-Open, I recently upgraded it to firefox 1.1. While , I am quite happy with most of the improvements, I can't seem to find out a way to disable these ugly… (read more)

My device is Zte-Open, I recently upgraded it to firefox 1.1. While , I am quite happy with most of the improvements, I can't seem to find out a way to disable these ugly notifications that keep popping up every few seconds. If I leave my phone unattended sometimes there might be even 50 of them in the notification bar!

The text in these notifications is usually : "Channel 50 location_information" Here is a screen shot of the phone with the active notifications http://s30.postimg.org/hl5yqk9tt/2013_12_20_15_48_57.png

Asked by feverDream 6 years ago

Answered by iamjayakumars 6 years ago