Showing questions tagged: Show all questions
  • Solved
  • Archived

How to find the URL to use for ExtensionSettings?

I am using group policy, extension settings. I want to block all extensions, require 1, and allow a handful. I think I have the JSON figured out but finding the URL to … (read more)

I am using group policy, extension settings. I want to block all extensions, require 1, and allow a handful. I think I have the JSON figured out but finding the URL to use is escaping me.

I can find the site in the Mozilla addons, https://addons.mozilla.org/en-US/firefox/addon, but how do I find the exact filename to use? I see that many end in latest.xpi but I'm unsure what that means or how I should know which is correct. I know how to find it in Chrome but I'm now trying for FireFox. I've had a hard time and it's not as clear as the direct GPO implementation as Chrome uses.

My next thing to figure out is when extension settings are mentioned in multiple levels of the GPO hierarchy. That's a separate question and not needed for an answer to this question. I only mention it as someone who knows one part is likely to know the other as well.

Thanks, -g

Asked by GrumpyGreg 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Attempting ExtensionSettings via Extension Managmement GPO - Error 'No text was entered...'

Hi, I'm trying to create a Windows GPO to control Addons/Extensions in our FireFox installations. From the doc I've read, the place is Policies|Administrative Templates|M… (read more)

Hi, I'm trying to create a Windows GPO to control Addons/Extensions in our FireFox installations.

From the doc I've read, the place is Policies|Administrative Templates|Mozilla|Firefox|Extensions Policy is "Extension Management"

I set it to enabled and include this text: {

 "*": {
   "blocked_install_message": "My Custom Test Message",
   "installation_mode": "blocked"
 }

}

When I hit apply, I get this error message: "No text was entered for this field. Make sure that you enter text."

If I put nothing (but still enabled) or "A" or A, then it accepts that. It's when I plop in the JSON that it fails.

What am I doing wrong?

I have ESR 91.0.1 and policy 3.0 installed. I do not have Firefox installed on the machine doing the GPO work, that's currently only on the test machine. I do have the policy definitions installed.

-g

Asked by GrumpyGreg 1 year ago

Answered by Mike Kaply 1 year ago