Showing questions tagged: Show all questions
  • Solved

Firefox packaging and auto update

I am trying to package Firefox, with the browsers auto update disabled (updates are handled by the package manager, not the browser; having Firefox prompt at the user may… (read more)

I am trying to package Firefox, with the browsers auto update disabled (updates are handled by the package manager, not the browser; having Firefox prompt at the user may cause confusion). However, I haven't been able to Firefox's nagging with recent (77+) versions.

I have tried writing a policies.json file seems to have no effect. In fact, Firefox didn't even look in system directories like /etc and /lib64/firefox. Is this an Enterprise Firefox feature? Is it even possible to share a single installation of Firefox between users (having their personal prefs in their home directories, ofcourse).

Thanks in advance!

Asked by Folkert 2 months ago

Answered by Mike Kaply 2 months ago

  • Solved

Push out "network.negotiate-auth" settings for firefox

I need to update the following settings on multiple computers: - network.negotiate-auth.delegation-uris - network.negotiate-auth.trusted-uris Is there a way to do this… (read more)

I need to update the following settings on multiple computers:

- network.negotiate-auth.delegation-uris
- network.negotiate-auth.trusted-uris 

Is there a way to do this either via script or GPO?


I've loaded the latest ADMX controls (https://github.com/mozilla/policy-templates/releases), but didn't see these particular settings in the controls.

Thank you,

Paul

Asked by pwashburn 2 months ago

Answered by Mike Kaply 2 months ago

  • Solved
  • Archived

Can not install add-ons since Firefox68 upgrade

Hello. I have installed an add-on using a GPO. However, after upgrading to Firefox 68, my add-on is getting an installation error. Is it impossible to install by GPO on F… (read more)

Hello. I have installed an add-on using a GPO. However, after upgrading to Firefox 68, my add-on is getting an installation error. Is it impossible to install by GPO on Firefox 68? If not, why is not it installed?

I attached the part that I confirmed by connecting to about: policies. Installation via download, not GPO, is installed normally, below is the installation link. https://addons.mozilla.org/firefox/downloads/file/3365031/gradius-7.3.11-fx.xpi?src=devhub

In the case of GPO installation, my add-on as well as other add-ons are not installed.

Please check the issue. Thank you.

Asked by kjh4789 1 year ago

Answered by Mike Kaply 1 year ago

  • Solved
  • Archived

Enterprise Security Device (PKCS) Setup

Good afternoon Community, I am a (very new) enterprise admin for a very large organization. We have decided to start distributing Firefox (Quantum Version 68.0 32 bit) ac… (read more)

Good afternoon Community,

I am a (very new) enterprise admin for a very large organization. We have decided to start distributing Firefox (Quantum Version 68.0 32 bit) across our organization. We utilize a smart card application for logon, and user website authentication. We have every setting exactly how we want it, save one. Each individual user, for each profile they create, will need to upload the .DLL file from our smartcard reader application to the security devices. If this were just a hundred or so users, that would be easy, but we are in the thousands (and more.....). And many of these users are not technically savvy. Is there a way to have a specific library uploaded as a part of building the profile? Sort of like a pre-built default profile. Ideally, we would like to do this with no additional extensions or plugins installed.

Asked by Mordeekin 1 year ago

Answered by cor-el 1 year ago