Showing questions tagged: Show all questions
  • Solved

Firefox ignores /etc/hosts on Macos

I am trying to edit /etc/hosts file. CLI utils respect the values that provided there, Chrome also. But the Firefox continues to ignore. I have disabled "Enable DNS over… (read more)

I am trying to edit /etc/hosts file. CLI utils respect the values that provided there, Chrome also.

But the Firefox continues to ignore. I have disabled "Enable DNS over HTTPS using:" and turned it off.

But it doesn't help. What else could be done?

Asked by Yuriy Peskov 2 weeks ago

Answered by zeroknight 2 weeks ago

  • Solved
  • Archived

Restore bookmarks from prior Firefox version - prior help posts cannot be followed

I just downloaded the new Firefox and replaced the old application. All my bookmarks are gone. When I go to Manage and Restore, it tells me to choose a file but I don't… (read more)

I just downloaded the new Firefox and replaced the old application. All my bookmarks are gone. When I go to Manage and Restore, it tells me to choose a file but I don't seem to have the file on my computer. Under library>application support there is no Firefox folder. There is a Mozilla folder, but the only thing in it is the "extensions" folder with one file. I have a backup of my full computer on a hard drive from before the download, but I can't seem to find a file there either. I don't think I ever specifically asked my computer to save the Bookmarks. Does it auto save in the application? Is there a way to restore the prior version of Firefox on my computer?

Asked by kate.kosoglow 6 months ago

Answered by cor-el 6 months ago

  • Solved

Google Search on Firefox not working

Google search no longer works on Firefox. Other browsers have no problems. Changing the default search engine on Firefox works (eg Bing), BUT. It can now find Google M… (read more)

Google search no longer works on Firefox. Other browsers have no problems. Changing the default search engine on Firefox works (eg Bing), BUT. It can now find Google Maps, but Google Maps cannot find a location, because it uses a Google search. I tried the fix in about:config, but it had no effect.

Asked by grahamppink 2 months ago

Answered by grahamppink 2 months ago

  • Solved

Dark Reader not working on mozilla.org

Dark Reader works for all sites except for mozilla.org, I think these webpages are over-ridden by the Firefox browser? I saw a couple archived posts recommending global c… (read more)

Dark Reader works for all sites except for mozilla.org, I think these webpages are over-ridden by the Firefox browser? I saw a couple archived posts recommending global changes for all sites via Firefox -> Settings -> Language and Appearance -> Colors, or to install themes. Neither option would work. I don't want to override all sites to dark globally, that's way to much change, just let Dark Reader change just mozilla.org.

Asked by Leland359 4 months ago

Answered by Terry 4 months ago

  • Solved

Stop Auto Open After Download

Hi, I am a student, who tend to mass download files at once. The annoying part is that after every download, firefox automatically opens up the downloaded file in a new … (read more)

Hi,

I am a student, who tend to mass download files at once. The annoying part is that after every download, firefox automatically opens up the downloaded file in a new tap. How can I disable automatically open files after download?

Thanks.

Asked by z7798xxzzz 4 months ago

Answered by Terry 4 months ago

  • Solved

New Tab: no cursor in the address bar

I frequently open new tabs by right-clicking the current tab and choosing "New Tab" from the context menu. Naturally, I want to start typing a URL or search term. But th… (read more)

I frequently open new tabs by right-clicking the current tab and choosing "New Tab" from the context menu. Naturally, I want to start typing a URL or search term.

But the focus/cursor/caret is nowhere and typing does nothing. I have to click on the address bar, and then I can type.

I'm not using New Tab Override and I have Firefox's new tab set to a blank page.

I tried disabling all my add-ons, but I still had the problem.

I tried setting new tab to the Firefox home page and for a short while I got a cursor in the address bar. But the problem returned after a few hours

Any clues on what might be wrong? Firefox version 120.0.1 (64-bit) on MacOS Ventura 13.5.1. Thanks!

(A similar problem is described here: https://support.mozilla.org/en-US/questions/1420220 -- but in my case this is not a container tab.)

Asked by jeremy76 3 months ago

Answered by jeremy76 3 months ago

  • Solved

Accessing Youtube.com causes immediate unlogged tab crash

Hey, I've been having an odd issue with Firefox where tabs where I attempt to access youtube.com will immediately crash. This issue first arose when I attempted to log i… (read more)

Hey,

I've been having an odd issue with Firefox where tabs where I attempt to access youtube.com will immediately crash. This issue first arose when I attempted to log in to Youtube, and had never occurred before. When I did that login, the tab crashed, and I have been unable to access the website since (100% crash rate).

Basic details: The website does not visually load at all. However, the URL bar icons for the website do briefly appear prior to tab crash. (Autoplay button, etc). The crash is never reported in about:crashes.

I've tried the following tests, unsuccessfully: - Logging out of all Google accounts separately - Disabling all extensions - Transferring all of my data to a new computer - Reinstalling Firefox - Rebooting Firefox in troubleshooting mode

This problem does not occur on my Windows machine but occurred on my previous intel-based Mac and now on my current Apple Silicon Mac.

The only success I have had is in creating an entirely new Firefox profile. However, I would prefer to fix the issue, as I assume that porting all my settings to the new profile would... also probably bring the bug along.

Thanks for reading & any advice is appreciated.

Asked by Michael 4 months ago

Answered by zeroknight 4 months ago

  • Solved

Youtube low FPS when put to fullscreen.

I am having an issue where youtube videos played at higher quality stutter when put to fullscreen. Up till about 720p60 works fine, at 1080p60 and above the framerate bec… (read more)

I am having an issue where youtube videos played at higher quality stutter when put to fullscreen. Up till about 720p60 works fine, at 1080p60 and above the framerate becomes unstable.

Things I have tried: - I have tried going into media.media-capabilities.enabled and changing it from false to true - I have set network.buffer.cache.size to 262144 - I have disabled all my plugins - I have tried changing my user agent to windows/chrome

My current setup: Firefox 122.0, Macbook pro Sonoma 14.1, Apple M1 Pro chip

Curiously, if I make a new firefox profile and play a video there, there is no stutter. Does anyone have ideas on how I can fix my current profile?

Asked by markus.maomao.ang 2 months ago

Answered by zeroknight 2 months ago

  • Solved
  • Archived

Mozilla Firefox ver. 50 not prompting user to install Java plug-in for legacy website

I have a user who runs SRS/Crystal Reports on their Windows 11 Lenovo laptop, but every time we go to the website where a Java-enabled pop-up window for viewing spreadshe… (read more)

I have a user who runs SRS/Crystal Reports on their Windows 11 Lenovo laptop, but every time we go to the website where a Java-enabled pop-up window for viewing spreadsheets is supposed to load we keep getting a "A plugin is required to play this content" error message, but no option to install/approve the running of Javascript.

I have downloaded and installed the JRE and JDK on the endpoint device, but still no luck getting Firefox to load it. I am running the 32-bit version of the web browser, not 64-bit, so I am kind of stumped about how to proceed from here.

Is there a place I can manually download/install these Java plug-ins?

Thanks.

Asked by kris.robinson 2 years ago

Answered by kris.robinson 2 years ago

  • Solved
  • Archived

Web browser thru Firefox

All of a sudden when I go into Firefox and type in the web browser it comes up on left hand side of the screen and is so small that it is impossible to read. It has neve… (read more)

All of a sudden when I go into Firefox and type in the web browser it comes up on left hand side of the screen and is so small that it is impossible to read. It has never done this before

Asked by teffy1 2 years ago

Answered by YongHan 2 years ago

  • Solved
  • Archived

Version 100 on Mac

I read that with version 100 on the Mac there will be some problems with some web pages like my bank can you tell me if this has been fixed or not, if not I don't want to… (read more)

I read that with version 100 on the Mac there will be some problems with some web pages like my bank can you tell me if this has been fixed or not, if not I don't want to go past version 99. Thanks for all help Michael Whitecotton

Asked by mdwhiteco 2 years ago

Answered by James 2 years ago

  • Solved
  • Archived

"This time, search with" bar still shows after disabling it.

I've removed all address bar suggestions except bookmarks and yet I'm still seeing the "This time, search with" bar. Firefox support's "upload images" not working, so i … (read more)

I've removed all address bar suggestions except bookmarks and yet I'm still seeing the "This time, search with" bar.

Firefox support's "upload images" not working, so i uploaded screenshots on an external site.

Settings page

Address Bar

Asked by Kiran 1 year ago

Answered by YongHan 1 year ago

  • Solved
  • Archived

Firefox forces me to enable 2FA when signing in to addons.mozilla.org

Hi everyone, Last Saturday, I was able to sign in to Firefox Add-Ons Firefox Add-Ons and submit a pre-release of an add-on I'm working on. But today, I'm being forced to… (read more)

Hi everyone,

Last Saturday, I was able to sign in to Firefox Add-Ons Firefox Add-Ons and submit a pre-release of an add-on I'm working on. But today, I'm being forced to enable 2FA to simply log in to the site. I don't want to enable 2FA, I just don't need it. Can someone explain me why is this happening ? Can I just log in and submit my add-on's update ?

I've tried to sign in two different MacBooks (M1 12.1 and Yosemite 10.10.5), using two different Firefox versions (99.0.1 and 78.15.0esr). Also, I haven't enabled 2FA in my personal account.

Thanks in advance.

Asked by snunezmeneses 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Virus / malware issue

Hi, I tried to download a script but Firefox warned me it had a virus / malware. So I immediately put it in trash, emptied trash, restarted my Macbook and used Bitdefende… (read more)

Hi, I tried to download a script but Firefox warned me it had a virus / malware. So I immediately put it in trash, emptied trash, restarted my Macbook and used Bitdefender to scan my Mac. Fortunately it detected no viruses. So I think I'm good (Hopefully!)

But, every time I open Firefox now, a little window appears at the top showing my last download and telling me it had a virus or malware - I'm posting a screenshot of this. I removed it from my history, and cleared the preview panel, but it still pops up. To be clear, this only happens when I completely close Firefox and reopen it, not when I just open new windows or tabs.

How can I get it to stop popping up with this message? Also - one other oddity, each time I open Firefox, it says the time this script was downloaded matches the time I open Firefox (as opposed to when I actually downloaded the pdf - about an hour ago)

Asked by sunnybleckinger 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Access to REI denied on Firefox WHY?

Please explain: Access Denied You don't have permission to access "http://www.rei.com/user/login" on this server. Reference #18.f697c68.1648515585.37d0ad20 … (read more)

Please explain: Access Denied You don't have permission to access "http://www.rei.com/user/login" on this server.

Reference #18.f697c68.1648515585.37d0ad20

Asked by xueshg12 2 years ago

Answered by xueshg12 2 years ago

  • Solved
  • Archived

FF cookie storage space 17,000,000,000 GB for Facebook

Even though I have removed the cookies for Facebook, the Manage Cookies screen shows a HUGE storage space. FF v99.0 on Mac == from preferences page: Your stored cookie… (read more)

Even though I have removed the cookies for Facebook, the Manage Cookies screen shows a HUGE storage space. FF v99.0 on Mac

==

from preferences page: Your stored cookies, site data, and cache are currently using 17,179,869,184 GB of disk space.

==

almost all are Facebook storage. I'm feeling a little reluctant to delete all site data. If I clear all cookies and site data will that fix the issue? will the issue re-occur?

Asked by michaelp2 2 years ago

Answered by michaelp2 2 years ago

  • Solved
  • Archived

Google map iframes not displaying in FF 99.0.1

MacOS Monterey 12.3.1 FF 99.0.1 Have tried clearing Cache, Cookies, Troubleshoot mode. Google Maps > Search > Share > Embed a Map, the map to be embedded is not… (read more)

MacOS Monterey 12.3.1 FF 99.0.1 Have tried clearing Cache, Cookies, Troubleshoot mode.

Google Maps > Search > Share > Embed a Map, the map to be embedded is not displayed (likewise when embed is pasted into Wordpress page, for example)

While same procedure in Safari or Brave works as expected (map to be embedded is displayed in Google maps and embed code displays map in webpage using Brave or Safari).

From the Google Maps page > share > Embed a map > right click This Frame > Open in new tab And then looking in the Console. There are a few other ignored errors but then this...

Loading failed for the <script> with source “https://maps.googleapis.com/maps/api/js?client=google-maps-embed&paint_origin=&libraries=geometry,search&v=3.exp&language=en&region=us&callback=onApiLoad”.

Asked by woolwit 1 year ago

Answered by woolwit 1 year ago

  • Solved
  • Archived

Importing passwords from Chrome

Hi there. I'm in the process of switching from Chrome and I want to import my passwords. I first tried the 'import from Chrome' option - it says it's successful, but not… (read more)

Hi there. I'm in the process of switching from Chrome and I want to import my passwords.

I first tried the 'import from Chrome' option - it says it's successful, but nothing has actually been added. Same result after several attempts.

I then tried the csv route. I found out I had to change the config settings, so I did just that, but the 'import CSV' option still isn't showing even after a reset.

So now I'm at a dead end. Any bright ideas please? TIA!

FYI I'm using Firefox 99.0.1

Asked by mjwhite82 2 years ago

Answered by Terry 2 years ago

  • Solved
  • Archived

Firefox is not applying userChrome.css

Hello, so I am not very experienced and recently discovered how to customize Fire Fox using the userChrome.css file. I went through all of the steps that are required in … (read more)

Hello, so I am not very experienced and recently discovered how to customize Fire Fox using the userChrome.css file. I went through all of the steps that are required in order to do this. I set up a folder called chrome in the directory /Users/my name/Library/Application Support/Firefox/Profiles/x1oheo82.default-release To test if it works I wrote this into the userChrome.css file: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

  1. TabsToolbar{ background-color: #FF0000 !important }

and set toolkit.legacyUserProfileCustomizations.stylesheets to true After restarting Fire Fox I saw that nothing changed. I double checked if there was a hidden file extension or if I might be in the wrong directory. I tried different code to see if there was some error in the code but nothing changed. I watched countless tutorials on You Tube and tried to find answers on google but nothing that I did seemed to help. I don't know if it has something to do with the operating system I am running or if it is a limitation of my computer hardware (I am running Fire Fox on an m1 mac).

Asked by Arihx 1 year ago

Answered by cor-el 1 year ago