Showing questions tagged: Show all questions
  • Solved

Number on Firefox Icon

The Firefox icon on my taskbar has a great big green number 1 plonked on it. It doesn't seem to relate to the number of windows I have open or the processes running. It's… (read more)

The Firefox icon on my taskbar has a great big green number 1 plonked on it. It doesn't seem to relate to the number of windows I have open or the processes running. It's there even when Firefox is closed. I thought it might be messages but I can't find those either. Its driving me nuts can you please tell me how to get rid of it? I'm running it in Ubuntu on a laptop.

Asked by megallen 3 months ago

Answered by zeroknight 3 months ago

  • Solved

Cannot upload files or add attachments in Firefox

This is the same problem listed below. Recently upgraded to Ubuntu 22.04.3 LTS and Firefox 117.0 a few weeks ago and can't get the files to attach. In fact it won't open … (read more)

This is the same problem listed below. Recently upgraded to Ubuntu 22.04.3 LTS and Firefox 117.0 a few weeks ago and can't get the files to attach. In fact it won't open the file system. Tried removing all extensions as suggested and rebooting, but nothing changed.

Asked by apolglaze 5 months ago

Answered by zeroknight 5 months ago

  • Solved

I am running Firefox on Ubuntu 22.04 and it constantly crashes. Trying to determine what is causing this.

I have a new installation of Ubuntu 22.04 on my 2015 Lenovo IdeaPad 300. I have a new SSD HD 1 TB in size and it should work, however, Firefox keeps crashing. Other app… (read more)

I have a new installation of Ubuntu 22.04 on my 2015 Lenovo IdeaPad 300. I have a new SSD HD 1 TB in size and it should work, however, Firefox keeps crashing. Other apps are crashing too.

Asked by Daniel Grindstaff 5 months ago

Answered by Daniel Grindstaff 5 months ago

  • Solved
  • Archived

Firefox seemed to "sync" the DisableAppUpdate policy from a Windows public comp to my Linux personal comp. I don't want that.

I normally use Firefox desktop on my Linux computer. Last week, I started using it on a public computer running Windows. I installed Firefox Portable and then logged/syn… (read more)

I normally use Firefox desktop on my Linux computer.

Last week, I started using it on a public computer running Windows. I installed Firefox Portable and then logged/synced into my Firefox account on this Win computer. I noticed that in the Firefox Portable Windows “about:preferences” page, it says “Your browser is being managed by your organization”, which links to about:policies. In that “about:policies” page, it shows this https://i.imgur.com/JmD8nXg.png Policy Name: DisableAppUpdate Policy Value: true. Now I’m back on my Linux desktop computer and it also has this “managed by your organization” message in “about:preferences” and the same “about:policies” stuff. In other words, it appears that this policy was copied from the Windows public computer to my personal Linux computer. I don’t want that.

How can I undo this? And how can I block this sort of policy syncing?

Asked by Mozilla cheese 2 years ago

Answered by jscher2000 - Support Volunteer 2 years ago

  • Solved
  • Archived

Repeatedly crashes . but only on this machine.

First of all , Hello  :) FF is a great wb and i use it everywhere i got a machine. Works fine everywhere .. but here on this computer. Why only on this machine … (read more)

First of all , Hello  :) FF is a great wb and i use it everywhere i got a machine. Works fine everywhere .. but here on this computer. Why only on this machine ? Same distros ( linux mint 20.3 ) radeon video cards , amd family cpu's This machine is AMD FX(tm)-6300 Six-Core Processor × 6 the video card atm is AMD PITCAIRN (DRM 2.50.0, 5.4.0-94-generic, LLVM 12.0.0) though i had the same crash issue with a nVidia graphics card. Memory is Corsair and the memtest86 reports no errors. This is where i get a bit lost. Memory issues or hardware defects might explain this but where's one to begin ? Trouble is , no other application ever crashes and it's rock solid. So is FF to point a finger at or something else ? That's the objective of me submitting this report. Try to find out what's really at fault here and fix it.

The crashes happen at all times. It can also be right at starting FF and never even reaching the main window. I tried with and without the --safe-mode and it's the same that also happens.

So i submitted one of the crash reports ID: 656264f4-7867-4c55-8b36-0637e0220114

The report can be found here : https://crash-stats.mozilla.org/report/index/656264f4-7867-4c55-8b36-0637e0220114

Since there's so many i hesitate to put them all up , there's dozens since the system reinstall yesterday , i reinstalled the whole OS again yesterday to try to get rid of the bug. Any help to solve this once and for all will be highly appreciated . :) thanks for reading

FuzzyTheBear

Asked by FuzzyTheBear 2 years ago

Answered by FuzzyTheBear 2 years ago

  • Solved
  • Archived

How to Turn Off Data Collection in Mozilla VPN

Hey there, When first opening the MozillaVPN app (in Linux) it gave me to option to consent or decline to data collection of technical information. I consented but would… (read more)

Hey there,

When first opening the MozillaVPN app (in Linux) it gave me to option to consent or decline to data collection of technical information. I consented but would like to decline/turn it off. I know how to do this for the Firefox browser, through the settings and privacy tab; however, I'm having trouble finding a way to turn off / opt-out for MozillaVPN.

Thanks!

(I'm asking this question in this Firefox forum because I was unable to make a new post in the MozillaVPN forum.)

Asked by crabbybabbler 2 years ago

Answered by edubon 2 years ago

  • Solved
  • Archived

All my addons "Could not be verified for use in firefox and has been disabled" (just seen today)

Hi everyone, I am running Firefox 91.5 on Red Hat Enterprise Linux 8.5 and just noticed that all my addons have been disabled and can't re-enable them. Some of them are… (read more)

Hi everyone,

I am running Firefox 91.5 on Red Hat Enterprise Linux 8.5 and just noticed that all my addons have been disabled and can't re-enable them.

Some of them are quite common modules such as Disconnect or Privacy Badger, so wondering what this may be.

There is a similar post on this forum dating back to 2019 and it mentioned a fix on Firefox was to be developped.

Anyone experiencing the same issue at the moment.?

Please see attached screenshot.

Kind regards,

Alex

Asked by Alex_Pk 2 years ago

Answered by Alex_Pk 2 years ago

  • Solved
  • Archived

How to make "Say hello to a new Firefox" not appear next time I open Firefox

Hello, I'm using Firefox 91.4.1esr (64-bit) from Debian repositories on Bullseye. Every time I open Firefox, a window with a greeting message appears ("Say hello to a ne… (read more)

Hello,

I'm using Firefox 91.4.1esr (64-bit) from Debian repositories on Bullseye. Every time I open Firefox, a window with a greeting message appears ("Say hello to a new Firefox"), and it doesn't matter if, as asked by that window, I choose a theme or not. Is this issue related to my settings? Is this a Debian issue? Is it possible to stop that window from reappearing?

Thanks in advance. And many thanks for making Firefox (I've been using it for so many years I can't recall when I tried it for the first time).

Esteban

Asked by lucchesi.esteban 2 years ago

Answered by lucchesi.esteban 2 years ago

  • Solved
  • Archived

Firefox 97.0 (Linux version) and previous version CREATES noise in whatever audio is running.

Firefox 97 and previous version CREATES noise in whatever audio is running. Whether it is audio from Audacious, my music player, or audio from the program I am watching … (read more)

Firefox 97 and previous version CREATES noise in whatever audio is running. Whether it is audio from Audacious, my music player, or audio from the program I am watching on Firefox. How can I stop the noise, which sounds like static from a week station on an old AM radio? Using other browser does not have this audio problem, UNLESS Firefox is running. Even if not actively using Firefox, just having it open on the desktop causes noise. Using Linux Mint 20 64bit. Audio produced by motherboard ASUS Prime B550 Plus with AMD Ryzen 9 3900X processor. Clicking on Firefox Help gets a message saying "Updates disabled by your system administrator" along with the normal text. I didn't disable updates and I am the Admin.

Asked by Anthony 2 years ago

Answered by jonzn4SUSE 2 years ago

  • Solved
  • Archived

Restore bookmarks and other data from hard drive out of dead computer

My old Linux computer died and I have removed the still good SSD from it. I have installed the latest Firefox on my new computer and would like to restore the bookmarks a… (read more)

My old Linux computer died and I have removed the still good SSD from it. I have installed the latest Firefox on my new computer and would like to restore the bookmarks and other saved data to the new computer.

I am running Ubuntu 20.04, the old computer was on Ubuntu 18.04.

Can these things be restored, and if so what do I need to do?

Asked by gwilson3 2 years ago

Answered by jscher2000 - Support Volunteer 2 years ago

  • Solved
  • Archived

How to disable all address bar features ?

I have found a few pages about address rewriting; how do I disable them all ? - searching single word into google (type "keyw" in about:config to disable it) - hidin… (read more)

I have found a few pages about address rewriting; how do I disable them all ? - searching single word into google (type "keyw" in about:config to disable it) - hiding http when not using https - trying to add "www" and ".com" around a single word when the word did not resolve

I consider most of them as security issues for various reasons.

And when editting an URL, I want firefox to keep showing the full url as it was invoqued; not add https randomly, or removing http other days. And the more I disable some, the more new ones appear.

Asked by Benoit-Pierre DEMAINE 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

User Agent Error

Arch Linux/Firefox Nightly 99: the user agent has a difference of 8 versions with the current version of the browser. Two browsers on the computer - exactly the same in … (read more)

Arch Linux/Firefox Nightly 99:

the user agent has a difference of 8 versions with the current version of the browser. Two browsers on the computer - exactly the same in regular Firefox 97.

Asked by Adrian 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Prevent websites from opening new tabs

I just reinstalled my operative system, and with that my Firefox settings got reset. I know there is an entry in about:config to prevent ads from opening new tabs and pop… (read more)

I just reinstalled my operative system, and with that my Firefox settings got reset. I know there is an entry in about:config to prevent ads from opening new tabs and pop ups without authorization, even from legit websites like the login pop-up windows when doing a sign in in Google, in those cases to allow the windows it's needed to click on the lock icon next to the URL bar and allow it from there. The problem is that I don't remember the name of that setting and I have spend an hour looking for it on Google.

Asked by ttfh3500 1 year ago

Answered by ttfh3500 1 year ago

  • Solved
  • Archived

Firefox update to version 91.6.1esr broke my tab bar

I have my tab bar below the other toolbars. I have a userChrome.css to help set things up the way I use them. System is Linux 64-bit. Just updated Firefox from a few-mon… (read more)

I have my tab bar below the other toolbars. I have a userChrome.css to help set things up the way I use them. System is Linux 64-bit.

Just updated Firefox from a few-months-older version to 91.6.1esr from the official repos and my tab bar is now blank. No tabs, no nothing. When I open a "new tab" I just get the new page; the "Back" arrow is greyed out, so it presumably is a net tabsheet. But I have no tab to get back to the previous page, all is blank.

The tab bar is there at the top OK in Troubleshooting Mode. En/dis-abling all my extensions etc. makes no difference in either mode.

Fixes for related issues tend to focus on userChrome.css but none offers a straight code sample to fix this issue. Here is an extract from mine, I have no idea whether any of it is relevant:

#nav-bar { /* main toolbar */
  -moz-box-ordinal-group: 1 !important;
  box-shadow: none !important;
}
#PersonalToolbar { /* bookmarks toolbar */
  -moz-box-ordinal-group: 2 !important;
}
#TabsToolbar { /* tab bar */
  -moz-box-ordinal-group: 3 !important;
  padding-top: 0 !important;
}

/* FIX TO MOVE TAB BAR BELOW TOOLBAR /*

#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {
  -moz-box-ordinal-group: 10 !important;
}

#TabsToolbar {
  -moz-box-ordinal-group: 1000 !important;
  display: block !important;
  position: absolute !important;
  bottom: 0 !important;
  width: 100vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}

*|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*adjust*/
}

/* Firefox 65-73 */
*|*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"])
 #toolbar-menubar[autohide="true"] ~ #TabsToolbar{
  bottom: var(--tab-min-height) !important;
  padding-top: calc(var(--tab-min-height) - 20px) !important; /*adjust*/
}

/* TABS: height */
*|*:root {
  --tab-toolbar-navbar-overlap: 0px !important;
  --tab-min-height: 25px !important; /*adjust or omit to use density*/
}

*|*:root #tabbrowser-tabs {
  --tab-min-width: 80px !important; /*adjust or omit to use default*/
}

#TabsToolbar {
  height: var(--tab-min-height) !important;
  margin-bottom: 1px !important;
  box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important; /*omit*/
  background-color: var(--toolbar-bgcolor) !important;
  color: var(--toolbar-color) !important;
}

Asked by guyinchbald 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Browsing on local development URLs derives on "Unable to connect"

Hi there, I'm using my PC for local web development. I use Firefox as my regular browser and recently, in order to distinguish between personal time and development time… (read more)

Hi there,

I'm using my PC for local web development. I use Firefox as my regular browser and recently, in order to distinguish between personal time and development time, I've established a new profile just for development purposes.

The local website I can't reach is "site.local.dev". My OS is Ubuntu 20.04 and that URL points to a local IP on my network (resolved via /etc/hosts file on my PC).

Funny thing is that: - In dev-profile: site.local.dev does not work => "Unable to connect" and the URL bar shows https://site.local.dev even if I force it to http:// - In personal-profile: site.local.dev does work :P

I have tried with CLI tools like "wget", "hosts", "ping", "telnet" and so on and the site loads ok. Even I have used Dillo (damn simple web browser) and the site loads ok also.

Things I've tried so far: - Suggestions at https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can - Suggestions at https://support.mozilla.org/en-US/questions/1011327 (similar issue, not exactly the same).

It must be a silly thing but I'm out of options now. Perhaps anybody has faced to this situation in the past: any suggestion on this issue?.

Thanks in advance, Ibon.

Asked by Ibon Castilla Varela 2 years ago

Answered by Ibon Castilla Varela 1 year ago

  • Solved
  • Archived

Error message on site login (solved)

Running Linux Mint Mate 19.2 on two computers. Starting about 2 weeks ago, when trying to sign into providencejournal.com (with a paid subscription) using Firefox 97.0.1… (read more)

Running Linux Mint Mate 19.2 on two computers. Starting about 2 weeks ago, when trying to sign into providencejournal.com (with a paid subscription) using Firefox 97.0.1, just one of the computers displays an error message, see attached. We have used that site for years without issues, and the other computer still signs in correctly. On the problem computer I have just installed the Opera browser, for test purposes, and with Opera the sign-in succeeds. In F/F, I have tried disabling extensions, allowing all trackers and cookies, and reinstalling Javascript, all to no avail. preference is to use F/F, can anyone offer a solution?

Asked by stevenartigas 1 year ago

Answered by James 1 year ago

  • Solved
  • Archived

Cannot login into many websites - redirect does not work

Hello, when I try to login into various services, such as Outlook, the browser fails to log in and does not redirect to the logged in page. I'm using Firefox 98.0 on Manj… (read more)

Hello, when I try to login into various services, such as Outlook, the browser fails to log in and does not redirect to the logged in page. I'm using Firefox 98.0 on Manjaro 5.15.25-1. I tried uninstalling firefox and deleting all the data but the problem remains the same.

Asked by Cristiano Colangelo 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Archived

Newest Firefox Has Annoying Display

Every time I do a new (first) save to a firefox item, I get an annoying brief display showing files which were opened. I don't need such a display and would like to turn… (read more)

Every time I do a new (first) save to a firefox item, I get an annoying brief display showing files which were opened.

I don't need such a display and would like to turn it off: It is distracting and might cause me to miss a REAL error message.

I am attaching a gif photo of this display, which is new to the latest firefox.

How can I turn off this feature?

Asked by jwill 1 year ago

Answered by FredMcD 1 year ago