Showing questions tagged: Show all questions
  • Solved
  • Archived

how to prevent users from disabling add-ins?

I want to install a security add-in to block adult content. I know it is easy to simply disable an add-in from the Tools menu. Is there any way to prevent users from do… (read more)

I want to install a security add-in to block adult content. I know it is easy to simply disable an add-in from the Tools menu. Is there any way to prevent users from doing this? Sort of like make the tools menu password protected or something similar?

Asked by dasadler 4 years ago

Answered by dasadler 4 years ago

  • Solved
  • Archived

How can I change my CAs in Firefox Mobile

Dear Mozilla, Firefox Mobile seems to lack the ability to add or remove Root CAs from the browser. This is a problem because I have my own CA that I use for the … (read more)

Dear Mozilla,

         Firefox Mobile seems to lack the ability to add or remove Root CAs from the browser. This is a problem because I have my own CA that I use for the TLD .senor. I would like to be able to add my certificate to Firefox and not have to use Chrome to browse my .senor TLD. I looked for addons as a simple workaround, but they all seem to either be for PC Firefox or are so outdated that they no longer work on Android. Thank You!

Brandon

Asked by SenorContento 5 years ago

Answered by user1355808 4 years ago

  • Solved
  • Archived

Youtube HTML5 videos not playing (some)

So I'm getting a error "Your browser does not currently recognize any of the video formats available" and when clicking the link, it says H.264 and MSE & H.264 are no… (read more)

So I'm getting a error "Your browser does not currently recognize any of the video formats available" and when clicking the link, it says H.264 and MSE & H.264 are not supported. I used to get the black error screen for a split second before the video would blink and (I'm guessing) select another player and just play normally. Today is the first day that I've had this screen permanently displayed and it only shows up for a few videos. I can watch other videos on the same channel, just one or two that have the error.

It's the same if I try it in Safe Mode or with a new profile. I updated Firefox to 49.0, updated java, updated windows media component, and tried it with "media.windows-media-foundation.enabled" true and on false. No changes

I'm at my wits end with this one! I can watch the videos just fine in Chrome, but would much rather prefer to continue to use firefox as my default browser. Any help is appreciated. Thanks!

Asked by acegeek 5 years ago

Answered by jscher2000 5 years ago

  • Solved
  • Archived

Iwhy does itv hub insisist I am using adblocker software when it is disabled

When I am streaming from itv hub it plays the first section of the programme and then the first set of adverts but then stops and says I am using adblock software. I am o… (read more)

When I am streaming from itv hub it plays the first section of the programme and then the first set of adverts but then stops and says I am using adblock software. I am on windows 10 and use a DNS vpn, I have adblock and ghostery add-ons installed but these are disabled on itv-hub. I have exactly the same set-up on google chrome and it works perfectly why not on firefox. I also had problems recently downloading programs from bbc i-player but I have read in your questions section that this is now fixed.

Asked by MrFixit1 4 years ago

Answered by alan_r 4 years ago

  • Solved
  • Archived

New spinning loading icon when a page in a new tab is loading in the background after updating to 49.0

I just updated to 49.0 When I typed "googlemail.com" into a tab and hit enter, then immediately switch to another tab to load something or browse something else - I waite… (read more)

I just updated to 49.0

When I typed "googlemail.com" into a tab and hit enter, then immediately switch to another tab to load something or browse something else - I waited for the "googlemail.com" tab to finish loading and then clicked back on it - the page showed a small spinning loading icon in the middle of the page before all the content appeared

Does this have any impact on page loading performance?

I checked the release notes and had a quick look through my FF settings and about:config but I couldn't find any way to disable this

Asked by MyPCHatesMe 5 years ago

Answered by Wesley Branton 5 years ago

  • Solved
  • Archived

I am an IT admin, after migrating our Exchange from 2010 to 2016 OWA wont open in fire fox, get Error code: NS_ERROR_NET_INADEQUATE_SECURITY

Just upgraded from Exchange 2010 to Exchange 2016, now OWA in Exchange 2016 will not open in Firefox or Chrome, it will open in IE and Microsoft Edge. Here is the error … (read more)

Just upgraded from Exchange 2010 to Exchange 2016, now OWA in Exchange 2016 will not open in Firefox or Chrome, it will open in IE and Microsoft Edge.

Here is the error I get in FireFox:


Your connection is not secure

The website tried to negotiate an inadequate level of security.

my.domain.com uses security technology that is outdated and vulnerable to attack. An attacker could easily reveal information which you thought to be safe. The website administrator will need to fix the server first before you can visit the site.

Error code: NS_ERROR_NET_INADEQUATE_SECURITY


I have google this for 2 days now and have double check all SSL certs, permission settings etc, and I don't know how to fix this, if anyone has any ideas I would love to hear them. Thanks John

Asked by AJZ 4 years ago

Answered by AJZ 4 years ago

  • Solved
  • Archived

Locking preferences in Redhat's firefox.

So I have to set some settings system wide for the Firefox browser in order to comply with a STIG that I'm required to do. I've followed the example at http://kb.mozillaz… (read more)

So I have to set some settings system wide for the Firefox browser in order to comply with a STIG that I'm required to do. I've followed the example at http://kb.mozillazine.org/Locking_preferences without any luck, namely I edited the /usr/lib64/firefox/default/preferences/all-redhat.js file and added:

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");

and then created the mozilla.cfg in the same directory, chmod it to 644 and inserted the following:

// lockPref("browser.startup.homepage", "https://www.us.army.mil/suite/page/429668"); lockPref("browser.download.dir", "N:"); lockPref("browser.download.downloadDir", "N:"); lockPref("app.update.enabled", false); lockPref("extensions.update.enabled", false); lockPref("browser.shell.checkDefaultBrowser", false); lockPref("browser.search.update", false); lockPref("browser.formfill.enable", false); lockPref("signon.prefillForms", false); lockPref("dom.disable_open_during_load", true); lockPref("dom.disable_window_move_resize", true); lockPref("dom.event.contextmenu.enabled", false); lockPref("dom.disable_window_status_change", true); lockPref("dom.disable_window_flip", true); lockPref("dom.disable_window_open_feature.status", true); lockPref("security.warn_leaving_secure", true); lockPref("privacy.sanitize.promptOnSanitize", false); lockPref("privacy.sanitize.sanitizeOnShutdown", true); lockPref("security.default_personal_cert", "Ask Every Time"); lockPref("signon.rememberSignons", false); lockPref("xpinstall.whitelist.required", true); lockPref(“network.protocol-handler.external.shell”,false); lockPref(“security.enable_ssl3”,true); lockPref(“security.enable_ssl2”,false); lockPref(“security.enable_tls”,true); lockPref("plugin.disable_full_page_plugin_for_types", "application/pdf,application/doc,application/xls,application/bat,application/ppt,application/mdb,application/mde,application/fdf,application/xfdf,application/lsl,application/lso,application/lss,application/iqy,application/rqy,application/xlk,application/pot,application/pps,application/dot,application/wbk,application/ps,application/eps,application/wch,application/wcm,application/wbi,application/wb1,application/wb3,application/rtf,application/wch,application/wcm,application/ad,application/adp,application/xlt, application/dos, application/wks"); lockPref("privacy.item.history", false)

Initially, when starting, firefox would complain that my config file could not be read, and that I should contact my admin. So I did, and I had no answer for myself.

Reading forums brought me to the conclusion that I should reinstall firefox. So I did. Same issue. I then deleted all of the mozilla and firefox associated files, and then reinstalled.

As to be expected, the third time was the charm. No errors. Except one. It never loaded, nor locked my preferences.

Thank you for any help.

Asked by redbranchwarrior 4 years ago

Answered by redbranchwarrior 4 years ago

  • Solved
  • Archived

if playback doesn't begin shortly, try restarting your device - SOLVED

Win 10 pro, version 1607, os build 14393.321 Firefox 49.0.1 For the past few days some videos will not play in firefox, not on my laptop, my kindle fire and my galaxy 3 p… (read more)

Win 10 pro, version 1607, os build 14393.321 Firefox 49.0.1

For the past few days some videos will not play in firefox, not on my laptop, my kindle fire and my galaxy 3 phone, and yet the videos work on any other browser (Chrome, Pale Moon, Edge) I have on my devices. It either says, "if playback doesn't begin shortly, try restarting your device" or the swirling circle just keeps on swirling to a black background.

I fix computers for a living and have done all of the standards: restarted my laptop, cleared cache/cookies, tested in safe mode, un/re-installed firefox, my drivers are the way they are supposed to be, ensured my plugins are all active and I had the latest versions of flash, java, and real player.

Then I went up a notch: installed a VLC add-on, disabled hardware acceleration and restarted ff, made sure my firewall and antivirus programs trust plugin-container.exe, and followed the instructions from here: https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows,

What gives? And why doesn't FireFox have a fix for this miserable problem?


SOLVED (for me): Installing YouTube Flash Player helped, but only for the youtube video part: https://addons.mozilla.org/en-us/firefox/addon/youtube-flash-player/?src=ss

Going to about:config, and changing media.autoplay.enabled from false to true, then restarting FF, fixed the remainder of the video problem.

Asked by cadwellm 4 years ago

Answered by jscher2000 4 years ago

  • Solved
  • Archived

can I save a set of tabs?

Is there a way that I can save a group of open tabs at once to a new folder in bookmarks? If not, I'd like to request it as a feature. The desired result would be an o… (read more)

Is there a way that I can save a group of open tabs at once to a new folder in bookmarks? If not, I'd like to request it as a feature.

The desired result would be an option in bookmarks to "save all open tabs to new folder". Then I would get a prompt to type in a name of the folder or cancel the request. Ideally, would also include a keyboard command such as CTRL + G (for "group").

Thanks all.

Asked by Heron01 4 years ago

Answered by jscher2000 4 years ago

  • Solved
  • Archived

Problem printing from the internet....print too small???

Cannot print from the internet........print is very small in upper corner of an 8 1/2 x 11 sheet of paper. Mozilla Firefox works great on my old Windows XP but I now hav… (read more)

Cannot print from the internet........print is very small in upper corner of an 8 1/2 x 11 sheet of paper. Mozilla Firefox works great on my old Windows XP but I now have a Windows 10 and it is a nightmare. Any help out here?

Asked by JanetLee 4 years ago

Answered by jscher2000 4 years ago

  • Solved
  • Archived

HTML styles for <option> elements no longer work with latest Firefox 49.0.1

Hi. We have a web application which has a number of <select> elements whose <option> child elements have CSS 'style' attributes to change the background colo… (read more)

Hi. We have a web application which has a number of <select> elements whose <option> child elements have CSS 'style' attributes to change the background color of some of the options, to make them stand out, like this simple test:

<select name="select">

 <option value="one">ONE</option>
 <option value="two" style="background-color: #00FF00;">TWO</option>
 <option value="three" style="color: #FF0000;">THREE</option>
 <option value="four" style="color: #FF0000; background-color: #00FF00;">FOUR</option>

</select>

This works with older version of Firefox but our users have discovered that the latest version, 49.0.1, ignores the styles for the <option> elements; in the example above all of the lines in the dropdown list for the <select> element have the same default background and color.

Older versions of Firefox show the different colors. Also Firefox 49.0.1 on Windows XP (must be the 32-bit version of Firefox) still does. But Firefox 49.0.1 for Windows Vista and Windows 7 does not show the colors.

Other browsers - Internet Explorer on XP, Google Chrome - also show the style colors.

We standardize on Firefox - we tell our users to use Firefox with our application. If there are no plans to return the styling then we will have to try and replace our <select> elements with customized javascript controls, which will be messy. Or move to another brower, which will take a lot of time in testing. Is there any way/setting to return the old behavior and have Firefox again take note of the 'style' attribute for <option> elements in a <select>? Or might there be plans to fix this in a future release? Thanks!

Asked by AlexS2 4 years ago

Answered by philipp 4 years ago

  • Solved
  • Archived

vertical lines showing when on internet pages. How do I fix?

When visiting internet pages and scrolling down the page, vertical lines run the length of the page and there is nothing to view but vertical color lines. How do I fix?… (read more)

When visiting internet pages and scrolling down the page, vertical lines run the length of the page and there is nothing to view but vertical color lines. How do I fix? thanks

Asked by lstiger1 4 years ago

Answered by Wesley Branton 4 years ago

  • Solved
  • Archived

Firefox do not ask confirmation when exit/close with multiple tabs open

I am having same issue like user there: https://support.mozilla.org/en-US/questions/1139845 (only i have different OS) When having multiple tabs open, Firefox never ask m… (read more)

I am having same issue like user there: https://support.mozilla.org/en-US/questions/1139845 (only i have different OS)

When having multiple tabs open, Firefox never ask me for confirmation when i click Firefox window close button in the corner (usually accidentally). And i want confirmation.

in about:config i have:

browser.showQuitWarning true (this is marked as customized (bold) value, like default is false)

browser.tabs.closeWindowWithLastTab true

and when i close Firefox (usually accidentally) i receive crash reporter window which i usually submit.


update: one member claims that close confirmation is never shown for single window Firefox, only multiple Firefox windows. I think this is bad idea s probably half people not using multiple windows, only multiple tabs.

Asked by #367259 4 years ago

Answered by #367259 4 years ago

  • Solved
  • Archived

When I click on the URL bar or search bar it has a blue border. How do I get rid of that?

Someone asked this before about a year ago but I didn't find any legit answers. Just suggesting to use a different theme which I don't want to do. Is there an option to d… (read more)

Someone asked this before about a year ago but I didn't find any legit answers. Just suggesting to use a different theme which I don't want to do. Is there an option to disable this or an add-on? If not, Mozilla needs to address this because that thick blue border is just terrible looking.

Also note, this is not because of Windows 10. Windows 10 doesn't put any weird borders around URL box in Chrome or Edge. So I am pretty sure this is a FF issue.

Asked by ffuser2020 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

Firefox 50 wants to install "new helper tool" , what is it?

I downloaded Firefox 50 via the built in update. When I hit restart to install the update, I get a window saying that Firefox wants to install a "new helper tool" and tha… (read more)

I downloaded Firefox 50 via the built in update. When I hit restart to install the update, I get a window saying that Firefox wants to install a "new helper tool" and that I need to enter an admin password to complete the update. I can't find anything about this "helper tool" in the release notes or through a google search. I was wondering just what is it? Running OSX 10.11.16. Thanks.

Asked by PLBK 4 years ago

Answered by James 4 years ago

  • Solved
  • Archived

Firefox won't submit online forms

I filled out an online form to send a letter to my state senator, i.e. a reliable .gov website. When I click on "submit," nothing happens. I don't know if this is a brows… (read more)

I filled out an online form to send a letter to my state senator, i.e. a reliable .gov website. When I click on "submit," nothing happens. I don't know if this is a browser problem or what to do about it. Hoping someone can help.

Asked by sherryar 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

my pop-up box is too big, I can't access the submit button

The solution provided previously re: the xulstore.json. Did not work at all and only caused terrible problems! At total mess. Thank goodness I was able to do a system res… (read more)

The solution provided previously re: the xulstore.json. Did not work at all and only caused terrible problems! At total mess. Thank goodness I was able to do a system restore. Whenever I click the share to Facebook option the Facebook share box appears quickly but immediately bounces to a big box I can not resize or remove. Even if I hide the task bar I and not see the final share button. All options are hidden off screen. Higher resolution is no fix. This does nor happen in IE.. I do run pop-up blocker in FF can the be the problem? If so how to I fix this? Very annoying.

Asked by LostInThisMaze 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

Remove new "Recently Bookmarked" section from Bookmarks Menu in Firefox 49

Firefox 49 introduced a new section to the Bookmarks Menu -- both the one that drops from the toolbar button and the one on the classic menu bar. It says Recently Bookmar… (read more)

Firefox 49 introduced a new section to the Bookmarks Menu -- both the one that drops from the toolbar button and the one on the classic menu bar. It says Recently Bookmarked and is followed by the five most recently added bookmarks. How to remove it?

(Yes, it's a little obnoxious to create a new question to answer it, but I think it's the best way to help spread this information to anyone searching for it.)

Asked by jscher2000 5 years ago

Answered by jscher2000 5 years ago