Showing questions tagged: Show all questions
  • Solved

Double icons on Stop & Reload buttons when using custom icons

When reloading a page, or navigating to a new page, the default Stop icon momentarily appears over my own Reload icon, and the default Reload icon also appears over my St… (read more)

When reloading a page, or navigating to a new page, the default Stop icon momentarily appears over my own Reload icon, and the default Reload icon also appears over my Stop icon.

Please see attached image and animation.

Any idea if this is a minor bug?

Below is my code to split the Reload button into Reload & Stop buttons, then to add text to the navigation buttons, and finally to add icons to the navigation buttons.

This anomaly happens whether or not I split the Reload & Stop buttons. With just a single Reload button, I'm also seeing the default Reload icon appear over my own.

Thank you.

/* ---------- SPLIT RELOAD BUTTON INTO RELOAD & STOP ------------- */
#reload-button, #stop-button {
   display: inherit !important; 
} 
#reload-button > .toolbarbutton-icon {
  -moz-appearance: none !important; 
}


/* ------------ ADD TEXT LABELS TO NAVIGATION TOOLBAR BUTTONS --------------- */
/* Shows both icon and label for toolbarbuttons */
toolbar .toolbarbutton-1[label]{
  flex-direction: column;
  align-items: center !important;
}
toolbar .toolbarbutton-1[label]:not([disabled]):hover{ background-color: var(--toolbarbutton-hover-background) !important; }
toolbar .toolbarbutton-1[label] > .toolbarbutton-icon,
toolbar .toolbarbutton-1[label] > .toolbarbutton-badge-stack{
  padding: var(--toolbarbutton-inner-padding) !important;
  padding-bottom: 0px !important;
  height: calc(var(--toolbarbutton-inner-padding) + 16px) !important;
  border: none !important;
  background-color: transparent !important;
  box-shadow: none !important;
}
toolbar .toolbarbutton-1[label] > .toolbarbutton-text {
  display: flex !important;
  min-height: 16px !important;
  padding-top: 3px !important;
  padding-bottom: 6px !important;
  background-color: transparent !important;
  overflow: hidden;
  width: 9ch; /* changes space between buttons */
}
toolbar .toolbarbutton-1[label] > .toolbarbutton-text::before{
  margin-inline: auto;
 }
:root:not([uidensity="compact"]) toolbar .toolbarbutton-1[label] > .toolbarbutton-text{ padding: 2px !important; }


/* ------------ ADD CUSTOM ICONS TO NAVIGATION TOOLBAR BUTTONS ----------- */
#back-button {
   list-style-image: url("image/back.png") !important;
   padding-top: 8px !important;
}
#back-button image{
   max-height: 16px !important; 
   max-width: 16px !important;
   padding: 0px !important;
   margin-bottom: 3px !important;
}
#forward-button {
   list-style-image: url("image/forward.png") !important;
   padding-top: 8px !important;
}
#forward-button image{
   max-height: 16px !important; 
   max-width: 16px !important;
   padding: 0px !important;
   margin-bottom: 3px !important;
}
#reload-button {
   list-style-image: url("image/reload.png") !important;
   padding-top: 8px !important;
}
#reload-button image{
   max-height: 16px !important; 
   max-width: 16px !important;
   padding: 0px !important;
   margin-bottom: 3px !important;
}
#stop-button {
   list-style-image: url("image/stop.png") !important;
   padding-top: 8px !important;
}
#stop-button image{
   max-height: 16px !important; 
   max-width: 16px !important;
   padding: 0px !important;
   margin-bottom: 3px !important;
}
#print-button {
   list-style-image: url("image/print.png") !important;
   padding-top: 8px !important;
}
#print-button image{
   max-height: 16px !important; 
   max-width: 16px !important;
   padding: 0px !important;
   margin-bottom: 3px !important;
}
#home-button {
   list-style-image: url("image/home.png") !important;
   padding-top: 8px !important;
}
#home-button image{
   max-height: 16px !important; 
   max-width: 16px !important;
   padding: 0px !important;
   margin-bottom: 3px !important;
}

Asked by Slouch 1 month ago

Answered by Slouch 1 month ago

  • Solved
  • Archived

No Audio in Firefox only.

There is no audio on any website in Firefox only. I'm using Windows 11 Numbered list item When a video is playing there used to be an audio icon showing the tab is pl… (read more)

There is no audio on any website in Firefox only. I'm using Windows 11

  1. Numbered list item When a video is playing there used to be an audio icon showing the tab is playing audio, this does not show anymore.
  2. Numbered list item Firefox does not appear in the Windows volume mixer
  3. Numbered list item The Firefox Task Manager Utility 'Windows Media Framework Audio Decoder is always idle.
  4. Numbered list item I've restarted the Windows AudioSrv service and Windows explorer process

Nothing works. Please help.

Asked by rtwymanjr 10 months ago

Answered by rtwymanjr 10 months ago

  • Solved
  • Archived

Full-screen video problem

I'm having a problem with playing videos on websites. When I click the expand to full screen button about half the time the full screen video comes up for half a second a… (read more)

I'm having a problem with playing videos on websites. When I click the expand to full screen button about half the time the full screen video comes up for half a second and then the window shrinks down to a small square on the bottom right-hand corner of my screen. Sort of like when the youtube app minimizes a video. This window is unclickable and also everything at or below it in android is unclickable while it's there. If I click the window button on android and swipe the firefox app up to close it and restart it, Firefox doesn't even close and I can still hear sound from the video. I have to select on the Firefox app again which will restore the full window and then click the full screen button one more time and it will work. This issue is happening on every website I play video on on the Firefox app and it is extremely irritating. I'm about ready to switch to another app if this can't be solved, but Firefox is the only browser that allows ublock origin so I don't want to do that. Can anyone help?

Asked by raistlinnuitari8 10 months ago

Answered by raistlinnuitari8 10 months ago

  • Solved
  • Archived

mysignins.microsoft.com

Hello I'm trying to sign into a Microsoft 365 email account but can't get beyond a screen saying "To use this site, you need to change your browser settings to enable DO… (read more)

Hello

I'm trying to sign into a Microsoft 365 email account but can't get beyond a screen saying "To use this site, you need to change your browser settings to enable DOM storage or cookies."

I've enabled DOM storage and cookies but no difference. I've cleared cookies and no help. I'm running Firefox 115.0.2 and Linux Mint.

Is part of the problem that I hate Microsoft and they know it?

Thanks

Asked by arthurjackson 11 months ago

Answered by jonzn4SUSE 11 months ago

  • Solved
  • Archived

Videos freeze when scrubbing back

For a few months, I have encountered an issue with videos playback on my browser. On most websites (including Reddit, Dailymotion, and even some videos on YouTube), whene… (read more)

For a few months, I have encountered an issue with videos playback on my browser. On most websites (including Reddit, Dailymotion, and even some videos on YouTube), whenever I scrub back a video, it will stop for about ten seconds, while the audio keeps playing.

My current extensions are: Metamask, Bionic Reader, uBlock Origin, Return Youtube Dislike, and TWP Translate Web Pages. I have tried using Troubleshooting mode, but the problem persisted, so I think it's not because of my extension.

My OS is Opensuse Tumbleweed, with Firefox version 155.0.3. I didn't have this issue with Firefox ESR on my previous Debian 11 installation. I hope someone can find a solution for this, as it is extremely troublesome switching to Chrome whenever I want to watch videos.

Asked by xuantung.trinh.63 10 months ago

Answered by zeroknight 10 months ago

  • Solved
  • Archived

webp images not loading at all

hello! i've been having an issue with mozilla where webp images are not loading at all. this is especially prevalent on youtube, where thumbnails simply do not load, as w… (read more)

hello! i've been having an issue with mozilla where webp images are not loading at all. this is especially prevalent on youtube, where thumbnails simply do not load, as well as on tumblr, where if an image or gif is a webp file, it will refuse to load. both are attached in the image below to see the difference between firefox and chrome, as the images load fine on chrome. as well as that, discord, when opened with browser instead of the app, does not load profile pictures, server icons, or custom emojis. google hadn't helped me at all, and i don't know what to do at this point. i don't want to go back to using chrome.

in the attached image, the top images show a set of shark sculptures. the first does not load on mozilla, and looking at the image file, it is a webp. the second image is revealed to be a jpg, which mozilla treats normally. in the second set of images, there's a quick look at a random youtuber's page, the top being mozilla and the bottom being chrome, and you can see the mozilla thumbnails do not load.

thank you for reading! i'm very confused and am unsure what to do. any help is appreciated!

Asked by kriber 10 months ago

Answered by zeroknight 10 months ago

  • Solved
  • Archived

[Firefox Android] Firefox freezes when I select an image on the main page of a Google search

I'm using Android 13 and Firefox is updated to the latest update. When I Google something and select an image, Firefox freezes and I either have to reload the page and th… (read more)

I'm using Android 13 and Firefox is updated to the latest update. When I Google something and select an image, Firefox freezes and I either have to reload the page and the image will load or I have to close & reopen the app and switch to the Images tab. This is on the main Google search page. Images selected in the Google Images tab work as expected.

Asked by popo 11 months ago

Answered by popo 11 months ago

  • Solved
  • Archived

Autofill Issue

When I'm using my Firefox browser and signing in to my Gmail account, the autofill function always gives me several old, expired gmail account names that I don't wish to … (read more)

When I'm using my Firefox browser and signing in to my Gmail account, the autofill function always gives me several old, expired gmail account names that I don't wish to see anymore. It's very annoying. I think I have turned off all the autofill options under Firefox>Preferences, but all these old account names keep showing up. Any suggestions for how to solve this? Thank you

Asked by bclough9377 11 months ago

Answered by cor-el 11 months ago

  • Solved
  • Archived

download file / not downloaded potential security risk - where do I tell it this url is approved?

I download a file. It stops and speaks of a security risk. The website is https, but the file is http. Is there a location I can pre-approve all files from the url to ove… (read more)

I download a file. It stops and speaks of a security risk. The website is https, but the file is http. Is there a location I can pre-approve all files from the url to override the objection? Thanks.

Asked by needsleep 10 months ago

Answered by zeroknight 10 months ago

  • Solved
  • Archived

Firefox is not asking where to save files

Firefox is downloading files directly to my Downloads folder instead of asking despite having turned on every setting that says it should ask first. Under about:preferenc… (read more)

Firefox is downloading files directly to my Downloads folder instead of asking despite having turned on every setting that says it should ask first. Under about:preferences I have turned on "Always ask you where to save files" under Downloads, and I have set Applications to "Ask whether to open or save files". I have even gone in to about:config and turned off "browser.download.useDownloadDir", but the files are still going directly to my default folder.

Asked by m_dessain 11 months ago

Answered by m_dessain 11 months ago

  • Solved
  • Archived

SEC_ERROR_UNKNOWN_ISSUER, no "Accept the Risk and Continue" button

When I'm trying to go to a specific website, it doesn't connect with an error code "SEC_ERROR_UNKNOWN_ISSUER". I was able to press a button labeled "Accept the Risk and C… (read more)

When I'm trying to go to a specific website, it doesn't connect with an error code "SEC_ERROR_UNKNOWN_ISSUER". I was able to press a button labeled "Accept the Risk and Continue" before, but the button seems to have disappeared?

Asked by Gauley 11 months ago

Answered by Gauley 11 months ago

  • Solved
  • Archived

Youtube Constantly Buffering after Pausing and Resuming

I've been watching and following along with a Unreal Engine 4 Course on Youtube for some time now (mentioning in case the resource usage has something to do with it), and… (read more)

I've been watching and following along with a Unreal Engine 4 Course on Youtube for some time now (mentioning in case the resource usage has something to do with it), and in the past couple days I've noticed a pretty serious and annoying bug. When I pause the video, tab (Cmd + Tab on MacOS) into Unreal Engine, do some things, then tab back and resume the video, it will play for one frame and then stop and buffer, but the audio will continue playing. The only way to get the video to resume is to skip forward/backward in the video (either with the arrow keys or the progress bar). I've also tried Troubleshooting/Safe mode and the issue still persits.

Asked by beatzoid 11 months ago

Answered by beatzoid 10 months ago

  • Solved
  • Archived

Firefox on iphone is frozen with pop-up that says "your apple iphone is severely damaged"

How do I remove the scam pop-up that won't let me access firefox on my iphone? The pop-up says "your apple iphone is severely damaged." I can't open a new tab or delete… (read more)

How do I remove the scam pop-up that won't let me access firefox on my iphone? The pop-up says "your apple iphone is severely damaged." I can't open a new tab or delete the current tab.

Asked by Gitana 11 months ago

Answered by Gitana 11 months ago

  • Solved
  • Archived

Fullscreen behaving oddly on macos firefox

When I go into fullscreen on firefox macos, hovering near the top shows the traffic lights (fullscreen, minimize, close window buttons) and moves everything down. This ma… (read more)

When I go into fullscreen on firefox macos, hovering near the top shows the traffic lights (fullscreen, minimize, close window buttons) and moves everything down. This may be expected behavior, but it is very annoying as when you try to open new tabs the tab bar moves out of the way of the traffic lights, and the traffic lights area is around the size of the tab bar. Is there any way to make the traffic lights always visible or keep them from moving?

Asked by a.b.liebgold 10 months ago

Answered by a.b.liebgold 10 months ago

  • Solved
  • Archived

Firefox History Set to "Always Use Private Browsing Mode" but "Recently Closed Tabs" Still Appear in History

I have my Firefox Firefox Privacy & Security History settings set to 'Always Use Private Browsing Mode.' Yet every time I open Firefox and visit the History tab, 'Rec… (read more)

I have my Firefox Firefox Privacy & Security History settings set to 'Always Use Private Browsing Mode.' Yet every time I open Firefox and visit the History tab, 'Recently Closed Tabs' shows a history of the websites I've visited. How do I disable this feature?

Asked by Nat 10 months ago

Answered by zeroknight 10 months ago

  • Solved
  • Archived

Viewing media in fullscreen mode adds black borders around the screen.

When I play a video in fullscreen, there is a strange black border that appears around the video which makes the content smaller than it would otherwise be. This border d… (read more)

When I play a video in fullscreen, there is a strange black border that appears around the video which makes the content smaller than it would otherwise be. This border does not display in Safari or Chrome, just in Firefox. It also occurs in every media player I've tested, including YouTube and Netflix.

Annoyingly, I can't get this to show up in a screenshot. It seems like Firefox guesses the aspect ratio or resolution wrong when it puts media in fullscreen, and it has the effect of downsizing the actual interactive part of the display. Meaning, I can't move my mouse into the border area to take a screenshot of it.

I'm on an ARM Macbook running MacOS 13.5, if that matters.

Is this a bug, and/or is there a way to fix this?

Asked by tsedan 10 months ago

Answered by zeroknight 10 months ago

  • Solved
  • Archived

Firefox 115: menu and tabs background color changed

After Firefox upgraded from 114.02 to 115 menu and tabs background color changed: FF 114: https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-… (read more)

After Firefox upgraded from 114.02 to 115 menu and tabs background color changed:

FF 114: https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-07-05-17-00-30-1a3adf.png FF 115: https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2023-07-05-17-00-34-cba7e0.png

These are screenshots of active window. When window of v115 becomes inactive, background color changes to lighter, but still no visible horizontal line between menu and tabs. I don't use any additional themes, "System theme — auto" is selected.

From release notes for FF 115: For users with a Firefox Colorways built-in theme, the theme will be automatically migrated to the same theme hosted on addons.mozilla.org for Firefox profiles that have disabled add-ons auto-updates. This will allow users to keep their Colorways theme when they are later removed from Firefox installer files. I guess it is relevant somehow, but i never installed Colorways and don't know what is it.

How to make FF 115 look like it was in 114? I can see changes in `browser/themes/` in sources between 114.02 and 115. Is it possible to "extract" default theme from 114 and install/apply it to 115?

I use Firefox under Fluxbox window manager in Arch Linux, if it matters.

Asked by dimich.dmb 11 months ago

Answered by a.j.buxton 10 months ago