Showing questions tagged: Show all questions
  • Solved
  • Archived

how do I stop autoplay of vids on yahoo.com news page. Settings do not work in autocofig media.autoplay = false anymore

I have u block origin already. I had media autoplay set to false. Now yahoo.com news autoplays vids (again). The autoplay literally started on October 24, 2018. 1- wh… (read more)

I have u block origin already.

I had media autoplay set to false. Now yahoo.com news autoplays vids (again). The autoplay literally started on October 24, 2018. 1- what happened to allow autoplay on yahoo when it was successfully blocked all this time? 2- what can I do to stop video autoplay? Idiot level instructions please- set one go here type instructions. I already went the "add on" route. Flash blockers didn't work at all. All other "vid blockers" are for youtube and will not work on yahoo news as I tried hoping one would work.

Maybe I am stupid, but exactly WHAT settings are needed to stop autoplay on yahoo.com that are in ublock origin or in firefox about: config settings (media.autoplay =false), which doesn't seem to have any effect anymore. Is something else in about:config needed?

Site example where annoy vid autoplay now exists: https://www.yahoo.com/lifestyle/dont-want-attention-mother-6-year-old-boy-whose-birthday-party-guests-no-shows-speaks-185110033.html

FF version: 63.0 , 64 bit, windows 10, Dell Laptop

Asked by Droxy 2 years ago

Answered by James 2 years ago

  • Solved
  • Archived

Block autoplay being ignored on Firefox 78

Prior to the latest version, I had set "media.autoplay.enabled.user-gestures-needed" in about:config to False in addition to blocking both audio and video within the sett… (read more)

Prior to the latest version, I had set "media.autoplay.enabled.user-gestures-needed" in about:config to False in addition to blocking both audio and video within the settings so that nothing would autoplay without my input.

I updated to version 78 yesterday, and it seems that "media.autoplay.enabled.user-gestures-needed" is now gone from within about:config. I'm getting videos autoplaying within sites like YouTube, despite me setting both audio and video to not autoplay.

Is there anything I can do to ensure that nothing starts playing without me allowing it?

Asked by Kakkun 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

How can I turn off AutoPlay in Firefox? It is not listed in preferences.

The new 'update' on Firefox (63.0, I think) turned on all my AutoPlays that I had previously turned off. Very annoying. How can I turn off AutoPlay? Do they have to up… (read more)

The new 'update' on Firefox (63.0, I think) turned on all my AutoPlays that I had previously turned off. Very annoying. How can I turn off AutoPlay? Do they have to update the software?

Asked by chrissporter 2 years ago

Answered by jscher2000 2 years ago

  • Solved
  • Archived

Block video autoplay not working

In the past few days, the block video autoplay option is not working. It had been working properly for years. I have video autoplay turned off in about:config and the o… (read more)

In the past few days, the block video autoplay option is not working. It had been working properly for years. I have video autoplay turned off in about:config and the option to block autoplay is no longer available under the settings menu. What settings need to be changed to re-enable this in the update. This is extremely annoying.

Asked by gsmnp34 2 years ago

Answered by philipp 2 years ago

  • Solved
  • Archived

Autoplay not always blocked

Firefox 78 sometimes fails to block autoplay, e.g. scrolling the front page of reddit.com or a subreddit will intermittently show videos playing. This worked in 77. Some … (read more)

Firefox 78 sometimes fails to block autoplay, e.g. scrolling the front page of reddit.com or a subreddit will intermittently show videos playing.

This worked in 77. Some about:config entries I'd swear were set in 77 have vanished; I tried adding them manually, but the autoplay blocking is still hit and miss.

Also, not sure if Troubleshooting Information uploaded successfully or the page broke (see screenshot).

Asked by Jens Lyn IV 1 year ago

Answered by Jens Lyn IV 1 year ago

  • Solved
  • Archived

stop streaming video

As of yesterday videos would only play if asked. installed latest update today 10/26/2018 0630MDT. Now I have to manually stop the videos. I had ALREADY used the link "ab… (read more)

As of yesterday videos would only play if asked. installed latest update today 10/26/2018 0630MDT. Now I have to manually stop the videos. I had ALREADY used the link "about:config" on previous versions & that worked. The line "media.autoplay.enabled" is already set to "false". This glitch happened as soon as I installed the latest update.

Asked by sailor842 2 years ago

Answered by jscher2000 2 years ago

  • Solved
  • Archived

Youtube autoplay videos when switching tabs (I don't want that)

Okay, so before, when I loaded up 100+ Youtube videos, they stayed when switching tabs - no autoplay. Suddenly they decide to autoplay when switching tabs - note, I've no… (read more)

Okay, so before, when I loaded up 100+ Youtube videos, they stayed when switching tabs - no autoplay. Suddenly they decide to autoplay when switching tabs - note, I've not done anything to my settings or plugins. Fair enough, maybe you changed something (which you often do, without informing). So I check the options. It was on "Block audio", which obviously didn't work, so I tried "Block Audio and Video" - which WORKS, but now both the video is paused (which I want) AND the audio is set to mute (which I DON'T want) - so... what does it take to have Youtube wait for a click to start playing a video loaded in a background tab, but KEEP AUDIO ACTIVE, so I don't also have to unmute the damn video?

Asked by langbakk 1 year ago

Answered by cor-el 1 year ago

  • Archived

How stop video autoplay?

After a recent update to version 63.0, videos with maximum audio automatically start. This problem is especially acute with CNN.com. I will not tolerate this problem and … (read more)

After a recent update to version 63.0, videos with maximum audio automatically start. This problem is especially acute with CNN.com. I will not tolerate this problem and either must find away to immediately prevent it or, undesirably, switch to another browser.

How do I stop video's from automatically starting?

Thank you.

Asked by Barryng 2 years ago

Last reply by jscher2000 2 years ago

  • Solved
  • Locked
  • Archived

Firefox 66 still auto-plays videos

I'm on Linux, and updated to Firefox 66 yesterday. I was looking forward to the new feature that disallows websites auto-playing videos. But I found that it's not the cas… (read more)

I'm on Linux, and updated to Firefox 66 yesterday. I was looking forward to the new feature that disallows websites auto-playing videos. But I found that it's not the case. For example, https://www.bloomberg.com/news/articles/2019-03-19/how-an-extra-man-in-cockpit-saved-a-737-max-that-later-crashed still starts playing the video automatically. This is just one of the many I've tried so far.

Am I missing any settings? There was none I could find having done a quick search on the preference page.

Asked by Jeenu 2 years ago

Answered by cor-el 2 years ago

  • Archived

autoplay options have effect - cnn.com, etc

I have never been able to get autoplay options to prevent blasting out audio when stumbling onto a malicious website like CNN. This is a major privacy problem as perhaps … (read more)

I have never been able to get autoplay options to prevent blasting out audio when stumbling onto a malicious website like CNN. This is a major privacy problem as perhaps you don't want the world to know you are studying how to seek legal or medical help etc with audio blasting out at max level.

I don't know why this is so hard to manage since detecting loud audio isn't that difficult and it seems like browsers have all sort of hooks into media features of the operating systems they run on.

Can't firefox take samples of the audio (we don't need advanced signal processing here), determine that it is blasting out, and kill it?

In any case I have never been able to get any impact from autoplay settings other than to screw up my browsing experience so bad I have to reset to defauts to even manually play a video.

Addins like no script are so restrictive they render browsing impossible.

Asked by Robert 1 year ago

Last reply by Robert 1 year ago

  • Solved
  • Archived

Just got upgrade to ver 66, Autoplay still not disabled

I just upgraded to ver 66.0 and thought one of the features was to not allow autoplay. I'm still getting autoplay, on yahoo.com, (and other sites) even after adding bloc… (read more)

I just upgraded to ver 66.0 and thought one of the features was to not allow autoplay. I'm still getting autoplay, on yahoo.com, (and other sites) even after adding block in exceptions. I thought it would be disabled. What must I do?

Asked by JussAskin 2 years ago

Answered by koooper 2 years ago

  • Solved
  • Archived

Firefox 63 (macOS) lets YouTube videos start automatically in spite of "media.autoplay.enabled" being set to "false."

Firefox 63 (macOS) lets YouTube videos start automatically in spite of "media.autoplay.enabled" being set to "false." Can that be fixed, please? I reverted for now to v6… (read more)

Firefox 63 (macOS) lets YouTube videos start automatically in spite of "media.autoplay.enabled" being set to "false."

Can that be fixed, please?

I reverted for now to v62.0.3 and the videos do - as before updating to v63 - not automatically start. That hints strongly to v63 being the culprit here.

Asked by resucami2 2 years ago

Answered by philipp 2 years ago

  • Archived

Stop ALL videos autoplaying - not just those with sound

Previously I had the 'autoplay' option set to false. Now with the update (I'm on 63.0.1, Windows, 64 bit) I have media.autoplay.default = 1 media.autoplay.ask-permission … (read more)

Previously I had the 'autoplay' option set to false. Now with the update (I'm on 63.0.1, Windows, 64 bit) I have

media.autoplay.default = 1 media.autoplay.ask-permission = true media.autoplay.enabled.user-gestures-needed = true

I want all videos to not play, not just those with sound. How can I stop all videos playing?

Thanks.

Asked by ChrompSquad 2 years ago

Last reply by cor-el 2 years ago

  • Archived

Disable autoplay media and all annoying notifications permantly!

Hi all, After searching and applying several settings, I am still getting those annoying messages, popups and whatsoever. No matter what I do. I always preferred Firefox … (read more)

Hi all,

After searching and applying several settings, I am still getting those annoying messages, popups and whatsoever. No matter what I do. I always preferred Firefox as my most favorable browser for many, many years, however I noticed that I started using Chrome more and more because of all these little annoyances.

The last few things I tried are:

about:config dom.webnotifications.enabled (false) dom.push.enabled (false) dom.webnotifications.serviceworker.enabled (false) (for notifications)

about:config media.autoplay.allow-muted (false) media.autoplay.default (2) (for autoplay media)

These ones didn't help: media.autoplay.enabled.user-gestures-needed (false) media.autoplay.ask-permission (false)

Though media doesn't autoplay, I do get a notifcation about if I want to play the media or something similar. Sigh.

Also the help page on Firefox doesn't help at all, like this one: https://support.mozilla.org/en-US/kb/block-autoplay For example; I don't have the "For websites that autoplay sound"-option at all there. See screenshot included.

So what I am trying to here (maybe someone can give me the exact config options):

1. Disable permantly the auto-play function for all media and for all websites 2. Disable every single notification type; I don't want to be asked if I want to play media/sound/music, nor do I want to be asked if I want website notifications or any other kind of notification. I don't want to see a single message at all!!

I hope someone can give me the right settings and/or what to change to make this happen permantly. It's driving me nuts....! Seriously. NUTS! :S

Sidenote; I am also experiencing issues with Firefox on my OnePlus 6T. Sometimes when I enter an URL it doesn't load at all, the screen stays white and doesn't do anything. Closing and starting the app doesn't help. The only solution (sometimes) is to close all my tabs (doesn't matter if it's 10, 40 or 99 tabs). If that fails the solution is a reboot of the phone. And no, it's not the internet connection because a) Chrome wouldn't work, b) nor my other apps. I do use Synchronization between my accounts. The OnePlus 6T was a fresh installation from a couple of weeks ago. Before that (and on my other phone) I had this issue also....

Maybe someone can shed some light as well on the Android issue??

Thank you in advance!

Regards

Asked by HHawk 2 years ago

Last reply by cor-el 2 years ago

  • Archived

Cannot turn off autoplay in Yahoo. Used to work but doesn't anymore

I have done everything suggested on this page: https://support.mozilla.org/en-US/questions/1238091#question-reply Let me repeat: I've tried every suggestion. None work. H… (read more)

I have done everything suggested on this page:

https://support.mozilla.org/en-US/questions/1238091#question-reply

Let me repeat: I've tried every suggestion. None work. Has Yahoo gotten sneakier within the past few days? Anything else I can do? Running 63.0.1

Attached is a pic of my settings.

Asked by SHELLIEMAC0602 2 years ago

Last reply by cor-el 2 years ago

  • Solved
  • Archived

I have media.autoplay.enabled set to false. That worked until the update today. How can I fix that?

I have the video addin "OpenH264 Video Codec provided by Cisco Systems, Inc.". I previously turned off autoplay but after today's update it no longer works. If I open a t… (read more)

I have the video addin "OpenH264 Video Codec provided by Cisco Systems, Inc.". I previously turned off autoplay but after today's update it no longer works. If I open a tab the video just starts. That is BS. How do I fix this annoying issue that Firefox has given me?

Asked by kentover1 2 years ago

Answered by philipp 2 years ago

  • Archived

How to really stop autoplaying videos

I can't stop autoplaying videos in FF77. I disabled them in the options, and also set media.autoplay.blocking_policy = 2 and the videos still play automatically after re… (read more)

I can't stop autoplaying videos in FF77. I disabled them in the options, and also set

media.autoplay.blocking_policy = 2

and the videos still play automatically after restarting FF.

Asked by useruser 1 year ago

Last reply by useruser 1 year ago

  • Archived

Videos autoplaying even with all the new settings

Until today the options for stopping videos auto playing worked OK, suddenly they don't work at all. I had changed all the settings in about:config - please see screen … (read more)

Until today the options for stopping videos auto playing worked OK, suddenly they don't work at all. I had changed all the settings in about:config - please see screen shot attached - a couple of weeks ago when they suddenly started auto playing and that solved the issue, but now I am back to square one. Even when I have ensured that the autoplay option is changed in the preferences section they are still auto-playing. Any suggestions please as this is driving me crazy!

Thanks in advance for your help. It is much appreciated.

Asked by KezzerN 2 years ago

Last reply by cor-el 2 years ago