Showing questions tagged: Show all questions

lock file not removed, which breaks selenium-webdriver

It seems that as of 79.0 the `lock` file in profile dir is no longer removed at browser close. That doesn't play very nicely with selenium driver (ruby API) when I want t… (read more)

It seems that as of 79.0 the `lock` file in profile dir is no longer removed at browser close. That doesn't play very nicely with selenium driver (ruby API) when I want to create a browser instance with existing profile name. It seems that profile directory is copied, but this fails for `lock` file, as it cannot be `stat`ed.

Is not removing `lock` file intended?

This can be reproduced with: ruby -r 'selenium-webdriver' -e 'Selenium::WebDriver.for :firefox, profile: "my_existing_profile_name"'

which gives the stacktrace: /usr/local/lib/ruby/gems/2.6/gems/rubyzip-2.3.0/lib/zip/entry.rb:409:in `stat': No such file or directory @ rb_file_s_stat - /mnt/work/webdriver-rb-profilecopy20200726-75146-9bn20t/lock (Errno::ENOENT) from /usr/local/lib/ruby/gems/2.6/gems/rubyzip-2.3.0/lib/zip/entry.rb:409:in `file_stat' from /usr/local/lib/ruby/gems/2.6/gems/rubyzip-2.3.0/lib/zip/entry.rb:551:in `gather_fileinfo_from_srcpath' from /usr/local/lib/ruby/gems/2.6/gems/rubyzip-2.3.0/lib/zip/file.rb:303:in `add' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/common/zipper.rb:92:in `add_zip_entry' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/common/zipper.rb:55:in `block (2 levels) in zip' from /usr/local/lib/ruby/2.6/find.rb:49:in `block (2 levels) in find' from /usr/local/lib/ruby/2.6/find.rb:48:in `catch' from /usr/local/lib/ruby/2.6/find.rb:48:in `block in find' from /usr/local/lib/ruby/2.6/find.rb:43:in `each' from /usr/local/lib/ruby/2.6/find.rb:43:in `find' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/common/zipper.rb:54:in `block in zip' from /usr/local/lib/ruby/gems/2.6/gems/rubyzip-2.3.0/lib/zip/file.rb:125:in `open' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/common/zipper.rb:81:in `with_tmp_zip' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/common/zipper.rb:53:in `zip' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/firefox/profile.rb:193:in `encoded' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/firefox/options.rb:136:in `as_json' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/firefox/marionette/driver.rb:81:in `create_capabilities' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/firefox/marionette/driver.rb:36:in `initialize' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/firefox/driver.rb:33:in `new' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/firefox/driver.rb:33:in `new' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver/common/driver.rb:54:in `for' from /usr/local/lib/ruby/gems/2.6/gems/selenium-webdriver-3.142.7/lib/selenium/webdriver.rb:88:in `for' from -e:1:in `<main>' 2020-07-26 21:58:10 WARN Selenium [DEPRECATION] :profile is deprecated. Use Selenium::WebDriver::Firefox::Options#profile= instead.


  1. ruby --version

ruby 2.6.6p146 (2020-03-31 revision 67876) [amd64-freebsd11]

  1. gem list selenium-webdriver

selenium-webdriver (3.142.7)

Asked by serpent7776 2 months ago

Video links in a online magazine

Hi I use a online magazine (Readly.com) and it has links to videos in the pages. Which should run. I have in the options tried to allow permissions to this site to allow … (read more)

Hi I use a online magazine (Readly.com) and it has links to videos in the pages. Which should run. I have in the options tried to allow permissions to this site to allow auto play. I have entered the web address and saved it. when I reopened permissions it is blank and the web page has not been saved. Any ideas. I wouldn't I am a computer expert some the answer would need to simple instructions. Firefox version is 79.0 windows 10 64 bit Thanks

Asked by derek61 2 months ago

displaying VR on firefox desktop (doesnt work)

When i visit any VR Website, i get aksed if i want to grant accsess to vr, i klick yes, a "Heading to Firefox" banner shows up in the vive, then nothing happens and steam… (read more)

When i visit any VR Website, i get aksed if i want to grant accsess to vr, i klick yes, a "Heading to Firefox" banner shows up in the vive, then nothing happens and steam VR home gets loaded. On any website (incls. Mozilla hubs) this happens, i cant accsess vr from firefox (games work just fine, its not a problem with the vive.

My setup: win 10 firefox newest version (79.0 (64-Bit)) plugins:

  no script (but always deactivated when trying vr)
  ABP
  Mobile View switcher
  citavi
  facebook container
  AdBlock Ultimate

htc vive via display port steam vr newest version amd Radeon rx vega amd ryzen 5 1600X

Asked by niel-hoier 2 months ago

Sync not working

Hey, I just got a new motherboard and an SSD, so I reinstalled my PC. The last time I did that, when I logged into Firefox, all of my tabs, passwords and accounts were sa… (read more)

Hey, I just got a new motherboard and an SSD, so I reinstalled my PC. The last time I did that, when I logged into Firefox, all of my tabs, passwords and accounts were saved. This time they aren't. Could I get some help or at least an explanation as to why this happened? Is it because of the new motherboard?

Asked by balanorrbg 2 months ago

Firefox logo isn´t showing on my homepage

hey there, I know the following is not a big deal, but I still appreciate any help. onto my problem: I reinstalled Firefox on Windows 10 (troubleshooting my PC) and turn… (read more)

hey there, I know the following is not a big deal, but I still appreciate any help. onto my problem: I reinstalled Firefox on Windows 10 (troubleshooting my PC) and turned off everything except for the search engine and the standard Firefox homepages in the settings for the homepage. Before the reinstall the Firefox logo was showing (pic below), now its just a white page with the search engine. i know this is not a real issue but I "enjoyed" the Firefox logo. thanks for help though!

Asked by The UwUinator 2 months ago

Firefox Sync: Can't log on -- Your e-mail was just returned

When I try to log onto Firefox Sync, I can enter my password and enter the code from my authentication app, but then I get "your e-mail was just returned". When I enter … (read more)

When I try to log onto Firefox Sync, I can enter my password and enter the code from my authentication app, but then I get "your e-mail was just returned". When I enter one of the recovery codes, I get the same message. What do I do?

Asked by gsmith001 2 months ago

Popup window for downloads does not popup

Previously, when I had an attachment and clicked on "Download" or the attachment's icon in the E-mail body, a popup window would appear to ask if I want to download or op… (read more)

Previously, when I had an attachment and clicked on "Download" or the attachment's icon in the E-mail body, a popup window would appear to ask if I want to download or open the file. Recently, that popup window began not appearing. Instead, another full Firefox window pops up, the throbber (load indicator) in the new Firefox window shows that it's loading something, then that Firefox window disappears and I am back at the E-mail body. I am not able to view or download any attachments. However, in Internet Explorer viewing and downloading attachments works, so I know it's not the Yahoo website that's messed up.

Can someone help me make that popup window for selecting "Download" or "Open" come back?

Thank you, Steve

Asked by SEKELLER1 2 months ago

Handle custom protocol

Dear community, I am desperately looking for a way to handle custom protocols in Firefox on macOS (both up-to-date). I have seen many questions and many answers, most of … (read more)

Dear community,

I am desperately looking for a way to handle custom protocols in Firefox on macOS (both up-to-date). I have seen many questions and many answers, most of them are outdated or irrelevant.

On our intranet, some of the pages have links pointing to "ictfast:xxxxxx". The first part (ictfast) is never changing. The second part (xxxxxx) can be anything. I would like to run an external application when people click on such links.

What I have done so far: step #A1: In "about:config", I created and set the key "network.protocol-handler.expose.ictfast" to false. step #A2: I clicked on a link "ictfast:xxxxxx" step #A3: A box appeared letting me choose my external application

After these steps, if I click on a "ictfast" link, the application runs but I can't access the content in "xxxxxx".

To reproduce this, it is very simple: step #B1: open Automator step #B2: create a new Application step #B3: add the "Run Shell Script" actions step #B4: choose "Pass input" to as arguments" step #B5: remove the default content of the shell script step #B6: type in `echo "$@" > /tmp/args.txt` (without the backticks) step #B7: save and choose this app in step #A3

Now if you click on a "ictfast" link, the file in "/tmp/args.txt" is created, but is empty. There is no arguments passed to the applications.

I was naively believing that when clicking on a "ictfast" link, Firefox would internally run the command `/foo/bar/whatever.app "address"`. But it seems to be more complicated and cryptic than that.

Could anyone help me on this? Thanks!

Asked by Slagt 2 months ago

Lost the SpellChecker in email https://www.outlook.live.com. Can't recover it...Please help

I think that a recent Windows 10 Update de-installed my Spell Checker. In Mozilla Firefox, I tried: MENU/OPTIONS/GENERAL/LANGUAGE and checked "Check your spelling a… (read more)

I think that a recent Windows 10 Update de-installed my Spell Checker.

In Mozilla Firefox, I tried: MENU/OPTIONS/GENERAL/LANGUAGE and checked "Check your spelling as you type".

I re-started Firefox and still no Spell Checker.

I downloaded a Firefox "Add-On" - a highly recommended Grammar & Spelling tool. It works OK, but not as good as the Spell Checker that HAD been installed & used on Outlook email.

If someone out there is confident they know the steps to re-install the original Spell Checker.....let's give it a try.

Thanks, Gary

Asked by Gary NH 2 months ago

copy and paste not working

I am going crazy as I have somehow lost the ability to copy and paste anything from a Firefox window or address bar into another document ie... email, word, text edit, at… (read more)

I am going crazy as I have somehow lost the ability to copy and paste anything from a Firefox window or address bar into another document ie... email, word, text edit, atom—nothing.

I have tried the About:config solution to no avail. Sometimes the copy and paste will work for a minute or so when opening Firefox, but it quickly degrades.

I have looked into settings for the browser as well and I can't find anything that would affect copy and paste. This change seemed to have happen a few weeks ago with an update that was released.

What is happening?!?!?!

Asked by keri.rasmussen 2 months ago

Firefox sync not working

I have Firefox sync on three computers, has worked flawlessly for years, yesterday had to reinstall Windows 10 Pro and all the software that I use, after installing Firef… (read more)

I have Firefox sync on three computers, has worked flawlessly for years, yesterday had to reinstall Windows 10 Pro and all the software that I use, after installing Firefox on this machine by the way it installed the latest version which happened to be Firefox 79. I signed into sync as usual because this is not the first time I've had to do this over the last few years actually about two months ago I did the exact same thing to another computer with no issues on the same account. This time however sync did everything except for all my add ins after waiting, trying to find solutions online etc. etc. gave up, but gave it 24 hours more to try to figure out what was going on. Ran across a few articles that Firefox 79 change something with sync but don't understand exactly what they're talking about why this would affect this installation, so I then looked at the versions installed on each system, my main system is running Firefox 78 or I should say was running Firefox 78 I thought upgrading it to 79 would fix the issue so I did and that did not work. in the meantime I proceeded to uninstall Firefox 79 on the second machine that refuses to sync the add-ons and replace it with Firefox 78, during this process I removed all Firefox entries related to profiles installs updates etc. I tried to wipe every mention of Firefox on the machine as if it never have Firefox installed on it before. Installed 78 signed in to sink expecting everything to work as normal and still nothing it's been two hours since the install I have re-synced multiple times in hopes of getting it to work with no success it appears to sync everything but the add-ons, and yes I have add-ons on the sync list on all computers have double triple and quadruple checked that to make sure . I really don't want to have to manually run from computer to computer to figure out what add-ons I have and all the settings of each one to make it perfect because I have had issues in the past of installing an add-on on one machine and the settings being different on another causing issues between the add-ons would appreciate if somebody could tell me how why or what the hell I'm supposed to do here to make Firefox think actually work again the way it had worked for years I really need these computers identical in every way as i am disabled and have mobility issues such related to all be installing and uninstalling. Thanks for your help in this matter and I'll do my best to answer any questions to help you guys figure this out. Also I'm not even remotely familiar how to file bug reports or anything else so somebody wants to suggest that I would appreciated if they are able to do it on my behalf and I will give them all the information so it's done properly. Thanks againI just noticed that there's troubleshooting information able to be shared this information is being shared from the computer that works absolutely perfect and is the computer I want to sync from below if somebody wants to explain to me how I can get that data and add it to this post so you guys can compare and figure out what the heck the problem is I will do it.

Asked by hillvalleyfarms 2 months ago

Images not preloading anymore on the selected Tab

Hello, I'm expriencing this issue since a few days : The images in the selected tab (the page I'm reading/scrolling into) don't preload anymore. A few days ago, when ever… (read more)

Hello,

I'm expriencing this issue since a few days :

The images in the selected tab (the page I'm reading/scrolling into) don't preload anymore. A few days ago, when everything was fine, I was able to scroll through long pages and all the images were already displayed. Now, whenever I scroll down, the images appear with half a second delay. Once everything has been loaded/displayed once, I can scroll through the page with all the images displayed correctly so I guess this is a matter of Firefox not preloading what's not currently displayed even though it's in the currently read page.

Does anyone know how to fix this please?

Thank you a lot for reading.

Asked by marcel.gavazza 2 months ago

firefox 79.0 fails with "Exiting due to channel error." when PC is sleeping

After upgrading to firefox 79.0 for 32-bit debian linux (from firefox 78.0.2), I've noticed firefox now goes away when the PC is put to sleep and see this error message … (read more)

After upgrading to firefox 79.0 for 32-bit debian linux (from firefox 78.0.2), I've noticed firefox now goes away when the PC is put to sleep and see this error message in logs (1 msg/tab):

   Exiting due to channel error.

Putting my PC to sleep means withdrawing the default route (so only devices on my local network are accessible) and running a screensaver.

Are there any suggestions for fixing this (minor) annoyance? It never happened with the previous firefox 78.0.2.

thanks!

Asked by em2jacks 2 months ago

Firefox always opens bhind other windows

When I open a new firefox browser, it always opens behind other windows on my PC. This just started happening yesterday for no apparent reason. Has anyone else run into … (read more)

When I open a new firefox browser, it always opens behind other windows on my PC. This just started happening yesterday for no apparent reason.

Has anyone else run into this and come up with a solution?

Asked by tasburath 2 months ago

Animated tab moving

So I've decided to give Firefox a try since chrome was eating up my ram and I like it so far except for when you're moving the tabs from another window to another one and… (read more)

So I've decided to give Firefox a try since chrome was eating up my ram and I like it so far except for when you're moving the tabs from another window to another one and to make this easier I'll provide two pictures of what im talking about so I'm wondering if I can move tabs like google on firefox?

Asked by ThimSTR 2 months ago

New UI for tabs in Firefox for Android

Hi. Maybe I havent yet got used to the new tabs, and with time it will be fine, but currently my experience is rather annoying. Yeah, sorry, it sounds silly to use "annoy… (read more)

Hi.

Maybe I havent yet got used to the new tabs, and with time it will be fine, but currently my experience is rather annoying. Yeah, sorry, it sounds silly to use "annoying" as an argument, ...but:

# Ideological issues:

  • Why would you completely change from conventional UI at all, without even any pros in the new solution!? E.g., the only reason why most text editing tools share the same interface over decades is the fact that "most text editing tools share this interface". Thus it is apriory intuitive to use. Some people may use something like Vim, ...but then thay install Vim. And you wount appreciate to get your favorite Notepad turning into something like Vim (you will be simply annoyed due to broken ituition (lets ignore here the pros of Vim)).
  • If I remember correctly, in previous versions tabs were hidden (unless you scroll upwards), so most of the time thay didn't block the view ...so what is the reason/purpose of moving them away from the top pannel to begin with? ...here I must mention that I use it on tablet (and I dont have a smartphone to check it out there), and I can believe that it is easier to navigate in the new vertical layout compared to the horisontal one (if people prefer to hold the phone in vertical orientation; I dont know, seriously). But still, why wouldnt you just accomplishe old interface with that small square button to open the new tabs interface, rather than replacing it completely?
  • What is the point of Collections? ...they are Bookmarks?

# Real issue:

  • When I open tabs being on the, e.g., second page counting from the end(or top in that vertical layout), and I scroll upward to find the next tab (I have to scroll since the topmost visible tab in that layout is the current tab) the whole widget (the box with the list of tabs) gets collapsed by half (so that the top of the widget is at the middle of the screen). It seems like another silly complain, but when you need to switch between a few latest tabs often, you'll be ready to smash you device with the wall. Note: maybe you need to open many tabs to reproduce it.

I love Firefox, and Im not going to switch from it in any case. I just hope to help you in this strange way (...also it is not the most efficient one).

Best Regards, Ivan

Asked by ivanpidhurskyi1997 2 months ago