Showing questions tagged: Show all questions

Websites not working/loading because of CORS

Hello guys, so in the past 2-3 days i started facing Cross-Origin Request Blocked for a lot of websites lets take chatgpt for example, if i visit it i get: Content-Secu… (read more)

Hello guys, so in the past 2-3 days i started facing Cross-Origin Request Blocked for a lot of websites lets take chatgpt for example, if i visit it i get:

Content-Security-Policy warnings 2 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://cdn.oaistatic.com/_next/static/chunks/sso.74deac81d652476b.js?dpl=f90a861ef09abad575887be5d613ce15a4fdb6d9. (Reason: CORS request did not succeed). Status code: (null). The resource from “https://cdn.oaistatic.com/_next/static/chunks/sso.74deac81d652476b.js?dpl=f90a861ef09abad575887be5d613ce15a4fdb6d9” was blocked due to MIME type (“text/plain”) mismatch (X-Content-Type-Options: nosniff).

and its getting so annoying that its blocking a lot of websites, i tried chromium it works fine and works awesomely no cors no problems. I even tried to disable the firefox protection, dns over https on/off, change my main dns upstream, installed firefox developer, compete uninstall/reinstall, cache clear from installers and from firefox it self nothing is working. I will provide firefox developer edition troubleshooting information but keep in mind it doesnt work on both firefox normal and developer

Please any help would be appreciate it.

Firefox v124.0.2-1

Asked by TMU RecKLesS 1 week ago

Last reply by zeroknight 1 week ago

tab crash on redirect to microsoft authentication

On all sites where I need to login with my work account I get a tab crash when the browser redirects to https://login.microsoftonline.com/ac4b0eb0-811e-4ab0-acca-8a870792… (read more)

On all sites where I need to login with my work account I get a tab crash when the browser redirects to https://login.microsoftonline.com/ac4b0eb0-811e-4ab0-acca-8a87079290dc/oauth2/v2.0/authorize?response_type=id_token&scope=user.read......

This is a recent failure (this week), that occured without any changes on my own account to Firefox developer version 121.0b2(64-bits)

I had to install google chrome to overcome this problem. Chrome has no issues with microsoft authentication.

Please solve as soon as possible, otherwise I will be switching to another browser.

Asked by chris vandert 4 months ago

Last reply by TyDraniu 4 months ago

Unable to Log in Google Accounts

Error Message: "Could'nt Sign You In: This Browser or APP May not be Sscure 1. Happened to Both Build 124 and 125 2. Virus Clean 3. Haved tried cleaning the cache and co… (read more)

Error Message: "Could'nt Sign You In: This Browser or APP May not be Sscure 1. Happened to Both Build 124 and 125 2. Virus Clean 3. Haved tried cleaning the cache and cookies

Asked by Samson Z 1 week ago

Last reply by cor-el 1 week ago

can not play live streams at 1080p60

Only in Firefox freeze the live streams in YouTube , Twitch , etc if I set 1080p60 , however if a select 720p60 then the live stream play smoothly . ple… (read more)

Only in Firefox freeze the live streams in YouTube , Twitch , etc if I set 1080p60 , however if a select 720p60 then the live stream play smoothly .

please someone can help me ?

I already try to change somethings in about:config , but nothing change. same issue .

Asked by Ed C:\ 1 month ago

Last reply by zeroknight 1 month ago

Firefox stickers

Hi! I switched to Firefox some years ago for a lot of purposes. Firstly I wanted a secure browser and a browser which help me in web devopment. Currently I use Firefox De… (read more)

Hi! I switched to Firefox some years ago for a lot of purposes. Firstly I wanted a secure browser and a browser which help me in web devopment. Currently I use Firefox Developer Edition on my pc, but I'm writing this message by my mobile phone. I want to represent Firefox with some stickers can I have one to decorate my laptop? Thanks a lot for every thing.

Asked by grottolaluigi516 5 months ago

Last reply by James 5 months ago

found old phone still using Lockwise

I just discovered that the android phone (Samsung A71) I am currently using was in fact still using Lockwise for Auto Fill. How do I force this old copy of Lockwise to d… (read more)

I just discovered that the android phone (Samsung A71) I am currently using was in fact still using Lockwise for Auto Fill.

How do I force this old copy of Lockwise to do a final sync before I uninstall it. I do know that at least some of the passwords stored in it are up to date. At this time, I DO NOT have access to a PC. I DO have access to a more recent android phone (Samsung A53 5G) that DOES NOT have Lockwise installed and is using the most up-to-date version of FireFox for Android.

Also is firefox typed out in lowercase or one of these ways: "Firefox" or "FireFox"? I have a habit of camelcasing some computer terms left over from my days as a UNIX Administrator (AT&T Bell Labs versions and not any BSD versions) and want to know the proper way to type it (from the horse's mouth so to speak).

Regards

Asked by Evil Dave of Canada 2 months ago

Last reply by Paul 2 months ago

Highlighting in PDFs using native tools.

Hello, as of recently Firefox got the new tool to highlight text in the native PDF viewer, and I really enjoyed using it. As of today, I had not updated or changed versio… (read more)

Hello, as of recently Firefox got the new tool to highlight text in the native PDF viewer, and I really enjoyed using it. As of today, I had not updated or changed versions, but I suddenly lost access to the highlight tool option. Refreshing the page didn't work, downloading a new PDF and opening it didn't work, restarting Firefox didn't work, and I haven't seen anybody else have this issue.


Firefox Version> Firefox Developer Edition 125.0 Beta 8 (20240403091602) OS> Windows 11

I don't know if this is just an issue due to it being in beta, or it being on beta 7 but not 8, but either way any solution is appreciated!

Asked by Missing 1 week ago

Last reply by zeroknight 1 week ago

How do I add the new bookmarks at top of the list in their folder?

When you add a new bookmark to a folder it's added at the end of the existing list. Is there a way to make Firefox add it at the top of the list, instead? I found an ol… (read more)

When you add a new bookmark to a folder it's added at the end of the existing list.

Is there a way to make Firefox add it at the top of the list, instead?

I found an old answer, but, sadly, the extension granting my wish is no longer.

Also, I already know about sorting, but it's not what I need, because I'm doing a lot of manual bookmarks reordering and sorting will nullify it.

Thank you :)

Asked by G 1 month ago

Last reply by jscher2000 - Support Volunteer 1 month ago

Tab Grouping app replacement or work-around

I am trying to migrate from a very old version of Firefox (v. 55) to the current one, but there is an app that is more helpful to me that all the other features combined.… (read more)

I am trying to migrate from a very old version of Firefox (v. 55) to the current one, but there is an app that is more helpful to me that all the other features combined. That is the "Tab Grouping" app that will not run in any version of FF higher than v. 55.

In my work, which often includes a tremendous amount of research, I need to be able to quickly go from one group of tabs to another. If I had to open all these sites manually, that would take the better part of the day and frankly I don't have near the mental capacity to remember the tremendous number of tabs. I have had a couple replies (Thanks!) to this question sometime back, but unfortunately none were even close in performance.

So, can anyone direct me to an app that will allow very quick movement from different sets of windows/tab groups (please see screen shots below)? Is there anyway that I can get this app to work in Legacy mode? I have several other old apps that work perfectly well in this mode.

Asked by Wolfgang Rotbart 4 months ago

Last reply by Wolfgang 4 months ago

about:config on Android

I have used Firefox on many systems - MacOS, Linux, Winblows and mainly Android Cellphone. "about:config" on a Cellphone has never worked, never worked consistently, or … (read more)

I have used Firefox on many systems - MacOS, Linux, Winblows and mainly Android Cellphone.

"about:config" on a Cellphone has never worked, never worked consistently, or mainly been confused with Desktop Firefox :P

Hello?!? The future is mobile not stationary desktops  :P But I digress. Please dont misunderstand me - I love FF - but when I want "about:config" on A Cellphone - I WANT IT to actually work on a freaking cellphone  :P

Is the software config too much for International Mozilla to understand? Or has Mozilla had way to much input from everyone on the planet thus watering down an otherwise great browser?

Kind of rhetorical - I know it will never be fixed in favor of locking in a dieing desktop setup  :P

CYa/Bill

Asked by Bill Jones 5 months ago

Last reply by Paul 5 months ago

New Firefox GPC 120 setting causes problems on Xfinity community forum

I just updated to Firefox 120, and tried the new GPC setting (Tell websites not to sell or share my data). I ran into a problem when I went to the Xfinity community forum… (read more)

I just updated to Firefox 120, and tried the new GPC setting (Tell websites not to sell or share my data). I ran into a problem when I went to the Xfinity community forums (https://forums.xfinity.com/) . It causes a banner on top showing they recognize the setting. There is an "X" in the corner, and some text that says "Hide this banner", but they are not active. Plus, I cannot make a new post or do a general reply (that weird forum software has both local replies to a particular post and general replies to the general thread.)

Is this a bug in Firefox, or a bug in their forum software? I attached a picture of the message it gives.

Asked by andyross 4 months ago

Last reply by zeroknight 4 months ago

playing video on youtube is always choppy!

To be really homest, I never had this kin of problem in chrome, your youtube video player has too many bugs. The issues I've faced are: 1.Whenever I play a video, it is a… (read more)

To be really homest, I never had this kin of problem in chrome, your youtube video player has too many bugs. The issues I've faced are: 1.Whenever I play a video, it is always choppy which is so frustrating. 2.This happened so many times, when I turn switch into full screen mode the whole app crashes.

Please look into this issue, I like the UI and that is the reason why I'm still using mozrilla on my phone.

Asked by yandada.lalit 2 months ago

Last reply by Paul 2 months ago

Firefox v122 --profile option is not working properly

Hi, I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap) and when using the --profile option to specify the startup pr… (read more)

Hi,

  I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap)

and when using the --profile option to specify the startup profile it fails to start even on a NEW system that never ran Firefox if I give it a directory that resides on a mounted ext3 filesystem.

  All the permissions are OK and yet running strace I see an error and after a few second will get the

generic pop-up with the error message: (after a few seconds)

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

 Running the SAME from /tmp works fine, but I need the profile to reside on a persistent storage area

so if the LIVE distro restarts then it can restore the previous session, bookmarks, options, etc...


============================================================
 The 2 directories were created identically and have the exact same permissions:

xubuntu@xubuntu:~$ mkdir /tmp/firefox3

xubuntu@xubuntu:~$ mkdir /media/xubuntu/sys_n01_home/mozilla/firefox3

xubuntu@xubuntu:~$ ls -ald /tmp/firefox3 drwxrwxr-x 17 xubuntu xubuntu 1080 Jan 21 22:05 /tmp/firefox3

xubuntu@xubuntu:~$ ls -ald /media/xubuntu/sys_n01_home/mozilla/firefox3 drwxrwxr-x 17 xubuntu xubuntu 4096 Jan 21 21:13 /media/xubuntu/sys_n01_home/mozilla/firefox3

============================================================

The only difference is that one is mounted on tmpfs and the other is on /dev/nvme0n1p2:

xubuntu@xubuntu:~$ df -k /tmp/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on tmpfs 32560016 351528 32208488 2% /tmp

xubuntu@xubuntu:~$ df -k /media/xubuntu/sys_n01_home/mozilla/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on /dev/nvme0n1p2 195751828 51056068 142695768 27% /media/xubuntu/sys_n01_home


============================================================

When starting firefox with the /tmp/firefox3 profile directory it works fine and starts up:

xubuntu@xubuntu:~$ firefox --profile /tmp/firefox3

newfstatat(AT_FDCWD, "/tmp/firefox3", {st_mode=S_IFDIR|0775, st_size=1040, ...}, 0) = 0 newfstatat(AT_FDCWD, "/tmp/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/tmp/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=-487933736}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0 uname({sysname="Linux", nodename="xubuntu", ...}) = 0


BUT when using the persistent storage on the real filesystem (but SAME exact permissions) it fails:

newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3", {st_mode=S_IFDIR|0775, st_size=4096, ...}, 0) = 0 newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=1519466008}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = -1 EACCES (Permission denied) close(11) = 0

Am I doing anything wrong or is this some weird startup issue / race condition in the parentlock management?

Thank you for looking into this.

  -Sanjiyan

PS: I can upload the full strace file for both scenarios if needed. Thanks again.

     running on an xubuntu distribution "22.04.2 LTS (Jammy Jellyfish)"

Asked by Sanjiyan 2 months ago

Last reply by zeroknight 2 months ago

error when using cell app android firefox 121 teying to sign onto cocofa.net website

error text - " Firefox cannot verify application " when I enter email and password on cocofax.net login, scrwen just sits … (read more)

error text - " Firefox cannot verify application "

when I enter email and password on cocofax.net login, scrwen just sits

Asked by Steve Alan Taylor 4 months ago

Last reply by Paul 4 months ago

Firefox Developer Edition starts up at a fixed position and size

I am running Firefox Developer Edition (123.0b1) on Windows 11 and every time I start Firefox it maximises and then resizes to a set size with the maximise button set to … (read more)

I am running Firefox Developer Edition (123.0b1) on Windows 11 and every time I start Firefox it maximises and then resizes to a set size with the maximise button set to restore size mode (I.e. the window thinks it is maximised). I have followed the steps detailed for this question: https://support.mozilla.org/en-US/questions/1411093 however that does not resolve my issue. This has only started recently after I turned the laptop into a tablet and back again. Once I "restore" the window and then I maximise the window it works as expected. However it is very annoying. Also if I start another instance of Firefox this new instance does not exhibit the same behavior.


Computer: HP Envy OS: Windows 11 with all current updates and as far as I can tell AI is turned off using a group policy.

Asked by graham.harris.1975 2 months ago

Last reply by zeroknight 2 months ago