Showing questions tagged: Show all questions

Slow Firefox

System: MSI B640 Tomahawk. I5 10600KU 32GB RAM Video: MSI 3070 X3 System Drive: 250GB fast Samsung SSD, with 50% free. System OS: W10Pro_x64 21H1, Defender, no Firewall,… (read more)

System: MSI B640 Tomahawk. I5 10600KU 32GB RAM

Video: MSI 3070 X3

System Drive: 250GB fast Samsung SSD, with 50% free.

System OS: W10Pro_x64 21H1, Defender, no Firewall, no extra AV. Firefox_93.0_x64

Network: TYPE: Dedicated FIBER LAN Provider: Telenet Account Type: FIBER_200 Plus +


Addons: Adblock + µblock FBPurity Block Sender New Tab Override Cookie Manager and Cookie quick Manager Auto-High-Quality for youtube Ant Downloader Video Downloadhelper Cute Save Button WebP Image Converter Translate Web Page

Additional Information: Open Pinned Tabs: In between 25 and 60, depending on my current activities.

Tried: Disabling each add-on until all were off. Safe Start. Nothing helps.

Understandings: 1) No browser is made to run up to 60 open tabs (possibly even more)!!! 2) I run a "plethora" (compared to most users) if add-ons; these also bring the use speed down. 3) Resource used: 2GB (with "mere 30 pages" open.

BUT: DESPITE that: I ALSO understand that, considering my system and Network Type, it should not even be problematic with 200 pages open at once. 2GB over 32GB of RAM? Not the slightest issue (and it often runs at 4GB RAM in use). My CPU never runs half high, even when I have like 60 pages open: Should not be an issue then either. My Video Card has plenty resource over as well when at highest for me usage." Again, it should be no issue. My Fiber Netware? Telenet BVBA, Mechelen Test results: Ping: 5ms Jitter: 2ms Download: 904.2 Mbps Upload: 038.3 Mbps Not the best, not the worst, but for simple browsing, more than, I would assume, plenty.

So, what gives, what is the issue? No extreme strain on the system, no background high-resource issues, sure: one or two add-ons in Firefox but these as well do not strain my system, no AV issues, no Firewall issues (I turned that off, I fail to get the need for one as a house-dog-tree user), yet slow performance. Also, while 30'ish tabs running, 2GB used of RAM? My my, what the hell do they do as Site Admins to have these amounts (and NO, I do not do porn, thank you.  :P I am well aware of other people having insane issues surfing porn, as I helped many of these folks)? Sure, Deviant is a larger one that is open, being a graphical site, but like Quora, FB, Hot- and G-Mail and similar, these ain't, so to get a 2GB usage is weird, I would assume. I said, assume: yes, I am not specifically an internet know-all, I know of networking as a former NOVEL Netware Supervisor under UNIX (also Spupervisor), but Networking in a company is not the same as internet.

So, what is going on, why is my browser so slow? Having turned of all and 1 page open it's lightning fast, but now ... So, it is the open tabs, and the add-ons, though when turned off, I see no real difference. Brings it to tabs. How come, it is this "heavy", even for my system, please?

Thank you. Xog.

Asked by Xogroroth 1 week ago

Last reply by Xogroroth 3 days ago

How do I disable the "Forget About This Site" warning?

The latest update added a new warning to the "Forget About This Site" feature. I use this sometimes, and when I saw this warning for the first time yesterday, I knew it w… (read more)

The latest update added a new warning to the "Forget About This Site" feature. I use this sometimes, and when I saw this warning for the first time yesterday, I knew it was going to be a pain in the arse. I understand it's useful to some people, but I do not want to see it every time. How do I disable this warning?

Asked by David_H23 1 week ago

Last reply by David_H23 2 days ago

Google pages fail to load at random intervals

Firefox will randomly stop resolving google search results. At random times, no search entered at the top url bar will resolve. The browser will just change the text in t… (read more)

Firefox will randomly stop resolving google search results. At random times, no search entered at the top url bar will resolve. The browser will just change the text in the bar, and then won't do anything else. If there is a Google page already open, it won't load any links from the results. Google.com won't even load. This typically lasts about 2-5 minutes.

I've seen this in both Windows and Linux. Linux Builds I've tested were the Flatpak from flathub, the snap, the Fedora Repo, and the Tarball binary. They all had the same result after a while of using it. This also happens on both my home network as well as my work network.

I have cleared my profile by manually deleting the folder in appdata or in ~/.mozilla, and tested with no extensions and no setting tweaks. The only tweak I made is disabling DNS over HTTPS. If I change the default search engine to DuckDuckGo or something else, It no longer happens. but that's because it's not trying to access a google domain.

I have attached a gif of my issue.

Asked by Joshua 1 week ago

Last reply by Joshua 1 day ago

Having to fix FF93 problem only with Windows Recovery

FF 93.0 64-bit - Windows 10 When I booted up the system and ran FF the first time for the day, its window opened, and it even asked for the primary password. After that, … (read more)

FF 93.0 64-bit - Windows 10

When I booted up the system and ran FF the first time for the day, its window opened, and it even asked for the primary password. After that, nothing I typed in the URL box came out. I could open new tabs but not able to switch to them. All Chromium-based browsers and Edge in the same system worked fine.

I did the following trying to fix the problem: I restarted Win10 and ran FF93. Same problem. I restarted using Troubleshooting Mode. Same problem. I reinstalled using the complete package. Same problem. I installed using FF92 and FF91. Same problem. I refreshed FF93 using Troubleshooting Mode. Same problem. I used Win10 Safe Mode to run FF93. It worked. I uninstalled FF93, removed as much as I could all traces of FF and Mozilla in the Win registry, and reinstalled FF93. Same problem.

In the end, I had to use Win10 Recovery and revert to an earlier date to fix it.

The first incident happened about two weeks ago. It happened again this morning. My use of PC has been routine for years, I would say for more than a decade, or at least in the last five years. No extraordinary applications or routines.

BTW, I haven't updated my Win10 in years, because doing so often times gave me new mysterious issues to troubleshoot, courtesy of MS. You should very well know Win updates produce issues, and the bug fixes following them produce even more. The annoying thing is I would research on the issues and find out later (sometimes days) that the updates were the culprits.

This is the second time it happened to my FF93, and I feel I have to report this to get some idea about why this is happening (only to me?) and how to fix or prevent it without having to go into Recovery (again?).

Asked by mobilesuit600 3 days ago

Last reply by mobilesuit600 2 days ago

Automatic calls to many Google services on launch (Windows 10, desktop)

Hello! Something in my Firefox installation seems to be making several Google network (google.com / forcesafesearch.google.com / www.youtube-nocookie.com / m.youtube.com,… (read more)

Hello! Something in my Firefox installation seems to be making several Google network (google.com / forcesafesearch.google.com / www.youtube-nocookie.com / m.youtube.com, and a couple of others) calls shortly after launch. I have a DNS sinkhole, so that is how I can see.

I have a few reputable extensions (or should be, from EFF, Firefox itself, or Ublock Origin), but it also happens in safe mode. I went through a good chunk of this: https://support.mozilla.org/en-US/kb/how-stop-firefox-making-automatic-connections and still the calls occur

I am on Windows 10, with FF v93.

Thanks very much!

Asked by hiciya6568 6 days ago

Last reply by hiciya6568 3 days ago

Bookmark sync accross devices

Hello, I have 4 devices (2 laptops, 1 phone and 1 PC), which I logged in to my Firefox account in all of them. I can see my bookmarks in all except for the PC (Windows 10… (read more)

Hello,

I have 4 devices (2 laptops, 1 phone and 1 PC), which I logged in to my Firefox account in all of them. I can see my bookmarks in all except for the PC (Windows 10). I can not see my pc under the connected devices from all other devices but I can not access my bookmarks from the browser that I am using on my PC. Can you please guide me how to fix this issue.

Thank you, Afsane

Asked by af.baghestani 3 days ago

Last reply by af.baghestani 22 hours ago

BSOD DRIVER POWER STATE FAILURE

I am using a Cambio W101 tablet with windows 10 21H1 and Firefox 93.0. After getting the BSOD with the error message DRIVER POWER STATE FAILURE I followed the recommen… (read more)

I am using a Cambio W101 tablet with windows 10 21H1 and Firefox 93.0.

After getting the BSOD with the error message DRIVER POWER STATE FAILURE I followed the recommended suggestions like checking the drivers, removing the sleep mode, changing the power options.

I continue to get the BSOD only in one specific situation but frequently. It is when I use Libreoffice as my active window, while Firefox is inactive in the background. When I use either only Libreoffice or only Firefox as my active window nothing happens. There has also not been problems with other programs.

Does an inactive Firefox do something which triggers the BSOD?

Asked by walumg 3 days ago

Last reply by walumg 3 days ago

facebook viseo do not have sound automatically

bold text recently i updated my realtech audio and now when i go to Facebook and playa video the video starts but i have to always clickon the sound. i have… (read more)

bold text recently i updated my realtech audio and now when i go to Facebook and playa video the video starts but i have to always clickon the sound. i have allow auto play but it does not open the sound i have to manually hit it

Asked by Mary 2 days ago

Last reply by Mary 1 day ago

Is My Browser Compromised?

I noticed the following message at the top of my browser settings page - "Your browser is being managed by your organization." Except, this is on my home computer and not… (read more)

I noticed the following message at the top of my browser settings page - "Your browser is being managed by your organization." Except, this is on my home computer and not being managed by an organization. Is my browser compromised?

Asked by jclane64 6 days ago

Last reply by jclane64 6 days ago

Play MP4 video

How do I reset the settings so I can play MPeg4 videos in the browser without a dialog box asking to download it? I've tried going under Settings but it won't let me sel… (read more)

How do I reset the settings so I can play MPeg4 videos in the browser without a dialog box asking to download it? I've tried going under Settings but it won't let me select "Open in FireFox."

Asked by bneri001 1 day ago

Last reply by bneri001 18 hours ago

Please unlock my account (valid email)

Hi, I have been using Firefox sync for many years now. I just got a new computer and when I tried to connect with my account, I received a message saying Firefox has lock… (read more)

Hi,

I have been using Firefox sync for many years now. I just got a new computer and when I tried to connect with my account, I received a message saying Firefox has locked my account.

Would you please fix this asap? I use your browser to work and not having my account back would force me to switch to Chromium, which I don't want to. Please note my account and my email address are both legit. Thanks

Asked by Ramen 4 days ago

Last reply by Ramen 4 hours ago

blocking email contacts

Firefox is blocking several of my email contacts, without my consent. I would like these restored as I have signed up for these emails. Any help would be appreciated! … (read more)

Firefox is blocking several of my email contacts, without my consent. I would like these restored as I have signed up for these emails. Any help would be appreciated!

Asked by grammiepnut 3 days ago

Last reply by grammiepnut 2 days ago

Frequent page crashes on a variety of sites

Here are some crash report IDs: bp-b62fab6a-df71-4382-bea5-d03050211024 bp-91a966b5-2a88-4712-b169-8f8dc0211024 bp-b8403004-faf3-4e38-a07d-201230211024 bp-666b6fbf-ecf4-4… (read more)

Here are some crash report IDs:

bp-b62fab6a-df71-4382-bea5-d03050211024 bp-91a966b5-2a88-4712-b169-8f8dc0211024 bp-b8403004-faf3-4e38-a07d-201230211024 bp-666b6fbf-ecf4-4085-9ac8-58dae0211024

Asked by sglenn06 1 day ago

Last reply by sglenn06 1 day ago

https-only mode is warning me against sites that are https

I have enabled https-only mode, but now Firefox is warning me against accessing various perfectly OK https sites, e.g. https://www.totalenergies.fr … (read more)

I have enabled https-only mode, but now Firefox is warning me against accessing various perfectly OK https sites, e.g. https://www.totalenergies.fr

Asked by BarbaraD 2 weeks ago

Last reply by BarbaraD 6 days ago

menus very short

All the firefox menus are suddenly very short. Unable to take screen shot as when I try with the Snipping Tool, the menu disappears. Windows 10, Firefox version 93.0 (6… (read more)

All the firefox menus are suddenly very short. Unable to take screen shot as when I try with the Snipping Tool, the menu disappears. Windows 10, Firefox version 93.0 (64 bit)

Asked by jvosburgh15 5 days ago

Last reply by jvosburgh15 4 days ago

Can't play videos from streaming sites with drm, like netflix

Starting a few weeks ago firefox refuses to play video from netflix and prime video. I've googled a bit, but nothing worked. Using firefox 93.0 on windows 10, here is wha… (read more)

Starting a few weeks ago firefox refuses to play video from netflix and prime video. I've googled a bit, but nothing worked. Using firefox 93.0 on windows 10, here is what I tried so far (not necessarily in that order):

  • Refresh page
  • Restart PC
  • clear cache
  • disable extensions
  • run in troubleshoot mode
  • refresh firefox profile
  • try a new firefox profile
  • reinstall firefox
  • checked whether the drm box is checked/checked and unchecked it a few times
  • reinstalled widevine
  • checked whether privacy.resistFingerprinting is false, since someone apparently had a netflix error related to that setting

Probably forgot some. Also works fine on other browsers, just thought it was odd.

Here is what the errors in the debugger say:

on prime video:

downloadable font: download failed (font-family: "Amazon Ember" style:normal weight:400 stretch:100 src index:0): status=2152398850 source: https://m.media-amazon.com/images/G/01/AUIClients/AmazonUIFont-amazonember_rg-cc7ebaa05a2cd3b02c0929ac0475a44ab30b7efa._V2_.woff2 The Components object is deprecated. It will soon be removed. amzn1.dv.gti.82b45cf3-7c88-8d4b-e754-2c59839b982d:2494:148 Content Security Policy: The report URI (about:blank) should be an HTTP or HTTPS URI. Content Security Policy: The page's settings observed the loading of a resource at blob:https://smile.amazon.de/15296b51-1883-49bd-b738-ab0bd00e2a82 ("worker-src"). A CSP report is being sent.

on netflix:

Content Security Policy: The report URI (about:blank) should be an HTTP or HTTPS URI. browse:194:28 Content Security Policy: The page's settings observed the loading of a resource at https://www.netflix.com/service-worker.js ("worker-src"). A CSP report is being sent. browse:194:28

Asked by lichterbring 3 hours ago

Last reply by lichterbring 3 hours ago

Firefox keeps redirecting my localhost web page to another internet domain

I am a web developer who often writes websites on my own local computer. I use Apache web server, and using both the httpd.conf file and Windows' "hosts" file ( C:\Window… (read more)

I am a web developer who often writes websites on my own local computer. I use Apache web server, and using both the httpd.conf file and Windows' "hosts" file ( C:\Windows\System32\etc\hosts ) I can make an alias for 127.0.0.1, otherwise known as localhost. Because my name is greg, I can add a server name to my localhost, like http://greg/test.html.

This works pretty well, but sometimes when I add a new alias, like greg or gregory, Firefox doesn't pick up on it right away. I can go to http://greg/test.html in Chrome, and it goes to the local web page just fine. But if I try it in Firefox, it tries to redirect me to "http://www.greg.com". The usual fix is to go into Settings -> Privacy & Security -> Cookies and Site Data -> Clear Data -> Cached Web Content, then press CLEAR.

But this doesn't always work, and it seems like no matter what I clear, Firefox insists on not looking up my local server alias, but instead redirects me to https://www.greg.com.

How do I force Firefox to look for http://greg/ only on my local server?

Asked by gregory.george.lewis 6 days ago

Last reply by gregory.george.lewis 6 days ago

Adding custom fonts (system-installed fonts)

Hi! I want to change the default serif and monospace fonts (Atkinson Hyperlegible and Hack, respectively) in Firefox. However, the fonts that are listed in the advanced f… (read more)

Hi!

I want to change the default serif and monospace fonts (Atkinson Hyperlegible and Hack, respectively) in Firefox. However, the fonts that are listed in the advanced font settings appear to be a specific list that doesn't update with the system-installed fonts, so I cannot pick the previously mentioned fonts. I tried working around by tweaking with the about:config values, but so far no luck. Any advice?

Thanks in advance, Lucas

Asked by Lucas 4 days ago

Last reply by Lucas 2 days ago