Showing questions tagged: Show all questions

FireFox Loads Every ASP page twice. Debugging assistance needed

I have a shopping cart that is now breaking, despite working without a hitch for many years. The behavior happens only when using the FireFox browser. Does not happen on… (read more)

I have a shopping cart that is now breaking, despite working without a hitch for many years. The behavior happens only when using the FireFox browser. Does not happen on Chrome, Edge, Android, etc. I am seeing this behavior from any customer visiting the cart using FireFox. Every ASP page loads twice. A customer puts quantity 1 in their cart, they are presented with an order of 2. I have traced execution, and every ASP page loops thru twice.

After significant debugging, I have the problem stripped down to the simplest form. ASP page consisting of nothing but VBScript which writes a record to a SQL database. Every write happens twice. Debugger shows 2 GETs -- the ASP page and Favicon.ico Tried to nullify favicon, but the problems remained

Below is the stripped down code. Fairly basic. Creates 1 record in the SQL database under other browsers, creates 2 records under FireFox. Any assistance would be most appreciated. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

<% 'DEFINE SQL DATABASE CONNECTION STRING

dim pDatabaseConnectionString, pTrapDbErrors

' database (access, sqlserver, mysql) private const pDataBase = "sqlserver"

' input string filterin type (1-3 being 1 hard, 3 light) pFilteringLevel = 1

' SQL Server local or remote IP in SERVER=

 pDatabaseConnectionString = "Provider='SQLOLEDB';Data Source=HARBORSALES;Integrated Security='SSPI';Initial Catalog='HarborSales'"

' error debug level, trap common DB errors pTrapDbErrors=-1 %> <% ' MAIN ROUTINE -- WRITE A SINGLE RECORD TO THE TABLE. ' THIS ROUTINE RUNS TWICE IN FIREFOX, ONLY ONCE IN OTHER BROWSERS on error resume next

call customerTracking("dummyTrack2.asp", request.querystring)

%>

<% ' SQL INSERT STATEMENT INTO THE DATABASE function customerTracking(pAction, pMisc)

dim rstempgSN, pIdCustomer, pDate, pHour

  mySQL="INSERT INTO customerTracking (idCustomer, action) VALUES ('99','dummy')"
 call updateDatabase(mySQL, rstempgSN, "customerTracking")    

end function %>

<% ' CALLED DATABASE ROUTINES HERE. 'OPENDB(), UPDATEDB(), CLOSEDB() function openDb()

if varType(Cnxn)=0 or varType(Cnxn)=1 then   
  set Cnxn	= CreateObject("ADODB.Connection") 
    
  Cnxn.Open pDatabaseConnectionString
end if   
 
  set openDb = Cnxn

end function


sub updateDatabase(mySQL, rs, scriptName)

 on error resume next 
  set Cnxn = openDb()
  set rs = CreateObject("ADODB.Recordset")
 Cnxn.execute(mySQL)

end sub


function closeDB()

 on error resume next
 rs.close
 set rs 		= nothing 
 Cnxn.close
 set Cnxn	 	= nothing

end function

%>

Asked by Dave Riba 3 hours ago

Last reply by Dave Riba 28 minutes ago

Problems loading some websites.

I just replaced my MacBook Pro with a newer one, running the same OS (10.15.5). I migrated everything onto the new laptop from my Time Machine back-up disc. Everything se… (read more)

I just replaced my MacBook Pro with a newer one, running the same OS (10.15.5). I migrated everything onto the new laptop from my Time Machine back-up disc. Everything seemed fine until I discovered that certain websites were not loading properly. Examples: Weather Underground starts to load but almost immediately goes to white screen. Bank and credit card sites display the Log In page properly, but once I log in the screen goes white. The site of one newspaper to which I subscribe opens with proper text and formatting, but no photos (white where photos should be), and the sites topmost menu bar functions do not respond, so I cannot even log in (other newspaper sites I subscribe to seem to be fine).

The problem sites loaded and operated fine when I tested them with Safari, but I am a longtime Firefox user and prefer it (especially since Safari apparently no longer supports Dashlane).

I tried changing my Firefox privacy & security setting to Standard. I have restarted Firefox and my laptop repeatedly while trying the few things within my ken. Any help would be appreciated.

Asked by CTYanqui 5 hours ago

Last reply by CTYanqui 3 hours ago

Can't login to Facebook: "The page isn’t redirecting properly"

Hi: so, for the last couple weeks or so, I've been unable to login to Facebook. I think this may have occurred after updating to the then-latest version of Firefox, but I… (read more)

Hi: so, for the last couple weeks or so, I've been unable to login to Facebook. I think this may have occurred after updating to the then-latest version of Firefox, but I can't be sure of that. When I try to log in, I get this message:


The page isn’t redirecting properly

An error occurred during a connection to www.facebook.com.

This problem can sometimes be caused by disabling or refusing to accept cookies.


I've tried clearing Facebook's cookies, clearing all cookies/cache data, and then refreshing Firefox. None of this has helped. (Meanwhile, Facebook sends me a "Is this you?" e-mail every time I try to log in...) Currently using Windows 10, and the latest version of Firefox.

Any help would be very much appreciated!

Asked by rperera00 1 day ago

Last reply by rperera00 1 day ago

The copy text tool bar isn't always showing up

Sometimes when I long press and highlight text the toolbar containing the option to copy text doesn't show up at all. Right before this I was reading the coment section o… (read more)

Sometimes when I long press and highlight text the toolbar containing the option to copy text doesn't show up at all. Right before this I was reading the coment section of a disqus story and trying to copy a link, and can't do so at all. No where in the cimmeny section is letting me copy text even if I refresh the page.

Asked by kioku119 1 day ago

Last reply by kioku119 1 day ago

oxid-shop login no longer works under Firefox

I think this is a problem of Firefox, because the login in my oxid shop works under MS Edge. Anyway, in Firefox I see the login window of oxid but despite entering the co… (read more)

I think this is a problem of Firefox, because the login in my oxid shop works under MS Edge.

Anyway, in Firefox I see the login window of oxid but despite entering the correct access data, I do not get into the oxid backend. The login window is always there.

Asked by gilada22 3 days ago

Last reply by gilada22 4 hours ago

Firefox on Chromebook does not recognize full screen

Firefox on my Chromebook does not recognize the full screen. This is true even when I check the "Request desktop site", and the URL shows that it is using it. It often le… (read more)

Firefox on my Chromebook does not recognize the full screen. This is true even when I check the "Request desktop site", and the URL shows that it is using it. It often leaves some of the display off-screen. Some pages in Facebook say "Expand your browser window to see this story" when the window is expanded to full already. Even the Firefox help website itself does not display the full screen. The Chrome browser, for all practical purposes, is using the desktop version of the browser. Is there a Firefox setting or version that I can use to accomodate this?

Asked by sspickering1 3 days ago

Last reply by sspickering1 1 day ago