Showing questions tagged: Show all questions
  • Solved
  • Archived

pulseaudio high CPU with no audio playing

Hey there, I have the following issue with Firefox, is this maybe something I should report to the Ubuntu support or directly to Bugzilla? Steps to reproduce: --- Open … (read more)

Hey there,

I have the following issue with Firefox, is this maybe something I should report to the Ubuntu support or directly to Bugzilla?

Steps to reproduce: ---

  1. Open Firefox
  2. Go to a page that contains an embedded video that is not playing automatically, e.g. https://www.rottentomatoes.com/m/sound_of_metal
  3. Do not play the video

Environment --- User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0 Firefox version: 83.0 (64-bit) pulseaudio version: 13.99.2 OS: Ubuntu 20.10 64-bit Gnome version: 3.38.1 Windowing system: Wayland CPU: Intel® Core™ i7-8565U CPU @ 1.80GHz × 8 RAM: 15,5 GiB GPU: Mesa Intel® UHD Graphics 620 (WHL GT2)

Actual results --- pulseaudio process is spawned and rapidly becomes the most CPU consuming process on my machine (especially after a few seconds, when the Web Content ones start to cool down). Even though no sound is actually played! When switching to another tab with no embedded video, pulseaudio keeps overloading the CPU. This only stops after closing Firefox.

Expected results --- I'm not sure this is what should be expected, but I'll give it a shot:

  • pulseaudio process should only be spawned when actually playing a media that requires audio
  • pulseaudio should not be the #1 CPU consuming process
  • pulseaudio process should at the very least not massively use CPU when no sound is playing

Asked by yarma22 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Trouble importing router certificate for HTTPS

I would like to use HTTPS to access my router's web interface without having to bypass the "Warning: Potential Security Risk Ahead" page. Following my router's instructi… (read more)

I would like to use HTTPS to access my router's web interface without having to bypass the "Warning: Potential Security Risk Ahead" page.

Following my router's instructions I exported the certificate. I then accessed the Privacy & Security settings in Preferences, and under View Certificates I imported the router's certificate.

When opening the HTTPS web interface Firefox reports SEC_ERROR_INADEQUATE_KEY_USAGE.

Asked by Joe Buckner 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Change default bookmark location to "other" instead of most recently used folder

Is there a way that I can change this setting in config rather than downloading an add-on? This changed with the most recent Firefox update for me (I'm currently on 85.0.… (read more)

Is there a way that I can change this setting in config rather than downloading an add-on? This changed with the most recent Firefox update for me (I'm currently on 85.0.1. for Ubuntu). Currently, the default save behavior is for bookmarks to save to the most recent folder you've picked. My preferred behavior would be for all bookmarks to save to "Other bookmarks" until I can file them away later.

Asked by reginakbuhl 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Address Bar Search Not Working

Hi, Firefox 84.0.1 (64-bit) on Linux Mint 18.3 I have the 'Use the address bar for search and navigation' option selected in settings but when I enter a search all I get … (read more)

Hi,

Firefox 84.0.1 (64-bit) on Linux Mint 18.3

I have the 'Use the address bar for search and navigation' option selected in settings but when I enter a search all I get is 'Hmm. That address doesn’t look right. Please check that the URL is correct and try again.'

Any ideas please?

Asked by caned_monkey 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

WebGL stopped working after the Firefox 88 upgrade

Per the title, webgl suddenly stopped working a couple days ago. The error seems to be: WebGL creation failed: * WebglAllowWindowsNativeGl:false restricts context creatio… (read more)

Per the title, webgl suddenly stopped working a couple days ago. The error seems to be:

WebGL creation failed: * WebglAllowWindowsNativeGl:false restricts context creation on this system.

I'm on Ubuntu 21.04 (X, not wayland) with an nvidia graphics card. The "share data" below seems comprehensive, but let me know if any other info will help.

Asked by john588 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Firefox 91 Linux - WebGL stopped working

WebGL has stopped working. I think this has happened with Firefox 91. For example, http://webglsamples.org/aquarium/aquarium.html gives the error Status: WebGL creation f… (read more)

WebGL has stopped working. I think this has happened with Firefox 91.

For example, http://webglsamples.org/aquarium/aquarium.html gives the error Status: WebGL creation failed: * tryNativeGL () * Exhausted GL driver options. (FEATURE_FAILURE_WEBGL_EXHAUSTED_DRIVERS)

I'm running Firefox on Debian on ChromeOS.

On about:support, WebGL 1 Driver Renderer: Red Hat -- virgl WebGL 2 Driver Rendered: Red Hat -- virgl

There are no WebGL errors in about:support

I've tried the Troubleshoot Mode but that made no difference.

Asked by Rob 9 months ago

Answered by Rob 7 months ago

  • Solved
  • Archived

Error code: SEC_ERROR_UNKNOWN_ISSUER on Linux

Surfing https://www.asimmetrie.it/ on Firefox 77.0.1 (64-bit) Linux produce SEC_ERROR_UNKNOWN_ISSUER while no error occurs on Windows. Standing on https://www.ssllabs.com… (read more)

Surfing https://www.asimmetrie.it/ on Firefox 77.0.1 (64-bit) Linux produce SEC_ERROR_UNKNOWN_ISSUER while no error occurs on Windows. Standing on https://www.ssllabs.com/ssltest/analyze.html?d=www.asimmetrie.it Linux is correct because the server's certificate chain is incomplete

Asked by eziogale 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Font wanted isn't the font that's displayed in Linux Ubuntu.

TL/DR: See the image. ;) I'm on Ubuntu 20.04 (Xubuntu flavor), using Firefox 79.0, working on a web site. I'm coding specifically for Arial... and it's returning Times … (read more)

TL/DR: See the image. ;)

I'm on Ubuntu 20.04 (Xubuntu flavor), using Firefox 79.0, working on a web site. I'm coding specifically for Arial... and it's returning Times New Roman.

I have Arial installed, via the ttf-mscorefonts package and also adding them from a Win10 box.

Please, no "But you should do 'font-family: Arial, Veranda, sans-serif'" dismissive answers. Why? Because if I do "font-family: Arial, Veranda" I still get Times New Roman. I can even substitute "Pulsar Beta" here (a font that is installed to my local account) and it still gives me Times New Roman.

If I do "font-family: sans-serif" I get Veranda, not Arial... which is odd because Arial is my default font.

Doing "font-family: Veranda" gets my Times New Roman.

Chrome doesn't have this issue!

As a picture is worth a thousand words, see the pic.

What can I do? I did see some bugs that were fixed in v56, but none of the debugging tips help there.

Asked by STrRedWolf 1 year ago

Answered by STrRedWolf 1 year ago

  • Solved
  • Archived

How to add image to my firefox home page / newtab page?

I am trying to add my own background to the home page but cannot find any way to do it. There must be an option for something so simple somewhere, but I cannot find it. I… (read more)

I am trying to add my own background to the home page but cannot find any way to do it. There must be an option for something so simple somewhere, but I cannot find it. I do not want to install an add-on for this as I am not comfortable handing out my personal info to some random guy or group to accomplish something so simple. Thanks.

Asked by me 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Hide Firefox titlebar (border) in Linux (Openbox)

I use openbox as my windowmanager with NO desktop environment on Archlinux. I want to hide the titlebar (border) but when using openbox this option is NOT SHOWN. It is sh… (read more)

I use openbox as my windowmanager with NO desktop environment on Archlinux.

I want to hide the titlebar (border) but when using openbox this option is NOT SHOWN. It is shown when i use another Desktop Environment like xfce4 or Gnome.

In the past i found out that a variable like DESKTOP_ENVIRONMENT, DE or XDG_SESSION_DESKTOP could be set with the value of another Desktop Environment to mislead Firefox.

However, i can't find the right variable any more and i have been googling and googling for days :-(

Please help, i like openbox & firefox (without titlebar)

Asked by ron80 1 year ago

Answered by ron80 1 year ago

  • Solved
  • Archived

Youtube keeps "pausing" the video im playing

Sometimes when watching youtube the video will be paused, once I unpause it it immediately pauses it again, I dont know when and why this happens but it happens. Only ext… (read more)

Sometimes when watching youtube the video will be paused, once I unpause it it immediately pauses it again, I dont know when and why this happens but it happens. Only extensions are honey, ecosia search and stylus

Asked by atiedebee 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

How can I prevent ctrl+q from closing the browser?

When I click ctrl+q by mistake, the browser window with all its tabs is closed immediately, with no warning. This has already made me lose data. is there a way to disable… (read more)

When I click ctrl+q by mistake, the browser window with all its tabs is closed immediately, with no warning. This has already made me lose data. is there a way to disable this keyboard shortcut?

Asked by Erel Segal-Halevi 2 years ago

Answered by Ruba 2 years ago

  • Solved
  • Archived

Opening a Command Terminal/Window

I am using a Linux/Ubuntu computer. I downloaded a program that instructs me to "Open a browser window" to enter certain commands. I am fairly new Linux user and am req… (read more)

I am using a Linux/Ubuntu computer. I downloaded a program that instructs me to "Open a browser window" to enter certain commands. I am fairly new Linux user and am requesting assistance on how to open a Firefox browser "command" window and enter a Linux command.

Here is the program's URL: https://frontend.bredbandskollen.se/download/README.txt

See Item: --Browser

Thanks for your assistance!

Asked by dwaggoner.phd 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Cursor goes to address bar instead of search bar

In Ubuntu 18.04, I bring up a new page, click in the search bar in the middle of the page. Then when I start typing it jumps to the address bar although I have already pl… (read more)

In Ubuntu 18.04, I bring up a new page, click in the search bar in the middle of the page. Then when I start typing it jumps to the address bar although I have already placed and preferred the search bar to the right. No! NO! NO!

I use Duck Duck Go but Google does the same.

It is bad enough that the upgrade was automatically loaded but on top of that, changing preferences including dumping my home page. Change privacy settings without asking ( to a lower level on top of that ).

Really POOR form.

Asked by dee3 11 months ago

Answered by jscher2000 - Support Volunteer 11 months ago

  • Solved
  • Archived

Firefox 89 on Raspberry Pi - visual codec artifacts

Firefox 89 on my Raspberry Pi 4 is displaying what I'm guessing is a codec issue. Videos can be watched but the picture is corrupted by brightly coloured patches around a… (read more)

Firefox 89 on my Raspberry Pi 4 is displaying what I'm guessing is a codec issue. Videos can be watched but the picture is corrupted by brightly coloured patches around areas of detail.

Prior to the version 89 upgrade, version 88 was working perfectly.

I have Firefox 89 on a Raspberry Pi and a PC. On the PC it still works perfectly, on the Pi video is displayed badly.

On the Pi Firefox 89 is running under Ubuntu 21.04. On the PC Firefox 89 is running under Ubuntu 18.04

Am I alone in this or have others seen the same issue ?

Assuming I am not alone, does anybody have any idea what has gone wrong ?

Asked by vw 11 months ago

Answered by cor-el 11 months ago

  • Solved
  • Archived

Full screen mode not working

For past few days browser fails to go into full screen mode properly. Tabs and url input section remain in sight. Screen mode is toggled with F11 or via menu bar, zoom. P… (read more)

For past few days browser fails to go into full screen mode properly. Tabs and url input section remain in sight. Screen mode is toggled with F11 or via menu bar, zoom. Previously it was working?

Asked by ab2qik 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Installation aborted because the add-on appears to be corrupt

We have a new add-on of our own that we were trying to add to the Firefox browser. This add-on was tested locally and worked fine. However, upon trying to install the off… (read more)

We have a new add-on of our own that we were trying to add to the Firefox browser. This add-on was tested locally and worked fine. However, upon trying to install the official add-on to the browser, it is throwing the following error, "Installation aborted because the add-on appears to be corrupt".

The add-on in question is, https://addons.mozilla.org/en-US/firefox/addon/searchgiggle-search/

Any suggestions to address this issue would be appreciated.

I also noticed another post or two about the same topic. As per those posts, the issue got resolved automatically after some time. Can I expect the same?

Asked by srik.kid2012 1 year ago

Answered by srik.kid2012 1 year ago

  • Solved
  • Archived

Firefox 76.0.1 not playing embedded Twitter videos

On the entertainment media site Buzzfeed, clicking on a post of an embedded Twitter video gives me a blank white image. No error message like "Unable to play the file". I… (read more)

On the entertainment media site Buzzfeed, clicking on a post of an embedded Twitter video gives me a blank white image. No error message like "Unable to play the file". I did a clear history, cache & cookies and refreshed Firefox. I ran the apt update for Ubunto. It had been operating smoothly in the past. If I go to Twitter, it plays. It just goes blank when I click on the video embedded in the post.

Thank you for any assistance.

Asked by varices 2 years ago

Answered by varices 1 year ago