• Solved
  • Locked

Firefox now saves files that I only wanted to open

After today's update to version 98 Firefox keeps saving files to the Downloads folder when I don't want it to, I just want to open them, but not keep them, with this new … (read more)

After today's update to version 98 Firefox keeps saving files to the Downloads folder when I don't want it to, I just want to open them, but not keep them, with this new behaviour the Downloads folder keeps filing up with useless clutter.

For example, before the update, when I downloaded a .zip file, a pop-up would show up asking if I wanted to save the file or open it with an application. If I chose to save it it would be saved to the Downloads folder, and if I chose to open it nothing would be saved to the Downloads folder.

After the update, when I download a .zip file, Firefox always saves the file to the Downloads folder, even if I choose to open it.

Can you please tell me if there is a way to make Firefox behave like in the previous version?

Asked by bayus.firestorm 3 months ago

Answered by bayus.firestorm 3 months ago

  • Solved
  • Archived

How to hide the address/URL bar again ?

Hello all, I run a bunch of web applets locally on my computer for personal use only (http://localhost/...), and until recently I could successfully launch FF using windo… (read more)

Hello all,

I run a bunch of web applets locally on my computer for personal use only (http://localhost/...), and until recently I could successfully launch FF using window.open(...) with the new window NOT showing the address bar (because it takes space and looks ugly within the applet, so I want to avoid it at all cost).

I believe this changed with FF 76 (I now run v. 76.0.1 64-bit on a Windows10 based computer), anyway at this point it seems impossible to NOT have the address bar show up in a FF window. :-/

To be clear : I have searched for a solution in this forum and elsewhere, found the solution to another new problem with FF ("megabar"), also seen the trick to hide the url in the address bar - but this is not what I'm looking for : I just want to *get rid of the address bar*, period.

Thanxx in advance for any help with this issue (surprised noone else seems to complain about this). :)

Asked by cfdhacker 2 years ago

Answered by jscher2000 - Support Volunteer 2 years ago

  • Solved
  • Archived

How can I customise/remove a default keyboard shortcut?

It's good to have those built-in shortcuts, but it's stupid you can't modify them. When I use this website I can't input the division sign by pressing / on the keypad bec… (read more)

It's good to have those built-in shortcuts, but it's stupid you can't modify them. When I use this website I can't input the division sign by pressing / on the keypad because it's the shortcut for Quick Find. I guess this is because the place to input is not a normal text box like in WolframAlpha , but part of the whole webpage(?). Add the function to customise shortcuts is much easier than let Firefox recognise and deal with this situation, I think. In fact, most software supports customising shortcuts, so I'm surprised to find there's no way for Firefox to do that.

Asked by WANGtheneighbor 2 years ago

Answered by McCoy 2 years ago

  • Solved
  • Archived

Can't get Thunderbird to work with Office 365 emails

I tried using Thunderbird to check my Office 365 email, with the following settings IMAP: outlook.office365.com Port: 143 SSL: STARTTLS SMTP: smtp.office365.com Port: 587… (read more)

I tried using Thunderbird to check my Office 365 email, with the following settings

IMAP: outlook.office365.com Port: 143 SSL: STARTTLS

SMTP: smtp.office365.com Port: 587 SSL: STARTTLS

Normal Password

All the settings are retried by Thunderbird once I enter the IMAP and SMTP details.

However upon clicking done, there will be a message saying "Unable to log in at server. Probably wrong configuration, username or password"

I have verified the username and password is correct, and also IMAP enabled for this account, but keep getting password wrong message.

Asked by siewkit84 1 year ago

Answered by siewkit84 1 year ago

  • Solved
  • Archived

stop saving image files as webp

Firefox has been saving images from some sites as webp instead of JPG for a long time. There have been repeated threads on this subject which get locked and then pushed i… (read more)

Firefox has been saving images from some sites as webp instead of JPG for a long time. There have been repeated threads on this subject which get locked and then pushed into the long grass.

Sure, I could botch a solution by installing an add-on to convert them, or I could use something like XnView (which I do, periodically, and in bulk) after the save event has happened, or I can edit about:info to tell Firefox not to accept webp - but this breaks functionality for some sites (like eBay), but I have found that in the end I have had to start switching to Microsoft Edge to do my browsing for a number of sites because Mozilla Firefox are ignoring repeated user requests to provide a simple option to STOP doing this.

I don't want to save any files as webp - save them as PNG if you like, or jpg, but I use an ancient copy (v3.24) of ACDsee (from the days of Windows 98) for my image browsing, sorting, viewing etc because it is perfect, blisteringly quick, has no extra editing or other functionality which I don't need or want, and it doesn't bloat up anywhere with thumbnail files... but sadly webp didn't exist back then so it doesn't support it. I have used a number of much more up to date browser-viewers, but there is nothing can touch this OLD version of ACDsee for basically brilliant design.

I'm not changing my image viewer. It's non-negotiable.

I WILL however change my web browser if I have to, if the developers of the browser continually kick into the long grass to lock, hide away and pretend there's isn't an issue which has been repeatedly flagged as an annoyance for so many users.

I have been using one form or other of 'Mozilla' family of browsers since the days of Quarterdeck Mosaic. I don't particularly want to switch my loyalty, especially to Microsoft, but if they are listening to what customers want and providing it, and Mozilla are not, what else is there to do ?

I am a retired systems developer. I cannot envisage this being SUCH a big ask.

Modern software treats its users like idiots and takes away control, doing everything it's assumes on their behalf that they will want.

It is not difficult to provide an option within settings for when saving webp files to save as webp, png or jpg with conversion if necessary. All you need to do is hear the screams and respond. :)

Asked by Ethan 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Cannot send email with smtp.office365.com

I was connected to O365 with my work email but cannot send any message. IMAP works just fine, all folders synced regularly, but sending not work for some unknown reason.… (read more)

I was connected to O365 with my work email but cannot send any message. IMAP works just fine, all folders synced regularly, but sending not work for some unknown reason.

SMTP setting is as follow: smtp.office365.com port 587 STARTTLS OAuth (this is correct setting, all others shows errors, including outlook.partner.cn & smtp.office365.cn, which is completely normal since I'm not in China).

The first thing that jump out is that my password is not OK, which is not correct. Password is OK. Click on "Retry" or "Enter new password" do nothing, just return the same pop up. If "Cancel", then receiving message with "unknown error 80004005" and all other blablabla about unknown reasons, with instruction to check my SMTP settings.

I've tried all variations available, but nothing works. Sometimes, at some moment after click on Cancel, it said "Message sent" and I can see it in my Sent Items folder, but it's fake because I never receive that test message to my personal Gmail address.

I have already tried all suggestions I could find (deleting passwords, resetting all, restarting, deleting and adding account again, changes in Config editor related to security.tls), but nothing worked for me.

My OS: Win 10 Pro, build 2004, TB version 78.3.2

Any advise is very welcome. Thank you all in advance.

Asked by denexi 1 year ago

Answered by Norbert 1 year ago

  • Solved
  • Archived

Backspace keyboard button not working in Firefox 87

Hello, I just upgraded to Firefox 87 and noticed that I wasn't able to go back to the previous webpage by clicking on the backspace button like what I have done in the pa… (read more)

Hello,

I just upgraded to Firefox 87 and noticed that I wasn't able to go back to the previous webpage by clicking on the backspace button like what I have done in the past if I'm not using a mouse on my laptop and had to click on the back button in the toolbar with the trackpad. I'm not too sure of why that happened with the upgrade and was a little surprised about that. Hope I can be able to get around this in some way if one of you know anything about this. Thanks.

Asked by Anduma22 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

watch video "in" firefox browser

I'm trying to watch videos in Firefox. Youtube works but Xvideos does not. Firefox pops up a window asking me: >> "Opening xvideos"."com ###.mp4". >> whi… (read more)

I'm trying to watch videos in Firefox. Youtube works but Xvideos does not. Firefox pops up a window asking me:

>> "Opening xvideos"."com ###.mp4". >> which is: MP4 Video (16.4MB) >> from https://cdn77-vid.xvideos-cdn"."com >> >> What should Firefox do with this file?

My only choice is: Open with Windows Media Player x86 (default)

suggestions?

I'm running Windows 7 Firefox 76.0.1

Thanks!!!!

Asked by G_Eak 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

you must log in to this network before you can access the internet

Hi everyone, I have this message that appears on every web page but my connection is fine: "you must log in to this network before you can access the internet". It appear… (read more)

Hi everyone,

I have this message that appears on every web page but my connection is fine: "you must log in to this network before you can access the internet". It appeared I don't know how (maybe after using my VPN?) and I can't get rid of it. Any idea?

In advance, thanks a lot.

Asked by jean.souviron 1 year ago

Answered by Scribe 1 year ago

  • Solved
  • Archived

Can't access about:config in new Firefox daylight update of Android

I would like to enable ESNI and bypass ISP watchdogs. So I prefer to keep ESNI on. After last update I'm not being able to access about:config. It shows an error. What's … (read more)

I would like to enable ESNI and bypass ISP watchdogs. So I prefer to keep ESNI on. After last update I'm not being able to access about:config. It shows an error.

What's the issue here, if anybody could help I'd be much obliged. Thank you.

It redirects here:

resource://android/assets/low_and_medium_risk_error_pages.html?&title=Cannot+Complete+Request&button=Try+Again&description=%3Cp%3EAdditional+information+about+this+problem+or+error+is+currently+unavailable.%3C%2Fp%3E&image=&showSSL=false&badCertAdvanced=Advanced%E2%80%A6&badCertTechInfo=%3Clabel%3ESomeone+could+be+trying+to+impersonate+the+site+and+you+should+not+continue.%3C%2Flabel%3E+%3Cbr%3E%3Cbr%3E+%3Clabel%3EWebsites+prove+their+identity+via+certificates.+Firefox+does+not+trust+%3Cb%3Eabout%3Aconfig%3C%2Fb%3E+because+its+certificate+issuer+is+unknown%2C+the+certificate+is+self-signed%2C+or+the+server+is+not+sending+the+correct+intermediate+certificates.%3C%2Flabel%3E&badCertGoBack=Go+Back+%28Recommended%29&badCertAcceptTemporary=Accept+the+Risk+and+Continue

Asked by niazmehedi 1 year ago

Answered by Paul 1 year ago

  • Solved
  • Archived

Enable/disable automatic redirect.

So I was having some trouble a few days ago with a website that automatically re-directed as soon as I landed on it to another page. So I happily went off in the settings… (read more)

So I was having some trouble a few days ago with a website that automatically re-directed as soon as I landed on it to another page. So I happily went off in the settings and disable the automatic redirect. Now a week or two later I'm sitting here going I can't find the setting anymore? I can't even search for it and have absolutely no results you would think searching for "redirect" in the settings pain would bring it up. it's probably something that got buried in developer tools that I would never be able to turn off/toggle again unless I get lucky with the right extremely memorable and easily accessible incantation in the about : config because that's just all so well documented. Is it a "1" is it a "0" is it a "5" which one disabled / enabled what is the other options do?

Asked by iMark77 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Locked
  • Archived

Gmail won't load

Gmail will not load in Firefox, but will in Chrome. I've cleared my history, cookies, and cache. I made sure I had the latest Firefox update, restarted my computer, check… (read more)

Gmail will not load in Firefox, but will in Chrome. I've cleared my history, cookies, and cache. I made sure I had the latest Firefox update, restarted my computer, checked in internet connection, everything I could think of. There is no error message; it just stops loading and the page is totally blank, as you can see on the attached image. I've run out of ideas and know-how. Anyone else had this issue and resolved it?

Asked by jvelmore 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

If I send an email with BCC recipients, can they "reply all" so that everyone sees their reply?

I am sending an email to several people and others as a BCC. If one of those people who receives it as a BCC hits "reply all", will everybody see his reply? Or do BCC rec… (read more)

I am sending an email to several people and others as a BCC. If one of those people who receives it as a BCC hits "reply all", will everybody see his reply? Or do BCC recipients even have the option to reply all?

Asked by relztrah 10 months ago

Answered by maxtheman 10 months ago

  • Solved
  • Archived

Touchpad gestures doesn't work in Firefox. Please add this very useful feature.

Windows 10 gesture two finger swipe left and two finger swipe right doesn't work in Firefox. Two finger swipe left allows user to go history backward and two finger swipe… (read more)

Windows 10 gesture two finger swipe left and two finger swipe right doesn't work in Firefox. Two finger swipe left allows user to go history backward and two finger swipe right allows user to go history forward. These gestures work in Firefox if the user hold Alt key and preform the gestures. But most of the users don't like to hold Alt key and preform the gestures. Please fix that issue.

Asked by Rifat Mahmud 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Locked
  • Archived

HERE is the answer to put "TABS BELOW" which will work with Firefox V90 using the - userChrome.css - file

HERE IS THE ANSWER Here is the answer to get TABS BELOW with Firefox V90 . . copy all of this code below the broken line into your - userChrome.css - file and save it. Yo… (read more)

HERE IS THE ANSWER Here is the answer to get TABS BELOW with Firefox V90 . . copy all of this code below the broken line into your - userChrome.css - file and save it. You can modify the 45px in this line if you wish to get an appropriate height . . just experiment with different numbers till you get it right --menubar-height: 45px; /*30px|41px=11px; caption buttons on menubar*/

Also to make the tabs wider or narrower, modify the line which is coded width: 50vw !important;

Finally you must enable - css - in Firefox, by typing about:config into your address bar, and search for toolkit. When all the toolkit options appear change the one which says toolkit.legacyUserProfileCustomizations.stylesheets to TRUE by click the icon in the right hand column. Than close Firefox and reopen, and check how it looks This will enable your - css - file to be read, and interpreted and accepted by the Firefox browser.

-------------------------------------------------------------------
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* TABS: bottom - Firefox 65 and later - updated for 89+ */
/* https://searchfox.org/mozilla-release/source/browser/themes/shared/tabs.inc.css */
/* https://raw.githubusercontent.com/Aris-t2/CustomCSSforFx/master/classic/css/tabs/tabs_below_navigation_toolbar_fx89.css */
/* https://developer.mozilla.org/en-US/docs/Tools/Browser_Toolbox */

/* ROOT - VARS */
/* you can adjust the CSS variables until it looks correct */
/* you can use the Browser Toolbox to get the toolbar heights */

*|*:root {
  --tab-toolbar-navbar-overlap: 0px !important;

  --tab-min-height: 40px !important;
  --tab-min-width:  60px !important;

  --tab-adjust:  0px; /* adjust tab bar - only for 68-73 */
  --tab-caption: 5px; /* caption buttons on tab bar */
}

/* TAB BAR - below nav-bar */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10 !important;}
#TabsToolbar {-moz-box-ordinal-group:1000 !important;}

#TabsToolbar {
  display: block !important;
  position: absolute !important;
  bottom: 0 !important;
  width: 50vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}

/* navigator-toolbox - PADDING */
*|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  position: relative !important; /*89+*/
  padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*ADJUST*/
  background-color: var(--toolbar-bgcolor) !important;
}

/* TabsToolbar with menubar and titlebar hidden - rules for Firefox 65-73 */
*|*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"]) #toolbar-menubar[autohide="true"] ~
 #TabsToolbar{
  bottom: var(--tab-adjust); /*ADJUST*/
}

/* TABS: height */
#tabbrowser-tabs,
#tabbrowser-tabs > .tabbrowser-arrowscrollbox,
.tabbrowser-tabs[positionpinnedtabs] > .tabbrowser-tab[pinned] {
  min-height: var(--tab-min-height) !important;
  max-height: var(--tab-min-height) !important;
}

#TabsToolbar {
  height: var(--tab-min-height) !important;
  margin-bottom: 1px !important;
  box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important; /*OPTIONAL*/
  background-color: var(--toolbar-bgcolor) !important;
  color:            var(--toolbar-color) !important;
/*  z-index: 1 !important; */
}

/* indicators *//*
*|*:root[privatebrowsingmode=temporary] .private-browsing-indicator {
  position: absolute !important;
  display: block !important;
  right: 0px !important;
  bottom: 0px !important;
  width: 14px !important;
  pointer-events: none !important;
}
*/
.private-browsing-indicator {display: none !important;}
.accessibility-indicator    {display: none !important;}

/* Indicators - HIDE *//*
*|*:root:not([accessibilitymode])             .accessibility-indicator    {display: none !important}
*|*:root:not([privatebrowsingmode=temporary]) .private-browsing-indicator {display: none !important}
*/

/* Drag Space */
.titlebar-spacer[type="pre-tabs"],
.titlebar-spacer[type="post-tabs"] {
  width: 20px !important;
}

/* Override vertical shifts when moving a tab */
#navigator-toolbox[movingtab] > #titlebar > #TabsToolbar {
  padding-bottom: unset !important;
}

#navigator-toolbox[movingtab] #tabbrowser-tabs {
  padding-bottom: unset !important;
  margin-bottom: unset !important;
}

#navigator-toolbox[movingtab] > #nav-bar {
  margin-top: unset !important;
}

/* Hide window-controls and caption buttons on Tab Bar */
#TabsToolbar #window-controls {display: none !important;}
#TabsToolbar .titlebar-buttonbox-container {display: none !important;}

Asked by Trevor George, Bristol, UK 1 year ago

Answered by Trevor George, Bristol, UK 1 year ago

  • Solved
  • Archived

set "print with system dialog" as default

dear ladies and gentlemen, Firefox has been delivered with the new print dialog since version 82. I have to print around a hundred PDF files at work (usually only the fir… (read more)

dear ladies and gentlemen,

Firefox has been delivered with the new print dialog since version 82.

I have to print around a hundred PDF files at work (usually only the first page of the document). The new print dialog means that there is a lot more work for me here.

Is it possible to set the "old" system print dialog by default or to instruct firefox to always print only the first page of the document by default?

Asked by Bruce Wayne 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

How to disable: "Your internet connection was restored" notifications?

How to disable: "Your internet connection was restored" notifications? – Terribly annoying and only started in the last version 77.0.1 very recently. I rather switch to a… (read more)

How to disable: "Your internet connection was restored" notifications? – Terribly annoying and only started in the last version 77.0.1 very recently. I rather switch to another browser if I cannot get rid of this. Checked my 3 plug-ins, but cannot find anything there, nor if it is something on Facebook I cannot find it. Any idea?

Asked by eyeless 2 years ago

Answered by McCoy 2 years ago