X
Tap here to go to the mobile version of the site.

Support Forum

Firefox fails to unload after closure

Posted

I am a veteran Firefox user ( internet user since 1990) & have upgraded to FF 29.0 but ever since upgrading the outstanding problem is almost every time I load a browser session. Once I have finished and close the browser. It seems FF doesnt actually unload FF from memory, so that the next time I attempt to open FF it fails to load and reports the previous session remains open. i.e. is still using memory & has a service/process open. Thus it appears FF fails to actually close one session & unload itself from memory so that a fresh session cannot be initiated. I have to terminate FF with windows task manager before I can re-open a new session. Please can you suggest a solution for this problem. PS: Firefox is working perfectly on my machine apart from this problem.

DELL Vostro 22os computer, OS= windows 7 pro 32bit with SP1, 4 GB memory, AMD 4300/4500 graphics adapter. Ethernet connection to the web over ADSL2 service.

I am a veteran Firefox user ( internet user since 1990) & have upgraded to FF 29.0 but ever since upgrading the outstanding problem is almost every time I load a browser session. Once I have finished and close the browser. It seems FF doesnt actually unload FF from memory, so that the next time I attempt to open FF it fails to load and reports the previous session remains open. i.e. is still using memory & has a service/process open. Thus it appears FF fails to actually close one session & unload itself from memory so that a fresh session cannot be initiated. I have to terminate FF with windows task manager before I can re-open a new session. Please can you suggest a solution for this problem. PS: Firefox is working perfectly on my machine apart from this problem. DELL Vostro 22os computer, OS= windows 7 pro 32bit with SP1, 4 GB memory, AMD 4300/4500 graphics adapter. Ethernet connection to the web over ADSL2 service.

Chosen solution

hello Cyteck, a wild guess: could you try entering "about:config" into the address bar, searching for the preference "network.seer.enabled" and setting it to "false" for testing purposes? thank you...

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Next Generation Java Plug-in 11.5.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.1.151
  • PDF-XChange Viewer Netscape Gecko Plugin
  • VLC media player Web Plugin 2.1.3

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23379 answers

Chosen Solution

hello Cyteck, a wild guess: could you try entering "about:config" into the address bar, searching for the preference "network.seer.enabled" and setting it to "false" for testing purposes? thank you...

hello Cyteck, a wild guess: could you try entering "about:config" into the address bar, searching for the preference "network.seer.enabled" and setting it to "false" for testing purposes? thank you...

Question owner

THANKS very much this does indeed apear to have resolved this matter as far as I can see. I have tested FF openning & closing it. It does indeed unload smaoothly now. THANKS Again much appreciated too.

Kind Regards Ivan

THANKS very much this does indeed apear to have resolved this matter as far as I can see. I have tested FF openning & closing it. It does indeed unload smaoothly now. THANKS Again much appreciated too. Kind Regards Ivan
rggntljr 0 solutions 5 answers

I made this change [it's still set to false] and it seemed to work one time only. But I'm right back to using Task Manager to kill FF29 before I can open a new window. HELP! or give me a "roll back" option to v28

I made this change [it's still set to false] and it seemed to work one time only. But I'm right back to using Task Manager to kill FF29 before I can open a new window. HELP! or give me a "roll back" option to v28
rggntljr 0 solutions 5 answers

Helpful Reply

At least for me, it seems to be more of an issue on my 64 bit Win 7 machine. My 32 bit Win 7 doesn't seem to act up this way. and yes, network.seer.enabled is still set to false and I continue to have to use Task Manager to kill FF29 before I can open another session.

At least for me, it seems to be more of an issue on my 64 bit Win 7 machine. My 32 bit Win 7 doesn't seem to act up this way. and yes, network.seer.enabled is still set to false and I continue to have to use Task Manager to kill FF29 before I can open another session.
Puzzled56 0 solutions 3 answers

Wow, mine was already set to "false" so changed it to "true" and, fingers crossed, it seems to be working on both computers.

Wow, mine was already set to "false" so changed it to "true" and, fingers crossed, it seems to be working on both computers.
Puzzled56 0 solutions 3 answers

Was wishful thinking. Playing up again and it is starting to really annoy me! Not interested in Chrome because I have to sign in to Google and I don't see why. IE is out of the question so it may be a Linux Mint solution for me.

Was wishful thinking. Playing up again and it is starting to really annoy me! Not interested in Chrome because I have to sign in to Google and I don't see why. IE is out of the question so it may be a Linux Mint solution for me.
John99 971 solutions 13138 answers

UPDATE

This relates to those cases where the problem continues in Firefox 29.0.1 if History is set to be cleared on close down.


Note one potential fix is now in the very recent Firefox Beta 30b8 Initial reports suggest this fixes the issue. (Bug1005487#c38) If you have been suffering from this problem and want a fix now instead of in a few weeks time you may wish to download and install the Beta version of Firefox.

The beta version is effectively a release candidate but is only intended for advanced users or testers. I would be interested to hear feedback from those of you that do test this out.

Beta version download

UPDATE This relates to those cases where the problem continues in Firefox 29.0.1 if History is set to be cleared on close down. Note one potential fix is now in the very recent Firefox Beta 30b8 Initial reports suggest this fixes the issue. <sup>(Bug1005487#c38)</sup> If you have been suffering from this problem and want a fix now instead of in a few weeks time you may wish to download and install the Beta version of Firefox. The beta version is effectively a release candidate but is only intended for advanced users or testers. I would be interested to hear feedback from those of you that do test this out. Beta version download * http://www.mozilla.org/en-US/firefox/channel/#beta/beta-desktop