Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I like my tabs on the bottom and changed browser.tabs.onTop to false but the tabs are still on top. Why?

  • 9 replies
  • 33 have this problem
  • 805 views
  • Last reply by rosawood

more options

Went to about:config and changed tabs on top to false but tabs are still on top.

Chosen solution

Well that's a bit of information that would have been useful up front. Rather critical, wouldn't you say?

At any rate, this worked, and I now have tabs on the bottom. Thank you.

And someone ought to hit Firefox developers who keep taking away functionality alongside the head with a 2 x 4. Apparently they're not going to "get it" any other way.

Read this answer in context 👍 1

All Replies (9)

more options

The interface you see in Firefox 29 is a major re-design (first one since Firefox 4) of Firefox's user interface called "Australis." We could argue about the UI similarity between 29 and Chrome but what good would that do? Main point is that Firefox is still way more customizable than Google and way more secure.

If you don't like the new Australis look, you can revert back to the view before Australis using the Classic Theme Restorer addon

more options
more options

You can move the Tab bar to the lower position with code in userChrome.css as basically you only need to give the Tab bar a higher -moz-box-ordinal-group value (most toolbars have a default 1 to show them in DOM order).

Add code to the userChrome.css file below the default @namespace line.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#TabsToolbar { -moz-box-ordinal-group:10000 !important; }

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

So the only way to get Tabs-On-Bottom is to throw out the baby with the bathwater? How User Oriented! How Friendly! How Customizable ! How "we know what is good for you"!

Of course, this post will be deleted because Mozilla is well known for tolerance of dissenting views.....

more options

the-edmeister gave out a link to Tabs on Bottom and you didn't let us know if you used it or not

You said:

Of course, this post will be deleted because Mozilla is well known for tolerance of dissenting views.....

Are you kidding? We Moderators only edit when it is needed such as when it's breaking the Mozilla Support rules and guidelines. FYI We aren't Mozilla staff. Just thought you might want to know in case you assume something else that's wrong.

more options

Why was such functionality taken out in the first place? Why couldn't it have been implemented in the about:config options so anyone could make it look anyway they wanted without having either to add another addon or learn how to program the chrome.css file?

Someone in Mozilla made a stupid decision in this case trying to make Firefox look and work more like IE ! I'll wager that most Firefox users want the Firefox look and feel, NOT the IE experience!

more options

I've gone to the profile folder and there are no chrome folders, no userChrome.css files, no css files at all that I can see. I do have hidden files showing, so that's not the issue. I'm using Windows XP.

more options

The chrome folder and the userChrome.css and userContent.css files aren't there by default and you need to create the chrome folder and the userChrome.css file.


  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userChrome.css file in this folder (the names are case sensitive)
  • Paste the code in the userChrome.css file in the editor window and make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css. Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Chosen Solution

Well that's a bit of information that would have been useful up front. Rather critical, wouldn't you say?

At any rate, this worked, and I now have tabs on the bottom. Thank you.

And someone ought to hit Firefox developers who keep taking away functionality alongside the head with a 2 x 4. Apparently they're not going to "get it" any other way.