X
Tap here to go to the mobile version of the site.

Support Forum

"Another program on your computer would like to modify Firefox with the following add-on" - how to disable?

Posted

I am using the latest Firefox (28.0) on Windows XP in a shared computer environment. Although I do not have Administrator access, I installed Firefox myself and can change whatever Firefox config settings I want (including about:config and mucking with the files in the installation directory).

I want to disable the tab that appears on Firefox startup, "Another program on your computer would like to modify Firefox with the following add-on". This tab usually appears once per day (the first time I startup Firefox each day). I want the tab not to appear at all, from now on.

The "another program" in question is some program that is used in the facility where I'm using the computer, so I can't just uninstall that program. Although this is a shared computer environment, they don't "wipe" the machine every day, just reboot. So the Firefox I installed is still there with all my config settings intact. As far as I know, I'm the only person who uses Firefox on this computer.

Solutions that don't work:

"Just click Continue" -- but then I still see the "Another program" tab every day, and don't want to see it.

"Click Remove in the Add-ons list" -- I removed the Add-on in question but the tab still appears every day.

I would like a solution that either eliminates the Add-on request for that particular application, or eliminates all such requests ("Another program...") regardless of what application requested it. The ideal solution would be if the request itself had a checkbox for "never ask this again" but, alas, no such luck.

I am using the latest Firefox (28.0) on Windows XP in a shared computer environment. Although I do not have Administrator access, I installed Firefox myself and can change whatever Firefox config settings I want (including about:config and mucking with the files in the installation directory). I want to disable the tab that appears on Firefox startup, "Another program on your computer would like to modify Firefox with the following add-on". This tab usually appears once per day (the first time I startup Firefox each day). I want the tab not to appear at all, from now on. The "another program" in question is some program that is used in the facility where I'm using the computer, so I can't just uninstall that program. Although this is a shared computer environment, they don't "wipe" the machine every day, just reboot. So the Firefox I installed is still there with all my config settings intact. As far as I know, I'm the only person who uses Firefox on this computer. Solutions that don't work: "Just click Continue" -- but then I still see the "Another program" tab every day, and don't want to see it. "Click Remove in the Add-ons list" -- I removed the Add-on in question but the tab still appears every day. I would like a solution that either eliminates the Add-on request for that particular application, or eliminates all such requests ("Another program...") regardless of what application requested it. The ideal solution would be if the request itself had a checkbox for "never ask this again" but, alas, no such luck.

Additional System Details

Installed Plug-ins

  • Google Update
  • 5.1.30214.0
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.3 r183
  • Adobe PDF Plug-In For Firefox and Netscape
  • Version 0.9.4, copyright 1996-2008 The VideoLAN Teamhttp://www.videolan.org/
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

AliceWyman
  • Moderator
240 solutions 2598 answers

Did you try to allow the installation but then disable the add-on in the Firefox Add-ons Manager Extensions list? (Tools -> Add-ons -> Extensions)

Otherwise, you could try this suggestion from another forum to add a new "Integer" preference extensions.enabledScopes with the value 5 (see http://kb.mozillazine.org/About:config for help with that)

patrickjdempsey posted April 17, 2013, in http://forums.mozillazine.org/viewtopic.php?f=7&t=2693441 locking toolbar and blocking add-ons


You can completely block the install of global extensions by creating and using the following Integer about:config preference:
extensions.enabledScopes = 5
http://mike.kaply.com/2012/02/21/understanding-add-on-scopes/

However, before trying the above, it would be better if you could first post some information from the Firefox Help - "Troubleshooting Information" page:

  1. In Firefox, click the Help menu and select Troubleshooting Information.
  2. Click the button that says "Copy text to clipboard".
  3. In your support forum thread, click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.

Ref: Use the Troubleshooting Information page to help fix Firefox issues

Did you try to allow the installation but then '''disable''' the add-on in the Firefox Add-ons Manager Extensions list? (Tools -> Add-ons -> Extensions) Otherwise, you could try this suggestion from another forum to add a new "Integer" preference '''extensions.enabledScopes''' with the value '''5''' (see http://kb.mozillazine.org/About:config for help with that) ''patrickjdempsey posted April 17, 2013'', in http://forums.mozillazine.org/viewtopic.php?f=7&t=2693441 ''locking toolbar and blocking add-ons'' ----- You can completely block the install of global extensions by creating and using the following Integer about:config preference: extensions.enabledScopes = 5 http://mike.kaply.com/2012/02/21/understanding-add-on-scopes/ ----- However, before trying the above, it would be better if you could first post some information from the Firefox Help - "Troubleshooting Information" page: #In Firefox, click the ''Help'' menu and select ''Troubleshooting Information''. #Click the button that says "Copy text to clipboard". #In your support forum thread, click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post. Ref: [[Use the Troubleshooting Information page to help fix Firefox issues]]

Question owner

Thanks for the response, AliceWyman. Regarding your question ("Did you try to allow the installation but then disable the add-on..."), yes, this is what I meant by "I removed the Add-on in question" (using a button called "Remove", there was no "Disable" button).

Regarding your suggestion ("However, before trying the above, it would be better if you could first post some information..."), please see below for that information. FYI, the Add-on I'm trying to suppress is called "iCafe Toolbar" (not currently installed). Thanks.

Application Basics


Name: Firefox Version: 28.0 User Agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Java Quick Starter Version: 1.0 Enabled: false ID: jqs@sun.com

Name: Microsoft .NET Framework Assistant Version: 0.0.0 Enabled: false ID: {20a82645-c095-46ed-80e3-08825760534b}

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.newtab.url: about:blank browser.places.smartBookmarksVersion: 6 browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517 browser.startup.homepage: http://www.google.com/ncr browser.startup.homepage_override.buildID: 20140314220517 browser.startup.homepage_override.mstone: 28.0 dom.mozApps.used: true extensions.lastAppVersion: 28.0 gfx.blacklist.direct2d: 3 gfx.blacklist.layers.direct3d10: 3 gfx.blacklist.layers.direct3d10-1: 3 gfx.blacklist.layers.direct3d9: 3 gfx.blacklist.layers.opengl: 3 gfx.blacklist.stagefright: 3 gfx.blacklist.suggested-driver-version: 6.1400.1000.5218 gfx.blacklist.webgl.angle: 3 gfx.blacklist.webgl.msaa: 3 gfx.blacklist.webgl.opengl: 3 network.cookie.prefsMigrated: true network.websocket.enabled: false places.database.lastMaintenance: 1398236145 places.history.enabled: false places.history.expiration.transient_current_max_pages: 53428 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npgoogleupdate: 1 privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1396778909

Graphics


Adapter Description: Intel(R) G33/G31 Express Chipset Family Adapter Drivers: igxprd32 Adapter RAM: Unknown Device ID: 0x29c2 Direct2D Enabled: Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. DirectWrite Enabled: false (0.0.0.0) Driver Date: 11-3-2008 Driver Version: 6.14.10.5009 GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. Vendor ID: 0x8086 windowLayerManagerRemote: false AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.3 Version in use: 4.10.3

NSS Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC

NSSSMIME Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC

NSSSSL Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC

NSSUTIL Expected minimum version: 3.15.5 Version in use: 3.15.5

Thanks for the response, AliceWyman. Regarding your question ("Did you try to allow the installation but then disable the add-on..."), yes, this is what I meant by "I removed the Add-on in question" (using a button called "Remove", there was no "Disable" button). Regarding your suggestion ("However, before trying the above, it would be better if you could first post some information..."), please see below for that information. FYI, the Add-on I'm trying to suppress is called "iCafe Toolbar" (not currently installed). Thanks. Application Basics ------------------ Name: Firefox Version: 28.0 User Agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0 Crash Reports for the Last 3 Days --------------------------------- All Crash Reports Extensions ---------- Name: Java Quick Starter Version: 1.0 Enabled: false ID: jqs@sun.com Name: Microsoft .NET Framework Assistant Version: 0.0.0 Enabled: false ID: {20a82645-c095-46ed-80e3-08825760534b} Important Modified Preferences ------------------------------ accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.newtab.url: about:blank browser.places.smartBookmarksVersion: 6 browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517 browser.startup.homepage: http://www.google.com/ncr browser.startup.homepage_override.buildID: 20140314220517 browser.startup.homepage_override.mstone: 28.0 dom.mozApps.used: true extensions.lastAppVersion: 28.0 gfx.blacklist.direct2d: 3 gfx.blacklist.layers.direct3d10: 3 gfx.blacklist.layers.direct3d10-1: 3 gfx.blacklist.layers.direct3d9: 3 gfx.blacklist.layers.opengl: 3 gfx.blacklist.stagefright: 3 gfx.blacklist.suggested-driver-version: 6.1400.1000.5218 gfx.blacklist.webgl.angle: 3 gfx.blacklist.webgl.msaa: 3 gfx.blacklist.webgl.opengl: 3 network.cookie.prefsMigrated: true network.websocket.enabled: false places.database.lastMaintenance: 1398236145 places.history.enabled: false places.history.expiration.transient_current_max_pages: 53428 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npgoogleupdate: 1 privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1396778909 Graphics -------- Adapter Description: Intel(R) G33/G31 Express Chipset Family Adapter Drivers: igxprd32 Adapter RAM: Unknown Device ID: 0x29c2 Direct2D Enabled: Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. DirectWrite Enabled: false (0.0.0.0) Driver Date: 11-3-2008 Driver Version: 6.14.10.5009 GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. Vendor ID: 0x8086 windowLayerManagerRemote: false AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0 JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.10.3 Version in use: 4.10.3 NSS Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC NSSSMIME Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC NSSSSL Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC NSSUTIL Expected minimum version: 3.15.5 Version in use: 3.15.5
AliceWyman
  • Moderator
240 solutions 2598 answers

I don't see anything helpful in your Troubleshooting Information list.

You wrote, "I removed the Add-on in question" (using a button called "Remove", there was no "Disable" button). and FYI, the Add-on I'm trying to suppress is called "iCafe Toolbar" (not currently installed).

It's odd that this "iCafe Toolbar" had a Remove button but no Disable button in the Add-ons - Extensions list when you had it installed. Normally, extensions installed in the profile have both; globally-installed extensions (those installed from outside the Firefox profile folder) have a Disable button but no Remove button.

You wrote earlier that The "another program" in question is some program that is used in the facility where I'm using the computer, so I can't just uninstall that program. It might help if you could you tell us the name of this other program that is trying to install the iCafe Toolbar into Firefox.

Did you ever try resetting Firefox? That would eliminate most issues caused by files and folders in the profile. See Refresh Firefox - reset add-ons and settings. You could alternately create a new Firefox profile, which will allow you to test the new profile and switch back to your original (default) profile. See Profile Manager - Create, remove, or switch Firefox profiles for details.

It might also help if you could confirm that you installed Firefox from an installer your downloaded from a Mozilla site; for example, from www.mozilla.org/firefox/all/ and not from some third-party site that offers a "customized" version of Firefox. If you did install a customized version, you should do a clean reinstall: Remove the Firefox installation directory (e.g., C:\Program Files\Mozilla Firefox) and then reinstall Firefox from a fresh download. See How to download and install Firefox on Windows for details.

In the meantime, I'll escalate this question to get another opinion on how you should proceed.

I don't see anything helpful in your Troubleshooting Information list. You wrote, ''"I removed the Add-on in question" (using a button called "Remove", there was no "Disable" button).'' and ''FYI, the Add-on I'm trying to suppress is called "iCafe Toolbar" (not currently installed).'' It's odd that this "iCafe Toolbar" had a Remove button but no Disable button in the Add-ons - Extensions list when you had it installed. Normally, extensions installed in the profile have both; globally-installed extensions (those installed from outside the Firefox [[Profiles|profile folder]]) have a Disable button but no Remove button. You wrote earlier that ''The "another program" in question is some program that is used in the facility where I'm using the computer, so I can't just uninstall that program.'' It might help if you could you tell us the name of this other program that is trying to install the iCafe Toolbar into Firefox. Did you ever try resetting Firefox? That would eliminate most issues caused by files and folders in the profile. See [[Reset Firefox – easily fix most problems]]. You could alternately create a new Firefox profile, which will allow you to test the new profile and switch back to your original (default) profile. See [[Use the Profile Manager to create and remove Firefox profiles]] for details. It might also help if you could confirm that you installed Firefox from an installer your downloaded from a Mozilla site; for example, from www.mozilla.org/firefox/all/ and not from some third-party site that offers a "customized" version of Firefox. If you did install a customized version, you should do a clean reinstall: Remove the Firefox '''installation directory''' (e.g., C:\Program Files\'''Mozilla Firefox''') and then reinstall Firefox from a fresh download. See [[How to download and install Firefox on Windows]] for details. In the meantime, I'll escalate this question to get another opinion on how you should proceed.

Modified by AliceWyman

guigs 1072 solutions 11697 answers

AliceWyman, you have pretty much summed up the troubleshooting to disable that popup.

I would not suggest this if there is important information stored in other extensions/addons, though it does not look like it from the troubleshooting information.

The files you can delete, though it is almost the same as resetting Firefox. and restart Firefox are in the Profile Folder called extensions.ini, extensions.cache, extensions.rdf, extensions.sqlite & extensions.sqlite-journal.

On second thought, I do not see the icafe Toolbar in your list of extensions or in the add ons in the addon searcj. Though it is possible that you removed some information? If not there are some ways we can uninstall this if this pop up will not go away after deleting the files above ^.'

The extension program folders are located: C:\Program Files (x86)\Mozilla Firefox\extensions\

Please post back to see if this is something you would like to do. If it is not something you want it may be a virus? We are happy to help.

AliceWyman, you have pretty much summed up the troubleshooting to disable that popup. I would not suggest this if there is important information stored in other extensions/addons, though it does not look like it from the troubleshooting information. The files you can delete, though it is almost the same as resetting Firefox. and restart Firefox are in the Profile Folder called extensions.ini, extensions.cache, extensions.rdf, extensions.sqlite & extensions.sqlite-journal. On second thought, I do not see the icafe Toolbar in your list of extensions or in the add ons in the addon searcj. Though it is possible that you removed some information? If not there are some ways we can uninstall this if this pop up will not go away after deleting the files above ^.' The extension program folders are located: C:\Program Files (x86)\Mozilla Firefox\extensions\ Please post back to see if this is something you would like to do. If it is not something you want it may be a virus? We are happy to help.

Question owner

I was unable to respond for a while due to traveling. I have left the site where I was having the reported problem. I plan to return there eventually, so I'm still interested in finding a solution, but I can't perform any further experiments on their systems since I'm not there now.

Responding to comments from above...

"It's odd that this "iCafe Toolbar" had a Remove button but no Disable button" - actually, if I allow the install, the result is that the toolbar appears, and the corresponding entry on the Add-ons - Extensions screen shows two buttons, "Enable" and "Remove", and the add-on in question is labeled "(disabled)". Even though it is marked "(disabled)", the associated toolbar is active. Clicking "Remove" effectively gets rid of the toolbar. That much is not a problem. The problem is that, each day, after the facility reboots their computers, the next time I start Firefox, I see the annoying "Another program..." tab as I specified above. I want it to stop doing that.

"It might help if you could you tell us the name of this other program" - since Firefox does not report this information, I'm not sure I can be precise, but I believe the name of the application is iCafe Manager.

"Did you ever try resetting Firefox?" - I tried it. I still got the "Another program..." tab showing up the next morning.

In addition, I manually put in the following text files: (1) "mozilla.cfg" (in the same directory where "firefox.exe" is):

lockPref("xpinstall.enabled", false); lockPref("browser.startup.homepage", "http://www.google.com/ncr"); lockPref("browser.newtab.url", "about:blank"); lockPref("network.proxy.socks_remote_dns", true); lockPref("network.websocket.enabled", false); lockPref("extensions.enabledScopes", 5);

and (2) "local-settings.js" (in the defaults\pref subdirectory under the above, the same directory where "channel-prefs.js" is):

pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 0);

The above files were installed several days prior to the reset (and survived the reset). All of the above (including reset) was done on two different computers in the facility. Same results on both computers (i.e., problem not solved).

"It might also help if you could confirm that you installed Firefox from an installer your downloaded from a Mozilla site" - My original installation of Firefox on both systems was a download from www.mozilla.org.

"I do not see the icafe Toolbar in your list of extensions" - I had already removed the extension before producing the report. The problem is not that I can't remove the extension. The problem is that the "Another program..." tab appears every morning, after the morning reboots. I also have a copy of a troubleshooting report with the extension installed, and can post that if you think it's useful.

I was unable to respond for a while due to traveling. I have left the site where I was having the reported problem. I plan to return there eventually, so I'm still interested in finding a solution, but I can't perform any further experiments on their systems since I'm not there now. Responding to comments from above... "It's odd that this "iCafe Toolbar" had a Remove button but no Disable button" - actually, if I allow the install, the result is that the toolbar appears, and the corresponding entry on the Add-ons - Extensions screen shows two buttons, "Enable" and "Remove", and the add-on in question is labeled "(disabled)". Even though it is marked "(disabled)", the associated toolbar is active. Clicking "Remove" effectively gets rid of the toolbar. That much is not a problem. The problem is that, each day, after the facility reboots their computers, the next time I start Firefox, I see the annoying "Another program..." tab as I specified above. I want it to stop doing that. "It might help if you could you tell us the name of this other program" - since Firefox does not report this information, I'm not sure I can be precise, but I believe the name of the application is iCafe Manager. "Did you ever try resetting Firefox?" - I tried it. I still got the "Another program..." tab showing up the next morning. In addition, I manually put in the following text files: (1) "mozilla.cfg" (in the same directory where "firefox.exe" is): lockPref("xpinstall.enabled", false); lockPref("browser.startup.homepage", "http://www.google.com/ncr"); lockPref("browser.newtab.url", "about:blank"); lockPref("network.proxy.socks_remote_dns", true); lockPref("network.websocket.enabled", false); lockPref("extensions.enabledScopes", 5); and (2) "local-settings.js" (in the defaults\pref subdirectory under the above, the same directory where "channel-prefs.js" is): pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 0); The above files were installed several days prior to the reset (and survived the reset). All of the above (including reset) was done on two different computers in the facility. Same results on both computers (i.e., problem not solved). "It might also help if you could confirm that you installed Firefox from an installer your downloaded from a Mozilla site" - My original installation of Firefox on both systems was a download from www.mozilla.org. "I do not see the icafe Toolbar in your list of extensions" - I had already removed the extension before producing the report. The problem is not that I can't remove the extension. The problem is that the "Another program..." tab appears every morning, after the morning reboots. I also have a copy of a troubleshooting report with the extension installed, and can post that if you think it's useful.
cor-el
  • Top 10 Contributor
  • Moderator
17581 solutions 159071 answers

Extensions that do not have a "Remove" button are installed by other software and are not under control of the Firefox extension manager.
Such globally installed extensions are usually found via a registry scan or are installed in a location that Firefox scans for installed extensions.

Extensions installed this way need to be removed via the settings (options/preferences) of the program that has added this extension or this program has to be uninstalled via "Control Panel > Programs".
In Firefox you an only disable such an extension.

Extensions that do not have a "Remove" button are installed by other software and are not under control of the Firefox extension manager.<br /> Such globally installed extensions are usually found via a registry scan or are installed in a location that Firefox scans for installed extensions. *https://developer.mozilla.org/en/Adding_Extensions_using_the_Windows_Registry Extensions installed this way need to be removed via the settings (options/preferences) of the program that has added this extension or this program has to be uninstalled via "Control Panel > Programs".<br /> In Firefox you an only disable such an extension.
AliceWyman
  • Moderator
240 solutions 2598 answers

cor-el, The iCafe Toolbar extension DOES have a Remove button and it can be removed. The problem is (when the toolbar is removed) Quote:

"I want to disable the tab that appears on Firefox startup, "Another program on your computer would like to modify Firefox with the following add-on". 

wkrp,

I don't understand why you are using a mozilla.cfg file to lock those preferences when you can modify the preferences for your current Firefox profile via about:config ... but I would look in about:config to make sure those preference modifications are in effect. See http://kb.mozillazine.org/Locking_preferences#Verifying_the_lock

Anyway, since A) removing the iCafe Toolbar extension from the Firefox Addons -> Extensions panel results in the "Another program" tab at startup, and B) when you allow the installation it shows up as "(disabled)" in the Extensions list but the unwanted toolbar still shows up (correct?):

You could explain the problem to the system administrator of your facility, to see if he can help. Short of that, I would allow the installation and then see if you can go to the Firefox Customize menu and HIDE the toolbar as a workaround. See Customize Firefox controls, buttons and toolbars

cor-el, The iCafe Toolbar extension DOES have a Remove button and it can be removed. The problem is (when the toolbar is removed) '''Quote''': "I want to disable the tab that appears on Firefox startup, "Another program on your computer would like to modify Firefox with the following add-on". wkrp, I don't understand why you are using a mozilla.cfg file to lock those preferences when you can modify the preferences for your current Firefox profile via about:config ... but I would look in about:config to make sure those preference modifications are in effect. See http://kb.mozillazine.org/Locking_preferences#Verifying_the_lock Anyway, since A) removing the iCafe Toolbar extension from the Firefox Addons -> Extensions panel results in the "Another program" tab at startup, and '''B) when you allow the installation it shows up as "(disabled)" in the Extensions list but the unwanted toolbar still shows up''' (correct?): You could explain the problem to the system administrator of your facility, to see if he can help. Short of that, I would '''allow the installation''' and then see if you can go to the Firefox Customize menu and HIDE the toolbar as a workaround. See [[Customize Firefox controls, buttons and toolbars]]

Modified by AliceWyman

AliceWyman
  • Moderator
240 solutions 2598 answers

P.S. I edited my above reply but forgot to add that it might help if you could post a new troubleshooting information list after you allow the iCafe Toolbar installation.

P.S. I edited my above reply but forgot to add that it might help if you could post a new troubleshooting information list after you allow the iCafe Toolbar installation.

Modified by AliceWyman

Question owner

Gosh... I spent about an hour preparing a response, then accidentally did control-something or alt-something which took me back a page and I lost everything I typed (even after I clicked Forward to try to get back to where I was). If anyone knows of a config setting like "don't ever trash an entire page of user input unless the user explicitly confirms it", or, "keep form input data even if the user goes Back or Forward", I think that would be a great feature.

OK, back to the original question...

I appreciate the responses thus far, but I think there have been some misunderstandings. Maybe a multiple-choice version would help:

Question: Is there a way to suppress the appearance of the notification tab that says, "Another program on your computer would like to modify Firefox with the following add-on" (meaning, any request from another program to install an add-on is to be silently ignored and discarded)?

Answer: (A) Yes, you can suppress that notification (please state how). (B) No, but you can request that feature (please state where). (C) No, you can't do that or request that feature.

That's basically my question in a nutshell. If the answer is (B), I might envision a boolean about:config setting like "extensions.allowProgrammaticAddonRequests" that defaults to "true" and can be set to "false" manually. I think that would be the most direct solution (if it were possible).

I will respond to some comments from above:

"I don't understand why you are using a mozilla.cfg file to lock those preferences when you can modify the preferences for your current Firefox profile via about:config" -- This is because the "other program" in question (iCafe Manager) was setting certain config options (browser.startup.homepage, and browser.newtab.url) on every reboot (which happens every morning at that facility). I got tired of manually changing the settings back every day. Using the above-mentioned files, I successfully defeated iCafe Manager's daily interference with those config settings. The other things (like stuff related to Socks tunnelling) I probably could have just set once in about:config but doing a lockPref seemed to do no harm. The settings for "enabledScopes" and "xpinstall" were to see if they'd help with the problem I originally asked about, but they did not.

"I would look in about:config to make sure those preference modifications are in effect" -- yes, I confirmed that the settings are in effect and locked. That much works as expected.

"A) removing the iCafe Toolbar extension from the Firefox Addons -> Extensions panel results in the "Another program" tab at startup" -- true, but I think it would be more accurate to say: while the toolbar extension is not installed (due to either having been removed, or, never having been installed at all), the "Another program" tab appears on at least the first startup of Firefox after every reboot.

"B) when you allow the installation it shows up as "(disabled)" in the Extensions list but the unwanted toolbar still shows up (correct?)" -- yes, correct.

"You could explain the problem to the system administrator of your facility" -- unfortunately, there's no administrator on site, only a person who makes sure the lights are on. They'll call a tech if there's a catastrophic problem (like the net connection goes dead). Since I installed Firefox myself, and since iCafe Manager is a program they installed, I don't think they'll go out of their way to help me with Firefox (especially if I'm trying to defeat iCafe Manager's attempts to interfere with Firefox). From their point of view, their systems are working just fine.

"allow the installation and then see if you can go to the Firefox Customize menu and HIDE the toolbar as a workaround" -- since I'm not in that facility now (and probably won't be again until this summer or so), I can't experiment with those systems now. But I do recall clicking just about everything I could, including "View - Toolbars" (which seems to be the same menu as when I right-click on a toolbar line). That menu allows hiding toolbars, but from my recollection, the offending toolbar was not displayed in the list, so I could not hide it that way. Also, the Customize menu ("View - Toolbars - Customize") seems to allow only modifications to a toolbar, and not a way to hide an entire toolbar.

"it might help if you could post a new troubleshooting information list after you allow the iCafe Toolbar installation" -- ok, that troubleshooting report is included below.

Thanks again for your help.

---

Application Basics


Name: Firefox Version: 28.0 User Agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: iCafe Manager Toolbar Version: 5.2.0.6 Enabled: false ID: {C058FE28-1E07-4FD1-8092-046F8A964D12}

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.newtab.url: about:blank browser.places.smartBookmarksVersion: 6 browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517 browser.startup.homepage: http://www.google.com/ncr browser.startup.homepage_override.buildID: 20140314220517 browser.startup.homepage_override.mstone: 28.0 dom.mozApps.used: true extensions.lastAppVersion: 28.0 gfx.blacklist.direct2d: 3 gfx.blacklist.layers.direct3d10: 3 gfx.blacklist.layers.direct3d10-1: 3 gfx.blacklist.layers.direct3d9: 3 gfx.blacklist.layers.opengl: 3 gfx.blacklist.stagefright: 3 gfx.blacklist.suggested-driver-version: 6.1400.1000.5218 gfx.blacklist.webgl.angle: 3 gfx.blacklist.webgl.msaa: 3 gfx.blacklist.webgl.opengl: 3 network.cookie.prefsMigrated: true network.websocket.enabled: false places.database.lastMaintenance: 1398414928 places.history.enabled: false places.history.expiration.transient_current_max_pages: 53428 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npgoogleupdate: 1 privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1396778909

Graphics


Adapter Description: Intel(R) G33/G31 Express Chipset Family Adapter Drivers: igxprd32 Adapter RAM: Unknown Device ID: 0x29c2 Direct2D Enabled: Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. DirectWrite Enabled: false (0.0.0.0) Driver Date: 11-3-2008 Driver Version: 6.14.10.5009 GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. Vendor ID: 0x8086 windowLayerManagerRemote: false AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.3 Version in use: 4.10.3

NSS Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC

NSSSMIME Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC

NSSSSL Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC

NSSUTIL Expected minimum version: 3.15.5 Version in use: 3.15.5

Gosh... I spent about an hour preparing a response, then accidentally did control-something or alt-something which took me back a page and I lost everything I typed (even after I clicked Forward to try to get back to where I was). If anyone knows of a config setting like "don't ever trash an entire page of user input unless the user explicitly confirms it", or, "keep form input data even if the user goes Back or Forward", I think that would be a great feature. OK, back to the original question... I appreciate the responses thus far, but I think there have been some misunderstandings. Maybe a multiple-choice version would help: Question: Is there a way to suppress the appearance of the notification tab that says, "Another program on your computer would like to modify Firefox with the following add-on" (meaning, any request from another program to install an add-on is to be silently ignored and discarded)? Answer: (A) Yes, you can suppress that notification (please state how). (B) No, but you can request that feature (please state where). (C) No, you can't do that or request that feature. That's basically my question in a nutshell. If the answer is (B), I might envision a boolean about:config setting like "extensions.allowProgrammaticAddonRequests" that defaults to "true" and can be set to "false" manually. I think that would be the most direct solution (if it were possible). I will respond to some comments from above: "I don't understand why you are using a mozilla.cfg file to lock those preferences when you can modify the preferences for your current Firefox profile via about:config" -- This is because the "other program" in question (iCafe Manager) was setting certain config options (browser.startup.homepage, and browser.newtab.url) on every reboot (which happens every morning at that facility). I got tired of manually changing the settings back every day. Using the above-mentioned files, I successfully defeated iCafe Manager's daily interference with those config settings. The other things (like stuff related to Socks tunnelling) I probably could have just set once in about:config but doing a lockPref seemed to do no harm. The settings for "enabledScopes" and "xpinstall" were to see if they'd help with the problem I originally asked about, but they did not. "I would look in about:config to make sure those preference modifications are in effect" -- yes, I confirmed that the settings are in effect and locked. That much works as expected. "A) removing the iCafe Toolbar extension from the Firefox Addons -> Extensions panel results in the "Another program" tab at startup" -- true, but I think it would be more accurate to say: while the toolbar extension is not installed (due to either having been removed, or, never having been installed at all), the "Another program" tab appears on at least the first startup of Firefox after every reboot. "B) when you allow the installation it shows up as "(disabled)" in the Extensions list but the unwanted toolbar still shows up (correct?)" -- yes, correct. "You could explain the problem to the system administrator of your facility" -- unfortunately, there's no administrator on site, only a person who makes sure the lights are on. They'll call a tech if there's a catastrophic problem (like the net connection goes dead). Since I installed Firefox myself, and since iCafe Manager is a program they installed, I don't think they'll go out of their way to help me with Firefox (especially if I'm trying to defeat iCafe Manager's attempts to interfere with Firefox). From their point of view, their systems are working just fine. "allow the installation and then see if you can go to the Firefox Customize menu and HIDE the toolbar as a workaround" -- since I'm not in that facility now (and probably won't be again until this summer or so), I can't experiment with those systems now. But I do recall clicking just about everything I could, including "View - Toolbars" (which seems to be the same menu as when I right-click on a toolbar line). That menu allows hiding toolbars, but from my recollection, the offending toolbar was not displayed in the list, so I could not hide it that way. Also, the Customize menu ("View - Toolbars - Customize") seems to allow only modifications to a toolbar, and not a way to hide an entire toolbar. "it might help if you could post a new troubleshooting information list after you allow the iCafe Toolbar installation" -- ok, that troubleshooting report is included below. Thanks again for your help. --- Application Basics ------------------ Name: Firefox Version: 28.0 User Agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0 Crash Reports for the Last 3 Days --------------------------------- All Crash Reports Extensions ---------- Name: iCafe Manager Toolbar Version: 5.2.0.6 Enabled: false ID: {C058FE28-1E07-4FD1-8092-046F8A964D12} Important Modified Preferences ------------------------------ accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.newtab.url: about:blank browser.places.smartBookmarksVersion: 6 browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517 browser.startup.homepage: http://www.google.com/ncr browser.startup.homepage_override.buildID: 20140314220517 browser.startup.homepage_override.mstone: 28.0 dom.mozApps.used: true extensions.lastAppVersion: 28.0 gfx.blacklist.direct2d: 3 gfx.blacklist.layers.direct3d10: 3 gfx.blacklist.layers.direct3d10-1: 3 gfx.blacklist.layers.direct3d9: 3 gfx.blacklist.layers.opengl: 3 gfx.blacklist.stagefright: 3 gfx.blacklist.suggested-driver-version: 6.1400.1000.5218 gfx.blacklist.webgl.angle: 3 gfx.blacklist.webgl.msaa: 3 gfx.blacklist.webgl.opengl: 3 network.cookie.prefsMigrated: true network.websocket.enabled: false places.database.lastMaintenance: 1398414928 places.history.enabled: false places.history.expiration.transient_current_max_pages: 53428 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npgoogleupdate: 1 privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1396778909 Graphics -------- Adapter Description: Intel(R) G33/G31 Express Chipset Family Adapter Drivers: igxprd32 Adapter RAM: Unknown Device ID: 0x29c2 Direct2D Enabled: Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. DirectWrite Enabled: false (0.0.0.0) Driver Date: 11-3-2008 Driver Version: 6.14.10.5009 GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 6.1400.1000.5218 or newer. Vendor ID: 0x8086 windowLayerManagerRemote: false AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0 JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.10.3 Version in use: 4.10.3 NSS Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC NSSSMIME Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC NSSSSL Expected minimum version: 3.15.5 Basic ECC Version in use: 3.15.5 Basic ECC NSSUTIL Expected minimum version: 3.15.5 Version in use: 3.15.5
guigs 1072 solutions 11697 answers

For form Lazarus add on or Tools > Options > Privacy > History: "Remember search and form history"

For form [https://addons.mozilla.org/en-US/firefox/addon/lazarus-form-recovery/ Lazarus add on] or Tools > Options > Privacy > History: "Remember search and form history"
guigs 1072 solutions 11697 answers

Also, to answer your question, apologies it took so long to get back to you. At this time the answer is B as you say and the place to request the feature is about this question's solution https://support.mozilla.org/en-US/que.../994658

Also, to answer your question, apologies it took so long to get back to you. At this time the answer is B as you say and the place to request the feature is about this question's solution [https://support.mozilla.org/en-US/questions/994658]