Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does the Avast online security tab now suddenly always open when I start Firefox, it never use to happen?

  • 12 replies
  • 20 have this problem
  • 3259 views
  • Last reply by Swotz

more options

As above sentence. Suddenly, every time I start Firefox it opens with the Firefox tab and the Avast online security tab. This didn't use to happen. I've tried disabling it via Firefox (as it was loaded on the computer long before I had Firefox) which solves that problem but then the large green tick icon doesn't show next to the search list to show the site is safe. It's very annoying that it has started doing this and certainly don't want it!

All Replies (12)

more options

If disabling the extension stops the extra tab, perhaps you can find a setting to disable the tab. On the Add-ons page, does the avast! Online Security extension have an Options button letting you adjust its behavior?

more options

No. It just has the option to disable or 'more' that only tells you what it is. Sorry I don't know all the computer 'speak'.

more options

Oops looks like I've questioned myself! I though when it had a box 'needs more info' it was for me to say I needed more as an answer from you.

more options

I checked avast!'s forums.

Apparently the extension sets a cookie indicating that you've seen the tab so it is not displayed again. However, in order for the "already seen it" cookie to survive, you must (1) allow persistent cookies for whatever is the relevant site, (2) not use Firefox's feature to clear your cookies at shutdown, (3) not use any external software to clear your Firefox cookies, and (4) not use private browsing mode. If any of these 4 requirements is not met, avast! Online Security will not find the "already seen it" cookie and will show that page again.

To address #1, when you get the tab, you can make sure you have "Allow" permission for "Set Cookie" in the Page Info dialog. While viewing the page, either:

  • right-click > View Page info > Permissions panel
  • Tools menu > Page Info > Permissions panel
  • click the padlock or globe on the address bar > More Information > Permissions panel

Then you can adjust the "Set Cookie" permission for the displayed site.

But #2, #3, and #4 could still be a problem.

more options

Or Plan B: Don't ever close Firefox. ;-)

It wouldn't surprise me if you could find another extension that suppresses unwanted pages that would recognize the URL of the avast! page and close it for you. But I'm not sure it's worth searching out and setting up if you only see it once or twice a day.

more options

Okay, one more: a user on the avast! forums posted a solution for CCleaner users: how to create an exception so the critical cookie isn't cleared by CCleaner: http://forum.avast.com/index.php?topic=148337.msg1082730#msg1082730 (I don't use CCleaner and haven't tested that myself).

Modified by jscher2000

more options

Maybe avast's own support can help you.

They have

more options

You can check for problems with preferences.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

more options

Have contacted vast, awaiting a reply.

more options

Sorry you might as well as written it in double dutch. I didn't understand it at all. Previously I have said I don't understand computer speak.

more options

The Avast software may be interacting with Firefox and the Avast Online security extension will be designed to work on Firefox but it is Avast software so they will be the best people to help you with problems with that.

You mention

 then the large green tick icon doesn't show next to the search list to show the site is safe.

Presumably that is some feature of Avast software, so if you disable the Avast software you will loose that feature. Maybe you should ask is the feature actually needed, and does it do anything Firefox does not already do.

We do not know what software you run on your computer but possibly you use Avast primarily because it provides Anti Virus software. Did you now Microsoft also provides free AntiVirus software as long as you are using their Windows software.

As for safe websurfing, Firefox itself has some protection built-in and enabled by default. See

more options

Thanks for your help. I have tried this as the simplest action. I did set cookies to be kept for Avast tho mine only said 'Avast.com' not 'Avast plugin ....etc' that was noted in the link. Couldn't find the latter.