Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows 7x64 FF 28 renders internal "Get Add-ons" page as text only

  • 7 replies
  • 14 have this problem
  • Last reply by guigs

more options

Setting up five new Acer Veriton E430G Windows 7 x64 desktop machines for work, each has been Windows live updated to latest spec as of end of March '14. All were brand new factory pre-installed Windows 7 x64, all have had the same set of software individually installed, Adobe Flash player, Adobe Shockwave, Acrobat Reader, QuickTime, Oracle Java 8x32 and x64, Picasa, 7-Zip, LibreOffice, Skype and of course Firefox 28.0. All have the exact same behaviour in that when the "Welcome to Firefox" first run page displays, it displays in text only with a large grey box "No video with supported format and MIME type found. If you go to Tools\Add-Ons\Get Add-ons, the internal page displays in full text only as well - no graphics, same problem when you load "Plugins" page and click "Check to see if your plugins are up to date", the following page/tab loads as text only.

After taking one of the machines brand new out of box and creating an Acronis snapshot of the entire drive [factory install before first run] using it as a test install, I played around with a number of software / driver / updates / Firefox add-ins scenarios trying to get to the bottom of this. I have come to a dead end in as much as all runs great within Firefox, web pages from all internal pages and many on-line websites render correctly when I load a previous version of Firefox [v26.0 or v25] rather than the latest v28.0 onto each of the machines, I tried v27.01 & v27.0, these gave the same text based pages. This has been replicated successfully on the other four machines with all of the above listed latest software versions installed [no AntiVirus software installed yet as not fully in use in Office yet], change nothing else other than load the latest version v28.0 Firefox and the problem reappears.

I did for the sake of completeness test the brand new factory install just past 'first boot set-up' and first time desktop hello, let everything settle and installed Firefox v28.0, [tested with v27.01 & v27.0] this too exhibits the exact same text only page rendering on internal Firefox pages. Yet again, over install Firefox v26.0, clear history and the same pages start loading correctly.

I am open to suggestions regards a fix for this as I really do not want to leave the machines with old version Firefox installed on each desktop. I would also prefer not to allow each member of staff to install Google Chrome. The on-line web pages that were found to be loading as text only within Firefox 28.0 were tested and rendered correctly within Chrome 33.0.1750.154 and IE 11, this would indicate something to be clashing with Firefox or Firefox not behaving with something else. I would like to get this resolved.

Modified by Jewelie

All Replies (7)

more options

Make sure that you aren't blocking content from

You can check the Network log in the Web Console (Firefox/Tools > Web Developer) (refresh the page to update/generate the log).

more options


Initially when I ran the Network log thing and loaded problem pages / refreshed pages, it did not appear to change or repair the "loading text only fault. I then flushed [everything] all history, closed Firefox 28.0 and repeated the process, opened the Network log console and loaded "Welcome to Firefox" page [still displaying as text only] and "Get Add-ons" internal page from Tools\Add-ons [still displaying as text only], "Plugin Check & Updates" [still displaying as text only], refreshed each page in turn - Ctrl+Alt and R and everything loaded normally again. Nice to see pictures, logos, video content etc.

I flushed all history again, closed Firefox, opened Firefox and checked problem pages were loading as they should - all sorted. Not too sure I fully understand what running the Web Console changed within Firefox settings but it did the trick - normal service has resumed!

Will now go and update Firefox to latest version and perform same trick on other four machines - Your a star!


Modified by Jewelie

more options

Unfortunately the boss man ordered another batch of these machines for our other office and I have the same 'text only' problems as before. The first five machines from two weeks ago are working great after the suggested fix? by cor-el. These new machines are the exact same model / part number / mfg date etc and same Windows 7 x64 factory install as the first batch.

Installed all available Microsoft live updates to all but this months [April], installed all usual base software as listed in first post, opened Firefox 28.0 and the text only issues are back. Opened the Network log thing and loaded problem pages / refreshed pages, it did not appear to change or repair the "loading text only fault. I then flushed [everything] all history, closed Firefox 28.0 and repeated the process, opened the Network log console and loaded "Welcome to Firefox" page [still displaying as text only] and "Get Add-ons" internal page from Tools\Add-ons [still displaying as text only], "Plugin Check & Updates" [still displaying as text only], refreshed each page in turn - Ctrl+Alt and R and the text only thing remains. I have flushed History, closed Firefox, reopened and repeated many times but text only remains - css styles sheets not loading?

These machines are driving me nuts, already told boss man to order no more of these things. I have performed hundreds of bare metal installs and set-up as many machines and have never come across this problem before with any installation except these Acer factory installed machines. Something within these factory installed machines is clashing with Firefox, Yet again I Acronis imaged a box to play with, performed 1st power on / very first boot into this factory install, changed nothing, installed Firefox 28.0 and opened all the usual pages, displaying as text only, no images or formatting straight out the box. There are no updated drivers available for any component within the box, they already have latests drivers installed. These was very little in the way of pre-loaded software as I halted the auto install Acer garbage script on first boot.

Yet again open to suggested fix for Firefox

more options

Minor update and workaround but still no fix: installing and uninstalling testing versions of Firefox again - if I stick with the bare Windows 7 Acer factory install clean out of the box [temp turn off Microsoft auto update], attach an Ethernet cable to give me internet, install Firefox 28.0 I get text only [are these pages css base?] pages for internal "Get Add-ons" page / "Welcome to Firefox" 1st run page / Mozilla "Plugin Check & Updates" page.

If I then flush all history and close - over install 27.0.1 and repeat all of the above I get then same results. Flush all history and close again, over install 27.0 and repeat all of the above - same text based results, flush all history and close again, over install 26.0 and repeat all of the above and we have a winner. Firefox 26.0 does not have a problem displaying any of the pages correctly.

Working my way back up version numbers again, flush all history, close Firefox, over install 27.0 and repeat all of the above and we are back to text based pages.

I have tried a forked version of Firefox - "Pale Moon - v24.4.2" on the same machine and this gives the exact same text based results. Would this then not indicate that it is something in the base coding or settings of Firefox that has been changed after Firefox v26.0?

Chrome and IE are displaying these Add-ons and Plugin Checks pages with no fault, why not Firefox 27 /28 ?

In the interests of curiosity I decided to try some of the beta builds, namely 28.b9 and 29.0b7 - unfortunately same text based results :-(

If I cannot get this to work correctly with these machines I may have to concede and let the Office users select Chrome which I really do not want to do.

Can I run any more logs files and upload them to assist in diagnoses of this problem for a hopeful fix?

more options

Hi Jewelie, yes please. There were other issues last week that may have been caused by a separation of Add ons and marketplace, but would have been resolved with a simple cache clearing. So, this is obviously not the case.

Have you tested to see if there is a Firewall or antivirus blocking these dns names for these particular pages? It looks like you already cleared the cache and deleted cookies for these sites? Also temporary files associated with this site? This might sound nuts, but since it is just the about:addons page for get add ons, make sure this page is not blocked for content:

Does it happen in another profile in another version that you downloaded. For example: Using Multiple Profiles

more options

I'm having the same issues.. It's a "refurbished" laptop, exact same make/model/os as my previous. Everything still works fine on the old.. but not on this one. Cache is cleared/cookies cleared. Even though I have no add-ons.. went through options and turned them/safe mode... no change... reset to default.. no change The page loads through IE browser though. Checked that clock date/time is current.. has exceptions rights

Modified by Palak86

more options

Hi Palak86, Thank you for your question, however please consider creating a new thread containing the specific details of your issue.

If I remember correctly this could be troubleshooted by clearing the cache, trying a new profile, trying safe mode, or a clean reinstall.

Doing so will allow the Mozilla volunteers to give you solutions that are more helpful to you. This may help them to solve your problem faster and more efficiently.

Please, feel free to post the link to your thread on this thread for volunteers interested in assisting you.

Thank you.

Modified by guigs