Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Same Cookie Prompts Each Time Firefox Starts

  • 12 replies
  • 6 have this problem
  • Last reply by jscher2000

more options

I am running Firefox 28.0 on Windows 7 Professional 32-bit. Every time I start Firefox (It crashes frequently) I get the same cookie prompts. On each one the "remember" box is checked. What does this "remember" box signify? If I tell Firefox that I do not want to save a cookie for site X, then I expect that Firefox will remember this, and if I visit the site again, then Firefox will not prompt me to ask if I want to save a cookie for that site.

--Barry Finkel

All Replies (12)

more options

Do you mean that you use the cookie setting "ask me every time"?

In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

There are other things that need your attention.

Note that your System Details List shows multiple Flash plugins.

  1. Shockwave Flash 12.0 r0
  2. Shockwave Flash 11.9 r900

You can find the installation path of all plugins on the about:plugins page.

You can check the Flash player installation folder for multiple Flash player plugins and remove all (older) version(s) of the plugin (NPSWF32) and (re)install the latest Flash player.

  • (32 bit Windows) C:\Windows\System32\Macromed\Flash\
  • (64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\
more options

I use the option - Privacy: keep cookies until: ask me every time. I think I have removed Shockwave Flash 11.9 r900 . I do not clear the history when Firefox closes. When I go to a web page, for example,, I will manually accept cookies from but not for other web sites not associated with (e.g., ad sites). But when Firefox restarts, I get the same pop-up windows for cookies, even though I have previously said, "No, and use this decision for future cookies from this site".

--Barry Finkel

more options

Firefox crashes frequently, and I have frequent BSOD reboots. This causes numerous Firefox restarts, and I have included five of my (currently) 14 screen shots of cookie prompts for wikimedia,org. Each time Firefox starts, I get the same prompts for cookies.

--Barry Finkel

more options

Is there any update to this problem? i am getting tired of giving the same responses to cookie prompts.

--Barry Finkel

more options

I started this problem report last April with FF 28.0.

I am now using FF 31.0, and the SAME THING IS OCCURRING. Every time I start (or restart) FF, I get the SAME prompts for cookie settings. I have checked "Use this choice for all cookies for this site". It appears that this setting DOES NOTHING. For example, I go to, and I get a request for a cookie - chipublib, I already have 11 cookies. I click "Allow". I expect that the next time FF starts, I will not get a prompt for another cookie from this site. But I DO GET A PROMPT, and the prompt says, again, that I have 11 cookies from this site. IT SEEMS TO ME THAT FF IS NOT REMEMBERING THIS COOKIE, and IT DEFINITELY IS NOT HONORING THE "USE THIS CHOICE" SETTING. What can I do to help debug this problem? Thanks.

--Barry Finkel

more options

I have the same issue, except worse. This just started over the weekend when Firefox updated itself.

When I open Firefox, while my homepage is loading, I get a LOT of pop-ups about asking for permission for cookies. The websites asking for permission are in my bookmarks, but are not opened. The website that has the most requests is followed by It has made my Firefox un-usable, so I have downloaded Chrome (using IE) and started using that. If this isn't resolved soon, I will have no choice but to continue using Chrome.

more options

More documentation for my case I just looked at the "Exceptions: Cookies" list. I have a lot of entries - some with "Allow", many with "Block" , and some with "Allow for Session". The sites that prompt me for cookies when Firefox restarts are NOT in the list, so it appears that Firefox is not saving my decision for each cookie request (or, possibly, is saving my decision in the wrong file).

--Barry FInkel

more options

More documentation. When I restart Firefox and then later go to a wiki page - - I ALWAYS get a cookie prompt for

and sometimes

even though I have the box checked to remember my response to accept the cookie. This has now happened on Firefox 32.0.

--Barry Finkel

more options

Hi Barry, cookie exceptions are in the category of site-specific permissions. If you type about:permissions in the address bar and press Enter you can see what is currently saved for those sites.

If this is cleared between Firefox sessions, could you check:

  • You do not have "Clear history when Firefox closes" set to clear "Site Preferences" (Options dialog, Privacy panel, with "Use custom settings for history" selected)
  • The file permissions.sqlite is not locked and never getting updated (this can be hard to judge from Windows Explorer; you can use the SQLite Manager extension to view the tables in the database if you want to peer inside).
  • The file permissions.sqlite is not getting rolled back by external software (possibly settings protection utility software like Advanced SystemCare)
more options

Hi rage777, do you want Firefox to prompt you about cookies or was that not your earlier setting? You certainly can turn that off if you like.

(Personally, I couldn't take it any more and a few years ago I switched to allowing all cookies for the current session, although I had built up a number of ad site blocks already.)

Does your home page have any content from NewEgg or does that seem to be an anomaly?

It might be better to start a new question rather than continue in Barry's question. You can start a new question using the "Ask a question" link at the top of this page. If none of the suggestions look relevant, scroll down to continue with the form (spread over a few pages).

more options

I do not have "Clear history when Firefox closes" set to clear, as my Firefox history is intact.

As I type this reply (9/15 11:23AM) the permissions.sqlite file has timestamp 09/14 02:07PM). It appears that this file is being updated, but I do not know how often this file is updated.

I do have Advanced System Care installed, but I do not use it. I do have the ASC Surfing Protection add-on installed. I do not know it that does anything with cookies. I had disabled it Aug 17, but it may have been re-enabled after some update or crash.

As i was typing this reply, FF was using 44% of the CPU, and FF was repeatedly becoming "not responding". It took me over 45 minutes to type this reply. I eventually had to cancel FF via the task manager and then restart FF. Upon restart, the permissions.sqlite has a timetamp 9/15 11:57AM (time of the restart). Right now, FF is taking 35% of the CPU, so I am typing this in an external editor and will cut-and-paste into the problem reply window.

--Barry Finkel

more options

After the restart, did Firefox still have the exceptions or were they gone again?

I don't think the timestamp on the permissions.sqlite updates each time you change a permission, at least, not in my test. It could be that once Firefox opens the file, it can make internal changes without Windows updating the timestamp until the file is closed.