Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Notification tray won't open in Firefox OS 1.2 (ZTE Open)

  • 8 replies
  • 17 have this problem
  • Last reply by guigs

more options

I upgraded my ZTE open (from ebay) to Firefox OS 1.2 (following carefully these instructions :

Now I can't pull the notification tray down, no matter how accurate I try to be.

What can I do ?

All Replies (8)

more options


After reading the information provided about your issue I suggest a soft reset of the phone.

  1. Take the back cover of the phone off.
  2. Take the battery out.
  3. Take the SIM card and microSD card out (if applicable).
  4. Wait 10 seconds.
  5. Put the SIM card and microSD card back in (if applicable).
  6. Put the battery back in.
  7. Put the back cover back on.
  8. Turn the device on.
  9. Check if the issue you were having is still present.

Please report back to us if this solved your problem!

Thank you

more options


Thanks for your quick reply.

Unfortunately, that didn't work.

I also tried to do a factory reset, and it only bricked my phone (the boot get stuck at the flame tail fox logo). I had to reflash 1.2 to make it work again.

With that, I can confirm that the notification tray never worked (at least for me). I tested it as soon as possible after the flash (just after the first boot config) and I couldn't pull it down.

Thank you

Modified by ThomasFromMontreal

more options


Thanks for reaching out to us.. Could you tell us where you got the build from? I have heard of the notification bar not working months ago but that has since been fixed.

Could you go to:

  1. Settings
  2. Device Information
  3. More information
  4. Provide me with the build identified and Git commit info

This will help me in assessing the situation and to further escalate this if it is necessary.

Thanks you!

more options


Thank again for the quick reply.

I've got the build from a link at this page :

Specifically, this one :

Build identifier: 20131114004004

git commit info : 2013-11-14 08:40:50 9969e2c8b0f339

I also see that the OS version reads, I guess the -prerelease thing is my problem. How do I upgrade this ?

Modified by ThomasFromMontreal

more options

I have the same problem after upgrading to that version. I didn't see any other version for the ZTE Open then the one mentioned by ThomasFromMontreal.

Is there any update on this topic? Any other version I didn't see? Do the people from ZTE Corporation already know about that? Does it help if I create a Bugzilla report?


more options

It's fixed in a more recent 1.2 build, chances are that the build doesn't have the fix.

If you have root access to the phone you could flash your own latest version of 1.2 on top of that build via : git clone -b v1.2 gaia_v1.2 cd gaia_v1.2 make reset-gaia

That would flash a newer v1.2 engineering gaia on your device. Having said that there's no real support for v1.2...

Flashing a newer gaia v1.3+ will cause the phone to "brick" so to speak without the proper gecko version flashed on the phone.

more options

Thanks, I will try that out to get it working again.

Of course in case of Firefox OS it's a bit harder, because it's up to the vendor to ship a new version for its mobile phones. Though Mozilla should w

Though it's surely not good PR for Mozilla when a (more or less) official release version of Firefox OS has such big problems and users require some deeper technical understanding to get their phone working correctly.

It's like Mozilla shipped Firefox with a major bug requiring users to compile it by themselves ork closely together with them to avoid such problems.

But I assume complaining about that here is not the right place. So maybe you can point me to the place where these critics hit the right persons, i.e. the ones that can change something related to this?


Modified by Sebastian

more options

Hi Sebastian,

Thank you for your feedback. The official input for Mozilla can be found at

Fortunately with the first update there has been alot learned. With the next launch of phones and version we are hoping for updates to go more smoothly.