Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Advanced Property Editor still pops up, how do I disable it?

  • 17 replies
  • 35 have this problem
  • 691 views
  • Last reply by Toad-Hall

more options

I've had this problem for a very long time and I'm sick of it; the Advanced Property Editor still pops up!

I've tried all these previously:

  • Safe mode (no add-ons present)
  • New profile
  • Change mouse several times (seriously, this is NOT the issue)
  • Changed version
  • Changed double-click speed in Windows
  • Even a portable version has the same issue

So now, I'm begging for some kind of solution that actually works! This is obviously something that is wrong in the program and I think it's strange that no one has solved it in development.

All Replies (17)

more options

What version of Thunderbird?

What do you mean with 'Advanced Property Editor'? Please provide more details.

https://support.mozilla.org/en-US/kb/ask-tb#w_how-to-ask-your-question

more options

Here's the troubleshoot information:

   Version: 28.0
   User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) 
   Gecko/20100101 Thunderbird/28.0
   Application Build ID: 20140305121112

My problem is that this window opens whenever I write a new e-mail from any given account. The trigger seems to be a double-mouse-click that firstly sellects all text in the message and then also opens this window.

This is very annoying since I never use this editor and it pops up all the time.

more options

It's triggered by a double-click on white space when editing or composing an html-formatted email message.

What are you double-clicking on, and why?

more options

It is very easy to click beside a word or line that I want to mark, but this is not possible since this editor pops up instantly.

Although it's my main question I'm wondering why is this function even is in Thunderbird from the start. If some people find the use of it, I suppose it would suffice with a button or similar instead of this annoying window?

more options

I really think I have been here before!

So now, I'm begging for some kind of solution that actually works!

Simple really. Stop double clicking in the white space of a message. I have been using this program for 10 years and have never had a problem with the dialog, when it appears I go ohh, I have made a mistake and clicked in the wrong place

This is obviously something that is wrong in the program

It is not a fault, or a bug, it is Thunderbird working exactly as designed.

The fact you do not like the functionality is not relevant the program is functioning correctly

I think it's strange that no one has solved it in development.

There is nothing to solve in development, because it is functioning exactly as designed. about once or twice a year someone comes along and complains about it, they rarely reply to questions and never file a bug.

If you seriously want a developer to modify the program because you keep double clicking on white space, go to bugzilla https://bugzilla.mozilla.org/ and file a request for enhancement bug explaining why the current action is inappropriate and your suggested solution for quick access to the dialog.

more options

Wow, this is very helpful: "stop double click white space". Is this how support forums work, telling the one with the issue to stop doing the thing that obviously triggers the annoyance?

It's obvious that this feature is annoying some non-perfect Thunderbird users that still loves the client. The fact that it appears when I want to mark text makes this to a fault for me at least.

I want to be able to double click white spaces so that my mark functionality works as I want instead of getting a (for me) useless dialog. I can reply in this matter and even file a bug even though it's not considered to be one by you.

more options
Is this how support forums work, telling the one with the issue to stop doing the thing that obviously triggers the annoyance?

We tell you to stop poking yourself in the eye and complaining it hurts.

I want to be able to double click white spaces so that my mark functionality works as I want instead of getting a (for me) useless dialog.
Did you file a bug Stefan?
more options

How can this be "poking in my eye and complain it hurts"!? I've describe why I don't like this feature and what I'm looking for instead.

Maybe the Thunderbird works exactly as i suppose to do, but this doesn't mean that you quit developing it, or am I wrong? Even though a software works as it should, it must be improved. And for me this would be a great improvement.

I've never heard of a user that uses this feature, so that would be an even bigger reason to at least make possible to disable in some way.

The bug report will be sent as soon as I know how to do it, since I've never done this before.

more options

I have come across this before and this was what was occuring.

  • Either the user was double clicking in a white space in the compose area to activate the pop up
  • or the mouse was becoming defective. The mouse perceived that a double click had occured and sent that message for that action, so that is why Thunderbird acted upon it. You could try to set the mouse to be less sensitive in Control Panel > Mouse or if that does not work get a new mouse/try another mouse.
more options

I kindly refer you to my first post where I describe what I've tried previously. I've tried several different mice and also the adjusted sensitivity. The popup will unfortunately appear either way.

more options

Stefan, I read your post, but you seem reluctant to accept what is being posted as responses. Thunderbird gets the message from your computer via the mouse to act upon a double click to open that popup. That popup box does not open on a single click.

If the mouse is fully operational and is not the issue then it is the user or a combination of the user and the settings.

Possible reason - user is single clicking the mouse and accidentally adding an additional pressure (like a wobble) to create a double click. This is down to how the user uses the mouse and is usually not realised as it is a habit in the way the user operates. Yes, I have sat next to people who insist they are not double clicking, but I could see they were; they are just not aware of it. This may not be your issue, but it does happen and the user is not usually aware of it.

I have also known people performing two single clicks too close together, so that their computer perceives this as a double click.

In all cases where the mouse was fully ok, it has always been the action of the user or a combination of how the user operates and the settings were not adjusted to suit how the user needs them.

I have just tried this myself in a new Write compose editing area, gradually increasing the speed beween clicks and there is a point (determined by my 'double click' speed settings) when the clicks stop being registered as single and become double. This setting is a personal thing and can only be set up by you, so that you get the result you need. Test this. If the timing between clicks is too little or too much then a long single or fast 'wobble' or a slow double may be perceived incorrectly, but can be fixed in the mouse settings with a little patience.

Modified by Toad-Hall

more options

I too have been trying this and find it surprisingly hard to provoke the Advanced Properties Editor pop-up. I thought any white space might do it, but here in Windows 7, at least, even spaces between words are correctly recognized as text and simply serve to select the adjacent word, or paragraph if you triple-click. I have to deliberately move well away from text in order to locate genuine whitespace in which the APE launches.

One little issue is that here in Windows it automatically includes the trailing space as part of the word. I think that elsewhere I have it set to select just the text, in which case its treatment of spaces between words might be different.

Well, I've just toggled this preference to true:

layout.word_select.eat_space_to_next_word

…so it no longer selects the space, and I still can't make it work any differently in respect of the non-appearance of the APE, so I don't think this is the reason either.

Anyhow, trying clicking the word, not the space. But your original description sounds to me like a quadruple click; two for the word, a third for the paragraph ("all text") and finally one that gets you to the APE. I too suspect that you're somehow inadvertently generating multiple events.

more options

BTW, if you don't need HTML, then working exclusively in plain text will totally avoid this issue.

more options

You have already stated that you are double clicking in a white space - quote 'I want to be able to double click white spaces so that my mark functionality works'.

So this explains why you get the popup box, you are deliberately invoking it.

Perhaps, you could say what you are trying to mark -so that my mark functionality works? I believe this issue may be more about what you want to do - what you are trying to achieve, because persistantly invoking the 'Advanced Property Editor' is clearly not helping you. Please give more explanation.

You type several words...then what do you want to do? If you want to change eg: colour or bold a single word which you have already typed, double clickon that word to highlight it, then choose from the formatting bar.

If you want to change eg: colour or bold all the words which you have already typed. single click at start of text, hold down Shift and single click at end of text, this highlights all the text, then choose from the formatting bar.

Or you could just choose the formatting options before you start typing.

more options

Thank you for the helpful replies. Just to clarify, I'm not reluctant, I'm just trying to understand why this feature is so easy to trigger. I understand that It's my doing that leads to the pop-up and that I could skip the double clicks, but my guess is that I'm used to text editors that marks a whole line when i double click a whitespace area on that line. For some reason Thunderbird will not do the same.

Let's say that I write a new mail and I has this text:

  Hello            **

                 
  World

Where the stars represents my double click position. This will result in a "mark all text" scenario and the APE popping up afterwards. My expected result would be selection of the exact lines content. That's the features that I'm looking for.

Could someone tell me how to only compose plain-text messages, I can't seem to find it in the menus while writing messages?

Thanks once again for the helpful replies, I very much appreciate it!

more options

Tools - Account Settings - =select account= - Composition

Which environment is it where you experience this "click in white space" function? On the face of it, it seems so counterintuitive I wouldn't have ever thought of trying it. To select a line in Word, for example, I'd put the cursor in the left-hand margin, watch it change to a right-pointing arrow, then click to select the line.

There are certain programming-oriented editors where selecting the whole line in the way you describe might be useful, but they are line oriented in a way that I wouldn't associate with email text editing. Email is, IMHO, paragraph centered.

more options

The other quick method of selecting a whole line, set focus at the beginning of sentence. Hold 'Shift' and press 'End' key.

re: Plain Text...good info here:- http://kb.mozillazine.org/Plain_text_e-mail_%28Thunderbird%29