X
Tap here to go to the mobile version of the site.

Support Forum

my search bar is gone, and it just shows an empty space

Posted

My search bar is gone from the top of my browser, it isn't gone as if i disabled it, the search bar seems to be invisible. it just shows an empty space with my theme.

I have tried uninstalling Firefox several times, I have deleted all of my extensions, I have reset Firefox under troubleshooting information and I have tried deleting the localstore.rdf file from my Firefox profile folder. But for some reason my search bar appears while in safe mode...

i don't know what else to do, any help would be appreciated, thanks! :)

My search bar is gone from the top of my browser, it isn't gone as if i disabled it, the search bar seems to be invisible. it just shows an empty space with my theme. I have tried uninstalling Firefox several times, I have deleted all of my extensions, I have reset Firefox under troubleshooting information and I have tried deleting the localstore.rdf file from my Firefox profile folder. But for some reason my search bar appears while in safe mode... i don't know what else to do, any help would be appreciated, thanks! :)

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • Google Update
  • 5.1.30214.0
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.9.1.16010
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • WildTangent Games App V2 Presence Detector
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • NPWLPG

Application

  • Firefox 28.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
  • Support URL: https://support.mozilla.org/1/firefox/28.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Norton Toolbar 2014.7.0.43 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 12.2.0.5 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)
  • Skype Click to Call 7.1.15383.6004 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0126
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 9-30-2011
  • driverDate2:
  • driverVersion: 8.882.2.3000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20140314220517
  • browser.startup.homepage_override.mstone: 28.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 28.0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True

Misc

  • User JS: No
  • Accessibility: No
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 solutions 40418 answers

Sounds like an incompatible theme.

The obvious solution would to not use a theme, or at least a theme that actually works properly.

Sounds like an incompatible theme. The obvious solution would to not use a theme, or at least a theme that actually works properly.

Question owner

ok cool ill try that

ok cool ill try that

Question owner

dang, it didn't work. thanks for trying though, also if you or anyone else is still willing to help, then here is a screenshot of my problem.

thanks again!

dang, it didn't work. thanks for trying though, also if you or anyone else is still willing to help, then here is a screenshot of my problem. thanks again!
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 solutions 40418 answers

The whole Navigation Tool;bar appears to be missing.

Try this. Right-click at the top of the window, to the right of the tab, and click on the Navigation Toolbar so that is has a check mark.

The whole Navigation Tool;bar appears to be missing. Try this. Right-click at the top of the window, to the right of the tab, and click on the Navigation Toolbar so that is has a check mark.
cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

You can try to disable hardware acceleration in Firefox (you need to close and restart Firefox).

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
You can try to disable hardware acceleration in Firefox (you need to close and restart Firefox). *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected

Question owner

nope sorry, none of those solutions worked thanks again for helping!

nope sorry, none of those solutions worked thanks again for helping!
cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

Is the Navigation Toolbar visible with all default buttons and the location bar and search bar?

Did you move any items from the Navigation Toolbar to another toolbar?

You can check for problems caused by a corrupted localstore.rdf file.

Is the Navigation Toolbar visible with all default buttons and the location bar and search bar? Did you move any items from the Navigation Toolbar to another toolbar? You can check for problems caused by a corrupted localstore.rdf file. *http://kb.mozillazine.org/Corrupt_localstore.rdf

Question owner

ok i just fixed it i had ended up accidentally moving a item from my navigational toolbar to my another toolbar.

thanks again!

ok i just fixed it i had ended up accidentally moving a item from my navigational toolbar to my another toolbar. thanks again!
cor-el
  • Top 10 Contributor
  • Moderator
17673 solutions 159870 answers

You're welcome

You're welcome