X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Scroll Lag Problem

Posted

Hi

I tested Firefox (28 and 29 beta) on my Galaxy S4 but when I zoom the page and scroll to anywhere,it is not smooth,it is too laggy so I can't use firefox on my mobile phone.Can I resolve this ?

Hi I tested Firefox (28 and 29 beta) on my Galaxy S4 but when I zoom the page and scroll to anywhere,it is not smooth,it is too laggy so I can't use firefox on my mobile phone.Can I resolve this ?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

guigs 1072 solutions 11697 answers

You can try to tweak the scrolling preferences in "about:config" https://wiki.mozilla.org/Mobile/Fenne.../Android#Tweaking_UI_prefs but this would alter the defaults. Another one is called scroll and scroll focus I think.

Though the s4 could use improvement. If you could file a bug with more information. Please see the Bug Writing Guidelines before reporting ithttps://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox%20for%20Android here]

In order to troubleshoot Firefox for Android issues please provide 1. your exact Galaxy S4 model number: Android Settings->General->About device-Model Number why? Samsung has many variants of their phones and tablets. We've found in the past that less popular variants can have weird issues that aren't noticed on the more popular variants. (e.g. a CDMA variant for the USA may have issues that the the LTE variant for Europe doesn't have)

2. Your exact configuration of the two add-ons: ghostery and self destructing cookies

3. Anything else e.g. you are running some sort of Android anti-virus if so please tell us what you are running

Finally, I have asked our community to try on their Samsung Galaxy S4s. Hopefully one of them can help.

Cheers!

You can try to tweak the scrolling preferences in "about:config" [https://wiki.mozilla.org/Mobile/Fennec/Android#Tweaking_UI_prefs] but this would alter the defaults. Another one is called scroll and scroll focus I think. Though the s4 could use improvement. If you could file a bug with more information. Please see the [https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines Bug Writing Guidelines before reporting it]https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox%20for%20Android here] In order to troubleshoot Firefox for Android issues please provide 1. your exact Galaxy S4 model number: Android Settings->General->About device-Model Number why? Samsung has many variants of their phones and tablets. We've found in the past that less popular variants can have weird issues that aren't noticed on the more popular variants. (e.g. a CDMA variant for the USA may have issues that the the LTE variant for Europe doesn't have) 2. Your exact configuration of the two add-ons: ghostery and self destructing cookies 3. Anything else e.g. you are running some sort of Android anti-virus if so please tell us what you are running Finally, I have asked our community to try on their Samsung Galaxy S4s. Hopefully one of them can help. Cheers!

Question owner

Thanks for reply.

I am using GT-I9500.I am not using any antivirus.You can try on "http://mail.zoho.com" firt zoom the page then scroll to anywhere you'll see scroll is too laggy.

If you want a video about this problem I can send.

Thanks for reply. I am using GT-I9500.I am not using any antivirus.You can try on "http://mail.zoho.com" firt zoom the page then scroll to anywhere you'll see scroll is too laggy. If you want a video about this problem I can send.
guigs 1072 solutions 11697 answers

You are right, it is pretty laggy.

Found one that helped only for that website in beta for a temp work around. general.smoothscroll.pages set to false.

But pull up about:healthreport and add to the Performance reports. This can help.

You are right, it is pretty laggy. Found one that helped only for that website in beta for a temp work around. general.smoothscroll.pages set to false. But pull up about:healthreport and add to the [https://support.mozilla.org/en-US/kb/firefox-health-report-understand-your-android-browser-perf?esab=a&s=health+report&r=0&as=s Performance reports]. This can help.

Modified by guigs

Question owner

I set the general.smoothscroll.pages to false but problem not resolved.I turned on healtreport and telemetry. Also this problem happening on top level images you can try on any image zoom it then scroll it.

(I tried on Ff 29 beta)

I set the general.smoothscroll.pages to false but problem not resolved.I turned on healtreport and telemetry. Also this problem happening on top level images you can try on any image zoom it then scroll it. (I tried on Ff 29 beta)
Moses
  • Moderator
459 solutions 3607 answers

Rachel/guigs2:

Tolgayt also created a bug report concerning this issue.

Rachel/guigs2: Tolgayt also created a [https://bugzilla.mozilla.org/show_bug.cgi?id=989534 bug report] concerning this issue.
Roland Tanglao
  • Administrator
72 solutions 783 answers

Hi all: This is fixed in Firefox 31 which will be released 6 weeks from June 10, 2014. If it's not fixed in FF31 , please open a new question.

Hi all: This is fixed in Firefox 31 which will be released 6 weeks from June 10, 2014. If it's not fixed in FF31 , please open a new question.