X
Tap here to go to the mobile version of the site.

Support Forum

When I open Firefox I get a black screen; how do I get rid of it?

Posted

When I first click on Firefox my monitor shows an all black window for a home page. A small rotating circle shows up on the black window; the indicator that a web site is loading. After a few seconds the circle goes away and for a flash the screen shows the url itself of my established home page, with a bit of an outline of that opening. Just as quickly, that disappears and the window goes black again. I can close it by right clicking on the Firefox logo and selecting "close all windows," and I can minimize it by using the windows key and the letter M. I feel that the correct screen is underneath the black window, but to which I have no access.

Before all this happened the search engine Ask had made itself the home page for Firefox without my consciously asking for that. By going to the control panel and the Internet entry, I removed what had become the url (of Ask's supplied home page) in the choice for home page, with my usual one (www.excite.com). That's when the above trouble started and remains.

Obviously, I am writing this contact to the Internet and a different machine. On the computer with the problem I couldn't see what I am doing. I could have also used Windows Explorer on the troubled machine; it has not been affected with the same problem.

When I first click on Firefox my monitor shows an all black window for a home page. A small rotating circle shows up on the black window; the indicator that a web site is loading. After a few seconds the circle goes away and for a flash the screen shows the url itself of my established home page, with a bit of an outline of that opening. Just as quickly, that disappears and the window goes black again. I can close it by right clicking on the Firefox logo and selecting "close all windows," and I can minimize it by using the windows key and the letter M. I feel that the correct screen is underneath the black window, but to which I have no access. Before all this happened the search engine Ask had made itself the home page for Firefox without my consciously asking for that. By going to the control panel and the Internet entry, I removed what had become the url (of Ask's supplied home page) in the choice for home page, with my usual one (www.excite.com). That's when the above trouble started and remains. Obviously, I am writing this contact to the Internet and a different machine. On the computer with the problem I couldn't see what I am doing. I could have also used Windows Explorer on the troubled machine; it has not been affected with the same problem.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • 5.1.30214.0
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Zeon PDF Plugin For Mozilla
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Windows Multimedia Services DRM Store Plug-In

Application

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.5.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • PDF Converter 7.0 1.0 (nuance@pdf7)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Clipmarks 4.0.1 ({e1170235-2845-420c-acc3-42261a29dd46}) (Inactive)
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)
  • Games.com Toolbar 5.87.1.7276 ({493b4069-8c4f-4b4a-8f8c-506200c9887a}) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • RealPlayer Browser Record Plugin 1.0 ({ABDE892B-13A8-4d1b-88E6-365A6E755758}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce4 Ti 4200
  • adapterDescription2:
  • adapterDeviceID: 0x0253
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'257.21']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 10-6-2003
  • driverDate2:
  • driverVersion: 5.2.1.6
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'257.21']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'257.21']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 25000
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.display.background_color: #C0C0C0
  • browser.display.use_document_fonts: 0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 180
  • browser.history_expire_days_min: 28
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage: http://start.usaa.net/?cookieset=L29wdC94bWwvZWFydGhsaW5rLm5ldC94bWwzLzAwMTQwL2tpc2xpazE2Ny9wc3AueG1s
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 27.0.1
  • font.default: sans-serif
  • font.internaluseonly.changed: False
  • font.minimum-size.x-western: 12
  • font.name.monospace.x-western: Letter Gothic
  • font.name.sans-serif.x-western: Lucida Sans
  • font.size.fixed.x-western: 12
  • font.size.variable.x-western: 12
  • general.useragent.extra.microsoftdotnet: (.NET CLR 3.5.30729)
  • gfx.blacklist.suggested-driver-version: 257.21
  • network.cookie.cookieBehavior: 3
  • network.cookie.prefsMigrated: True
  • network.http.proxy.version: 1.0
  • network.protocol-handler.warn-external.dnupdate: False
  • places.database.lastMaintenance: 1395404313
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 26818
  • places.history.expiration.transient_optimal_database_size: 42908220
  • places.last_vacuum: 1296158406
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.np_gp: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.enable_tls: False
  • security.OCSP.signingCA: Builtin Object Token:IPS CLASE1 root
  • security.OCSP.URL:
  • security.warn_entering_weak.show_once: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1395015999

Misc

  • User JS: Yes
  • Accessibility: No
Daniel Phillips 14 solutions 77 answers

Sorry to hear about your problems. It could sound like you haven't completely removed all of the remaining of ASK tool bar, or you've accidentally have broken something.

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

Sorry to hear about your problems. It could sound like you haven't completely removed all of the remaining of ASK tool bar, or you've accidentally have broken something. The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. <br> '''Note''': ''This will cause you to lose any Extensions and some Preferences.'' *Open websites will not be saved in Firefox versions lower than 25. To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us! Thank you.
jscher2000
  • Top 10 Contributor
8634 solutions 70616 answers

If you want to try a little further troubleshooting before you reset, try starting up in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is already running, you can start Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still run)

If Firefox is not running, hold down the Shift key when starting Firefox.

Then, in the small dialog that should eventually appear, click "Start in Safe Mode" (not Reset)

Any difference?

If you want to try a little further troubleshooting before you reset, try starting up in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is already running,'' you can start Firefox in Safe Mode using Help > Restart with Add-ons Disabled ''(Flash and other plugins still run)'' ''If Firefox is not running,'' hold down the Shift key when starting Firefox. Then, in the small dialog that should eventually appear, click "Start in Safe Mode" (''not'' Reset) Any difference?

Question owner

It seems to me that these solutions require seeing the Firefox screen, which is exactly what my problem is. The same holds true resetting.

It seems to me that these solutions require seeing the Firefox screen, which is exactly what my problem is. The same holds true resetting.
Daniel Phillips 14 solutions 77 answers

That leaves out only one option, a complete re-install. A Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not run Firefox's uninstaller or use a third party remover as part of this process, because that could permanently delete your Firefox data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be recovered unless they have been backed up to an external device!

Please report back to see if this helped you!

Thank you.

That leaves out only one option, a complete re-install. A ''Clean reinstall''. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps: '''Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer. #After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu). #Delete the Firefox installation folder, which is located in one of these locations, by default: #*'''Windows:''' #**C:\Program Files\Mozilla Firefox #**C:\Program Files (x86)\Mozilla Firefox #*'''Mac:''' Delete Firefox from the Applications folder. #*'''Linux:''' If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see [[Installing Firefox on Linux]]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page], simply remove the folder ''firefox'' in your home directory. #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. More information about reinstalling Firefox can be found [https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems?esab=a&s=troubleshooting&r=3&as=s#w_5-reinstall-firefox here]. <b>WARNING:</b> Do not run Firefox's uninstaller or use a third party remover as part of this process, because that could permanently delete your Firefox data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. <u>These cannot be recovered unless they have been backed up to an external device!</u> Please report back to see if this helped you! Thank you.
jscher2000
  • Top 10 Contributor
8634 solutions 70616 answers

Here's another thought: maybe there was a video running full screen and Firefox crashed and is trying to restore that video. Try to break the cycle by starting Firefox up to a blank page. The command line is:

firefox.exe "about:blank"

If it's a Windows XP system, use Start > Run, type or paste the above line, and press Enter.

If it's Windows Vista or later, use the Start menu search box, type or paste the above line, and press Enter.

Can you get a blank page? If so, if you click your Home icon or press Alt+Home, will your home page load normally?

Here's another thought: maybe there was a video running full screen and Firefox crashed and is trying to restore that video. Try to break the cycle by starting Firefox up to a blank page. The command line is: firefox.exe "about:blank" If it's a Windows XP system, use Start > Run, type or paste the above line, and press Enter. If it's Windows Vista or later, use the Start menu search box, type or paste the above line, and press Enter. Can you get a blank page? If so, if you click your Home icon or press Alt+Home, will your home page load normally?

Question owner

A couple of the suggestions came close to resolving the problem, but it took Ask.com's help screen to go a step further, which did call for resetting Firefox in a way that did not first require that Firefox be opened: hold the shift key down when starting Firefox and do select Reset Firefox. I had to go out my way (not use a short cut) to get that process to work. It is interesting to note that Ask.com identifies the number of other requests they get for solving a particular problem. "Eliminating the Ask home page" from Firefox was their second most frequently received problem! My wife had gone to Ask to search for an entry. In the process, Ask must have slipped in, hardly noticed, a checked box to add the Ask home page to be installed (and make it the default as well). A negative choice for opting out is indeed an unfair and troublesome practice!

A couple of the suggestions came close to resolving the problem, but it took Ask.com's help screen to go a step further, which did call for resetting Firefox in a way that did not first require that Firefox be opened: hold the shift key down when starting Firefox and do select Reset Firefox. I had to go out my way (not use a short cut) to get that process to work. It is interesting to note that Ask.com identifies the number of other requests they get for solving a particular problem. "Eliminating the Ask home page" from Firefox was their second most frequently received problem! My wife had gone to Ask to search for an entry. In the process, Ask must have slipped in, hardly noticed, a checked box to add the Ask home page to be installed (and make it the default as well). A negative choice for opting out is indeed an unfair and troublesome practice!
KoroshiSvarta 0 solutions 2 answers

I've got the same problem, Aurora tries to open my homepage (DuckDuckGo) but i have this black screen.

I've got the same problem, Aurora tries to open my homepage (DuckDuckGo) but i have this black screen.
jscher2000
  • Top 10 Contributor
8634 solutions 70616 answers

Hi KoroshiSvarta, your screen shot is blurred...

What is the URL of the unwanted page?

When you launch a new window (Ctrl+n), do multiple tabs open? If so:

Please check for extra home pages in the Options dialog. This article describes where to check for multiple addresses separated by a vertical bar (|) character: Startup, home page, tabs, and download settings.

Or it might be easier to reset your home page. This article has methods for that: How to set the home page.

If Firefox ignores your home page settings and displays a different page when you use Ctrl+n, test whether one of your extensions is involved by starting Firefox in its Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

Hi KoroshiSvarta, your screen shot is blurred... What is the URL of the unwanted page? When you launch a new window (Ctrl+n), do multiple tabs open? If so: Please check for extra home pages in the Options dialog. This article describes where to check for multiple addresses separated by a vertical bar (|) character: [[Startup, home page and download settings]]. Or it might be easier to reset your home page. This article has methods for that: [[How to set the home page]]. If Firefox ignores your home page settings and displays a different page when you use Ctrl+n, test whether one of your extensions is involved by starting Firefox in its Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled Not all add-ons are disabled: Flash and other plugins still run After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Any difference?
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157293 answers

This looks like a Mozilla Support page?

You can use one of these to start Firefox in Safe Mode:

  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • Help > Restart with Add-ons Disabled

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to internet for Firefox and the plugin-container process and the updater process.

See:

This looks like a Mozilla Support page? You can use one of these to start Firefox in <u>[[Safe Mode|Safe Mode]]</u>: *On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut *On Mac, hold down the Options key while starting Firefox *Help > Restart with Add-ons Disabled *https://support.mozilla.org/kb/Safe+Mode ---- It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to internet for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/kb/Server+not+found *https://support.mozilla.org/kb/Firewalls *https://support.mozilla.org/kb/fix-problems-connecting-websites-after-updating
KoroshiSvarta 0 solutions 2 answers

@jscher2000: that is actually my window when I open Aurora is not the screen shot blurred itself but the opened window.

@cor-el: the only way to access to Aurora is in safe mode. I've checked but is still the same. I've even tried to delete all the folders and files on my PC and reinstall everything but nothing change..

@jscher2000: that is actually my window when I open Aurora is not the screen shot blurred itself but the opened window. @cor-el: the only way to access to Aurora is in safe mode. I've checked but is still the same. I've even tried to delete all the folders and files on my PC and reinstall everything but nothing change..
el_cheque 0 solutions 2 answers

Helpful Reply

I had the same problem with Aurora Firefox 32 and 33. I just reinstalled windows and that did not solve my issue, so I thought this might has something to do with my graphics card (NVIDIA GeForce GT 525M with optimus technology). So I started Aurora in safe mode, and played around with some settings after I found that changing gfx.direct2d.disabled from false to true solves this issue. Hope you guys can use this solution as well.

Edit: To start Firefox in safe mode, keep shift pressed while you start the browser. Edit 2: To change FIrefox settings, type "about:config" in the address bar.

I had the same problem with Aurora Firefox 32 and 33. I just reinstalled windows and that did not solve my issue, so I thought this might has something to do with my graphics card (NVIDIA GeForce GT 525M with optimus technology). So I started Aurora in safe mode, and played around with some settings after I found that changing '''gfx.direct2d.disabled''' from ''false'' to ''true'' solves this issue. Hope you guys can use this solution as well. Edit: To start Firefox in safe mode, keep shift pressed while you start the browser. Edit 2: To change FIrefox settings, type "about:config" in the address bar.

Modified by el_cheque

el_cheque 0 solutions 2 answers

Helpful Reply

I have also found that unchecking the "Use hardware acceleration when available" option solves this issue. This option is in the Advanced section, under the General tab.

I have also found that unchecking the "Use hardware acceleration when available" option solves this issue. This option is in the Advanced section, under the General tab.