X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 28 ignores plugin.disable_full_page_plugin_for_types ?

Posted

As of Firefox 28 the plugin.disable_full_page_plugin_for_types setting seems to be ignored. I had set it in previous versions so I could get audio/mpeg files to display a download notification instead of playing in-browser but as of the latest update it seems to make no difference.

As of Firefox 28 the plugin.disable_full_page_plugin_for_types setting seems to be ignored. I had set it in previous versions so I could get audio/mpeg files to display a download notification instead of playing in-browser but as of the latest update it seems to make no difference.

Chosen solution

Yes, seems to be a constant bug which ticks people off.

In the bug discussion someone mentioned that you should also set media.directshow.enabled to false and, sure enough, that seems to work. Not that this won't also be broken in a future build but for now it looks like the old functionality (which is actually functional for the user) is back.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • 5.1.30214.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • GEPlugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17265 solutions 156032 answers

This pref should still be working for plugins.

If it doesn't work then Firefox may be using the HTML5 media player to handle this file type.
You can set the Boolean pref media.windows-media-foundation.enabled to false on the about:config page to disable the HTML5 media player.

This pref should still be working for plugins. *http://mxr.mozilla.org/mozilla-release/search?string=disable_full_page_plugin_for_types&find=&findi=&filter=^[^\0]*%24&hitlimit=&tree=mozilla-release If it doesn't work then Firefox may be using the HTML5 media player to handle this file type.<br /> You can set the Boolean pref <b>media.windows-media-foundation.enabled</b> to <i>false</i> on the <b>about:config</b> page to disable the HTML5 media player.

Question owner

That's a setting that I had already configured as well. Sadly, Firefox seems to ignore that too.

And yes, I can confirm that it is the built-in HTML5 player that comes up and not any third-party plugin.

That's a setting that I had already configured as well. Sadly, Firefox seems to ignore that too. And yes, I can confirm that it is the built-in HTML5 player that comes up and not any third-party plugin.
cor-el
  • Top 10 Contributor
  • Moderator
17265 solutions 156032 answers

What content is played by this player?

If this are audio files other than MP3 then you need to disable the related media.*.enabled pref by setting its value to false.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

What content is played by this player? If this are audio files other than MP3 then you need to disable the related media.*.enabled pref by setting its value to false. Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?
madpanic 1 solutions 4 answers

I have the same problem and posted a very similar question

Both settings appear to be correct, but FF is opening a new tab to try to play an mp3. Seems to do it for an m3u playlist type file as well, but there it is calling the VLC plugin in a new window instead of its own player in a new tab.

In any event, any page with an mp3 will do, here is one. The mp3 link is labeled "mp3 (audio file) in the middle of the page in a purple box.

I have the same problem and posted a very [https://support.mozilla.org/en-US/questions/991356 similar question] Both settings appear to be correct, but FF is opening a new tab to try to play an mp3. Seems to do it for an m3u playlist type file as well, but there it is calling the VLC plugin in a new window instead of its own player in a new tab. In any event, any page with an mp3 will do, here [http://crapfromthepast.com/ is one.] The mp3 link is labeled "mp3 (audio file) in the middle of the page in a purple box.
cor-el
  • Top 10 Contributor
  • Moderator
17265 solutions 156032 answers

The MP3 file in that link is send as audio/mpeg and that makes Firefox use the HTML5 media player.
For me Firefox opens the HTML5 media player in the same tab if I left-click.

The MP3 file in that link is send as audio/mpeg and that makes Firefox use the HTML5 media player.<br /> For me Firefox opens the HTML5 media player in the same tab if I left-click. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/change-firefox-behavior-when-open-file
madpanic 1 solutions 4 answers

Helpful Reply

Sure, so how do you get FF to pop up the dialog to ask you if you want to Open With... or Save? I have the config settings set to turn off media-foundation and audio/mpeg is part of the "disable_full_page..." setting and audio/mpeg is set to "Always Ask" in the Applications tab under options.

When I set audio/mpeg to "Save" in the Options->Applications tab it still opens the full page plugin and tries to play the file.

Is there another setting I should be using? I just want the option of either saving or launching another app to play the file outside of Firefox.


Edit - Adding what I put in my other question for more background on what I see:

No settings change from 27 where all was fine. plugin.disable_full_page_plugin_for_types still contains "application/pdf,audio/x-mpeg,audio/mpeg", the media.windows-media-foundation.enabled is still set to "false", and the mime types are all set to "always ask". Is there a reason why these settings are being ignored in FF 28? Major pain in the neck to have to save something and then run it in VLC as opposed to just being asked from FF as I was until 15 minutes ago when I restarted FF and the upgrade happened.

I also just tried this with a pdf and it opened in the current tab. When I set FF to "ask" about pdfs instead of "preview in Firefox" I got the dialog asking what I wanted to do. Since the plugin.disable_full_page_plugin_for_types already included "application/pdf" I don't know if it should have previewed in FF as I don't know how the different settings interact, but to be honest I'm okay with that behaviour.

Sure, so how do you get FF to pop up the dialog to ask you if you want to Open With... or Save? I have the config settings set to turn off media-foundation and audio/mpeg is part of the "disable_full_page..." setting and audio/mpeg is set to "Always Ask" in the Applications tab under options. When I set audio/mpeg to "Save" in the Options->Applications tab it still opens the full page plugin and tries to play the file. Is there another setting I should be using? I just want the option of either saving or launching another app to play the file outside of Firefox. ------------------ Edit - Adding what I put in my other question for more background on what I see: No settings change from 27 where all was fine. plugin.disable_full_page_plugin_for_types still contains "application/pdf,audio/x-mpeg,audio/mpeg", the media.windows-media-foundation.enabled is still set to "false", and the mime types are all set to "always ask". Is there a reason why these settings are being ignored in FF 28? Major pain in the neck to have to save something and then run it in VLC as opposed to just being asked from FF as I was until 15 minutes ago when I restarted FF and the upgrade happened. I also just tried this with a pdf and it opened in the current tab. When I set FF to "ask" about pdfs instead of "preview in Firefox" I got the dialog asking what I wanted to do. Since the plugin.disable_full_page_plugin_for_types already included "application/pdf" I don't know if it should have previewed in FF as I don't know how the different settings interact, but to be honest I'm okay with that behaviour.

Modified by madpanic

Question owner

I think it's worth mentioning that Firefox 28 also displays this behavior with all addons disabled as well. The default HTML5 audio player takes over.

I think it's worth mentioning that Firefox 28 also displays this behavior with all addons disabled as well. The default HTML5 audio player takes over.
cor-el
  • Top 10 Contributor
  • Moderator
17265 solutions 156032 answers

You can try rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can try rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions. *http://kb.mozillazine.org/mimeTypes.rdf *http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions

Question owner

Yeah, tried that already. As the second link says:

Note: The "media.windows-media-foundation.play-stand-alone" preference was added in Firefox 24; setting it to "false" should disable built-in playback of "standalone" media (downloaded files) while allowing playback of embedded HTML5 audio and video content for supported MP3/M4A/MP4 files. Note, however, that this preference may not be working (bug 861090).

https://bugzilla.mozilla.org/show_bug.cgi?id=861090

So it's a known long-running bug that keeps resurfacing.

Yeah, tried that already. As the second link says: Note: The "media.windows-media-foundation.play-stand-alone" preference was added in Firefox 24; setting it to "false" should disable built-in playback of "standalone" media (downloaded files) while allowing playback of embedded HTML5 audio and video content for supported MP3/M4A/MP4 files. '''Note, however, that this preference may not be working (bug 861090).''' https://bugzilla.mozilla.org/show_bug.cgi?id=861090 So it's a known long-running bug that keeps resurfacing.

Modified by taquinvol

madpanic 1 solutions 4 answers

Chosen Solution

Yes, seems to be a constant bug which ticks people off.

In the bug discussion someone mentioned that you should also set media.directshow.enabled to false and, sure enough, that seems to work. Not that this won't also be broken in a future build but for now it looks like the old functionality (which is actually functional for the user) is back.

Yes, seems to be a constant bug which ticks people off. In the bug discussion someone mentioned that you should also set media.directshow.enabled to false and, sure enough, that seems to work. Not that this won't also be broken in a future build but for now it looks like the old functionality (which is actually functional for the user) is back.