Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

ZTE Open hangs most of the times

  • 12 replies
  • 2 have this problem
  • 289 views
  • Last reply by guigs

more options

I've been using ZTE Open for months now but i have a problem. It hangs most of the times. First of all i thought it was an early build(1.0) so i installed 1.1(stable), 1.2, 1.3 and running 1.4 now but the problem is same. It hangs! and when it does i have to lock the phone and wait for sometime to unlock it or just direct remove the battery(sometimes it doesn't solve the problem but sometimes it does). I can't now know for sure that will i be able to receive my incoming call or not? It just freezes most of the times. Tried so many things like clearing cache installing different ROMs(1.2, 1.3) etc but same problem Anyone having the same problem?

Any suggestions?

Chosen solution

Thanks to all of you who helped me :)

I did solved the problem by myself :)

The strip which connects screen to the motherboard wasn't properly attached :D

And no i never dropped my phone :D

So now it's working fine ;-)

Read this answer in context 👍 0

All Replies (12)

more options

Get your warranty honoured.

more options

Hello,

Thank you for contacting Mozilla Support! After reviewing the information that you provided, we think that the best way to fix this issue would be to reset your device.

Warning: Resetting your phone will delete all data stored on the device, including apps, calendar data, email accounts, and settings.

To reset the device, follow these instructions:

  1. Open the Settings application.
  2. Tap on the Device Information button.
  3. Tap on the More Information button.
  4. Tap on the Reset phone button.
  5. Tap OK to continue or Cancel to cancel.

We hope that this fixed the issue you were having. Please report back to us if this helped!

Thank you!

more options

Already tried :)

more options

Other than contacting your place of purchase for assistance, I'm not sure what more can be done to fix your issue.

However, I have escalated your matter to our helpdesk who will respond within 24-72 hours.

Thank you for your patience!

more options

Apologies for the delay, there was a spike in questions with the Firefox 28 release on Friday. I will answer to the best of my ability.

Discussion for updates [1-25-false] In this case if it is hanging, I am wondering if the size of the update is larger than the space on the device. When you go between updates, are the files on the device wiped before updating? What are the file sizes when you navigate via usb mode?

more options

I mostly update through .img files. First i installed 1.2 from [b][url=http://forum.xda-developers.com/showthread.php?t=2621001]this/url/b post. I have custom recovery installed from which i flash zip file(if available)

Then i tried 1.3 from ZTE Open Nightly [b][url=https://daylightpirates.org/b2g_inari_nightly_builds/]Builds/url/b. Now i'm running 1.4 compiled by someone else :D

And Yes i erase everything(system, boot, userdata) before flashing the ROM :)

I started to flash custom ROMs on my device because 1.1 released by ZTE Open wasn't good on my device(same problem)

I thought updating my ZTE Open will solve this problem :(

more options

Hey linuxholic,

After some further investigation there are a few more troubleshooting steps we need for confirmation:

  1. What steps are you taking right before it hangs, if you could provide an example where it happens every time please :-)
  2. Once you have the steps, connect the device via Remote debugging, run this in the terminal "adb logcat" and run the steps one more time.

Then I can get a stability expert to take a look at it, thank you!

more options

What do you mean steps? It hangs no matter what i do e.g in the middle of typing text message, in middle of a call, searching for contacts, browsing etc.

Again, what do you mean by steps?

Thanks for the help :)

more options

There you go: http://1drv.ms/OYzx4K Logcat result while phone is freezed :D

It won't affect my call or if i'm listening to songs. Problem is i can't touch anything when my phone hangs :)

Thanks for the help ;-)

more options

Another LogCat Status:- Phone hanged with incoming call :D

http://1drv.ms/P3PC9t

more options

Chosen Solution

Thanks to all of you who helped me :)

I did solved the problem by myself :)

The strip which connects screen to the motherboard wasn't properly attached :D

And no i never dropped my phone :D

So now it's working fine ;-)

more options

linuxholic,

I have a bit a learning curve with logs, but I am really happy that this issue was resolved for you.

I did find this in your second log

D/memalloc( 114): /dev/pmem: Freeing buffer base:0x4ccb3000 size:16384 offset:1 409024 fd:159 E/AudioPolicyManager( 118): setOutputDevice() setting same device 0x0 or null d evice for output 1 I/Adreno200-EGLSUB( 114): <CreateImage:991>: Android Image I/Adreno200-EGLSUB( 114): <GetImageAttributes:1256>: RGBX_8888 D/memalloc( 114): /dev/pmem: Freeing buffer base:0x4ccef000 size:81920 offset:1 654784 fd:166 D/memalloc( 114): /dev/pmem: Freeing buffer base:0x4cd03000 size:81920 offset:1 736704 fd:199 I/Gecko ( 114): -*- QCContentHelper_QC_B2G: receiveMessage: 'RIL:RegisterMobi leConnectionMsg' arrived from content process I/Gecko ( 114): -*- QCContentHelper_QC_B2G: Already registered this target! I/ONCRPC ( 117): rpc_handle_rpc_call: for Xid: 3d8, Prog: 31000000, Vers: fc37 ad5c, Proc: 00000012 I/ONCRPC ( 117): rpc_handle_rpc_call: Find Status: 0 Xid: 3d8 I/ONCRPC ( 117): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: 3d8 D/SST_QC_B2G( 114): Signal Strength changed; sending info to content process D/SIGNAL_STRENGTH_QC_B2G( 114): GetDbm = -57 D/SIGNAL_STRENGTH_QC_B2G( 114): GetRelSignalStrength = 90 D/SIGNAL_STRENGTH_QC_B2G( 114): GetDbm = -57 D/SIGNAL_STRENGTH_QC_B2G( 114): GetRelSignalStrength = 90 I/Gecko ( 114): -*- QCContentHelper_QC_B2G: sendMessage to content process: R IL:VoiceInfoChanged{connected : true,emergencyCallsOnly : false,roaming : false, type : 'unknown',signalStrength : -57,relSignalStrength : 90,network : {mcc : '4 10', mnc : '07', longName : 'WaridTel', shortName : 'Warid'},cell : {gsmLocation AreaCode : 711, gsmCellId :44393},state : 'registered'} I/Gecko ( 114): -*- QCContentHelper_QC_B2

Something was incoming to freeze the buffer then a process went in to change the setting of the network connection strength. But I do not speak log. If the issue did continue though, what I meant by steps were the exact actions you took while you were capturing the logs. These steps help when filing a bug in bugzilla.