Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't delete emails. They just move from Spam to Bin to Spam

  • 1 reply
  • 16 have this problem
  • 824 views
  • Last reply by Matt

more options

Hi,

I can no longer delete emails using thunderbird. When I try to delete emails from spam, they move to bin and when I try to delete them from there they just move back to the spam folder. This has only started to happen recently and it only happens with one account of my accounts [gmail] but not on the other two [both of which are also gmail]. The only way I can delete them is by logging into my account from a browser and deleting them there and then deleting them again in thunderbird. Obviously this defeats the purpose of thunderbird and makes it more hassle to use a program that is meant to reduce hassle, therefore making it redundant.

I have not changed any settings recently and the program is always up to date. I have searched online for a solution to this but have been unable to find any answers. I have cleared thunderbirds cache, history, cookies and download history to no avail. The ways I have tried to delete the emails are by marking them as junk [which is my normal way], by right clicking and selecting move to bin/trash, by right clicking and selecting delete message and by selecting the messages and pressing delete on the keyboard. What I really don't understand is why it is only affecting one account that isn't any different to the other accounts. Any help to fix this would be appreciated.

All Replies (1)

more options

lets see, Google really do not like you deleting mail and even when deleted it is retained by them in your all mail folder.

Now to some specifics. Using the junk folder to delete your mail is about the best way I can think of to confuse the junk mail filter in Thunderbird as all your old mail is "junk" and it is a learning filter. So over time it will learn all your mail is all junk and it will all automatically be treated as spam and go directly to the junk folder.

Have you tried right clicking the junk and trash folders and selecting empty from the menu? Just in case there is something corrupt on them that is making the synchronization go wrong