X
Tap here to go to the mobile version of the site.

Support Forum

I use gmail on Firefox, but it won't let me attach files to emails. Is there something I need to turn off?

Posted

I click on the attach files icon on my gmail email message and nothing happens.

I click on the attach files icon on my gmail email message and nothing happens.

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.9
  • GEPlugin
  • 5.1.20513.0
  • Google Updater pluginhttp://pack.google.com/
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • MetaStream 3 Plugin r4

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

krissie
  • Locale Leader
11 solutions 75 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.
BoBrown 0 solutions 2 answers

I tried all these things, I promise, and none of them has had any effect. I've just updated Windows and I updated my graphics drivers. Yesterday I could attach documents, and today I cannot. I finally had to resort to using gmail in Explorer, which worked just fine. But we all know I don't want to use Explorer, for all the obvious reasons. So I'm hoping you'll be able to give me some other ideas of what to do. The only things I've downloaded, not including the updates and Windows Defender updates (and that scan is fine), was Gimp and the Gimp manual, both from the official Gimp website.

I tried all these things, I promise, and none of them has had any effect. I've just updated Windows and I updated my graphics drivers. Yesterday I could attach documents, and today I cannot. I finally had to resort to using gmail in Explorer, which worked just fine. But we all know I don't want to use Explorer, for all the obvious reasons. So I'm hoping you'll be able to give me some other ideas of what to do. The only things I've downloaded, not including the updates and Windows Defender updates (and that scan is fine), was Gimp and the Gimp manual, both from the official Gimp website.
cor-el
  • Top 10 Contributor
  • Moderator
17774 solutions 160751 answers

If you can't add attachments to Gmail messages then you need to add an allow exception to allow pop-ups for the Google website. Easiest to do this is to click the padlock on the location bar and click the "More Information" button to open the "Tools > Page Info" window with the Security tab selected. Proceed to the Permissions tab Remove the tick on "Open Pop-up Windows" > "Use Default" and click the Allow radio button to change the permission to allow pop-ups for this domain.

Google is looking into this issue, see:

If you can't add attachments to Gmail messages then you need to add an allow exception to allow pop-ups for the Google website. Easiest to do this is to click the padlock on the location bar and click the "More Information" button to open the "Tools > Page Info" window with the Security tab selected. Proceed to the Permissions tab Remove the tick on "Open Pop-up Windows" > "Use Default" and click the Allow radio button to change the permission to allow pop-ups for this domain. Google is looking into this issue, see: * https://productforums.google.com/forum/#!topic/gmail/q0BxcGOa6pk
ideato 893 solutions 6250 answers

Helpful Reply

Firefox's pop-up blocker may have prevented the file upload window from opening. Please try adding Gmail to your list of allowed sites by following the steps below:

  1. Click on the menu button new fx menu and choose Options.
  2. Select the Content panel.
  3. Click on the Exceptions button next Block pop-up windows.
  4. In the Allowed Sites window, type in mail.google.com in the address field, then click Allow to add it to the list.
  5. Click Close to finish.

thank you

Firefox's pop-up blocker may have prevented the file upload window from opening. Please try adding Gmail to your list of allowed sites by following the steps below: # Click on the menu button [[Image:new fx menu]] and choose '''Options'''. # Select the '''Content''' panel. # Click on the '''Exceptions''' button next ''Block pop-up windows''. # In the ''Allowed Sites'' window, type in ''mail<!---->.google.com'' in the address field, then click '''Allow''' to add it to the list. # Click '''Close''' to finish. thank you
cor-el
  • Top 10 Contributor
  • Moderator
17774 solutions 160751 answers

Helpful Reply

According to the link to the Google forum this issue has been fixed by Google, so it should work without the allow pop-up block permission setting.

  1. https://productforums.google.com/forum/#%21topic/gmail/q0BxcGOa6pk
According to the link to the Google forum this issue has been fixed by Google, so it should work without the allow pop-up block permission setting. #https://productforums.google.com/forum/#%21topic/gmail/q0BxcGOa6pk
ideato 893 solutions 6250 answers

cor-el said :

According to the link to the Google forum this issue has been fixed by Google, so it should work without the allow pop-up block permission setting.

yes, indeed

cor-el said : ''According to the link to the Google forum this issue has been fixed by Google, so it should work without the allow pop-up block permission setting.'' yes, indeed
BoBrown 0 solutions 2 answers

When I came into the office today, the issue had been resolved. Perhaps by Google, I don't know, I'm having all kinds of strange issues with this new computer (Windows 8.1) and every single program on it, and many times they simply evaporate after a few days. Doesn't help when I'm in the middle of something though. But thanks so much for your help.

When I came into the office today, the issue had been resolved. Perhaps by Google, I don't know, I'm having all kinds of strange issues with this new computer (Windows 8.1) and every single program on it, and many times they simply evaporate after a few days. Doesn't help when I'm in the middle of something though. But thanks so much for your help.